IPB

Bienvenue invité ( Connexion | Inscription )

 
Reply to this topicStart new topic
> ATTENTION : Catalina peut flasher votre BIOS
Options
Krazubu
posté 5 Oct 2019, 10:33
Message #1


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 2 875
Inscrit : 5 Sep 2005
Membre no 45 266



Information importante et pour moi une première dans la scène hackintosh.
La maj Catalina DP8 a flashé mon BIOS.

Pour rappel des faits, j'ai un PC vieillissant mais qui se porte encore très bien avec un carte mère Asus P8P67 Pro, et 2 cartes graphiques, une RX 580 et une RX560.

J'ai suivi au fur et à mesure les maj de Catalina, et puis à la DP8, il s'est passé un truc étrange.
Après l'un des multiples redémarrage de la maj, le PC a fait un "cold reboot", c'est à dire qu'il n'a pas simplement redémarré comme d'habitude mais s'est physiquement éteint quelques secondes, puis rallumé.
Ça m'a interpellé, car c'est généralement ce qui arrive lorsqu'il y a un profond changement qui nécessite un reboot complet de la ROM : maj du BIOS, changement des réglages du CPU, PCI...
Rien de grave en soi mais pas "normal" pour une maj OSX.
Puis juste après, j'ai constaté que l'écran principal avait changé. Je ne me suis toujours pas inquiété car je surveillais ça de loin, j'ai pensé que l'une des 2 cartes ne fonctionnait plus à cause de la maj et nécessiterait quelques ajustements de clover ou autre.
Après quelques investigations, je me rends finalement compte que la carte graphique secondaire est totalement invisible par le système, pas juste mal configurée.
Je teste dans windows, rien, même dans clover, il ne liste plus qu'une seule carte dans les options graphiques.
La je vois que ça comment à sentir mauvais, il n'y a pas 36 pistes : mauvais contact d'une carte (relativement courant), carte graphique morte, carte mère morte, ou firmware corrompu.
J'ai plutôt pensé d'abord à un problème physique, je pensais peu probable que OSX aille flasher "accidentellement" du matériel non Apple.
J'ai checké les cartes graphiques, RAS, toutes deux fonctionnelles sur d'autres PC, à la fois en mode EFI et BIOS.
j'ai ensuite constaté que ce n'était pas la carte elle même, mais le port PCI qui était mort. Dans la foulée, j'ai réalisé que ma RAM était à 8Go au lieu de 12.
Après des tests croisés, toutes la barrettes et les connecteurs allaient bien, en fait ça plafonnait à 8go quelle que soit la combinaison.
J'ai donc alors pensé que la carte mère se faisait vieille et commençait à avoir fait son temps.

Il y a quelques minutes, je me décide quand même à attaquer la piste du BIOS.
J'ai un flasheur USB et une sauvegarde de mon dernier BIOS valide. Je reflash et bingo, la carte s'est immédiatement réveillée et la RAM et revenue à sa taille normale...
Donc la conclusion me semble maintenant raisonnable : Catalina a flashé et corrompu mon BIOS.

Ça aurait pu être pire, l'ordinateur bootait encore et était fonctionnel.
J'ai quand même dumpé la ROM, je la posterai ici pour les curieux qui voudraient voir ce qui a changé, en tout cas j'ai jeté un oeil avec un comparateur hexa, et il ne s'agit pas juste de quelques octets ici et là, il y a des pans entiers de la ROM qui ont été changés.

Depuis quelques années, les maj de ROM sont couramment intégrées avec les updates, on a aussi vu apparaître un petit message d'alerte qui nous averti après avoir été fureter dans le BIOS que notre système à un problème.
Je n'avais néanmoins jamais vu ou entendu parler de tels cas.
A noter que le cold boot a encore eu lieu avec la maj suivante, donc je suppose qu'il a été bricoler ma ROM une nouvelle fois, alors faites très attention !
Tout le monde n'a pas un flasheur USB, une sauvegardes et les connaissances... et même si on les a, ben j'me serais bien passé de ça !

EDIT : je n'en avais pas parlé car je ne pensais pas que c'était lié, mais le son avait foutu le camp aussi et est maintenant revenu.

Ce message a été modifié par Krazubu - 5 Oct 2019, 15:36.
Go to the top of the page
 
+Quote Post
Yellocab
posté 5 Oct 2019, 11:16
Message #2


Macbidouilleur de vermeil !
****

Groupe : Membres
Messages : 1 188
Inscrit : 7 May 2017
Lieu : Lyon
Membre no 202 099



le hack a tranquillement cru jusqu'au bout qu'il était sur un mac... mais c'est dingue que ça ait pu amorcer la MAJ du Bios.

C'etait quel SMBIOS?


--------------------
N°1: 🍀GA-Z390 Designare - i9 9900k - Nitro+ Vega 64 8GO - 32 Go 3600 DDR4 - 1xSSD NVMe 960 evo 256 Go + 1XSSD 500 Go (TimeMachine) + 1XSSD 256 Go Données
N°2: 🍀AsRock H110 ITX AC - i5 7500 - GTX660 - 8G 2133 DDR4 - 1XSSD - HD500Go
N°3: 🍀GA-H110M S2H- i7 6700k- GA GT 1030 - 8 Go DDR4 2133- 2XSSD (macOS+Win10) - Carte Combo Wifi/BT PCI
N°4: 🍀HP 8300 SFF - i5 3470 - GA GT 1030 - 8Go DDR3 - 1 SSD 1 HDD
N°5: 🍀HP 4300 SFF - i3 3220 - GT710 - 4Go DDR3 - 1 SSD

 MBP 2017 13 pouces Touch Bar

Rapport MacBidouille - Lexique et utilité des kexts - Tuto 10.13/10.14 - Politique vis à vis des outils automatisés et des distributions - Mon EFI
Go to the top of the page
 
+Quote Post
Krazubu
posté 5 Oct 2019, 11:22
Message #3


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 2 875
Inscrit : 5 Sep 2005
Membre no 45 266



Mac Pro 6.1
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 utilisateur(s) sur ce sujet (1 invité(s) et 0 utilisateur(s) anonyme(s))
0 membre(s) :

 



Nous sommes le : 20th November 2019 - 08:48