IPB

Bienvenue invité ( Connexion | Inscription )

 
Reply to this topicStart new topic
> UBUNTU-18.04.2 LTS, Comment l'installer en simple boot
Options
Xander Cage
posté 17 Feb 2019, 21:24
Message #1


Macbidouilleur de bronze !
**

Groupe : Membres
Messages : 386
Inscrit : 14 Oct 2012
Lieu : Paris - France
Membre no 179 687



Bonjour à tous,

Ce petit post pour vous faire part de mon évolution avec Linux sur un MacPro camion.

Tout d'abord la configuration :

MacPro 2012 Xeon 3,2Ghz QuadCore
Micro code flashé pour booter sur PCIe / NVMe
32 Go de RAM
512Go de SSD NVMe
Carte graphique RADEON X570 - 4Go
Lecteur Blu-Ray
Carte USB 3.1 - 2 ports
UBUNTU 18.04.2 en simple boot (Pas de MacOS)

L'install' proprement dite:
Après avoir galèré pour flasher le micro code de la machine et installé MOJAVE tant bien que mal,
je suis passé aux choses sérieuses ... et ça ne s'est pas fait tout seul.
En effet la configuration d'un disque bootable sous Linux n'est pas la même que sous MOJAVE ...

Table de partition GPT, jusque là tout va bien, ça se gâte ensuite.
Il faut une partition de 256Mo (ou moins) formatée en FAT-32 avec le point de montage "/boot/efi" et le drapeau "boot, legacy_boot,esp"
Puis une autre partition de 1Go sans nom, non formatée, mais avec le drapeau bios_grub sur laquelle va s'installer "grub2core.img"
Et enfin une dernière partition "/" qui occupera tout les reste du SSD et formatée en EXT4.

Voilà, après quelques tâtonements et des ré-installations en boucle, ça fonctionne bien.

Je précise encore une fois que c'est une configation en simple boot Linux


@tchao
Xander


--------------------
MacPro 2012 3,2 GHz XEON Octo-Core - RADEON RX 570 - Ubuntu 18.04.3 LTS
MacBook Air 2012 i5-1.8 Ghz - Ubuntu 18.04.3 LTS

PowerMac G4 QuickSilver 1467Mhz 2002 - Ubuntu MATE 16.04.2LTS
iPhone 6 - IOS 12.4.3
Go to the top of the page
 
+Quote Post
ch21
posté 19 Feb 2019, 20:08
Message #2


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 10 071
Inscrit : 4 Nov 2003
Lieu : 21000
Membre no 11 306



Whaou, et tout fonctionne ?
Il boote sur le SSD NVMe
La carte graphique est à fond
Le lecteur BR fonctionne
Les ports Usb/3 fonctionnent

Bravo !!!


--------------------
de l'Apple IIGS (1987) en GS/OS System 6.0.1 au Mac Mini I7 (2012) en Os 10.11.6 (et le dernier Système en date sur MBP)
Go to the top of the page
 
+Quote Post
Xander Cage
posté 19 Feb 2019, 20:49
Message #3


Macbidouilleur de bronze !
**

Groupe : Membres
Messages : 386
Inscrit : 14 Oct 2012
Lieu : Paris - France
Membre no 179 687



Citation (ch21 @ 19 Feb 2019, 20:08) *
Whaou, et tout fonctionne ?
Il boote sur le SSD NVMe
La carte graphique est à fond
Le lecteur BR fonctionne
Les ports Usb/3 fonctionnent

Bravo !!!


Bah oui,
Tout fonctionne nickel. Je réponds d'ailleurs à partir de cette machine.
La seule difficulté a été de trouver la bonne configuration de partition pour que ça marche.

En fait, j'étais quasiment sûr de réussir avec UBUNTU puisque le boot marchait sur le NVMe avec MOJAVE ...
Mais je le répète encore une fois, c'est du simple boot UBUNTU.


@+
Xander


--------------------
MacPro 2012 3,2 GHz XEON Octo-Core - RADEON RX 570 - Ubuntu 18.04.3 LTS
MacBook Air 2012 i5-1.8 Ghz - Ubuntu 18.04.3 LTS

PowerMac G4 QuickSilver 1467Mhz 2002 - Ubuntu MATE 16.04.2LTS
iPhone 6 - IOS 12.4.3
Go to the top of the page
 
+Quote Post
Xander Cage
posté 22 Feb 2019, 04:36
Message #4


Macbidouilleur de bronze !
**

Groupe : Membres
Messages : 386
Inscrit : 14 Oct 2012
Lieu : Paris - France
Membre no 179 687



mad.gif
Raahh, je n'arrive pas à inclure une image de capture d'écran dans ce post

Ce message a été modifié par Xander Cage - 22 Feb 2019, 04:37.


--------------------
MacPro 2012 3,2 GHz XEON Octo-Core - RADEON RX 570 - Ubuntu 18.04.3 LTS
MacBook Air 2012 i5-1.8 Ghz - Ubuntu 18.04.3 LTS

PowerMac G4 QuickSilver 1467Mhz 2002 - Ubuntu MATE 16.04.2LTS
iPhone 6 - IOS 12.4.3
Go to the top of the page
 
+Quote Post
baron
posté 22 Feb 2019, 09:22
Message #5


Macbidouilleur d'Or !
*****

Groupe : Modérateurs
Messages : 13 300
Inscrit : 22 Jul 2004
Lieu : Louvain-la-Neuve (Gaule Gelbique)
Membre no 21 291



Le plus simple est parfois de poster ton image sur un site d'hébergement puis d'utiliser le bouton insérer une image


--------------------
MacBook Pro 15’’ mi-2010 Core i5 2,53 GHz, 4 Go/SSD Samsung 850EVO 500 Go – Mac OSX 10.6.8  Power Macintosh G3 beige de bureau, rev.1 @ 233MHz, 288 Mo/4Go – MacOS 9.1 — + carte PCI IDE/ATA Tempo 66 Acard 6260 avec HD interne Maxtor 80 Go + graveur interne CDRW/DVD LG GCC-4520B + tablette A4 Wacom UD-0608-A + LaCie ElectronBlueIV 19" + HP ScanJet 6100C   Routeur/modem ADSL Trendnet TW100-BRM504 > B-Box 3 + HP LaserJet 4000 N  
La recherche dans MacBidouille vous paraît obscure ? J'ai rédigé une proposition de FAQ. Le moteur logiciel a un peu changé depuis mais ça peut aider quand même.
Les corsaires mettent en berne…
Go to the top of the page
 
+Quote Post
Xander Cage
posté 24 Feb 2019, 18:18
Message #6


Macbidouilleur de bronze !
**

Groupe : Membres
Messages : 386
Inscrit : 14 Oct 2012
Lieu : Paris - France
Membre no 179 687



https://postimg.cc/cg4txGKv][img]https://i.postimg.cc/mD7YSbBy/Capture-Struture-NVMe.png


Mouais, c'est pas encore ça ...

Ce message a été modifié par Xander Cage - 24 Feb 2019, 18:19.


--------------------
MacPro 2012 3,2 GHz XEON Octo-Core - RADEON RX 570 - Ubuntu 18.04.3 LTS
MacBook Air 2012 i5-1.8 Ghz - Ubuntu 18.04.3 LTS

PowerMac G4 QuickSilver 1467Mhz 2002 - Ubuntu MATE 16.04.2LTS
iPhone 6 - IOS 12.4.3
Go to the top of the page
 
+Quote Post
baron
posté 24 Feb 2019, 19:36
Message #7


Macbidouilleur d'Or !
*****

Groupe : Modérateurs
Messages : 13 300
Inscrit : 22 Jul 2004
Lieu : Louvain-la-Neuve (Gaule Gelbique)
Membre no 21 291



Ah oui… Outre que ton code était un peu embrouillé au final, une des deux adresses proposées par l'hébergeur n'était pas acceptée (*) :
Code
[img]https://postimg.cc/cg4txGKv[/img]


Mais celle-ci fonctionne :


Voici le BBCode correspondant :
Code
[img]https://i.postimg.cc/mD7YSbBy/Capture-Struture-NVMe.png[/img]

[Tu remarqueras que le codage est un peu différent des liens proposés par l'hébergeur.]

De manière ordinaire, pour utiliser le bouton Insérer une image, il suffit de cliquer dessus puis de coller l'URL de l'image dans la petite fenêtre de dialogue qui s'affiche.

(*) Cependant, quand l'URL se termine par un chiffre ou une référence « cabalistique », elle est rejetée par le moteur des forums. — Je présume que c'est pour éviter que la même référence soit réutilisée pour afficher tout autre chose… wink.gif


--------------------
MacBook Pro 15’’ mi-2010 Core i5 2,53 GHz, 4 Go/SSD Samsung 850EVO 500 Go – Mac OSX 10.6.8  Power Macintosh G3 beige de bureau, rev.1 @ 233MHz, 288 Mo/4Go – MacOS 9.1 — + carte PCI IDE/ATA Tempo 66 Acard 6260 avec HD interne Maxtor 80 Go + graveur interne CDRW/DVD LG GCC-4520B + tablette A4 Wacom UD-0608-A + LaCie ElectronBlueIV 19" + HP ScanJet 6100C   Routeur/modem ADSL Trendnet TW100-BRM504 > B-Box 3 + HP LaserJet 4000 N  
La recherche dans MacBidouille vous paraît obscure ? J'ai rédigé une proposition de FAQ. Le moteur logiciel a un peu changé depuis mais ça peut aider quand même.
Les corsaires mettent en berne…
Go to the top of the page
 
+Quote Post
Xander Cage
posté 25 Feb 2019, 05:55
Message #8


Macbidouilleur de bronze !
**

Groupe : Membres
Messages : 386
Inscrit : 14 Oct 2012
Lieu : Paris - France
Membre no 179 687



Merci baron pour le coup de main biggrin.gif


--------------------
MacPro 2012 3,2 GHz XEON Octo-Core - RADEON RX 570 - Ubuntu 18.04.3 LTS
MacBook Air 2012 i5-1.8 Ghz - Ubuntu 18.04.3 LTS

PowerMac G4 QuickSilver 1467Mhz 2002 - Ubuntu MATE 16.04.2LTS
iPhone 6 - IOS 12.4.3
Go to the top of the page
 
+Quote Post
Xander Cage
posté 30 Mar 2019, 02:28
Message #9


Macbidouilleur de bronze !
**

Groupe : Membres
Messages : 386
Inscrit : 14 Oct 2012
Lieu : Paris - France
Membre no 179 687




Bonjour,

J'ai essayé la même configuration de SSD (non NVME) sur un MacBook blanc de 2008 et ça ne marche pas.

Précision, en fait ça fonctionne, mais la 18.04 est trèèèès longue au boot et à l'utilisation les délais entre le clic de souris et
l'exécution de la commande sont insupportables.

Je pense que le noyau Linux 4.15 .xx est inadapté à un processeur IC2D car même avec une partition de SWAP, c'est inutilisable.

Je vous tiendrais au courrant de la suite de mes investigations ...

@ peluche
tongue.gif


--------------------
MacPro 2012 3,2 GHz XEON Octo-Core - RADEON RX 570 - Ubuntu 18.04.3 LTS
MacBook Air 2012 i5-1.8 Ghz - Ubuntu 18.04.3 LTS

PowerMac G4 QuickSilver 1467Mhz 2002 - Ubuntu MATE 16.04.2LTS
iPhone 6 - IOS 12.4.3
Go to the top of the page
 
+Quote Post
Xander Cage
posté 31 Mar 2019, 13:03
Message #10


Macbidouilleur de bronze !
**

Groupe : Membres
Messages : 386
Inscrit : 14 Oct 2012
Lieu : Paris - France
Membre no 179 687



Bonjour à tous,
Avancement des travaux sur UBUNTU-18.04 et les Mac's :

Je l'ai installée sur un MacBook Air de 2012 avec cette config':

Mémoire vive : 8 Go
SSD : OWC 256 Go
Processeur : i5-3427U CPU @ 1.80GHz × 4
Carte graphique : Ivybridge Mobile

J'ai utilisé exactement la même configuration de disque que sur la Mac Pro et ça fonctionne du premier coup !
biggrin.gif

Je posterais une recopie d'écran plus tard car je cherche toujours la solution pour faire fonctionner la distrib' sur le MacBook blanc de 2008
avec des délais d'utilisation raisonnables ... dry.gif


@ Plus

Ce message a été modifié par Xander Cage - 31 Mar 2019, 13:04.


--------------------
MacPro 2012 3,2 GHz XEON Octo-Core - RADEON RX 570 - Ubuntu 18.04.3 LTS
MacBook Air 2012 i5-1.8 Ghz - Ubuntu 18.04.3 LTS

PowerMac G4 QuickSilver 1467Mhz 2002 - Ubuntu MATE 16.04.2LTS
iPhone 6 - IOS 12.4.3
Go to the top of the page
 
+Quote Post
Xander Cage
posté 31 Mar 2019, 21:18
Message #11


Macbidouilleur de bronze !
**

Groupe : Membres
Messages : 386
Inscrit : 14 Oct 2012
Lieu : Paris - France
Membre no 179 687



Et hop, la recopie d'écran du MacBook Air



Bon, l'installation de la 18.04 LTS sur un MacBook blanc de 2008 s'avère largement au dessus de mes compétences techniques actuelles ... voir impossible vu le noyau Linux 4.15.0.46 de celle-ci.

En revanche, la 16.04 LTS s'est installé comme une fleur, le noyau 4.4.0.143 est très bien supporté par la machine.
La recopie d'écran kivabien :


La config' de la bête :

Mémoire vive : 4 Go
Processeur : IC2D T8100 @ 2.10 Ghz
Carte graphique : Intel 965GM
SSD : VERTEX 256 Go

Voili, voilou, voilà biggrin.gif

Ce message a été modifié par Xander Cage - 31 Mar 2019, 21:27.


--------------------
MacPro 2012 3,2 GHz XEON Octo-Core - RADEON RX 570 - Ubuntu 18.04.3 LTS
MacBook Air 2012 i5-1.8 Ghz - Ubuntu 18.04.3 LTS

PowerMac G4 QuickSilver 1467Mhz 2002 - Ubuntu MATE 16.04.2LTS
iPhone 6 - IOS 12.4.3
Go to the top of the page
 
+Quote Post
ch21
posté 5 Apr 2019, 17:26
Message #12


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 10 071
Inscrit : 4 Nov 2003
Lieu : 21000
Membre no 11 306



Chez moi c'est Mint18 sur mon MB blanc 2007 qui tourne très bien (en Dual-Boot)





--------------------
de l'Apple IIGS (1987) en GS/OS System 6.0.1 au Mac Mini I7 (2012) en Os 10.11.6 (et le dernier Système en date sur MBP)
Go to the top of the page
 
+Quote Post
Xander Cage
posté 5 Apr 2019, 18:21
Message #13


Macbidouilleur de bronze !
**

Groupe : Membres
Messages : 386
Inscrit : 14 Oct 2012
Lieu : Paris - France
Membre no 179 687



Citation (ch21 @ 5 Apr 2019, 17:26) *
Chez moi c'est Mint18 sur mon MB blanc 2007 qui tourne très bien (en Dual-Boot)

blink.gif
C'est normal le noyau 4.4.0.53 ?

Je viens de passer au 4.4.0.145 ... sur le MacBook blanc

Ce message a été modifié par Xander Cage - 5 Apr 2019, 18:23.


--------------------
MacPro 2012 3,2 GHz XEON Octo-Core - RADEON RX 570 - Ubuntu 18.04.3 LTS
MacBook Air 2012 i5-1.8 Ghz - Ubuntu 18.04.3 LTS

PowerMac G4 QuickSilver 1467Mhz 2002 - Ubuntu MATE 16.04.2LTS
iPhone 6 - IOS 12.4.3
Go to the top of the page
 
+Quote Post
ch21
posté 7 Apr 2019, 16:55
Message #14


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 10 071
Inscrit : 4 Nov 2003
Lieu : 21000
Membre no 11 306



Citation (Xander Cage @ 5 Apr 2019, 18:21) *
Citation (ch21 @ 5 Apr 2019, 17:26) *
Chez moi c'est Mint18 sur mon MB blanc 2007 qui tourne très bien (en Dual-Boot)

blink.gif
C'est normal le noyau 4.4.0.53 ?

Je viens de passer au 4.4.0.145 ... sur le MacBook blanc

Pas la moindre idée pour le 4.4.0.53…
J'ai bêtement installé ce que j'avais téléchargé sur le site de Mint, puis fait les MaJ.
Je n'y connais absolument rien, c'est juste pour avoir des navigateurs à jour dans certaines situations.


--------------------
de l'Apple IIGS (1987) en GS/OS System 6.0.1 au Mac Mini I7 (2012) en Os 10.11.6 (et le dernier Système en date sur MBP)
Go to the top of the page
 
+Quote Post
blueG3
posté 8 Apr 2019, 21:34
Message #15


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 3 783
Inscrit : 20 Nov 2001
Lieu : vitry sur seine (94)
Membre no 1 346



alors ce qu'il faut savoir :en demarrage install type USB avec Alt vous devriez voir monter les partition EFI d'install pour linux
pour parvenir a l'installer ( cas de mon macpro2008 )j'ai à la base formatter avec outils disque dur ( /boot/efi + GPt )
et effectuer l'installation en suite ( dans mon cas une manjaro )par contre , IL NE FAUT PAS COCHER /SELECTIONNER UN DISQUE DE DEMARRAGE sous osx--> recherche osx bootable + systeme , suppression de la ligne d’entrée pour vos linux ( ou autres systemes )

donc je démarre a chaque fois par Alt --> Grub --> la distribution Linux



--------------------
macpro 2008 quad core +8Go + 8800GT merci Nvidia & Apple pour la qualité et le choix de la carte! => ATI 5770 Apple + 2 DD WD 640Go + 2 SSD M4 Crucial 512Go(Raid 0) et Snow Leopard 10.6.8 + LG IPS235 flatron + Manjaro Linux sur DD interne - 18.03 Maté
Desktop - CPU : Intel® i7-6700K @ 4,2GHz - RAM 16 Go - CM: Gygabyte Z170X-UD5-TH CG : GeForce GTX 970- Audio: Intel® Sunrise Point-H HD Manjaro 18.04 xfce (testing)
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 utilisateur(s) sur ce sujet (1 invité(s) et 0 utilisateur(s) anonyme(s))
0 membre(s) :

 



Nous sommes le : 12th December 2019 - 08:17