IPB

Bienvenue invité ( Connexion | Inscription )

2 Pages V  < 1 2  
Reply to this topicStart new topic
> Clean install Mojave plante, install à partir d'un disque High Sierra sur un disque externe
Options
deneb
posté 23 Aug 2019, 23:47
Message #31


Adepte de Macbidouille
*

Groupe : Membres
Messages : 54
Inscrit : 16 Jul 2007
Membre no 90 739



Citation (polyzargone @ 23 Aug 2019, 20:00) *
Donc actuellement, tu as 2 disques branchés dans ton Hack contenant 2 Clover différents : 1 sous High Sierra et 1 sous Mojave.

Alors à moins que tu ne veuilles pas garder les deux OS sur ton Hack, il faut que tu n'aies qu'un seul Clover pour les démarrer tous les deux, pas 2. C'est pour ça que ta carte mère perd les pédales et change aléatoirement les réglages. C'est parce qu'elle ne sait pas choisir quel est le bon Clover.

Donc supprime l'un des deux Clover (celui de High Sierra par exemple) et utilise le dossier CLOVER que je t'ai fourni dans le post #17.


Je suis étonné de ta réponse car la carte mère sait bien sur quel disque démarrer (je lui dis si problème) donc elle devrait démarrer sur l'EFI du disque choisi pour le boot, non ?
Je veux garder la partition EFI et le Clover de mon disque High Sierra, qui ne démarre pas avec l'EFI/CLOVER de mon disque Mojave. Je vais tout simplement le cloner sur un vieux HD plateaux puis le débrancher...Je suis preneur d'une unique config EFI/CLOVER qui puisse faire démarrer les deux disques, mais pour l'instant j'ai pas trouvé ! Ton dossier CLOVER ne fait démarrer ni mon disque High sierra ni Mojave donc... je reste avec mon disque Mojave et son dossier EFI qui va bien. Tout fonctionne, mise en veille, réveil avec le son, etc. il ne me reste que les ports USB à régler mais je suis bloqué dans le tutoriel car je ne trouve pas les noms de ports avec IOJones.
Merci pour l'aide.


--------------------
Mac: Macbook Pro 13' 2015 SSD 256Mo Mem 8Mo
Plusieurs Hacks: Gigabyte Z77HN Wifi core i5, 16Mo, d'abord sous Chimera puis passé sous Clover pour El Capitan puis Sierra, Gigabyte H87N Wifi core i5, 16 Mo, et le plus récent Gigabyte Z97X-UD3H Z97PD3 -la précédente ayant rendu l'âme!- Intel Core i5 4690K 16Go et carte graphique Zotac GeForce GTX 750 2Go Gigabyte Aorus Radeon Rx 570 4Go dans un super boitier Cooler Master Silencio 550 (qui permet d'insérer à chaud dans une baie connectée en SATA un disque 3,5' )
Go to the top of the page
 
+Quote Post
polyzargone
posté 24 Aug 2019, 07:23
Message #32


Macbidouilleur d'Or !
*****

Groupe : Modérateurs
Messages : 11 150
Inscrit : 11 May 2006
Membre no 60 938



Quel est le souci avec le dossier Clover que je t'ai fourni ? Tu peux donner plus de détails (kernel panic, reboot direct, écran noir, etc.) ?

PS : En ce qui concerne le choix de l'EFI au démarrage, je me suis mal exprimé. Je voulais dire que même si tu indiques à ta carte-mère quel disque elle doit démarrer, c'est lorsque Clover est chargé qu'il ne sait pas quel config.plist utiliser.


--------------------
Un MacmacOS 10.13 MacBook Air mi-2012 Core i5 1,7 GHz Intel HD 4000 SSD 64 Go
Des Hacks Asus Z170-P - Core i7 6700 3,40 GHz - Sapphire RX 580 8 Go - 16 Go DDR4 - macOS 10.14/Win 10 Gigabyte H110M-S2H - Core i5 6600 3,30 GHz - Zotac GTX 750 Ti 2 Go - 16 Go DDR4 - macOS 10.14/macOS 10.13.6/macOS 10.12.6/Win 10 Gigabyte GA-H97-HD3 - Core i5 4570 3,20 GHz - Zotac Geforce GTX 1060 6 Go - 16 Go DDR3 - macOS 10.14/macOS 10.13.6/macOS 10.12/OS X 10.11.6/Win 10/Mint 18 Acer Aspire V3 772G Core i5 4210M 2,60 GHz - Intel HD 4600 + GTX 850M 2 Go (désactivée) - 16 Go DDR3 - macOS 10.14/macOS 10.13.6/Win 10/Mint 18 Dell Latitude e7440 Core i7 4600U 2,10 GHz - Intel HD 4400 - 16 Go DDR3 - macOS 10.14/macOS 10.13.6/Win 10 HP Elite 8300 USFF - Core i7 3770S 3,90 GHz - Intel HD 4000 - macOS 10.12/Win 10 - Clover (+ quelques autres...)

Politique vis à vis des outils automatisés et des distributions - Guide d'installation - Tutoriels - Lexique et utilité des Kexts - FAQ Générale du Hackintosh - FAQ des Bootloaders - FAQ des Bootflags - FAQ des problèmes les plus courants - FAQ sur les Mises à jour Majeures sur Hackintosh
Go to the top of the page
 
+Quote Post
deneb
posté 24 Aug 2019, 12:21
Message #33


Adepte de Macbidouille
*

Groupe : Membres
Messages : 54
Inscrit : 16 Jul 2007
Membre no 90 739



Citation (polyzargone @ 24 Aug 2019, 08:23) *
Quel est le souci avec le dossier Clover que je t'ai fourni ? Tu peux donner plus de détails (kernel panic, reboot direct, écran noir, etc.) ?

Démarrage sans écran Clover (on ne peut donc choisir le disque de boot), on arrive aux lignes violettes, long temps d'attente, bref flash, on arrive au bout de l'indicateur de progression, puis écrans noirs. Et ensuite je dois couper carrément le courant pour retrouver un fonctionnement normal (démarrage sur High Sierra en choisissant ce disque au boot de la CM). Autrement quelque soit le disque choisi au niveau CM on repart sur le démarrage auto sans écran Clover.

Citation (polyzargone @ 24 Aug 2019, 08:23) *
PS : En ce qui concerne le choix de l'EFI au démarrage, je me suis mal exprimé. Je voulais dire que même si tu indiques à ta carte-mère quel disque elle doit démarrer, c'est lorsque Clover est chargé qu'il ne sait pas quel config.plist utiliser.

Je croyais naïvement que Clover utilisait toujours la partition EFI du disque de démarrage !


--------------------
Mac: Macbook Pro 13' 2015 SSD 256Mo Mem 8Mo
Plusieurs Hacks: Gigabyte Z77HN Wifi core i5, 16Mo, d'abord sous Chimera puis passé sous Clover pour El Capitan puis Sierra, Gigabyte H87N Wifi core i5, 16 Mo, et le plus récent Gigabyte Z97X-UD3H Z97PD3 -la précédente ayant rendu l'âme!- Intel Core i5 4690K 16Go et carte graphique Zotac GeForce GTX 750 2Go Gigabyte Aorus Radeon Rx 570 4Go dans un super boitier Cooler Master Silencio 550 (qui permet d'insérer à chaud dans une baie connectée en SATA un disque 3,5' )
Go to the top of the page
 
+Quote Post
maclinuxG4
posté 24 Aug 2019, 12:37
Message #34


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 2 554
Inscrit : 28 Dec 2001
Lieu : ile de france
Membre no 1 715



Je croyais naïvement que Clover utilisait toujours la partition EFI du disque de démarrage !

oui, c'est le cas. Dans ton config.plist, tu indique que le disque de démarrage est celui ou il charge EFI.

il y as des mutualisation possible (par exemple, si les dossiers sont pratiquement identiques kexts, et patch kernel, si les os sont différents cela reste possible sans autre ajout. il te suffit d'avoir 2 config.plists l'un pour chaque os)


--------------------
hack gigadesign Z170-UD5 TH Skylane i7 6700k + 16 Go dimm + radeon 580 pulse 8192 mo+ 2 x 1 xT + SSD 1 T / 2 T + ethernet + acer XF240H+ macOS Mac OS 10.12.6 Mac OS 10.14.6 + imprimante HP5520 + (port DP / carte HDMI ) + H75 v2 +r5070
 macpro1,1 Dual core 2,66 GHz, 4 Go FB-dimm+ radeon HD 5770 + ST 500 Go + LCD Samsung 710T + Mac OS 10.6.8 + plantronics DSP 500 + Canon S50 + imprimante HP5520 +  ipad mini
► NO WINDOWS BOOT... Only  linux manjaro

--------------------
Go to the top of the page
 
+Quote Post
polyzargone
posté 25 Aug 2019, 18:32
Message #35


Macbidouilleur d'Or !
*****

Groupe : Modérateurs
Messages : 11 150
Inscrit : 11 May 2006
Membre no 60 938



Citation (deneb @ 24 Aug 2019, 12:21) *
Je croyais naïvement que Clover utilisait toujours la partition EFI du disque de démarrage !


Eh bien détrompe-toi.

Si tu ouvre le bdmesg.txt du Rapport de Mojave ( EFI Mojave), celui qui ne contient aucun kext dans le dossier Other, tu verras ça à la fin du fichier :

Citation
13:831 0:011 Preparing kexts injection for arch=x86_64 from EFI\CLOVER\kexts\Other
13:831 0:000 Extra kext: EFI\CLOVER\kexts\Other\IntelGraphicsFixup.kext (v.1.2.0)
13:841 0:009 Extra kext: EFI\CLOVER\kexts\Other\AppleALC.kext (v.1.2.6)
14:046 0:205 Extra kext: EFI\CLOVER\kexts\Other\Lilu.kext (v.1.2.3)
14:055 0:009 Extra kext: EFI\CLOVER\kexts\Other\realtekALC.kext (v.1.0)
14:075 0:019 Extra kext: EFI\CLOVER\kexts\Other\RealtekRTL8111.kext (v.2.2.1)
14:088 0:013 Extra kext: EFI\CLOVER\kexts\Other\FakeSMC.kext (v.1800)
14:108 0:019 Extra kext: EFI\CLOVER\kexts\Other\FakeSMC_LPCSensors.kext (v.1723)
14:381 0:273 Extra kext: EFI\CLOVER\kexts\Other\FakeSMC_GPUSensors.kext (v.1723)
14:394 0:013 Extra kext: EFI\CLOVER\kexts\Other\FakeSMC_ACPISensors.kext (v.1723)
14:412 0:017 Extra kext: EFI\CLOVER\kexts\Other\FakeSMC_CPUSensors.kext (v.1723)
14:421 0:008 Extra kext: EFI\CLOVER\kexts\Other\USBInjectAll.kext (v.0.5.17)
14:895 0:474 Preparing kexts injection for arch=x86_64 from EFI\CLOVER\kexts\10.13
14:896 0:000 SetScreenResolution: 1600x1200 - already set


Si tu ouvre le bdmesg du Rapport de High Sierra (EFI 860EVO), voilà ce que tu trouveras à la fin du bdmesg.txt :

Citation
16:846 0:005 Preparing kexts injection for arch=x86_64 from EFI\CLOVER\kexts\Other
16:848 0:002 Preparing kexts injection for arch=x86_64 from EFI\CLOVER\kexts\10.14
16:852 0:003 SetScreenResolution: 1600x1200 - already set


Alors que dans ce même EFI, dans kexts/Other, il y a ça :

IntelGraphicsFixup.kext
AppleALC.kext
Lilu.kext
realtekALC.kext
RealtekRTL8111.kext
FakeSMC.kext
FakeSMC_LPCSensors.kext
FakeSMC_GPUSensors.kext
FakeSMC_ACPISensors.kext
FakeSMC_CPUSensors.kext
USBInjectAll.kext

Donc pour résumer, lorsque tu as choisi de démarrer sur le disque Mojave, ce sont les fichiers du dossier CLOVER de High Sierra qui ont été utilisés lors du démarrage. Et inversement, lorsque tu as choisi la partition High Sierra, ce sont ceux de Mojave qui ont été chargés. Heureusement que les kexts dans Other de High Sierra se trouvent également dans Library/Extensions (pour le coup, tu peux remercier MultiBeast dry.gif) car sinon, tu n'aurais même pas pu démarrer.

C'est donc bien la preuve que Clover ne choisi pas obligatoirement la partition EFI que tu sélectionnes au démarrage pour charger le config.plist, les kexts, etc.

J'espère que tu comprends maintenant pourquoi il vaut mieux éviter d'avoir plusieurs installations de Clover (je ne reviendrai pas sur MultiBeast) parce qu'au final, tout cela est un joyeux bordel qui est inutilement compliqué à gérer et à maintenir à jour !

Donc la première chose que tu dois faire*, c'est virer les kexts installés par MultiBeast dans Library/Extensions à la fois sur High Sierra et Mojave (mais visiblement cet OS a été épargné), mettre les kexts dont tu as besoin dans l'unique dossier CLOVER/kexts/Other, et reconstruire le cache système sous High Sierra (car là, tu as touché au dossier Library/Extensions).

Ensuite, supprime le dossier EFI de la partition EFI de Mojave de façon à ce que seul le dossier EFI/CLOVER de High Sierra soit ton unique bootloader.

Une fois que tu auras fait ça, on verra plus clair sur ce qui t'empêche de démarrer…


* Je te sonseille également de faire une sauvegarde sur une clé de ton dossier CLOVER actuel, celui qui est fonctionnel.


--------------------
Un MacmacOS 10.13 MacBook Air mi-2012 Core i5 1,7 GHz Intel HD 4000 SSD 64 Go
Des Hacks Asus Z170-P - Core i7 6700 3,40 GHz - Sapphire RX 580 8 Go - 16 Go DDR4 - macOS 10.14/Win 10 Gigabyte H110M-S2H - Core i5 6600 3,30 GHz - Zotac GTX 750 Ti 2 Go - 16 Go DDR4 - macOS 10.14/macOS 10.13.6/macOS 10.12.6/Win 10 Gigabyte GA-H97-HD3 - Core i5 4570 3,20 GHz - Zotac Geforce GTX 1060 6 Go - 16 Go DDR3 - macOS 10.14/macOS 10.13.6/macOS 10.12/OS X 10.11.6/Win 10/Mint 18 Acer Aspire V3 772G Core i5 4210M 2,60 GHz - Intel HD 4600 + GTX 850M 2 Go (désactivée) - 16 Go DDR3 - macOS 10.14/macOS 10.13.6/Win 10/Mint 18 Dell Latitude e7440 Core i7 4600U 2,10 GHz - Intel HD 4400 - 16 Go DDR3 - macOS 10.14/macOS 10.13.6/Win 10 HP Elite 8300 USFF - Core i7 3770S 3,90 GHz - Intel HD 4000 - macOS 10.12/Win 10 - Clover (+ quelques autres...)

Politique vis à vis des outils automatisés et des distributions - Guide d'installation - Tutoriels - Lexique et utilité des Kexts - FAQ Générale du Hackintosh - FAQ des Bootloaders - FAQ des Bootflags - FAQ des problèmes les plus courants - FAQ sur les Mises à jour Majeures sur Hackintosh
Go to the top of the page
 
+Quote Post
polyzargone
posté 25 Aug 2019, 18:54
Message #36


Macbidouilleur d'Or !
*****

Groupe : Modérateurs
Messages : 11 150
Inscrit : 11 May 2006
Membre no 60 938



Utilise ce dossier CLOVER cette fois : https://drive.google.com/open?id=17KNhhnO4y...2V4LJbIXadzNRNS

PS : Met à jour ta signature. La Z97P-D3 n'y est pas.


--------------------
Un MacmacOS 10.13 MacBook Air mi-2012 Core i5 1,7 GHz Intel HD 4000 SSD 64 Go
Des Hacks Asus Z170-P - Core i7 6700 3,40 GHz - Sapphire RX 580 8 Go - 16 Go DDR4 - macOS 10.14/Win 10 Gigabyte H110M-S2H - Core i5 6600 3,30 GHz - Zotac GTX 750 Ti 2 Go - 16 Go DDR4 - macOS 10.14/macOS 10.13.6/macOS 10.12.6/Win 10 Gigabyte GA-H97-HD3 - Core i5 4570 3,20 GHz - Zotac Geforce GTX 1060 6 Go - 16 Go DDR3 - macOS 10.14/macOS 10.13.6/macOS 10.12/OS X 10.11.6/Win 10/Mint 18 Acer Aspire V3 772G Core i5 4210M 2,60 GHz - Intel HD 4600 + GTX 850M 2 Go (désactivée) - 16 Go DDR3 - macOS 10.14/macOS 10.13.6/Win 10/Mint 18 Dell Latitude e7440 Core i7 4600U 2,10 GHz - Intel HD 4400 - 16 Go DDR3 - macOS 10.14/macOS 10.13.6/Win 10 HP Elite 8300 USFF - Core i7 3770S 3,90 GHz - Intel HD 4000 - macOS 10.12/Win 10 - Clover (+ quelques autres...)

Politique vis à vis des outils automatisés et des distributions - Guide d'installation - Tutoriels - Lexique et utilité des Kexts - FAQ Générale du Hackintosh - FAQ des Bootloaders - FAQ des Bootflags - FAQ des problèmes les plus courants - FAQ sur les Mises à jour Majeures sur Hackintosh
Go to the top of the page
 
+Quote Post
deneb
posté 26 Aug 2019, 00:33
Message #37


Adepte de Macbidouille
*

Groupe : Membres
Messages : 54
Inscrit : 16 Jul 2007
Membre no 90 739



Citation (polyzargone @ 25 Aug 2019, 19:32) *
Citation (deneb @ 24 Aug 2019, 12:21) *
Je croyais naïvement que Clover utilisait toujours la partition EFI du disque de démarrage !

Eh bien détrompe-toi.

Donc pour résumer, lorsque tu as choisi de démarrer sur le disque Mojave, ce sont les fichiers du dossier CLOVER de High Sierra qui ont été utilisés lors du démarrage. Et inversement, lorsque tu as choisi la partition High Sierra, ce sont ceux de Mojave qui ont été chargés. Heureusement que les kexts dans Other de High Sierra se trouvent également dans Library/Extensions (pour le coup, tu peux remercier MultiBeast dry.gif ) car sinon, tu n'aurais même pas pu démarrer.

C'est donc bien la preuve que Clover ne choisi pas obligatoirement la partition EFI que tu sélectionnes au démarrage pour charger le config.plist, les kexts, etc.

J'espère que tu comprends maintenant pourquoi il vaut mieux éviter d'avoir plusieurs installations de Clover (je ne reviendrai pas sur MultiBeast) parce qu'au final, tout cela est un joyeux bordel qui est inutilement compliqué à gérer et à maintenir à jour !

C'est encore bien pire: j'ai maintenant compris pourquoi le hack démarrait dans certains cas (par ex. avec ton dossier Clover) directement sur le disque sans passer par Clover: j'ai découvert un dossier EFI à la racine de mon disque Mojave ! Je ne sais pas comment il est arrivé là, je ne pense pas que Multibeast soit coupable, mais j'avais tenté avant une installation manuelle de Clover. Et comme la partition EFI n'apparaissait pas au niveau carte mère (ou plus simplement que j'ai installé Clover ayant booté sur mon dossier Clover sans apfs.efi, qui donc ne pouvait voir le disque en APFS, l'installateur a sans doute installé Clover là où il pouvait: sur la partition Mojave ! J'ai viré tout ça (y compris le fichier boot.efi). Pour l'instant après redémarrage pas de différence, mais j'avais déjà rétabli une situation correcte avec mon dossier Clover qui va bien...Fichier joint  Capture_d___e__cran_2019_08_25_a___13.08.39.jpg ( 62.25 Ko ) Nombre de téléchargements : 4


Citation (polyzargone @ 25 Aug 2019, 19:32) *
Donc la première chose que tu dois faire*, c'est virer les kexts installés par MultiBeast dans Library/Extensions à la fois sur High Sierra et Mojave (mais visiblement cet OS a été épargné), mettre les kexts dont tu as besoin dans l'unique dossier CLOVER/kexts/Other, et reconstruire le cache système sous High Sierra (car là, tu as touché au dossier Library/Extensions).Ensuite, supprime le dossier EFI de la partition EFI de Mojave de façon à ce que seul le dossier EFI/CLOVER de High Sierra soit ton unique bootloader.

Une fois que tu auras fait ça, on verra plus clair sur ce qui t'empêche de démarrer…

OK c'est fait pour le nettoyage déplacement des kexts. Mais je me suis occupé essentiellement du disque Mojave (je vais effacer le SSD High Sierra dès que je suis sûr que tout est OK). Donc je garde pour l'instant les deux dossiers EFI car je n'ai encore jamais réussi à avoir une seule config Clover qui marche pour deux systèmes différents (sauf peut-être avec mon disque Sierra de secours qui fait aussi booter High Sierra). Quand je poursuivrai mes essais (je fais une pause de qq jours pour la rentrée) je débrancherai carrément le disque High Sierra pour éviter les interférences.[Jusqu'à maintenant je gardais les dossiers EFI des disques de boot par mesure de sécurité, pour être sûr qu'au moins je pourrai booter avec ceux-là ! Mais je suis d'accord avec toi, si Clover se trompe de dossier EFI ça fout le bordel !]


--------------------
Mac: Macbook Pro 13' 2015 SSD 256Mo Mem 8Mo
Plusieurs Hacks: Gigabyte Z77HN Wifi core i5, 16Mo, d'abord sous Chimera puis passé sous Clover pour El Capitan puis Sierra, Gigabyte H87N Wifi core i5, 16 Mo, et le plus récent Gigabyte Z97X-UD3H Z97PD3 -la précédente ayant rendu l'âme!- Intel Core i5 4690K 16Go et carte graphique Zotac GeForce GTX 750 2Go Gigabyte Aorus Radeon Rx 570 4Go dans un super boitier Cooler Master Silencio 550 (qui permet d'insérer à chaud dans une baie connectée en SATA un disque 3,5' )
Go to the top of the page
 
+Quote Post

2 Pages V  < 1 2
Reply to this topicStart new topic
1 utilisateur(s) sur ce sujet (1 invité(s) et 0 utilisateur(s) anonyme(s))
0 membre(s) :

 



Nous sommes le : 21st October 2019 - 23:58