IPB

Bienvenue invité ( Connexion | Inscription )

2 Pages V   1 2 >  
Reply to this topicStart new topic
> Pb MBP 15r El Capitan [Résolu], MBP 15r qui s'éteint tout seul
Options
mowg
posté 5 May 2018, 10:06
Message #1


Adepte de Macbidouille
*

Groupe : Membres
Messages : 257
Inscrit : 6 Feb 2013
Membre no 182 571



Bonjour à tous,

Depuis quelque temps, mon MBP 15 retina (2015) s'éteint tout seul.
J'ai l'impression que le problème arrive quand il se met à chauffer (à partir de 55°C 60°C selon SMC Fan control), mais aucune certitude à ce niveau là.

Après plusieurs Reset PRAM / SMC - clean install (El Capitan), le problème persiste.

Je pense à un problème hardware, mais avant de l'emmener en boutique j'aimerais essayer de vérifier toutes les autres options.

Du coup, après plusieurs recherches (et il semble que je ne sois pas le seul à qui ce probleme soit arrivé), je suis tombé sur ce site, dont le sujet a été marqué en "résolu" mais aucun retour de la part des utilisateurs quant à la solution proposée.
https://fr.ifixit.com/Answers/View/357764/M...Without+Warning

Pouvez vous me dire ce que vous pensez de la solution proposée (en bas de la page) ? En quoi consiste t'elle concrètement ?
Pensez vous que cela peut régler le pb ? Et surtout, n'est ce pas "dangereux" pour mon mac ?

Merci pour vos retours,



La solution proposée (pour ceux qui ne souhaitent pas lire tout le thread en anglais) :

"it's a software bug.

Rename /System/Library/Extensions/AppleThunderboltNHI.kext to /System/Library/Extensions/AppleThunderboltNHI.kext.BAK and the problem will go away.

Restart in Recovery mode (hold ⌘+r at Startup). Enter Terminal and type:

csrutil disable

to turn off System Integrity Protection (you cannot rename the file otherwise).

Restart

Enter Terminal and type:

sudo mv /System/Library/Extensions/AppleThunderboltNHI.kext /System/Library/Extensions/AppleThunderboltNHI.kext.BAK

Crashing is now solved.

Now turn System Integrity Protection back on by restarting in Recovery mode (hold ⌘+r at Startup). Enter Terminal and type:

csrutil enable

Restart and enjoy your Mac as normal.
"

Ce message a été modifié par mowg - 5 May 2018, 10:05.
Go to the top of the page
 
+Quote Post
stratele52
posté 5 May 2018, 11:16
Message #2


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 2 723
Inscrit : 5 Jan 2010
Lieu : Province de Québec
Membre no 148 203



Ton lien fait référence à un Mac Book Pro 15 po Unibody de 2009 .
À mon avis c'est très loin de ton modèle

Il chauffe ou pas ? As tu Macs Fan Control d'installé pour bien lire la température ?
Chauffe ; poussière à l'intérieur ? A nettoyer
Pâte thermique a remplacer ?

Il coupe même branché sur le transformateur ?

As-tu essayé sans aucun périphérique de branché ? Même pas de souris ?

Des modifications / réparations récentes effectuées ? Batterie , carte.....?

Ce message a été modifié par stratele52 - 5 May 2018, 11:18.


--------------------
I Mac fin 2013, 2,9 Ghz Intel core I5, 8 Go, SSD en externe , OS ...il change constamment
MacBook Pro 13 po fin 2011, 2,4Ghz Intel Core i5 16Go SSD , Sierra
I Pad mini , un vieux 2009 (?)
I Pod 2017
Go to the top of the page
 
+Quote Post
mowg
posté 5 May 2018, 11:44
Message #3


Adepte de Macbidouille
*

Groupe : Membres
Messages : 257
Inscrit : 6 Feb 2013
Membre no 182 571



Ok, j'avais pas fait attention qu'il s'agissait d'un MBP late 2008 dans le lien.

Sinon, pour répondre à tes questions, j'ai effectivement eu qqs problemes avec mon mac :

- 1 verre de coca qui s'est renversé sur le clavier il y a 1 an : PAs de dégâts apparents/directs
- Envoyé chez un réparateur (non agrée) pour un nettoyage
- Je lui fais confiance mais moyennement.... Certaines visses ont mal été replacées (j'ai perdu 3 visses sous le capot, je suppose qu'il n'a pas bien respecté les différentes positions)
- Il coupe aussi bien sur alimentation que sur batterie
- Aucun périph branché dessus

- J'ai SMC fan control (qui me permet de voir la température, et de régler les ventilos. D'ailleurs en cas de coupure, il a tendance à recouper aussitot si je rallume. Faire tourner les ventilos à fond grace à SMC me permet de pouvoir maintenir l'ordi allumé

- J'ai pensé à la solution du changement de la pâte thermique, mais le réparateur (susnommé) me le fait pour 79 euros.

- Aussi, j'avais eu un pb de batterie qui gonflait et qui provoquait un dysfonctionnement du trackpad il y a 2 ans. Ce pb avait été réglé et pris en charge par un réparateur agrée.


Sinon, en quoi consiste la solution proposée sur le forum ? (j'y connais rien)

Merci pour ta réponse
Go to the top of the page
 
+Quote Post
stratele52
posté 5 May 2018, 11:52
Message #4


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 2 723
Inscrit : 5 Jan 2010
Lieu : Province de Québec
Membre no 148 203



Oh là là tout ça peut être la cause de la fermeture inopinée.

Ça doit être absolument mentionné au départ.
Tous ces travaux ont peut-être été mal fait à voir les vis perdues .....?

Bonne chance.


--------------------
I Mac fin 2013, 2,9 Ghz Intel core I5, 8 Go, SSD en externe , OS ...il change constamment
MacBook Pro 13 po fin 2011, 2,4Ghz Intel Core i5 16Go SSD , Sierra
I Pad mini , un vieux 2009 (?)
I Pod 2017
Go to the top of the page
 
+Quote Post
mowg
posté 5 May 2018, 12:51
Message #5


Adepte de Macbidouille
*

Groupe : Membres
Messages : 257
Inscrit : 6 Feb 2013
Membre no 182 571



Et est ce qu'il y a moyen de savoir d'où vient le probleme dans la console ?

Mais effectivement, je pense que le probleme provient du fait que j'ai un jour renversé un verre PLEIN de coca sur le clavier (l'accident bete !). et même si j'ai eu de bons réflexes sur le coup (éponger, le retourner, faire tourner les ventilos), j'ai tjs pensé que tôt ou tard des condensateurs, ou des circuits souffriraient sans doute d'une usure/corrosion prématurée.

Mais comment savoir ? ohmy.gif

Et sinon, le simple fait qu'il manque 3 visses (celles qui tiennent le capot) pourrait être la cause ?? J'ai du mal à comprendre ça.
Go to the top of the page
 
+Quote Post
stratele52
posté 5 May 2018, 13:09
Message #6


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 2 723
Inscrit : 5 Jan 2010
Lieu : Province de Québec
Membre no 148 203



Citation (mowg @ 5 May 2018, 07:51) *
Et sinon, le simple fait qu'il manque 3 visses (celles qui tiennent le capot) pourrait être la cause ?? J'ai du mal à comprendre ça.



Non pas du tout


--------------------
I Mac fin 2013, 2,9 Ghz Intel core I5, 8 Go, SSD en externe , OS ...il change constamment
MacBook Pro 13 po fin 2011, 2,4Ghz Intel Core i5 16Go SSD , Sierra
I Pad mini , un vieux 2009 (?)
I Pod 2017
Go to the top of the page
 
+Quote Post
baron
posté 5 May 2018, 13:11
Message #7


Macbidouilleur d'Or !
*****

Groupe : Modérateurs
Messages : 13 228
Inscrit : 22 Jul 2004
Lieu : Louvain-la-Neuve (Gaule Gelbique)
Membre no 21 291



Citation (mowg @ 5 May 2018, 11:06) *
Pouvez vous me dire ce que vous pensez de la solution proposée (en bas de la page) ? En quoi consiste t'elle concrètement ?
Pensez vous que cela peut régler le pb ? Et surtout, n'est ce pas "dangereux" pour mon mac ?

Bonjour,

La solution proposée consiste simplement à désactiver l'« extension noyau » (kext), une forme de pilote, qui gère Ethernet via l'interface Thunderbolt, apparemment buguée. En la renommant (ajout de l'extension .BAK à la fin), elle ne se chargera plus au démarrage.

Ça ne coûte rien d'essayer. Au pire, il suffit de faire la manœuvre inverse pour remettre les choses en l'état.

Je traduis les instructions :
Citation
1) Désactiver le SIP
• Redémarrer en mode Recovery (enfoncer les touches ⌘+r au démarrage),
• Lancer le Terminal (via le menu Utilitaires) et taper la commande :
Code
csrutil disable
en validant la commande avec la touche Enter. — Ceci désactive le SIP (System Integrity Protection), qui autrement empêche de renommer l'extension.
• Redémarrer.

2) Désactiver l'extension buguée en la renommant
• De retour dans votre session, ouvrir le Terminal (qui se trouve dans le dossier Applications > Utilitaires) et taper (ou copier-coller pour plus de sûreté…) :
Code
sudo mv /System/Library/Extensions/AppleThunderboltNHI.kext /System/Library/Extensions/AppleThunderboltNHI.kext.BAK
suivi d'Enter.
• Le mot de passe administrateur est demandé ; le taper à l'aveugle (rien ne s'affiche) et valider de nouveau.
Le problème est résolu.

3) Réactiver le SIP
• Redémarrer en mode Recovery (⌘+r au démarrage).
• Ouvrir le Terminal (via le menu Utilitaires) et taper la commande :
Code
csrutil enable
suivie d'Enter,
• Redémarrer.


— En cas de besoin, pour remettre les choses dans leur état d'origine, passer de la même manière la commande inverse :
Code
sudo mv /System/Library/Extensions/AppleThunderboltNHI.kext.BAK /System/Library/Extensions/AppleThunderboltNHI.kext


(Le problème semble assez courant et sur plusieurs modèles, voir p.ex. https://outluch.wixsite.com/rmbp-crash — solution trouvée à partir de ce post : https://forums.macrumors.com/threads/help-u...#post-25605293)

+++++++++++++++++++
[Edit du 12 octobre 2019]

Depuis Catalina, le Système est monté en lecture seule. Pour renommer le fichier incriminé, il faut donc redémarrer sur la partition de récupération et indiquer le chemin complet vers le disque principal.
Voir le message suivant pour la procédure détaillée : https://forum.macbidouille.com/index.php?s=...t&p=4294514

Ce message a été modifié par baron - 12 Oct 2019, 13:19.
Raison de l'édition : Précisions sur le lancement du Terminal, en mode Recovery ou normal


--------------------
MacBook Pro 15’’ mi-2010 Core i5 2,53 GHz, 4 Go/SSD Samsung 850EVO 500 Go – Mac OSX 10.6.8  Power Macintosh G3 beige de bureau, rev.1 @ 233MHz, 288 Mo/4Go – MacOS 9.1 — + carte PCI IDE/ATA Tempo 66 Acard 6260 avec HD interne Maxtor 80 Go + graveur interne CDRW/DVD LG GCC-4520B + tablette A4 Wacom UD-0608-A + LaCie ElectronBlueIV 19" + HP ScanJet 6100C   Routeur/modem ADSL Trendnet TW100-BRM504 > B-Box 3 + HP LaserJet 4000 N  
La recherche dans MacBidouille vous paraît obscure ? J'ai rédigé une proposition de FAQ. Le moteur logiciel a un peu changé depuis mais ça peut aider quand même.
Les corsaires mettent en berne…
Go to the top of the page
 
+Quote Post
mowg
posté 5 May 2018, 16:17
Message #8


Adepte de Macbidouille
*

Groupe : Membres
Messages : 257
Inscrit : 6 Feb 2013
Membre no 182 571



Merci pour la traduction de l'opération. Je viens de faire une tentative, mais je crois pas que ça ait marché. Y'a t'il un moyen de vérifier ?

Concernant les travaux qui ont été mal faits, je veux bien y croire, car je me rappelle avoir du ramener le mac car il avait oublié de brancher un HP...
Mais vu que le probleme n'est apparu plusieurs mois après, je ne pense pas que ces travaux mal faits soient soient la cause de la panne. A voir.
Go to the top of the page
 
+Quote Post
bigmechantmou
posté 5 May 2018, 17:19
Message #9


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 11 416
Inscrit : 16 Jul 2010
Lieu : Paris, Montmartre
Membre no 156 738



Bonjour,

Les symptômes semblent indiquer la mise en sécurité du mac pour cause de surchauffe CPU ou GPU.

Les causes sont souvent la poussière accumulée jusqu'au ventirad, mais dans le cas du verre de coca renversé ça peut jouer aussi si la désoxydation de la CM n'a pas été correctement réalisée.

Je conseille donc d'ouvrir via tutoriel sur ifixit, nettoyer et remplacer la pâte thermique, et inspecter d'éventuelles traces de corrosion sur la CM. Tenter un nettoyage éventuel à l'alcool.


--------------------

"Les virus sur mac c'est comme les extra-terrestres, certains en ont vu..."

----------------------

Mac mini early 2009 2GHz, SSD Crucial MX500 250Go, 8Go ram (Snow Leopard) + iiyama 27".
Macbook Pro mid 2009 13" 2,53Ghz, SSD intel 40Go, 4Go ram (Snow Leopard).
Macbook Pro mid 2009 15" 2,53Ghz, SSD Crucial MX500 1To, 8Go ram (Snow Leopard).
Powermac G4 Quicksilver 800Mhz, 1.5Go ram, carte ATI Radeon 9200, carte 2x sata, carte 5x USB (Tiger).
Go to the top of the page
 
+Quote Post
baron
posté 5 May 2018, 17:40
Message #10


Macbidouilleur d'Or !
*****

Groupe : Modérateurs
Messages : 13 228
Inscrit : 22 Jul 2004
Lieu : Louvain-la-Neuve (Gaule Gelbique)
Membre no 21 291



Citation (mowg @ 5 May 2018, 17:17) *
Merci pour la traduction de l'opération. Je viens de faire une tentative, mais je crois pas que ça ait marché. Y a-t-il un moyen de vérifier ?

Passe la commande informative (qui liste le contenu du dossier indiqué)
Code
ls /System/Library/Extensions/
et regarde si l'extension AppleThunderboltNHI.kext a bien été renommée en /AppleThunderboltNHI.kext.BAK.


--------------------
MacBook Pro 15’’ mi-2010 Core i5 2,53 GHz, 4 Go/SSD Samsung 850EVO 500 Go – Mac OSX 10.6.8  Power Macintosh G3 beige de bureau, rev.1 @ 233MHz, 288 Mo/4Go – MacOS 9.1 — + carte PCI IDE/ATA Tempo 66 Acard 6260 avec HD interne Maxtor 80 Go + graveur interne CDRW/DVD LG GCC-4520B + tablette A4 Wacom UD-0608-A + LaCie ElectronBlueIV 19" + HP ScanJet 6100C   Routeur/modem ADSL Trendnet TW100-BRM504 > B-Box 3 + HP LaserJet 4000 N  
La recherche dans MacBidouille vous paraît obscure ? J'ai rédigé une proposition de FAQ. Le moteur logiciel a un peu changé depuis mais ça peut aider quand même.
Les corsaires mettent en berne…
Go to the top of the page
 
+Quote Post
mowg
posté 5 May 2018, 18:29
Message #11


Adepte de Macbidouille
*

Groupe : Membres
Messages : 257
Inscrit : 6 Feb 2013
Membre no 182 571



Checked !

L'extension AppleThunderboltNHI.kext a bien été renommée en /AppleThunderboltNHI.kext.BAK (voir pj)
De plus, j'ai fait chauffer un peu la température du mac tout à l'heure, en poussant un peu le CPU; il est resté entre 65°C et 70°C (avec des pointes à 75°C) pendant un bon quart d'heure et pas de coupures.
Vu que les coupures sont quand même trés aléatoires, j'attends encore quelques jours pour passer le fil en résolu (si la solution proposée a marché)
Sinon, je passerais pas la case ifixit, démontage/nettoyage. (étape 1 : acheter un tournevis cool.gif )

Merci à tous !




Mais ca serait quand même bien étrange que ce problème qui semble tout à fait hardware soit en fait un simple bug...

Ce message a été modifié par mowg - 5 May 2018, 18:23.
Go to the top of the page
 
+Quote Post
mowg
posté 7 May 2018, 21:30
Message #12


Adepte de Macbidouille
*

Groupe : Membres
Messages : 257
Inscrit : 6 Feb 2013
Membre no 182 571



Incroyable mais cette solution a l'air de fonctionner !! D'autant que les symptômes décrits dans le site (écran noir + ventilos + coupure) correspondaient parfaitement.
Je veux pas crier victoire trop tôt, mais c'est pas trop mal parti, car malgré une utilisation intensive : aucune coupure depuis l'opération.


Mais y'a quand même un truc qui j'ai du mal à comprendre, c'est que si c'est software, pourquoi je n'ai eu aucun probleme pendant des années et que tout d'un coup il s'est mis à buguer. Ca semble assez illogique avec un bug du driver.

Si jamais qqn a une théorie je suis preneur.


PS : et du coup si c'est software, j'avais posté mon fil au bon endroit wink.gif
Go to the top of the page
 
+Quote Post
mowg
posté 9 May 2018, 22:08
Message #13


Adepte de Macbidouille
*

Groupe : Membres
Messages : 257
Inscrit : 6 Feb 2013
Membre no 182 571



Improbable solution mais ça marche !
J'ai pas réussi à passer le fil en résolu, mais problem solved !
Merci à tous ! J'ai économisé des centaines d'euros et j'espère garder mon mac encore qqs années ! (je commençais déjà à lorgner sur les nouveauw DELL XPS 2en1)

Enfin bon, je voulais quand même dire, pour finir, qu'on ne peut pas dire qu'Apple se soit beaucoup manifesté concernant ce problème (connu)...Tout comme le fait que certaines clés USB 3 provoquent un dysfonctionnement du wifi sur certains MBP (une histoire de "basses fréquences" encore...)

Bref, content de garder mon MBP, mais ca sera le dernier.

Ce message a été modifié par mowg - 9 May 2018, 22:09.
Go to the top of the page
 
+Quote Post
bigmechantmou
posté 9 May 2018, 22:22
Message #14


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 11 416
Inscrit : 16 Jul 2010
Lieu : Paris, Montmartre
Membre no 156 738



Citation (mowg @ 9 May 2018, 23:08) *
J'ai pas réussi à passer le fil en résolu, mais problem solved !

Faut faire édition complète et taper Résolu dans le titre.

Par contre si le sujet est trop vieux ça ne sera plus possible


--------------------

"Les virus sur mac c'est comme les extra-terrestres, certains en ont vu..."

----------------------

Mac mini early 2009 2GHz, SSD Crucial MX500 250Go, 8Go ram (Snow Leopard) + iiyama 27".
Macbook Pro mid 2009 13" 2,53Ghz, SSD intel 40Go, 4Go ram (Snow Leopard).
Macbook Pro mid 2009 15" 2,53Ghz, SSD Crucial MX500 1To, 8Go ram (Snow Leopard).
Powermac G4 Quicksilver 800Mhz, 1.5Go ram, carte ATI Radeon 9200, carte 2x sata, carte 5x USB (Tiger).
Go to the top of the page
 
+Quote Post
baron
posté 9 May 2018, 23:59
Message #15


Macbidouilleur d'Or !
*****

Groupe : Modérateurs
Messages : 13 228
Inscrit : 22 Jul 2004
Lieu : Louvain-la-Neuve (Gaule Gelbique)
Membre no 21 291



Citation (bigmechantmou @ 9 May 2018, 23:22) *
Citation (mowg @ 9 May 2018, 23:08) *
J'ai pas réussi à passer le fil en résolu, mais problem solved !

Faut faire édition complète et taper Résolu dans le titre.

Par contre si le sujet est trop vieux ça ne sera plus possible

On a un mois pour le faire, autrement un modérateur peut s'en charger s'il passe par là. wink.gif


--------------------
MacBook Pro 15’’ mi-2010 Core i5 2,53 GHz, 4 Go/SSD Samsung 850EVO 500 Go – Mac OSX 10.6.8  Power Macintosh G3 beige de bureau, rev.1 @ 233MHz, 288 Mo/4Go – MacOS 9.1 — + carte PCI IDE/ATA Tempo 66 Acard 6260 avec HD interne Maxtor 80 Go + graveur interne CDRW/DVD LG GCC-4520B + tablette A4 Wacom UD-0608-A + LaCie ElectronBlueIV 19" + HP ScanJet 6100C   Routeur/modem ADSL Trendnet TW100-BRM504 > B-Box 3 + HP LaserJet 4000 N  
La recherche dans MacBidouille vous paraît obscure ? J'ai rédigé une proposition de FAQ. Le moteur logiciel a un peu changé depuis mais ça peut aider quand même.
Les corsaires mettent en berne…
Go to the top of the page
 
+Quote Post
vousti
posté 17 May 2018, 11:44
Message #16


Adepte de Macbidouille
*

Groupe : Membres
Messages : 53
Inscrit : 11 Jun 2006
Lieu : hirtzbach
Membre no 62 792



Citation (mowg @ 5 May 2018, 19:29) *
Checked !

L'extension AppleThunderboltNHI.kext a bien été renommée en /AppleThunderboltNHI.kext.BAK (voir pj)
De plus, j'ai fait chauffer un peu la température du mac tout à l'heure, en poussant un peu le CPU; il est resté entre 65°C et 70°C (avec des pointes à 75°C) pendant un bon quart d'heure et pas de coupures.
Vu que les coupures sont quand même trés aléatoires, j'attends encore quelques jours pour passer le fil en résolu (si la solution proposée a marché)
Sinon, je passerais pas la case ifixit, démontage/nettoyage. (étape 1 : acheter un tournevis cool.gif )

Merci à tous !




Mais ca serait quand même bien étrange que ce problème qui semble tout à fait hardware soit en fait un simple bug...




Bonjour, j'ai les mêmes soucis avec un MacBook Pro late 2013 et Sierra, j'ai fait cette manipulation et quand je vérifie j'ai l'extension en double.
Une qui se termine en .kext et l'autre renommée en .kext.BAK et il continue de planter....
Des idées?

Update.

J'ai fait une mise à jour juste derrière cela a peut être réactivé l'extension, j'ai refait la manipulation j'espère que c'est ça.

Ce message a été modifié par vousti - 17 May 2018, 12:00.


--------------------
macbook 1.1 core duo 2ghz 10.6.8 - MacBook Pro late 2013 2ghz 10.12.6
Go to the top of the page
 
+Quote Post
baron
posté 17 May 2018, 12:53
Message #17


Macbidouilleur d'Or !
*****

Groupe : Modérateurs
Messages : 13 228
Inscrit : 22 Jul 2004
Lieu : Louvain-la-Neuve (Gaule Gelbique)
Membre no 21 291



Citation (vousti @ 17 May 2018, 12:44) *
Update.

J'ai fait une mise à jour juste derrière, cela a peut être réactivé l'extension, j'ai refait la manipulation j'espère que c'est ça.
thumb.gif
Oui, c'est un contournement qui ne résiste pas aux mises-à-jour du système. Il faut donc répéter la manœuvre.


--------------------
MacBook Pro 15’’ mi-2010 Core i5 2,53 GHz, 4 Go/SSD Samsung 850EVO 500 Go – Mac OSX 10.6.8  Power Macintosh G3 beige de bureau, rev.1 @ 233MHz, 288 Mo/4Go – MacOS 9.1 — + carte PCI IDE/ATA Tempo 66 Acard 6260 avec HD interne Maxtor 80 Go + graveur interne CDRW/DVD LG GCC-4520B + tablette A4 Wacom UD-0608-A + LaCie ElectronBlueIV 19" + HP ScanJet 6100C   Routeur/modem ADSL Trendnet TW100-BRM504 > B-Box 3 + HP LaserJet 4000 N  
La recherche dans MacBidouille vous paraît obscure ? J'ai rédigé une proposition de FAQ. Le moteur logiciel a un peu changé depuis mais ça peut aider quand même.
Les corsaires mettent en berne…
Go to the top of the page
 
+Quote Post
mowg
posté 19 May 2018, 10:30
Message #18


Adepte de Macbidouille
*

Groupe : Membres
Messages : 257
Inscrit : 6 Feb 2013
Membre no 182 571



Je ne savais pas que les MàJ réinitialisaient ce paramètre, c'est bon à savoir.

Sinon, je passais juste par là pour confirmer que cette solution fonctionne (après 2 semaines d'utilisation, plus aucun crash).
Et les ports thunderbolt en HDMI continuent de fonctionner.

Par contre, je me pose toujours la question du pourquoi et qu'est ce qui a fait que pendant 3 ans mon mac a fonctionné parfaitement et que ce bug est apparu subitement ?
Est ce que ce bug pourrait disparaitre comme il est apparu ?

Ce message a été modifié par mowg - 19 May 2018, 10:31.
Go to the top of the page
 
+Quote Post
vousti
posté 20 May 2018, 18:00
Message #19


Adepte de Macbidouille
*

Groupe : Membres
Messages : 53
Inscrit : 11 Jun 2006
Lieu : hirtzbach
Membre no 62 792



Citation (baron @ 17 May 2018, 13:53) *
Citation (vousti @ 17 May 2018, 12:44) *
Update.

J'ai fait une mise à jour juste derrière, cela a peut être réactivé l'extension, j'ai refait la manipulation j'espère que c'est ça.
thumb.gif
Oui, c'est un contournement qui ne résiste pas aux mises-à-jour. Il faut donc répéter la manœuvre.


Tout à fait!!!


--------------------
macbook 1.1 core duo 2ghz 10.6.8 - MacBook Pro late 2013 2ghz 10.12.6
Go to the top of the page
 
+Quote Post
Yakalo
posté 24 Jun 2018, 11:41
Message #20


Macbidouilleur d'argent !
***

Groupe : Membres
Messages : 648
Inscrit : 8 Feb 2003
Lieu : à un bout du fil…
Membre no 6 062



Putains de 1000 merci ! ! ! ! ! cool.gif


--------------------
MAC YARD - Qr design

MacBook Pro (Retina, 15 pouces, fin 2013)
Go to the top of the page
 
+Quote Post
effixl88
posté 5 Nov 2018, 00:38
Message #21


Nouveau Membre


Groupe : Membres
Messages : 1
Inscrit : 5 Nov 2018
Membre no 206 275



J'avais exactement le même problème avec mon MBP Retina 15po mid 2014. 2 ans après l'achat il avait les mêmes symptômes : arrêt brutal, écran noir, parfois les ventilos au max puis il s'éteignait. Plus souvent lorsque je l'avais sur les genoux. On m'a alors changé la carte mère (sous garantie) et tout allait bien. Puis il y a quelques semaines (septembre 2018), le même cirque a recommencé. On m'a re-changé la carte mère, mais cette fois sans résultat.

Je suis tombé sur ce post et à mon immense, mais vraiment titanesque surprise, il semble que la recette du " AppleThunderboltNHI.kext" fonctionne. Je crois vraiment rêver, mais depuis 3 jours, aucun plantage.

Mille mercis aux gens qui ont relayé cette précieuse information. Je dois dire que je partage l'avis qu'on émis certains sur le service de Apple : on fait avant tout dans l'obsolescence programmée, le vieux matos préhistorique d'il y a quatre longues années, on s'en tape. C'est mon dernier mac, ça c'est certain.

Go to the top of the page
 
+Quote Post
mowg
posté 8 Nov 2018, 13:13
Message #22


Adepte de Macbidouille
*

Groupe : Membres
Messages : 257
Inscrit : 6 Feb 2013
Membre no 182 571



Content que ca marche ! wink.gif
Juste au cas où t'aurais pas lu le fil intégralement, manip à refaire après chaque grosse Mise à jour (MàJ sécurité, ou upgrade par exemple)

Enjoy !
Go to the top of the page
 
+Quote Post
durant45
posté 9 Nov 2018, 11:00
Message #23


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 3 009
Inscrit : 8 Feb 2002
Membre no 2 000



j'ai le soucis sur un macbook pro 17 pouce, je vais tenter la manipe. Nan ca veut pas.


Ce message a été modifié par durant45 - 12 Nov 2018, 08:07.


--------------------
Imac Corei7 2011 Full options sous High Sierra

ipad Mini 4, iphone 6
NAS QNAP TS-420
Go to the top of the page
 
+Quote Post
tibo38
posté 10 Apr 2019, 15:38
Message #24


Nouveau Membre


Groupe : Membres
Messages : 5
Inscrit : 10 Apr 2019
Membre no 207 810



Citation (vousti @ 20 May 2018, 18:00) *
Citation (baron @ 17 May 2018, 13:53) *
Citation (vousti @ 17 May 2018, 12:44) *
Update.

J'ai fait une mise à jour juste derrière, cela a peut être réactivé l'extension, j'ai refait la manipulation j'espère que c'est ça.
thumb.gif
Oui, c'est un contournement qui ne résiste pas aux mises-à-jour. Il faut donc répéter la manœuvre.


Tout à fait!!!


Hello, pour ma part j'avais essayé dans le passé et votre magnifique méthode fonctionnait.
Mais lors de la mise à jour en Mojave c'est revenu.
Je re-tente la solution : sudo mv /System/Library/Extensions/AppleThunderboltNHI.kext /System/Library/Extensions/AppleThunderboltNHI.kext.BAK

mais quand je met le mdp et j'appuie sur "entrée" il me dit : mv: rename /System/Library/Extensions/AppleThunderboltNHI.kext to /System/Library/Extensions/AppleThunderboltNHI.kext.BAK/AppleThunderboltNHI.kext: Directory not empty

Que dois-je faire ?

Merci pour votre aide !
Go to the top of the page
 
+Quote Post
jeanjd63
posté 10 Apr 2019, 16:34
Message #25


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 3 715
Inscrit : 15 Nov 2007
Lieu : Ardèche
Membre no 99 922



Citation (tibo38 @ 10 Apr 2019, 16:38) *
Hello, pour ma part j'avais essayé dans le passé et votre magnifique méthode fonctionnait.
Mais lors de la mise à jour en Mojave c'est revenu.
Je re-tente la solution :
sudo mv /System/Library/Extensions/AppleThunderboltNHI.kext /System/Library/Extensions/AppleThunderboltNHI.kext.BAKsudo mv /System/Library/Extensions/AppleThunderboltNHI.kext /System/Library/Extensions/AppleThunderboltNHI.kext.BAK

mais quand je met le mdp et j'appuie sur "entrée" il me dit : mv: rename /System/Library/Extensions/AppleThunderboltNHI.kext to /System/Library/Extensions/AppleThunderboltNHI.kext.BAK/AppleThunderboltNHI.kext: Directory not empty

Que dois-je faire ?

Merci pour votre aide !


Tu peux tenter :

soit :

Code
sudo mv /System/Library/Extensions/AppleThunderboltNHI.kext /System/Library/Extensions/AppleThunderboltNHI.kext.OLD


soit :

Code
sudo rm -r  /System/Library/Extensions/AppleThunderboltNHI.kext.BAK


suivi de :

Code
sudo mv /System/Library/Extensions/AppleThunderboltNHI.kext /System/Library/Extensions/AppleThunderboltNHI.kext.BAK



Go to the top of the page
 
+Quote Post
tibo38
posté 10 Apr 2019, 17:08
Message #26


Nouveau Membre


Groupe : Membres
Messages : 5
Inscrit : 10 Apr 2019
Membre no 207 810



Citation (jeanjd63 @ 10 Apr 2019, 16:34) *
Citation (tibo38 @ 10 Apr 2019, 16:38) *
Hello, pour ma part j'avais essayé dans le passé et votre magnifique méthode fonctionnait.
Mais lors de la mise à jour en Mojave c'est revenu.
Je re-tente la solution :
sudo mv /System/Library/Extensions/AppleThunderboltNHI.kext /System/Library/Extensions/AppleThunderboltNHI.kext.BAKsudo mv /System/Library/Extensions/AppleThunderboltNHI.kext /System/Library/Extensions/AppleThunderboltNHI.kext.BAK

mais quand je met le mdp et j'appuie sur "entrée" il me dit : mv: rename /System/Library/Extensions/AppleThunderboltNHI.kext to /System/Library/Extensions/AppleThunderboltNHI.kext.BAK/AppleThunderboltNHI.kext: Directory not empty

Que dois-je faire ?

Merci pour votre aide !


Tu peux tenter :

soit :

Code
sudo mv /System/Library/Extensions/AppleThunderboltNHI.kext /System/Library/Extensions/AppleThunderboltNHI.kext.OLD


soit :

Code
sudo rm -r  /System/Library/Extensions/AppleThunderboltNHI.kext.BAK


suivi de :

Code
sudo mv /System/Library/Extensions/AppleThunderboltNHI.kext /System/Library/Extensions/AppleThunderboltNHI.kext.BAK







Ca me dit pour les 2 :

MacBook-Pro-de-Thibault:~ thibault$ sudo rm -r /System/Library/Extensions/AppleThunderboltNHI.kext.BAK
Password:
rm: /System/Library/Extensions/AppleThunderboltNHI.kext.BAK: No such file or directory
MacBook-Pro-de-Thibault:~ thibault$ sudo mv /System/Library/Extensions/AppleThunderboltNHI.kext /System/Library/Extensions/AppleThunderboltNHI.kext.BAK
mv: rename /System/Library/Extensions/AppleThunderboltNHI.kext to /System/Library/Extensions/AppleThunderboltNHI.kext.BAK: No such file or directory
MacBook-Pro-de-Thibault:~ thibault$
Go to the top of the page
 
+Quote Post
jeanjd63
posté 10 Apr 2019, 17:13
Message #27


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 3 715
Inscrit : 15 Nov 2007
Lieu : Ardèche
Membre no 99 922



Et si tu fais :

Code
ls -ld /System/Library/Extensions/AppleThunderboltNHI.kext*


ça dit quoi?

Ce message a été modifié par jeanjd63 - 10 Apr 2019, 17:14.
Go to the top of the page
 
+Quote Post
tibo38
posté 10 Apr 2019, 17:19
Message #28


Nouveau Membre


Groupe : Membres
Messages : 5
Inscrit : 10 Apr 2019
Membre no 207 810



Citation (jeanjd63 @ 10 Apr 2019, 17:13) *
Et si tu fais :

Code
ls -ld /System/Library/Extensions/AppleThunderboltNHI.kext*


ça dit quoi?


Ca dit :

MacBook-Pro-de-Thibault:~ thibault$ ls -ld /System/Library/Extensions/AppleThunderboltNHI.kext*
ls: /System/Library/Extensions/AppleThunderboltNHI.kext*: No such file or directory
Go to the top of the page
 
+Quote Post
jeanjd63
posté 10 Apr 2019, 17:28
Message #29


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 3 715
Inscrit : 15 Nov 2007
Lieu : Ardèche
Membre no 99 922



Ce qui indique que /System/Library/Extensions/AppleThunderboltNHI.kext n'est plus présent sur ton système. biggrin.gif
Go to the top of the page
 
+Quote Post
tibo38
posté 10 Apr 2019, 17:33
Message #30


Nouveau Membre


Groupe : Membres
Messages : 5
Inscrit : 10 Apr 2019
Membre no 207 810



biggrin.gif
Citation (jeanjd63 @ 10 Apr 2019, 17:28) *
Ce qui indique que /System/Library/Extensions/AppleThunderboltNHI.kext n'est plus présent sur ton système. biggrin.gif



biggrin.gif purée mais pourquoi il recommence à s'éteindre ce mac de m****** alors !
Go to the top of the page
 
+Quote Post

2 Pages V   1 2 >
Reply to this topicStart new topic
2 utilisateur(s) sur ce sujet (2 invité(s) et 0 utilisateur(s) anonyme(s))
0 membre(s) :

 



Nous sommes le : 17th November 2019 - 02:04