IPB

Bienvenue invité ( Connexion | Inscription )

2 Pages V  < 1 2  
Reply to this topicStart new topic
> INSTALLATION UBUNTU 22.04, Sur un MacPro 2012
Options
Laszlo Lebrun
posté 12 Nov 2022, 21:33
Message #31


Macbidouilleur de vermeil !
****

Groupe : Membres
Messages : 989
Inscrit : 1 Nov 2021
Membre no 214 848



Citation (moby59 @ 12 Nov 2022, 20:41) *
A priori je ne suis pas le seul...
https://bbs.archlinux.org/viewtopic.php?pid=1910114#p1910114 (gros truc bien compliqué) et les 2 posts en dessous évoquent un peu les mêmes soucis que moi. Par contre grub ça dépasse encore un peu mon domaine de compétences, j'ai du mal à tout capter sad.gif


Ouais la carte GeForce 320M a la sauce Apple, c'est la chienlit (comme disait De Gaulle).

Grub se paramètre plus confotablement en installant grub-customizer. Mais c'est une usine à gaz quand même.
Go to the top of the page
 
+Quote Post
moby59
posté 13 Nov 2022, 00:16
Message #32


Adepte de Macbidouille
*

Groupe : Membres
Messages : 163
Inscrit : 26 May 2005
Membre no 39 913



Bon j'ai installé glxinfo (apt install mesa-utils)

Ensuite on peut tester :
glxinfo | grep "render"

Et si ça affiche "direct rendering: Yes"
C'est que c'est censé être avec une accélération matérielle.

... et malgré le fait que la commande setpci ne me retourne toujours pas les valeurs attendues, moi j'ai bien yes. Va comprendre

J'ai tenté de switcher de codec pour youtube : https://blog.kylemanna.com/media/force-yout...c-with-h264ify/
c'est un micro poil mieux (testé dans firefox) mais pas transcendant non plus, le CPU est quand même très chargé (en 1080p ça oscille entre 70 et 95%) et j'ai un aspirateur en guise de Mac.

Dans VLC, une vidéo 1080p h264 c'est 50% d'occupation CPU, assez stable.

C'est pas clair cette histoire sad.gif

Edit :
Il y a aussi vainfo https://doc.ubuntu-fr.org/vaapi qui retourne des infos... et là c'est moins glorieux dans mon cas. Aucune ligne concernant le h264 par exemple.
Et encore de la lecture : https://amigotechnotes.wordpress.com/2022/0...tion-on-ubuntu/
pff...

Ce message a été modifié par moby59 - 13 Nov 2022, 00:35.


--------------------
MBA 11" late 2010 / iPad 2018 ... et des PCs
Go to the top of the page
 
+Quote Post
moby59
posté 13 Nov 2022, 13:59
Message #33


Adepte de Macbidouille
*

Groupe : Membres
Messages : 163
Inscrit : 26 May 2005
Membre no 39 913



Je viens d'installer kubuntu pour voir si ça pouvait être mieux...
Ca a l'air de tourner un poil mieux de manière générale (l'interface graphique, les programmes semblent plus rapides à lancer...)

Par contre côté youtube 1080p c'est globalement pire sad.gif

Exactement le même comportement en terme de setpci machin chose. C'est pas trop une surprise étant donné que c'est la même "base", mais bon on ne sait jamais, ça aurait pu être différent...

Je ne sais pas si je vais me tenter plein de distributions différentes ou si ça n'a aucun intérêt...

Edit : en fait la blague c'est que le moniteur d'activité (avec le graphique d'occupation cpu dans le temps) bouffe visiblement plus de ressources graphiques sur kubuntu smile.gif La bonne blague, en gros j'ai va vidéo h264 1080p fluide dans youtube... si je n'active pas le moniteur de ressources.
J'ai essayé avec htop à la place (mode terminal) et c'est à peu près fluide.
Enfin on reste quand même dans des valeurs très hautes d'occupation CPU, pas loin des 100%.

Après je n'ai pas de base de repères, je ressors ce Mac qui était un peu à l'abandon depuis son passage catastrophique à El Capitan. Il faudrait pouvoir le ressortir en 10.4 comme à son achat et faire un test :-p Mais bon à l'époque youtube c'était un player en Flash...


Petite différence quand même par rapport à Ubuntu normal, lors du boot je vois 2 lignes avec "FAULT" dedans à propos à première vue des 2 commandes setpci...
Nov 13 16:27:08 moimeme-MacBookAir kernel: [ 3.627053] nouveau 0000:02:00.0: bus: MMIO write of 0000807f FAULT at 100c18
Nov 13 16:27:08 moimeme-MacBookAir kernel: [ 3.710117] nouveau 0000:02:00.0: bus: MMIO write of 0000807e FAULT at 100c1c

Ca c'était avec le pilote dit "nouveau" (open source).
Je viens de switcher au pilote nvidia 450... et double effet kiss-kool :
- on apprend au reboot suivant que les Geforce 320M ne sont supportés que par les pilotes "340.xx Legacy" et que le pilote 450 ignorera le GPU.
- et ça plante direct après avec ce joli message. Là j'avoue que je ne sais pas bien comment je vais m'en sortir sad.gif

Re-edit :
je m'en suis sorti :
1/ là où c'est planté : ctrl + alt + fn +f2 -> premet de se loguer
2/ suivi du tuto : https://linuxconfig.org/how-to-uninstall-th...jellyfish-linux
3/ c'est pas suffisant, au reboot suivant ça plante toujours avec des messages de pilote nvidia
4/ apt remove nvidia*
5/ reboot : ouf de retour sur le pilote "nouveau", je reviens de loin, j'étais à 2 doigts de tout réinstaller sad.gif


Au passage sans rapport (désolé du 3615 mylife), pour la résolution des soucis dans vi (touches flèches qui font les lettres ABCD par exemple) :
vi ~/.vimrc
(ou tout autre programme d'édition genre gedit, kate... Le fichier est vide c'est normal)
ajouter :
set nocompatible
enregistrer.
Au prochain lancement de vi ça devrait aller nettement mieux smile.gif

Ce message a été modifié par moby59 - 13 Nov 2022, 17:21.


--------------------
MBA 11" late 2010 / iPad 2018 ... et des PCs
Go to the top of the page
 
+Quote Post
Fars
posté 13 Nov 2022, 18:33
Message #34


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 9 832
Inscrit : 4 Nov 2002
Lieu : Carcassonne
Membre no 4 494



Zorin est une distri basée sur Ubuntu. Elle est bien sympa, et un peu plus aboutie dans le détail.


--------------------
Raspberry Pi4 B (Overclock 2.0 Ghz) / 4 Go Ram / SSD Samsung T5 500 Go Usb3 / Ventila Pi4 / Raspberry Pi OS (Buster) / boot SD Card / rootfs SSD (fait accessoirement office de serveur pour Apple TV 4K 128Go)
Raspberry Pi4 B / 2 Go Ram/ SD 16Go / RETROFLAG NESPI 4 Case / Recalbox 7.2 / Kodi 18 / 8BitDo SN30 Pro+ Pac Man et 1942
MacBook 6,1 2009 / 8 Go Ram Corsair /SSD Crucial 500MX 500 Go SATA / (Single boot) Ubuntu 18.04.4 LTS (Bionic Beaver)
MacBook Pro 8,1 2011 / 8 Go Ram Corsair /SSD Crucial 500MX 500 Go SATA / (Single boot) Ubuntu 18.04.4 LTS (Bionic Beaver)
HP X360 (LORdi) 2015 / 4 Go Ram / SSD 250 Go M2 / (Single boot) Ubuntu 20.04 LTS (Focal Fossa)
HP Laptop 17 Core i3-11th gen 3.00GHz x 4 / 8 Go Ram / SSD 512 Go / (Single boot) Zorin 16.1
Apple TV 4K 128Go / 8BitDo SN30 Pro+
Trek Emonda SL6 pour le plaisir, pour s'amuser et se faire mal :) Ultegra 50x34/11x28, Ksyrium Pro, Keo Blade Carbon, Edge 520Plus, GP5000. Vittoria Rubino Pro G2
Go to the top of the page
 
+Quote Post
Laszlo Lebrun
posté 13 Nov 2022, 21:00
Message #35


Macbidouilleur de vermeil !
****

Groupe : Membres
Messages : 989
Inscrit : 1 Nov 2021
Membre no 214 848



Citation (moby59 @ 13 Nov 2022, 00:16) *
C'est pas clair cette histoire sad.gif

Après un plantage avec le pilote nouveau, j'ai eu ce message en essayant d'arrêter lightdm depuis le terminal:
[ 768.739781] nouveau 0000:04:00.0 Trapped read at 010062e000 on channel -1 .... reason 00000000d [VRAM_LIMIT]
Tiens tiens, VRAM_LIMIT...

Aurait-ton oublié d'assigner suffisamment de VRAM à l'initialisation?

Ce qui m'irrite c'est que je nai jamais les pilotes Nvidia dans l'appli Software & Updates. Il n'y a que le pilote Broadcom de la carte WiFi.

Je me demande si la carte NVidia à la sauce Apple est bien reconnue.
Chez moi
Code
lspci | grep nvidia

ne renvoie rien.

Ce message a été modifié par Laszlo Lebrun - 13 Nov 2022, 21:27.
Go to the top of the page
 
+Quote Post
blueG3
posté 13 Nov 2022, 22:37
Message #36


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 3 800
Inscrit : 20 Nov 2001
Lieu : vitry sur seine (94)
Membre no 1 346



bonsoir ,

la carte vidéo nvidia est trop ancienne , la gestion n'est plus prise en charge avec ces anciens drivers legacy 390 par nvidia.
de mon côté sur quad macpro 2008 + carte radeon 5770 , cest 35-45% cpu en avc1 pour du 1080p a 60hz sur une base manjaro.





--------------------
macpro 2008 quad core +8Go + 8800GT merci Nvidia & Apple pour la qualité et le choix de la carte! => ATI 5770 Apple + 2 DD WD 640Go + 2 SSD M4 Crucial 512Go(Raid 0) et Snow Leopard 10.6.8 + LG IPS235 flatron + Manjaro Linux sur DD interne - 20.1 Maté
Desktop - CPU : AMD Ryzen [email protected],3Ghz - RAM 16 Go - CM: Gygabyte X570-Aorus Pro CG : GeForce GTX 970- Audio: AMD Starship/Matisse HD Manjaro 20.1 xfce (testing)
Go to the top of the page
 
+Quote Post
Laszlo Lebrun
posté 14 Nov 2022, 08:25
Message #37


Macbidouilleur de vermeil !
****

Groupe : Membres
Messages : 989
Inscrit : 1 Nov 2021
Membre no 214 848



Citation (blueG3 @ 13 Nov 2022, 22:37) *
bonsoir ,
la carte vidéo nvidia est trop ancienne , la gestion n'est plus prise en charge avec ces anciens drivers legacy 390 par nvidia.
de mon côté sur quad macpro 2008 + carte radeon 5770 , cest 35-45% cpu en avc1 pour du 1080p a 60hz sur une base manjaro.


Finalement j'ai bloqué le pilote nouveau et ai supprimé les drivers Nvidia.
IL semble que le processur Intel du MBA2010 soit une version sans graphique intégré. sad.gif
Ca tourne maintenant sans acceleration graphique sad.gif , mais au moins ca ne plante plus, sauf au reveil de pause.
Go to the top of the page
 
+Quote Post
moby59
posté 14 Nov 2022, 12:40
Message #38


Adepte de Macbidouille
*

Groupe : Membres
Messages : 163
Inscrit : 26 May 2005
Membre no 39 913



Citation (Laszlo Lebrun @ 14 Nov 2022, 08:25) *
Finalement j'ai bloqué le pilote nouveau et ai supprimé les drivers Nvidia.
IL semble que le processur Intel du MBA2010 soit une version sans graphique intégré. sad.gif
Ca tourne maintenant sans acceleration graphique sad.gif , mais au moins ca ne plante plus, sauf au reveil de pause.


Tu as désactivé comment ce pilote "nouveau" (quel nom !) ? Dans la fenêtre de choix, moi j'ai 3 possibilités : 2 versions nvidia propriétaire et la version nouveau libre.

Ca donne quoi sans accélaration graphique ? Lecture full HD dans vlc ? dans youtube en h264/vp9 ?

Pour ma part je pense que je vais m'en tenir à peu près à ce pilote nouveau, dans l'ensemble ça fonctionne à peu près ok. J'ai juste toujours ce petit bug graphique de temps en temps (barre verticale sur toute la hauteur de l'écran, à une dizaine de pixels du bord droit, et qui pulse un peu). Parfois ça le fait, parfois non. Pour l'instant je n'ai pas trouvé de solution.

J'ai ENFIN pu installer wireguard et peut donc me connecter en VPN à mes serveurs lorsque je suis en déplacement.

J'ai aussi testé MacOS directement sur le disque de sauvegarde (2.5 pouces en usb2 !). Forcément c'est lent et ça gratte dès qu'on fait une opération, mais :
1/ ça fonctionne nickel, c'est un super point ça quand même de booter direct sur un support externe usb et d'avoir l'OS tel que je l'avais laissé avant le backup
2/ j'ai regardé les occupations CPU en lecture vidéo, globalement c'est assez proche de ce qui se passe sous linux. Dans firefox et Chrome c'est même pire j'ai l'impression, et dans Safari ça passe mieux... tout en sachant que c'est en avc1(h264) par défaut et non pas en vp9. N'empêche que la lecture a l'air quand même mieux en h264 dans Safari que en h264 dans Firefox sous kubuntu. On sent l'ordi moins à la peine lorsqu'on bouge la souris (affiche l'overlay youtube avec les boutons, le titre de la vidéo...) Dans Safari/MAcOS la vidéo continue à être lue de manière fluide, sous linux ça rame et "droppe" des images à la pelle.

Rien de catastrophique par rapport à mes besoins, mais ça donne un ordre d'idée.

Ce message a été modifié par moby59 - 14 Nov 2022, 12:47.


--------------------
MBA 11" late 2010 / iPad 2018 ... et des PCs
Go to the top of the page
 
+Quote Post
Laszlo Lebrun
posté 14 Nov 2022, 13:00
Message #39


Macbidouilleur de vermeil !
****

Groupe : Membres
Messages : 989
Inscrit : 1 Nov 2021
Membre no 214 848



Citation (moby59 @ 14 Nov 2022, 12:40) *
Citation (Laszlo Lebrun @ 14 Nov 2022, 08:25) *
Finalement j'ai bloqué le pilote nouveau et ai supprimé les drivers Nvidia.
IL semble que le processur Intel du MBA2010 soit une version sans graphique intégré. sad.gif
Ca tourne maintenant sans acceleration graphique sad.gif , mais au moins ca ne plante plus, sauf au reveil de pause.


Tu as désactivé comment ce pilote "nouveau" (quel nom !) ? Dans la fenêtre de choix, moi j'ai 3 possibilités : 2 versions nvidia propriétaire et la version nouveau libre.


Il faut "pas de version du tout":
https://linuxconfig.org/how-to-disable-blac...jellyfish-linux
J'avais essayé de faire tourner ça en mode IntelGMA950, mais il semble bien que Apple aie utilisé une version de CPU sans carte graphique intégrée.
Ubuntu Xorg tourne en frame-buffer, à la rame, quoi...

Citation
Ca donne quoi sans accélaration graphique ? Lecture full HD dans vlc ? dans youtube en h264/vp9 ?


Ça, j'ai même pas osé essayer.
J'ai abandonné l'idée même de vouloir tenter. Je peux aller sur le web sans planter la bécane; c'est déjè ça.
De toute façon Linux ne me sert que de test sur ce matos NVidia.

Par contre sur mon MBA2012 ou un MB blanc de 2008 Linux avec des Intels intégrés, fait un excellent boulot, même en multimédia.
Go to the top of the page
 
+Quote Post
moby59
posté 14 Nov 2022, 14:41
Message #40


Adepte de Macbidouille
*

Groupe : Membres
Messages : 163
Inscrit : 26 May 2005
Membre no 39 913



OK, merci des précisions.

Donc je vais m'en tenir à ce qui fonctionne de mon côté smile.gif


--------------------
MBA 11" late 2010 / iPad 2018 ... et des PCs
Go to the top of the page
 
+Quote Post
jeandemi
posté 14 Nov 2022, 22:29
Message #41


Macbidouilleur de vermeil !
****

Groupe : Membres
Messages : 1 035
Inscrit : 20 Aug 2020
Lieu : Belgique
Membre no 212 269



Citation (Laszlo Lebrun @ 14 Nov 2022, 14:00) *
J'avais essayé de faire tourner ça en mode IntelGMA950, mais il semble bien que Apple aie utilisé une version de CPU sans carte graphique intégrée.

Les Core2 Duo et Quad n'ont jamais de carte graphique intégrée, c'est dans le chipset (GMA950, X3000, etc.) que ça se trouve quand il y en a une

Est-ce que la vieille version du driver est encore disponible ? Installable ?


--------------------
Hackintosh1 "Photo" : Asus P7P55D i5-750 2x8GB DDR3, Gigabyte GTX770/4GB, USB3 FL1100, SSD4TB SATA, Mac OS-X Sierra
Hackintosh 2, 3, 4 et 5: Asus P5B/P5E-VM DO/P5KPL-VM, Q9550, 8/4GB DDR2-800, Quadro K600/8800GTX/8500GT, SSD+HDD SATA, Mac OS-X 10.9, 10.11, 10.12.6 et 10.13.6 (+ Snow Léopard incomplet en cours d'essais)
Hack6 "Dual" : Kllisre Dual-X79 2xXeon E5-2630Lv2 8x2GB DDR3-1333ECC UDIMM, Asus GTX760/2GB, SSD256GB Mac OS-X Mojave
Hackintosh 7 "en cours futur photo" : JingSha X79-P3 Xeon E5-2667v2 (8c/[email protected],3GHz) 3x16GB DDR3-1600RegECC XFX RX580/8GB USB3 FL1100 PCI-E SSD500GB NVME 970Evo+ HDD500GB SATA (à remplacer plus tard par 1TB NVME et 4TB SATA Samsung) Mojave
Hackintosh 8: Double Xeon E5-2670v2 (total 20c/[email protected],5GHz) sur Supermicro X9DAi, 6x16GB DDR3-1600RegECC, RX570/8GB, USB3 FL1100, OC 0.7.9 Catalina et Ubuntu 20.04LTS
Go to the top of the page
 
+Quote Post
Laszlo Lebrun
posté 15 Nov 2022, 07:43
Message #42


Macbidouilleur de vermeil !
****

Groupe : Membres
Messages : 989
Inscrit : 1 Nov 2021
Membre no 214 848



Citation (jeandemi @ 14 Nov 2022, 22:29) *
Est-ce que la vieille version du driver est encore disponible ? Installable ?


je crains que ce ne soit pas une question d'ancienneté du driver, mais plutôt que le chip nVidia n'aie pas été implémenté comme il faut par Apple.
Nvidia n'a jamais écrit de driver Linux pour cette version.
Go to the top of the page
 
+Quote Post
moby59
posté 15 Nov 2022, 08:26
Message #43


Adepte de Macbidouille
*

Groupe : Membres
Messages : 163
Inscrit : 26 May 2005
Membre no 39 913



Ca m'a intrigué cette histoire de legacy driver quand même...

J'ai été ressortir les message d'erreur (dans /var/syslog) avec un grep sur nvidia et en fait dans l'erreur ils font référence à une page :
https://www.nvidia.com/object/unix.html
Où en effet on peut télécharger des pilotes plus anciens...

Me voilà donc en train de télécharger la version 340.108

On récupère un fichier .run

Hum on en fait quoi, c'est pas un script pur texte, je pars aux renseignements :
Sur la page https://linuxconfig.org/how-to-install-the-...cal-fossa-linux je cherche ".run" pour voir s'il n'y a pas d'infos sur le sujet...

Donc il faut les outils de dev au préalable :

Code
sudo apt install build-essential libglvnd-dev pkg-config


Ah et ensuite il faut désactiver le driver nouveau... hum... bon allez testons.

Je reboote, comme prévu l'os "crashe" et je n'ai pas d'interface graphique.

Je me logue en root et poursuit l'installation, ne pas cocher DKMS sinon ça finit en :

Code
Failed to run '/usr/sbin/dkms build -m nvidia -v 340.108 -k 5.15.0-52-generic' ...
Error Bad return status for module build on jernet...
Consult /var/lib/dkms/nvidia/340.108/build/make.log


Mais même si on fait autrement ça se finit en :
Code
ERROR : Unable to build the NVIDIA kernel module


J'adore...
Et rien trouvé dans les logs pour m'aider sad.gif

Retour à la case départ, sauf que désormais (en ayant supprimé le blacklist du pilote nouveau et mis à jour initramfs) le moniteur d'activité râle pour indiquer que l'activation graphique est désactivée.
Je viens de tenter la réinstallation du pilote nouveau, et au boot suivant ça ne démarre plus en mode graphique et reste bloqué sur un écran:(
grr

linux...

Edit : va comprendre, bug de la boite de dialogue de choix de pilote, si lors de l'ouverture nouveau est coché, que tu choisis le bouton radio nvidia, puis le bouton nouveau et que tu fais apply, ça apply "nvidia", d'où le fait que ça ne reboote plus correctement ensuite.

Après un peu de nettoyage / réinstallation ça refonctionne de nouveau sous... nouveau.
Bref un coup dans l'eau, ça n'a servi à rien, c'est dommage...

Ce message a été modifié par moby59 - 15 Nov 2022, 11:15.


--------------------
MBA 11" late 2010 / iPad 2018 ... et des PCs
Go to the top of the page
 
+Quote Post
jeandemi
posté 15 Nov 2022, 09:30
Message #44


Macbidouilleur de vermeil !
****

Groupe : Membres
Messages : 1 035
Inscrit : 20 Aug 2020
Lieu : Belgique
Membre no 212 269



Désolé pour la fausse piste
Go to the top of the page
 
+Quote Post
Laszlo Lebrun
posté 15 Nov 2022, 11:52
Message #45


Macbidouilleur de vermeil !
****

Groupe : Membres
Messages : 989
Inscrit : 1 Nov 2021
Membre no 214 848



Citation (moby59 @ 15 Nov 2022, 08:26) *
Ca m'a intrigué cette histoire de legacy driver quand même...

J'ai été ressortir les message d'erreur (dans /var/syslog) avec un grep sur nvidia et en fait dans l'erreur ils font référence à une page :
https://www.nvidia.com/object/unix.html
Où en effet on peut télécharger des pilotes plus anciens...

Me voilà donc en train de télécharger la version 340.108

On récupère un fichier .run

Hum on en fait quoi, c'est pas un script pur texte, je pars aux renseignements :
Sur la page https://linuxconfig.org/how-to-install-the-...cal-fossa-linux je cherche ".run" pour voir s'il n'y a pas d'infos sur le sujet...

Donc il faut les outils de dev au préalable :

Code
sudo apt install build-essential libglvnd-dev pkg-config


Ah et ensuite il faut désactiver le driver nouveau... hum... bon allez testons.

Je reboote, comme prévu l'os "crashe" et je n'ai pas d'interface graphique.

Je me logue en roote et poursuit l'installation, ne pas cocher DKMS sinon ça finit en :

Code
Failed to run '/usr/sbin/dkms build -m nvidia -v 340.108 -k 5.15.0-52-generic' ...
Error Bad return status for module build on jernet...
Consult /var/lib/dkms/nvidia/340.108/build/make.log
)

Mais même si on fait autrement ça se finit en :
Code
ERROR : Unable to build the NVIDIA kernel module


J'adore...
Et rien trouvé dans les logs pour m'aider sad.gif

Retour à la case départ, sauf que désormais (en ayant supprimé le blacklist du pilote nouveau et mis à jour initramfs) le moniteur d'activité râle pour indiquer que l'activation graphique est désactivée.
Je viens de tenter la réinstallation du pilote nouveau, et au boot suivant ça ne démarre plus en mode graphique et reste bloqué sur un écran:(
grr

linux...

Edit : va comprendre, bug de la boite de dialogue de choix de pilote, si lors de l'ouverture nouveau est coché, que tu choisis le bouton radio nvidia, puis le bouton nouveau et que tu fais apply, ça apply "nvidia", d'où le fait que ça ne reboote plus correctement ensuite.

Après un peu de nettoyage / réinstallation ça refonctionne de nouveau sous... nouveau.
Bref un coup dans l'eau, ça n'a servi à rien, c'est dommage...



Oups! je suis passé par là aussi.
Installer un .run de NVidia c'est la galère pour aucun résultat.
Go to the top of the page
 
+Quote Post
twist67
posté 15 Nov 2022, 16:31
Message #46


Nouveau Membre


Groupe : Membres
Messages : 12
Inscrit : 17 Oct 2022
Membre no 216 806



Citation (moby59 @ 15 Nov 2022, 08:26) *
Code
Failed to run '/usr/sbin/dkms build -m nvidia -v 340.108 -k 5.15.0-52-generic' ...
Error Bad return status for module build on jernet...
Consult /var/lib/dkms/nvidia/340.108/build/make.log


Mais même si on fait autrement ça se finit en :
Code
ERROR : Unable to build the NVIDIA kernel module


En lisant ceci https://github.com/NixOS/nix/issues/4970 et en voyant ta ligne de commande de build, ton kernel 5.15 semble trop récent. Cela fonctionne visiblement avec le kernel 5.4 d'après le lien github.
Go to the top of the page
 
+Quote Post
moby59
posté 15 Nov 2022, 16:32
Message #47


Adepte de Macbidouille
*

Groupe : Membres
Messages : 163
Inscrit : 26 May 2005
Membre no 39 913



Pour rigoler, à tout hasard je viens d'installer minecraft.

Bon ben pareil, on oublie. Quelle que soit la résolution, les effets, ... au mieux j'ai 1 image par seconde.
Sans parler du temps de génération du terrain qui a bien pris 15 minutes.


--------------------
MBA 11" late 2010 / iPad 2018 ... et des PCs
Go to the top of the page
 
+Quote Post
Laszlo Lebrun
posté 15 Nov 2022, 16:50
Message #48


Macbidouilleur de vermeil !
****

Groupe : Membres
Messages : 989
Inscrit : 1 Nov 2021
Membre no 214 848



Citation (twist67 @ 15 Nov 2022, 16:31) *
En lisant ceci https://github.com/NixOS/nix/issues/4970 et en voyant ta ligne de commande de build, ton kernel 5.15 semble trop récent. Cela fonctionne visiblement avec le kernel 5.4 d'après le lien github.


Ça confirme mes observations.
Sur la version 20.4 LTS d'Ubuntu ça marchait encore.
Les ennuis ont commencé avec 22.2 LTS
Go to the top of the page
 
+Quote Post
moby59
posté 16 Nov 2022, 11:00
Message #49


Adepte de Macbidouille
*

Groupe : Membres
Messages : 163
Inscrit : 26 May 2005
Membre no 39 913



Tu m'as presque motivé 5 secondes à installer une version 20... mais non, l'idée de passer à linux c'est justement d'avoir un OS à jour sur lequel je pourrai installer tout ce dont j'ai besoin sans que ça me finisse par me dire "désolé votre matos/OS est trop vieux on ne peut plus rien pour vous" (Apple tu vois ce que je veux dire... ), donc faire ça ça serait revenir en arrière et figer l'OS/noyau, c'est contre-productif.

N'empêche que ça aurait été sympa de savoir si ça changeait quelque chose...

Ce message a été modifié par moby59 - 16 Nov 2022, 11:01.


--------------------
MBA 11" late 2010 / iPad 2018 ... et des PCs
Go to the top of the page
 
+Quote Post
twist67
posté 17 Nov 2022, 17:41
Message #50


Nouveau Membre


Groupe : Membres
Messages : 12
Inscrit : 17 Oct 2022
Membre no 216 806



J'ai dépoussiéré mon vieux macbook air 11 pouces de mi 2011. Il a également une carte geforce 320M.

J'ai installé NixOS et fait quelques tests.
Le driver nvidia 340 il s'installe au build de la config NixOS si je configure le noyau en 5.4, mais il plante au chargement à l'étape "Reached target graphical interface".
Avec le driver nouveau ça fonctionne avec les kernels 5.4, 5.15 et 6.0

La machine n'ayant que 2Go de RAM, je suis tout de même agréablement surpris de la fluidité de l'interface avec gnome 43.

Fichier joint  Screenshot_from_2022_11_17_17_38_29.png ( 52.19 Ko ) Nombre de téléchargements : 12
Go to the top of the page
 
+Quote Post
Laszlo Lebrun
posté 17 Nov 2022, 17:56
Message #51


Macbidouilleur de vermeil !
****

Groupe : Membres
Messages : 989
Inscrit : 1 Nov 2021
Membre no 214 848



Citation (twist67 @ 17 Nov 2022, 17:41) *
La machine n'ayant que 2Go de RAM, je suis tout de même agréablement surpris de la fluidité de l'interface avec gnome 43.


Sur cette bécane, Gnome et le reste ne prennent qu'environ 900Mo de mémoire.
Mais ça commnce à foirer si on lance un browser et on va sur un site réclamant une accélération matérielle.

Go to the top of the page
 
+Quote Post
moby59
posté 18 Nov 2022, 13:42
Message #52


Adepte de Macbidouille
*

Groupe : Membres
Messages : 163
Inscrit : 26 May 2005
Membre no 39 913



Citation (twist67 @ 17 Nov 2022, 17:41) *
J'ai dépoussiéré mon vieux macbook air 11 pouces de mi 2011. Il a également une carte geforce 320M.

J'ai installé NixOS et fait quelques tests.
Le driver nvidia 340 il s'installe au build de la config NixOS si je configure le noyau en 5.4, mais il plante au chargement à l'étape "Reached target graphical interface".
Avec le driver nouveau ça fonctionne avec les kernels 5.4, 5.15 et 6.0

La machine n'ayant que 2Go de RAM, je suis tout de même agréablement surpris de la fluidité de l'interface avec gnome 43.

Fichier joint  Screenshot_from_2022_11_17_17_38_29.png ( 52.19 Ko ) Nombre de téléchargements : 12


Merci du test, ça m'évite des heures de réinstallation alors que j'ai à peu près configuré kubuntu smile.gif

Donc bilan "probable" : sur cette machine il faut arrêter de chercher à faire fonctionner un driver nvidia... et s'en tenir au driver "nouveau"...
En théorie l'accélération matérielle est bien activée, mais c'est dur de savoir si et comment elle est exploitée en pratique.


--------------------
MBA 11" late 2010 / iPad 2018 ... et des PCs
Go to the top of the page
 
+Quote Post
Laszlo Lebrun
posté 18 Nov 2022, 14:12
Message #53


Macbidouilleur de vermeil !
****

Groupe : Membres
Messages : 989
Inscrit : 1 Nov 2021
Membre no 214 848



Citation (moby59 @ 18 Nov 2022, 13:42) *
Donc bilan "probable" : sur cette machine il faut arrêter de chercher à faire fonctionner un driver nvidia... et s'en tenir au driver "nouveau"...
En théorie l'accélération matérielle est bien activée, mais c'est dur de savoir si et comment elle est exploitée en pratique.


Oh non, c'est très simple: si ça plante c'est que l'accélération matérielle a été utilisée.
Go to the top of the page
 
+Quote Post
twist67
posté 18 Nov 2022, 14:19
Message #54


Nouveau Membre


Groupe : Membres
Messages : 12
Inscrit : 17 Oct 2022
Membre no 216 806



Citation (moby59 @ 18 Nov 2022, 13:42) *
Merci du test, ça m'évite des heures de réinstallation alors que j'ai à peu près configuré kubuntu smile.gif


Un des multiples avantages de NixOS, c'est que tous ces tests se sont fait en quelques dizaines de minutes smile.gif
Go to the top of the page
 
+Quote Post
moby59
posté 22 Nov 2022, 15:32
Message #55


Adepte de Macbidouille
*

Groupe : Membres
Messages : 163
Inscrit : 26 May 2005
Membre no 39 913



Citation (Laszlo Lebrun @ 18 Nov 2022, 14:12) *
Citation (moby59 @ 18 Nov 2022, 13:42) *
Donc bilan "probable" : sur cette machine il faut arrêter de chercher à faire fonctionner un driver nvidia... et s'en tenir au driver "nouveau"...
En théorie l'accélération matérielle est bien activée, mais c'est dur de savoir si et comment elle est exploitée en pratique.


Oh non, c'est très simple: si ça plante c'est que l'accélération matérielle a été utilisée.


Tu as des cas concrets où ça se produit ? Des moyens clairs de tester une opération avec et sans accélération matérielle ?
C'est un peu la difficulté je trouve.

Comme j'avais posté plus haut, glxinfo dit que l'activation matérielle est bien disponible... mais on ne sait pas à un instant donné si une appli l'utilise ou non.


--------------------
MBA 11" late 2010 / iPad 2018 ... et des PCs
Go to the top of the page
 
+Quote Post
Laszlo Lebrun
posté 22 Nov 2022, 16:02
Message #56


Macbidouilleur de vermeil !
****

Groupe : Membres
Messages : 989
Inscrit : 1 Nov 2021
Membre no 214 848



Citation (moby59 @ 22 Nov 2022, 15:32) *
Citation (Laszlo Lebrun @ 18 Nov 2022, 14:12) *
Citation (moby59 @ 18 Nov 2022, 13:42) *
Donc bilan "probable" : sur cette machine il faut arrêter de chercher à faire fonctionner un driver nvidia... et s'en tenir au driver "nouveau"...
En théorie l'accélération matérielle est bien activée, mais c'est dur de savoir si et comment elle est exploitée en pratique.


Oh non, c'est très simple: si ça plante c'est que l'accélération matérielle a été utilisée.


Tu as des cas concrets où ça se produit ? Des moyens clairs de tester une opération avec et sans accélération matérielle ?
C'est un peu la difficulté je trouve.

Comme j'avais posté plus haut, glxinfo dit que l'activation matérielle est bien disponible... mais on ne sait pas à un instant donné si une appli l'utilise ou non.


You tube devrait l'utiliser pour ses contenus HD.
L'activation matérielle est bien activée, mais le chip NVidia renvoie apparemment l'interruption attendue dans le vide.
J'aimerais bien avoir la solution pour désactiver cette accélération matérielle qui fait tout planter.
Go to the top of the page
 
+Quote Post
blueG3
posté 27 Nov 2022, 22:49
Message #57


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 3 800
Inscrit : 20 Nov 2001
Lieu : vitry sur seine (94)
Membre no 1 346



bonsoir

pour bien comprendre ,
il y a 3 version actives de drivers nvidia
- nvidia 390 ( legacy )
- nvidia 470 ( legacy)
- nvidia 5.20 ( current )

chaque type de driver nivdia fonctionne avec un ensemble de composants
( glx , mesa , xorg et /ou wayland , vulkan , noyau)
la partie legacy fonctionne jusqu'à une certaine version de Xorg / mesa / glx
toute évolution d'un de ces composants peu casser la gestion graphique

les drivers legacy vont être arrêté en terme de support ( 390 fin décembre 2022 )
vous utilisez des cartes graphiques qui ne sont plus supportés en version 390 , la serie 340 est depuis 1 an abandonnée.

comme nouveau n'a jamais reçu le support Open source de la part de Nvidia , ces cartes nfonctionne au minimum de fonction sous nouveau quand ça marche :
- jeux déconseillé ,
- consommation trop élevé
- performances globales a 10% des drivers nvidia fonctionnant antérieurement

Apple ayant jamais eu une politique correcte pour les cartes vidéos de 2002 a 2012, il ne faut pas espérer un support de ce côté par la suite côté linux

Ce message a été modifié par blueG3 - 27 Nov 2022, 22:51.


--------------------
macpro 2008 quad core +8Go + 8800GT merci Nvidia & Apple pour la qualité et le choix de la carte! => ATI 5770 Apple + 2 DD WD 640Go + 2 SSD M4 Crucial 512Go(Raid 0) et Snow Leopard 10.6.8 + LG IPS235 flatron + Manjaro Linux sur DD interne - 20.1 Maté
Desktop - CPU : AMD Ryzen [email protected],3Ghz - RAM 16 Go - CM: Gygabyte X570-Aorus Pro CG : GeForce GTX 970- Audio: AMD Starship/Matisse HD Manjaro 20.1 xfce (testing)
Go to the top of the page
 
+Quote Post
Laszlo Lebrun
posté 27 Nov 2022, 23:12
Message #58


Macbidouilleur de vermeil !
****

Groupe : Membres
Messages : 989
Inscrit : 1 Nov 2021
Membre no 214 848



Citation (blueG3 @ 27 Nov 2022, 22:49) *
bonsoir

pour bien comprendre ,
il y a 3 version actives de drivers nvidia
- nvidia 390 ( legacy )
- nvidia 470 ( legacy)
- nvidia 5.20 ( current )

chaque type de driver nivdia fonctionne avec un ensemble de composants
( glx , mesa , xorg et /ou wayland , vulkan , noyau)
la partie legacy fonctionne jusqu'à une certaine version de Xorg / mesa / glx
toute évolution d'un de ces composants peu casser la gestion graphique

les drivers legacy vont être arrêté en terme de support ( 390 fin décembre 2022 )
vous utilisez des cartes graphiques qui ne sont plus supportés en version 390 , la serie 340 est depuis 1 an abandonnée.

comme nouveau n'a jamais reçu le support Open source de la part de Nvidia , ces cartes nfonctionne au minimum de fonction sous nouveau quand ça marche :
- jeux déconseillé ,
- consommation trop élevé
- performances globales a 10% des drivers nvidia fonctionnant antérieurement

Apple ayant jamais eu une politique correcte pour les cartes vidéos de 2002 a 2012, il ne faut pas espérer un support de ce côté par la suite côté linux


Une carte NVidia 390 pour PC marche avec les pilotes legacy.
Mais le chipset NVidia390 a été (d'après ce que j'ai lu) mal implanté sur les MBP2010 et il n'y a pas d'interruption de fin en cas d'acceleration matérielle.
Go to the top of the page
 
+Quote Post

2 Pages V  < 1 2
Reply to this topicStart new topic
1 utilisateur(s) sur ce sujet (1 invité(s) et 0 utilisateur(s) anonyme(s))
0 membre(s) :

 



Nous sommes le : 8th December 2022 - 06:30