IPB

Bienvenue invité ( Connexion | Inscription )

2 Pages V   1 2 >  
Reply to this topicStart new topic
> Flashage Sapphire RX580 8Go Pulse, Pour profil conso, refroissement
Options
thunder72fr
posté 29 Aug 2018, 14:39
Message #1


Macbidouilleur de bronze !
**

Groupe : Membres
Messages : 472
Inscrit : 5 Jun 2015
Lieu : LE MANS
Membre no 195 534



Bonjour,

Je vous propose une rom modifiée par mes soins pour la Sapphire RX580 8Go Pulse (mémoire Samsung)


En plus de modifier le profil ventilo, la fréquence GPU et les timing pour un meilleur rapport consommation, silence, performances de la carte sous Mac Os (à partir de High Sierra), j'ai inscrit le nom Orinoco pour le RadeonFramebuffer (exactement comme la carte vendue dans le pack eGPU d'Apple)

Température max: 75°C
Fréquence mémoire max: 2000
Fréquence GPu: 1340



RX 580 Pulse Modded For Mac Pro

Outil de flashage fourni à faire sous Windows.



--------------------
Materiel APPLE :
Macbook Pro 15" Retina (Mid 2012) / i7 3620QM / 8Go DDR3 / Nvidia 650M / 500Go SSD / Catalina - Win10 Pro


Matériel Non APPLE:
PC Gamer Hackintosh / i7 8700K / ASUS Z370-E Gaming / 32Go DDR4 / EVGA RTX 2080 Ti FTW3 Ultra Gaming / 2 x 500Go SSD Nvme - 1x1To SSD Sata - 8To DD - 2To DD / Catalina - Win10 Pro - Ubuntu 19.04 / Clover 5080

Un futur mini Hackintosh à base de Ryzen 3xxx
Go to the top of the page
 
+Quote Post
neo
posté 31 Aug 2018, 09:40
Message #2


Macbidouilleur de vermeil !
****

Groupe : Membres
Messages : 1 437
Inscrit : 22 Jul 2001
Membre no 531



Salut

Très intéressant. Tu peux en dire plus sur les gains par rapport à la carte retails?
Est-ce que le MacApp Store reconnait ensuite le MacPro comme machine supportant Metal? Je ne peux toujours pas updater Pixelmator Pro directement...

Merci!


--------------------
MacPro 5.1 de 2012: 6x 3.46Ghz (CPU upgrade) | 20 Go | RX580 Pulse 8Go | 2x SSD sur carte PCI Sonnet Tempo | USB 3 sur carte PCI
MacBook Pro mid-2010 15 pouces | i7 2.66 Ghz | 8Go | "downgradé" avec un patch logiciel pour éviter le switch sur le GPU nVidia buggé, qu'Apple refuse de réparer
Go to the top of the page
 
+Quote Post
thunder72fr
posté 31 Aug 2018, 09:45
Message #3


Macbidouilleur de bronze !
**

Groupe : Membres
Messages : 472
Inscrit : 5 Jun 2015
Lieu : LE MANS
Membre no 195 534



Citation (neo @ 31 Aug 2018, 10:40) *
Salut

Très intéressant. Tu peux en dire plus sur les gains par rapport à la carte retails?
Est-ce que le MacApp Store reconnait ensuite le MacPro comme machine supportant Metal? Je ne peux toujours pas updater Pixelmator Pro directement...

Merci!



C'est déjà reconnu Metal sans flashage.

Ma rom a juste été modifiée pour les caractéristiques citées plus haut


--------------------
Materiel APPLE :
Macbook Pro 15" Retina (Mid 2012) / i7 3620QM / 8Go DDR3 / Nvidia 650M / 500Go SSD / Catalina - Win10 Pro


Matériel Non APPLE:
PC Gamer Hackintosh / i7 8700K / ASUS Z370-E Gaming / 32Go DDR4 / EVGA RTX 2080 Ti FTW3 Ultra Gaming / 2 x 500Go SSD Nvme - 1x1To SSD Sata - 8To DD - 2To DD / Catalina - Win10 Pro - Ubuntu 19.04 / Clover 5080

Un futur mini Hackintosh à base de Ryzen 3xxx
Go to the top of the page
 
+Quote Post
teddy7545
posté 31 Aug 2018, 13:21
Message #4


Macbidouilleur de vermeil !
****

Groupe : Membres
Messages : 879
Inscrit : 4 Apr 2004
Lieu : Lorraine - 54
Membre no 17 184



Bonjour,

Il semble exister deux modèles de carte Grapphire Pulse RX580 8go.
En effet j'ai trouvé deux références et la seule chose qui semble les différencier serait la fréquence du GPU

11265-06 Fréquence GPu: 1340
11265-05 Fréquence GPu: 1366 (qui porte également une mention OC sur la boite)

Du coup le Flash pour une carte OC est t'il également fonctionnel ? est t'il pertinent (sachant que ça va downgradé la fréquence) ?

C'est que j'attend prochainement est de ce type (OC)
Y a t'il à votre connaissance d'autre différences entre ces deux références ?

Merci



--------------------
MP Intel Dual Xéon 3 GHz - MacOSX 10.10.3 - ATI Radeon HD 5770 - ATTO UL5D - Apple Cinema HD Display 23 pouces
MBP 15' 2017 - MBP 13' mid 2009 - iMac 24' 8,1 2,8GHz - MP G4 MDD Bi 1,25 GHz - MP G4 Quicksylver 933MHz
Go to the top of the page
 
+Quote Post
ULYSSED
posté 1 Sep 2018, 17:35
Message #5


Adepte de Macbidouille
*

Groupe : Membres
Messages : 120
Inscrit : 26 Jan 2003
Membre no 5 854



Bonsoir

Pouvez-vous préciser si ça fonctionne avec les deuxmodèles de la carte.
Est-ce que le boot se fait toujours à l'aveugle?

Cordialement


--------------------
ULYSSE
Go to the top of the page
 
+Quote Post
thunder72fr
posté 1 Sep 2018, 18:30
Message #6


Macbidouilleur de bronze !
**

Groupe : Membres
Messages : 472
Inscrit : 5 Jun 2015
Lieu : LE MANS
Membre no 195 534



Pour répondre en images:


Mon Mac pro en video


Je n'ai jamais parler d'obtenir le bootscreen!!! (Et sincèrement, il ne sert à rien (RX580 Pulse fonctionne en mode recovery & Dualboot fonctionne aussi avec Bootchamp))

Le bios moddé que j'ai créé permet juste d'avoir le meilleur profil avec les caractéristiques que j'ai cité dans le premier post:

Température max: 75°C
Fréquence mémoire max: 2000
Fréquence GPu: 1340
Une courbe vitesse ventilation régulière.
Une carte plus silencieuse
Une consommation moindre
Une montée de fréquences progréssive.
RadeonFramebuffer: Orinoco


Mes sources à partir de ce sujet:

Sapphire PULSE RX580 8GB VBIOS Study


et :

Turn a "new" Sapphire RX580 PULSE into the "Mac Edition" card

Quand aux 2 modèles de cartes, c'est juste du pipeau marketing (en montant de 26 GHz et en collant OC sur la boite)

Ce message a été modifié par thunder72fr - 1 Sep 2018, 18:34.


--------------------
Materiel APPLE :
Macbook Pro 15" Retina (Mid 2012) / i7 3620QM / 8Go DDR3 / Nvidia 650M / 500Go SSD / Catalina - Win10 Pro


Matériel Non APPLE:
PC Gamer Hackintosh / i7 8700K / ASUS Z370-E Gaming / 32Go DDR4 / EVGA RTX 2080 Ti FTW3 Ultra Gaming / 2 x 500Go SSD Nvme - 1x1To SSD Sata - 8To DD - 2To DD / Catalina - Win10 Pro - Ubuntu 19.04 / Clover 5080

Un futur mini Hackintosh à base de Ryzen 3xxx
Go to the top of the page
 
+Quote Post
teddy7545
posté 1 Sep 2018, 22:17
Message #7


Macbidouilleur de vermeil !
****

Groupe : Membres
Messages : 879
Inscrit : 4 Apr 2004
Lieu : Lorraine - 54
Membre no 17 184



Citation
Quand aux 2 modèles de cartes, c'est juste du pipeau marketing (en montant de 26 GHz et en collant OC sur la boite)

J'aimerais que ce soit une augmentation de 26 GHz mais il faudra se contenter de 26 MHz tongue.gif
Oui sans doute du marketing ... car une si petite différence ne doit pas se voir beaucoup (2 %)


--------------------
MP Intel Dual Xéon 3 GHz - MacOSX 10.10.3 - ATI Radeon HD 5770 - ATTO UL5D - Apple Cinema HD Display 23 pouces
MBP 15' 2017 - MBP 13' mid 2009 - iMac 24' 8,1 2,8GHz - MP G4 MDD Bi 1,25 GHz - MP G4 Quicksylver 933MHz
Go to the top of the page
 
+Quote Post
thunder72fr
posté 2 Sep 2018, 08:09
Message #8


Macbidouilleur de bronze !
**

Groupe : Membres
Messages : 472
Inscrit : 5 Jun 2015
Lieu : LE MANS
Membre no 195 534



Plusieurs benchmarks:

Sous Mojave:




Sous Windows 10 Pro:



--------------------
Materiel APPLE :
Macbook Pro 15" Retina (Mid 2012) / i7 3620QM / 8Go DDR3 / Nvidia 650M / 500Go SSD / Catalina - Win10 Pro


Matériel Non APPLE:
PC Gamer Hackintosh / i7 8700K / ASUS Z370-E Gaming / 32Go DDR4 / EVGA RTX 2080 Ti FTW3 Ultra Gaming / 2 x 500Go SSD Nvme - 1x1To SSD Sata - 8To DD - 2To DD / Catalina - Win10 Pro - Ubuntu 19.04 / Clover 5080

Un futur mini Hackintosh à base de Ryzen 3xxx
Go to the top of the page
 
+Quote Post
neo
posté 6 Sep 2018, 07:32
Message #9


Macbidouilleur de vermeil !
****

Groupe : Membres
Messages : 1 437
Inscrit : 22 Jul 2001
Membre no 531



Citation (thunder72fr @ 31 Aug 2018, 10:45) *
Citation (neo @ 31 Aug 2018, 10:40) *
Salut

Est-ce que le MacApp Store reconnait ensuite le MacPro comme machine supportant Metal? Je ne peux toujours pas updater Pixelmator Pro directement...

Merci!



C'est déjà reconnu Metal sans flashage.



Je viens d'installer une RX580 Pulse 8GB qui remplace une RX460 Nitro 4GB. Je suis encore sous High Sierra: Le MacApp Store ne reconnait pas la 580. Est-ce que c'est uniquement le cas à partir de Mojave?


--------------------
MacPro 5.1 de 2012: 6x 3.46Ghz (CPU upgrade) | 20 Go | RX580 Pulse 8Go | 2x SSD sur carte PCI Sonnet Tempo | USB 3 sur carte PCI
MacBook Pro mid-2010 15 pouces | i7 2.66 Ghz | 8Go | "downgradé" avec un patch logiciel pour éviter le switch sur le GPU nVidia buggé, qu'Apple refuse de réparer
Go to the top of the page
 
+Quote Post
thunder72fr
posté 6 Sep 2018, 08:16
Message #10


Macbidouilleur de bronze !
**

Groupe : Membres
Messages : 472
Inscrit : 5 Jun 2015
Lieu : LE MANS
Membre no 195 534



Je ne comprends pas ce que tu veux dire quand MacApp Store ne reconnait pas ta RX580...

Déjà tu es à jour avec ton High Sierra?

Ou j'ai raté quelque chose

Ce message a été modifié par thunder72fr - 6 Sep 2018, 08:21.


--------------------
Materiel APPLE :
Macbook Pro 15" Retina (Mid 2012) / i7 3620QM / 8Go DDR3 / Nvidia 650M / 500Go SSD / Catalina - Win10 Pro


Matériel Non APPLE:
PC Gamer Hackintosh / i7 8700K / ASUS Z370-E Gaming / 32Go DDR4 / EVGA RTX 2080 Ti FTW3 Ultra Gaming / 2 x 500Go SSD Nvme - 1x1To SSD Sata - 8To DD - 2To DD / Catalina - Win10 Pro - Ubuntu 19.04 / Clover 5080

Un futur mini Hackintosh à base de Ryzen 3xxx
Go to the top of the page
 
+Quote Post
neo
posté 6 Sep 2018, 12:53
Message #11


Macbidouilleur de vermeil !
****

Groupe : Membres
Messages : 1 437
Inscrit : 22 Jul 2001
Membre no 531



Impossible de mettre à jour des applications qui ont besoin de Métal (exemple Pixelmator Pro) par le MacApp Store (voir message d'erreur sur l'image jointe). Je dois passer par une autre machine, télécharger la nouvelle version et la copier sur le Mac Pro.

Oui, High Sierra est à jour et la Radeon correctement reconnu par le système.


Fichier(s) joint(s)
Fichier joint  GPU.png ( 47.9 Ko ) Nombre de téléchargements : 30
Fichier joint  MacApp_Store.png ( 49.55 Ko ) Nombre de téléchargements : 30
Fichier joint  Systeme.png ( 77.8 Ko ) Nombre de téléchargements : 33
 


--------------------
MacPro 5.1 de 2012: 6x 3.46Ghz (CPU upgrade) | 20 Go | RX580 Pulse 8Go | 2x SSD sur carte PCI Sonnet Tempo | USB 3 sur carte PCI
MacBook Pro mid-2010 15 pouces | i7 2.66 Ghz | 8Go | "downgradé" avec un patch logiciel pour éviter le switch sur le GPU nVidia buggé, qu'Apple refuse de réparer
Go to the top of the page
 
+Quote Post
gimli
posté 6 Sep 2018, 19:43
Message #12


Macbidouilleur de vermeil !
****

Groupe : Membres
Messages : 856
Inscrit : 5 Dec 2004
Lieu : Namur
Membre no 28 224



Sous Mojave ça fonctionne pour Pixelmator Pro. J'avais le même souci sous HS


--------------------
PowerMac Quad G5 - 3 Go RAM - MacOS X 10.5
MacBookPro retina - Core i7 - 16 Go RAM - OS X 10.14
MacPro 8x2,8 Ghz - 24 Go RAM - OS X 10.13
MacPro 24x3,46 Ghz - RX580 - 32 Go RAM - MacOS X 10.14
Go to the top of the page
 
+Quote Post
thunder72fr
posté 11 Oct 2018, 10:02
Message #13


Macbidouilleur de bronze !
**

Groupe : Membres
Messages : 472
Inscrit : 5 Jun 2015
Lieu : LE MANS
Membre no 195 534



HDMI et Displayport fonctionnent avec Lilu.kext, ALC.kext (Disable Sip) installé dans le dossiers Extensions (Systeme) et mon bios pour la carte:




--------------------
Materiel APPLE :
Macbook Pro 15" Retina (Mid 2012) / i7 3620QM / 8Go DDR3 / Nvidia 650M / 500Go SSD / Catalina - Win10 Pro


Matériel Non APPLE:
PC Gamer Hackintosh / i7 8700K / ASUS Z370-E Gaming / 32Go DDR4 / EVGA RTX 2080 Ti FTW3 Ultra Gaming / 2 x 500Go SSD Nvme - 1x1To SSD Sata - 8To DD - 2To DD / Catalina - Win10 Pro - Ubuntu 19.04 / Clover 5080

Un futur mini Hackintosh à base de Ryzen 3xxx
Go to the top of the page
 
+Quote Post
teiki arii
posté 29 Nov 2018, 20:09
Message #14


Nouveau Membre


Groupe : Membres
Messages : 9
Inscrit : 19 Mar 2016
Membre no 198 393



Citation (thunder72fr @ 29 Aug 2018, 14:39) *
Bonjour,

Je vous propose une rom modifiée par mes soins pour la Sapphire RX580 8Go Pulse (mémoire Samsung)


En plus de modifier le profil ventilo, la fréquence GPU et les timing pour un meilleur rapport consommation, silence, performances de la carte sous Mac Os (à partir de High Sierra), j'ai inscrit le nom Orinoco pour le RadeonFramebuffer (exactement comme la carte vendue dans le pack eGPU d'Apple)

Température max: 75°C
Fréquence mémoire max: 2000
Fréquence GPu: 1340



RX 580 Pulse Modded For Mac Pro

Outil de flashage fourni à faire sous Windows.


Bonjour,
j'ai bien acheté une carte Sapphire 11265-05-20G Carte Graphique AMD Radeon RX 580 1366 MHz 8 Go Pulse. Elle est reconnue nativement par Mojave 10.14.1 (ROM 140.0.0.0) et affiche d'emblée ATY,Orinoco. J'ai essayé de la flasher avec le fichier téléchargé sur Windows 7 mais cela n'a pas réussi...
Merci en tout cas pour le partage.

Ce message a été modifié par teiki arii - 29 Nov 2018, 20:10.
Fichier(s) joint(s)
Fichier joint  Capture_d___e__cran_2018_11_29_a___19.31.07.png ( 98.53 Ko ) Nombre de téléchargements : 23
Fichier joint  Capture_d___e__cran_2018_11_29_a___19.27.03.png ( 71.13 Ko ) Nombre de téléchargements : 14
 
Go to the top of the page
 
+Quote Post
thunder72fr
posté 3 Dec 2018, 18:05
Message #15


Macbidouilleur de bronze !
**

Groupe : Membres
Messages : 472
Inscrit : 5 Jun 2015
Lieu : LE MANS
Membre no 195 534



Télécharger:

AMD/ATI ATIFlash

Décompresser à la racine de votre disque système. Coller aussi le bios à flasher.

Dans la barre de recherche sous Windows, tapez « cmd » et vous verrez « invite de commandes » apparaître, faites un clic droit dessus puis « exécuter en tant qu’administrateur.

Aller dans le dossier qui contient le bios et le logiciel atiflash permettant de l' installer sur votre GPU AMD. (Avec la commande « cd »)

Dans l'invité de commande: atiwinflash -f -p 0 « nom du bios modifié.rom » puis touche entrée pour valider.

A la fin du flashage, on vous demande de rebooter votre machine.






--------------------
Materiel APPLE :
Macbook Pro 15" Retina (Mid 2012) / i7 3620QM / 8Go DDR3 / Nvidia 650M / 500Go SSD / Catalina - Win10 Pro


Matériel Non APPLE:
PC Gamer Hackintosh / i7 8700K / ASUS Z370-E Gaming / 32Go DDR4 / EVGA RTX 2080 Ti FTW3 Ultra Gaming / 2 x 500Go SSD Nvme - 1x1To SSD Sata - 8To DD - 2To DD / Catalina - Win10 Pro - Ubuntu 19.04 / Clover 5080

Un futur mini Hackintosh à base de Ryzen 3xxx
Go to the top of the page
 
+Quote Post
teiki arii
posté 9 Dec 2018, 00:32
Message #16


Nouveau Membre


Groupe : Membres
Messages : 9
Inscrit : 19 Mar 2016
Membre no 198 393



Citation (thunder72fr @ 3 Dec 2018, 18:05) *
Télécharger:

AMD/ATI ATIFlash

Décompresser à la racine de votre disque système. Coller aussi le bios à flasher.

Dans la barre de recherche sous Windows, tapez « cmd » et vous verrez « invite de commandes » apparaître, faites un clic droit dessus puis « exécuter en tant qu’administrateur.

Aller dans le dossier qui contient le bios et le logiciel atiflash permettant de l' installer sur votre GPU AMD. (Avec la commande « cd »)

Dans l'invité de commande: atiwinflash -f -p 0 « nom du bios modifié.rom » puis touche entrée pour valider.

A la fin du flashage, on vous demande de rebooter votre machine.
Je découvre le message, je vais travailler dessus demain. Merci.
Sinon, j'ai effectué en tant qu'administrateur... De toute façon, je vois ça demain.
Merci encore!!!

Sinon, pour le son par HDMI, ça a fonctionné mais avec de drôles de trucs. Le son apparaît distordu et non homogène: très fort sur l'enceinte arrière gauche par exemple avec la voie de l'enceinte centrale avant... Bref, bizarre. Et puis après un redémarrage, tout a disparu (plus de témoin du son par HDMI dans le profil, ni de son d'ailleurs)...

Ce message a été modifié par teiki arii - 9 Dec 2018, 00:39.
Go to the top of the page
 
+Quote Post
teiki arii
posté 9 Dec 2018, 12:52
Message #17


Nouveau Membre


Groupe : Membres
Messages : 9
Inscrit : 19 Mar 2016
Membre no 198 393



Bien, j'ai suivi les instructions comme citées ci-dessus mais ça n'a pas fonctionné. Raison évoquée: "Non-correspondance des SubsystemID"...

Radeon RX 580 Series
Revision Asic N/A
DeviceID 0x67df
Type de M25P40/c

VBIOS actuel: P/N 113-4E353BU-O50
E353 Polaris20 XTX A1 GDDR5 256Mx32 8GB
Image Size 0xE800 CRC 0xFD00

Nouveau: P/N 113-4E353BU-O4E
E387 Polaris20 XTX A1 GDDR5 256Mx32 8GB
Image Size 0x40000 CRC 0xC00

Néanmoins, ma carte est reconnue nativement (ATY,Orinoco) sur le Mac Pro 5.1 (Early 2009 flashée depuis des années) par MacOs Mojave (10.14.2), BootROM 140.0.0.0.0.

Merci beaucoup de m'avoir répondu. Sinon, je n'ai pas de problème de ventilateurs, la température de la carte dépasse rarement les 50°C (traitement photo, vision UHD) sur écran P271W en 2560x1440, idéalement entre 40°C et 45°C sans ventilo, sur processeur W3680/X5675, 48Go RAM (3X16Go 1333MHz). Je viens de changer le processeur W3680 (5 ans) pour un X5675 (moins gourmand). La température du X5675 monte rarement au dessus de 60°C en pleine charge sur deux heures (ventilo à medium plutôt silencieux) contrairement au W3680 donné pour 70°C pleine charge (ventilo à fond) pour une rapidité de traitement multi-processeurs légèrement meilleure.
Si je ne trouve pas de solution (très intéressante concernant la consommation de la carte modifiée par votre mod), j'en resterai là, ce n'est pas grave...
Merci encore.

Ce message a été modifié par teiki arii - 9 Dec 2018, 13:35.
Go to the top of the page
 
+Quote Post
teiki arii
posté 9 Dec 2018, 20:39
Message #18


Nouveau Membre


Groupe : Membres
Messages : 9
Inscrit : 19 Mar 2016
Membre no 198 393



Bien, comme je n'ai pas pu flasher la carte avec le Vbios "Modded" de thunder72fr pour incompatibilité, j'ai pris le problème à la base. J'ai enregistré le bios original de ma carte dans bios.com (grâce à ATIWinFlash) puis en ai fait une copie que j'ai modifiée grâce à PolarisBiosEditor 1.6.7 selon la procédure décrite dans le Thread "Sapphire PULSE RX580 8GB VBIOS Study" du site MacRumors. Du coup, n'ayant plus d'incompatibilité de bios lié à la carte (puisque c'est l'orignal de ma carte modifié), le flashage a fonctionné comme il faut... Sur la version E353, les VRAM ne sont pas Samsung mais MICRON dans mon cas...
Les résultats? C'est encore "pire" tongue.gif , en mode repos, la carte stagne à 40-41°c et 46°C (@1,23Ghz) en charge sur vidéo UHD (vs 50°c @1,30Ghz).. La différence de consommation sans passer par les benchs semble évidente.. Même s'ils sont moins éloquents (8% moins rapide après flash en OpenCL/Metal).
Merci encore!!!

Ce message a été modifié par teiki arii - 9 Dec 2018, 23:51.
Fichier(s) joint(s)
Fichier joint  CaptureRX580biosOriginal.PNG ( 63.93 Ko ) Nombre de téléchargements : 43
Fichier joint  CaptureRX580biosModded.PNG ( 64.93 Ko ) Nombre de téléchargements : 46
Fichier joint  Capture_d___e__cran_2018_12_09_a___23.39.17.png ( 636.23 Ko ) Nombre de téléchargements : 13
 
Go to the top of the page
 
+Quote Post
Rorqual
posté 10 Dec 2018, 08:49
Message #19


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 3 992
Inscrit : 7 Sep 2001
Lieu : Sartrouville
Membre no 755



QUOTE (teiki arii @ 9 Dec 2018, 12:52) *
Je viens de changer le processeur W3680 (5 ans) pour un X5675 (moins gourmand). La température du X5675 monte rarement au dessus de 60°C en pleine charge sur deux heures (ventilo à medium plutôt silencieux) contrairement au W3680 donné pour 70°C pleine charge (ventilo à fond) pour une rapidité de traitement multi-processeurs légèrement meilleure.

Je crois bien que c'est la première fois que je vois quelqu'un sur Macbidouille changer son processeur pour un plus lent, volontairement ! biggrin.gif

(Je l'ai fait une fois aussi, il y a longtemps dans un Power Mac G4, mais c'est juste car la carte CPU (ou le CPU) était tombée en panne, et que je ne voulais pas mettre une fortune dans sa remplaçante.)


--------------------
Mac Pro 2009 flashé 2010, bien boosté : ça c'était avant. A présent : Windows 10 Pro sur Core i7-7700K 4,2 GHz - RAM DDR4 16 Go à 3200 MHz - NVIDIA GeForce RTX 2070 KFA2 - Carte-mère ASUS Strix Z270E - Boîtier Lian-Li tout alu - Ventirad Noctua - Alimentation Seasonic 80+ Platinum - SSD WD Black PCIe - SSD Samsung 840 Pro (x2) - Disques durs 7200 tours/mn Toshiba (x2) et HGST - Graveur DVD Lite-On - Webcam Logitech C930e - Moniteur Dell U2713HM (27" QHD dalle IPS) - Clavier mécanique Logitech G710+ - Souris Razer Naga 2014
Go to the top of the page
 
+Quote Post
teiki arii
posté 10 Dec 2018, 11:34
Message #20


Nouveau Membre


Groupe : Membres
Messages : 9
Inscrit : 19 Mar 2016
Membre no 198 393



Citation (Rorqual @ 10 Dec 2018, 08:49) *
Je crois bien que c'est la première fois que je vois quelqu'un sur Macbidouille changer son processeur pour un plus lent, volontairement ! biggrin.gif

(Je l'ai fait une fois aussi, il y a longtemps dans un Power Mac G4, mais c'est juste car la carte CPU (ou le CPU) était tombée en panne, et que je ne voulais pas mettre une fortune dans sa remplaçante.)


En fait, sur des charges soutenues en multi-coeurs, le X5675 (60 euros) est tout aussi véloce (un peu meilleur même) et bien moins gourmand que le W3680 (que j'ai eu en fait il y a 7 et non 5 ans pour 250 euros). Ce dernier m'a bien rendu service par rapport à celui d'origine (W3620 Quad 2.66 Ghz recyclé dans un PC pour mes enfants qui a servi à flasher ma RX580). Mais il chauffe terriblement pour des capacités intrinsèques limitées thermiquement: il tient difficilement la charge avec l'impression de se trouver dans une soufflerie. Le traitement de fichier RAW/TIFF par le logiciel Piccure+ très demandeur en ressources multi-threads est un très bon exemple: 70°c et tous vents dehors pour le W3680 vs 56°c agrémenté d'une simple brise pour des performances quasi identiques (un peu meilleures même)...
J'essaie de rallonger le plus possible la vie de mon Mac Pro early 2009 (SSD PciE et 48Go de RAM) acheté soldé à la F..c en 2010 à moitié prix (à Paris, je ne l'aurais même pas vu passer mais à Perpignan...), digne remplaçant de mon PowerMac G4 de 2000 qui avait rendu l'âme en 2010... Pour du traitement photo, c'est amplement suffisant même avec des fichiers RAW de 50Mo (Tiff à 250Mo)...
Bref, grâce au passage du W3680 vers le X5675, j'ai l'impression de redonner un petit coup de jeune (les ventilos presque au minimum le plus souvent) à mon ordinateur.... Le modded de la carte RX580 proposé ici est encore une pièce à l'édifice de l'économie et de la longévité des composants jusqu'à ce que Apple décide de nous lâcher.
Merci en tout cas à tous ceux qui œuvrent pour cette belle machine qu'est le Mac Pro 5.1... Bonne journée.

Pour info, on trouve la Sapphire RX580 Pulse 8Go à moins de 200 euros sur e..y en France. C'est toujours moins que l'augmentation de 270-->330 euros cette semaine sur A..z...fr



Ce message a été modifié par teiki arii - 10 Dec 2018, 12:49.
Go to the top of the page
 
+Quote Post
teiki arii
posté 14 Dec 2018, 20:20
Message #21


Nouveau Membre


Groupe : Membres
Messages : 9
Inscrit : 19 Mar 2016
Membre no 198 393



Citation (teiki arii @ 9 Dec 2018, 00:32) *
Sinon, pour le son par HDMI, ça a fonctionné mais avec de drôles de trucs. Le son apparaît distordu et non homogène: très fort sur l'enceinte arrière gauche par exemple avec la voie de l'enceinte centrale avant... Bref, bizarre. Et puis après un redémarrage, tout a disparu (plus de témoin du son par HDMI dans le profil, ni de son d'ailleurs)...
Bonjour à tous,
quelques précisions concernant les sorties HDMI activées sur la carte Sapphire RX580 Pulse 8Go nativement reconnue par Mojave. L'option sortie du son numérique par la prise HDMI s'affiche lorsqu'un écran est branché à la carte par une des sorties HDMI comme il se doit après modification selon thunder72fr. Donc, de ce côté pas de souci. Le problème du mélange et de la saturation des voies semblent être liés à un bug avec le programme VLC en lecture. J'ai utilisé le logiciel Elmedia Player avec succès: le son, reconnu dans son format numérique natif par l'ampli home-cinema Marantz SR-7011, sort par les canaux appropriés sans saturation aucune. Le câble HDMI reliant l'une des sorties de la carte à l'ampli home-cinema permet la reconnaissance du format vidéo 1080p 60Hz et audio PCM tous canaux sans problème et donc sans passer par la fiche DisplayPort couplée à un adaptateur actif DP-HDMI. En ce qui concerne le format UHD 4K 60Hz, je n'en sais rien, mon téléviseur est cantonné au format 1080p.
Cependant, l'image n'est pas moins bonne que celle du lecteur Dune HD Max (je la trouve un peu "plus analogique") et l'ordinateur décode nativement le format X/H265, ce qui n'est pas le cas du lecteur multimedia cantonné au H264. Pour faciliter les choses(?), j'utilise un RAMDisk pour le stockage de fichiers en lecture audio-video. L'upsizing de fichiers 720p en 1080p est tout aussi bon, pas de saccades dans les travellings ni de saut d'images...
La température de la carte Sapphire ne dépasse pas les 45°C (absence de ventilation) et le CPU les 49°C dans ces conditions.
J'espère que cela peut aider...

Ce message a été modifié par teiki arii - 14 Dec 2018, 20:28.
Go to the top of the page
 
+Quote Post
MacProAlu4Ever
posté 21 Dec 2018, 16:56
Message #22


Nouveau Membre


Groupe : Membres
Messages : 6
Inscrit : 21 Dec 2018
Membre no 206 783



Bonjour à tous,

tout d'abord merci beaucoup pour cet expertise, que je vais étudier avec une très grande attention avant de me jeter dans son application.


J'ai acquis une RX580 Nitro+ 4go pour suivre Mojave (sur un MP4.1 flashé 5.1, doté d'une Radeon 5770*). J'ai eu le souci du "black screen boot", très embêtant pour changer de disque de boot par exemple. J'ai lu ailleurs qu'il s'agirait d'un problème avec FileVault, puisque la mire d'authentification de FileVault arrive avant le chargement du pilote de la carte graphique (qui n'a pas l'EFI "Mac d'origine"). Il faudrait donc désactiver FileVault ; je ne m'explique pas comment on fini par avoir les mires des comptes sans avoir saisi le mot de passe FileVault pour déverrouiller le volume. L'autre désagrément de cet écran noir est que le démarrage est bien plus long.

Mais je lis que le flash proposé par notre ami ne résout pas le souci, rencontré tout autant sous HighSierra que Mojave. Je vais essayer en ayant désactivé FileVault, et avant de refaire la migration Mojave. Le pire est que le logo "Mac" n'apparaît pas sur les boites ; l'achat d'un carte d'occasion est donc délicat...



* après avoir migré mon MacBookAir mid-2012 sans aucun problème, je l'ai cloné sur le MacPro Alu ... et ça marche avec la 5770, au prix de petits bugs d'affichage, pas méchants mais suffisants pour m'embêter avec Lightroom par exemple.


--------------------
MacPro alu 5,1 - mono X5690 3,46Ghz - 48 Go RAM
Go to the top of the page
 
+Quote Post
thunder72fr
posté 21 Dec 2018, 18:41
Message #23


Macbidouilleur de bronze !
**

Groupe : Membres
Messages : 472
Inscrit : 5 Jun 2015
Lieu : LE MANS
Membre no 195 534



Attention, le bios proposé est pour une Sapphire RX580 Pulse 8Go


--------------------
Materiel APPLE :
Macbook Pro 15" Retina (Mid 2012) / i7 3620QM / 8Go DDR3 / Nvidia 650M / 500Go SSD / Catalina - Win10 Pro


Matériel Non APPLE:
PC Gamer Hackintosh / i7 8700K / ASUS Z370-E Gaming / 32Go DDR4 / EVGA RTX 2080 Ti FTW3 Ultra Gaming / 2 x 500Go SSD Nvme - 1x1To SSD Sata - 8To DD - 2To DD / Catalina - Win10 Pro - Ubuntu 19.04 / Clover 5080

Un futur mini Hackintosh à base de Ryzen 3xxx
Go to the top of the page
 
+Quote Post
teiki arii
posté 22 Dec 2018, 19:41
Message #24


Nouveau Membre


Groupe : Membres
Messages : 9
Inscrit : 19 Mar 2016
Membre no 198 393



Citation (teiki arii @ 14 Dec 2018, 20:20) *
Citation (teiki arii @ 9 Dec 2018, 00:32) *
Sinon, pour le son par HDMI, ça a fonctionné mais avec de drôles de trucs. Le son apparaît distordu et non homogène: très fort sur l'enceinte arrière gauche par exemple avec la voie de l'enceinte centrale avant... Bref, bizarre. Et puis après un redémarrage, tout a disparu (plus de témoin du son par HDMI dans le profil, ni de son d'ailleurs)...
Bonjour à tous,
quelques précisions concernant les sorties HDMI activées sur la carte Sapphire RX580 Pulse 8Go nativement reconnue par Mojave. L'option sortie du son numérique par la prise HDMI s'affiche lorsqu'un écran est branché à la carte par une des sorties HDMI comme il se doit après modification selon thunder72fr. Donc, de ce côté pas de souci. Le problème du mélange et de la saturation des voies semblent être liés à un bug avec le programme VLC en lecture. J'ai utilisé le logiciel Elmedia Player avec succès: le son, reconnu dans son format numérique natif par l'ampli home-cinema Marantz SR-7011, sort par les canaux appropriés sans saturation aucune. Le câble HDMI reliant l'une des sorties de la carte à l'ampli home-cinema permet la reconnaissance du format vidéo 1080p 60Hz et audio PCM tous canaux sans problème et donc sans passer par la fiche DisplayPort couplée à un adaptateur actif DP-HDMI. En ce qui concerne le format UHD 4K 60Hz, je n'en sais rien, mon téléviseur est cantonné au format 1080p.
Cependant, l'image n'est pas moins bonne que celle du lecteur Dune HD Max (je la trouve un peu "plus analogique") et l'ordinateur décode nativement le format X/H265, ce qui n'est pas le cas du lecteur multimedia cantonné au H264. Pour faciliter les choses(?), j'utilise un RAMDisk pour le stockage de fichiers en lecture audio-video. L'upsizing de fichiers 720p en 1080p est tout aussi bon, pas de saccades dans les travellings ni de saut d'images...
La température de la carte Sapphire ne dépasse pas les 45°C (absence de ventilation) et le CPU les 49°C dans ces conditions.
J'espère que cela peut aider...


Grâce au thread HOWTO: Play Surround Sound with your Mac and A/V Receiver Properly, je peux désormais utiliser le son correctement avec VLC (mais l'image est la plus mauvaise des logiciels testés). J'ai toujours le même problème avec MPlayerX malgré le patch. Si quelqu'un savait comment s'en affranchir avec ce logiciel?
Sinon, il existe un logiciel gratuit, le meilleur que j'ai trouvé, IINA 1.0.0-rc qui:
- fait un excellent travail pour la lecture des fichiers X265,
- permet la compatibilité totale avec la sortie audio via HDMI (sans patch),
- permet l'utilisation de la télécommande Apple remote (acier) grâce à la clef USB remote smartgus avec le Mac Pro 5.1.
Bonnes fêtes.
Go to the top of the page
 
+Quote Post
MacProAlu4Ever
posté 2 Jan 2019, 11:37
Message #25


Nouveau Membre


Groupe : Membres
Messages : 6
Inscrit : 21 Dec 2018
Membre no 206 783



Citation (thunder72fr @ 21 Dec 2018, 18:41) *
Attention, le bios proposé est pour une Sapphire RX580 Pulse 8Go


Oui, bien noté. En fait j'ai remis la carte en vente et je vais chercher la "spécial Mac", ça me semble plus simple et moins risqué, d'autant que la migration sous Mojave ne presse pas (High Sierra est encore sous MCS).


--------------------
MacPro alu 5,1 - mono X5690 3,46Ghz - 48 Go RAM
Go to the top of the page
 
+Quote Post
MacProAlu4Ever
posté 21 Aug 2019, 11:45
Message #26


Nouveau Membre


Groupe : Membres
Messages : 6
Inscrit : 21 Dec 2018
Membre no 206 783



Bonjour chers amis,

après moulte pérégrinations dont je vous fais grâce, voici où nous en sommes hier soir :
- la 5770 et la Sapphire installées et alimentées (eh oui, la Sapphire se contente d'un mini-6.... cf. plus bas)
- BIOS : 144.0.0.0
- la 5770 pilote l'écran
- installation HighSierra "vierge" sur APFS non chiffré
- les deux cartes sont reconnues par l'OS (si si malgré un seul mini 6 pour la Sapphire...)
- extinction
- déconnexion électrique de la 5770
- rallumage avec bouton power enfoncé 10 secondes => clignotements, "beuuuuuuhhhh" puis "chboing"
- vidage PRAM (par Alt+Cmd+P+R trois fois)
- pas de boot screen jusqu'à la mire de d'ouverture de session
- installation de Mojave
- reboot
- pas de boot screen jusqu'à la mire de d'ouverture de session
- carte parfaitement reconnue par l'OS ("A propos de ce Mac").

J'en viens donc à penser que, voulant absolument conserver le boot screen et l'activation de FileVault (que je sais impossible dans la situation actuelle), je vais m'orienter vers une "Mac edition" gravé dans le plastique.

Je lis vos retours avec intérêt.


--------------------
MacPro alu 5,1 - mono X5690 3,46Ghz - 48 Go RAM
Go to the top of the page
 
+Quote Post
Toffti
posté 21 Aug 2019, 15:17
Message #27


Macbidouilleur d'argent !
***

Groupe : Membres
Messages : 709
Inscrit : 24 Feb 2004
Lieu : Maisons-Laffitte
Membre no 15 335



Hello, une RX 580 Mac Edition n'existe pas malheureusement..........

Tof


--------------------
Des Macs depuis 1988 et tout ce qui va avec !
Go to the top of the page
 
+Quote Post
X_Gebo
posté 21 Aug 2019, 16:18
Message #28


Macbidouilleur d'argent !
***

Groupe : Membres
Messages : 781
Inscrit : 2 Aug 2011
Lieu : Montpellier
Membre no 169 375



Citation (MacProAlu4Ever @ 21 Aug 2019, 11:45) *
- la 5770 et la Sapphire installées et alimentées (eh oui, la Sapphire se contente d'un mini-6.... cf. plus bas)
[...]
- les deux cartes sont reconnues par l'OS (si si malgré un seul mini 6 pour la Sapphire...)

Possible que la simple reconnaissance par l'OS ne sollicite pas autant la carte, et donc sa consommation, que le calcul d'une image photoréaliste, par exemple... A tester ?


--------------------
Go to the top of the page
 
+Quote Post
Krazubu
posté 22 Aug 2019, 08:24
Message #29


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 2 846
Inscrit : 5 Sep 2005
Membre no 45 266



Tu ne devrais pas jouer à ça, tu es en train de tirer plus de puissance que les lignes ne peuvent en fournir théoriquement, s'il y a une bonne tolérance, elle n'est pas infinie et tu prends le risque de griller la carte mère, l'alimentation, voire la carte graphique avec.

Ce message a été modifié par Krazubu - 22 Aug 2019, 08:58.
Go to the top of the page
 
+Quote Post
MacProAlu4Ever
posté 22 Aug 2019, 10:33
Message #30


Nouveau Membre


Groupe : Membres
Messages : 6
Inscrit : 21 Dec 2018
Membre no 206 783



Bonjour chers amis,

partant du principe que si des ingénieurs y ont pensé, et que les acheteurs des pièces détachées l'ont validé, la présence des broches 8+6 doit être utilisée. Donc, sans avoir pensé au risque de "tirer trop fort" sur la mini6 qui alimente la 8, j'ai bien branché les deux*. Grâce à vous, j'ai maintenant une raison claire de le faire.

Voici le résultat de l'installation "sur deux pattes" :
- volume "MacOS" : tout sauf /users, pas de FileVault
- volume "Users" : crypté à la création avec l'utilitaire disque, "/users" sauf le compte admin (j'ai pas osé)

Toujours pas de bootscreen (pas d'attente à ce sujet) mais ça marche plutôt bien (je dis "plutôt" parce que j'ai juste lancé un Cinebench** après avoir ouvert la session. A deux du mat', pas capable de plus biggrin.gif ). Je vais travailler comme ça pendant une petite semaine, notamment avec Lightroom (ce qui me permettra de concrétiser l'écart de score entre la 5770 et la Sapphire vu sous Geekbench). Je reste quand même embêté de ne pas pouvoir changer de disque de boot (pendant le boot, avec Alt), ou de lancer le boot en verbose, etc...

Bref, l'achat d'une HD7950 "Mac edtion"*** qu'on me promet comme compatible avec le bootscreen et FileVault (ce que je trouve étrange, puisque ce dernier est coincé par Apple sous Mojave) reste en tête (au même prix que la Sapphire, mais 40% moins performante sous Geekbench). Bref, ça me dérange de "bricoler" (bi-partitions) et de vivre la première régression fonctionnelle de ce MacPro adoré (10 ans l'an prochain...). Et rester sous HighSierra avec la Sapphire ne résoud pas la problème. Je tremble pour Catalina, annoncé comme non installable, bien qu'en bricolant un peu, certains semblent y être parvenus.

Merci pour vos remarques utiles. Je vais réfléchir à l'utilité de flasher la Sapphire (j'avoue être franchement frileux).




* La 5770 n'ayant pas vocation à rester dans le cMP :-)
** ATI5770 : 1610 points. Sapphire RX580 : 1551 points. L'écart est faible, et même en retrait. A refaire pour être sûr.
*** c'est à celle-là que je pensais avec cette appellation

Ce message a été modifié par MacProAlu4Ever - 22 Aug 2019, 10:58.


--------------------
MacPro alu 5,1 - mono X5690 3,46Ghz - 48 Go RAM
Go to the top of the page
 
+Quote Post

2 Pages V   1 2 >
Reply to this topicStart new topic
1 utilisateur(s) sur ce sujet (1 invité(s) et 0 utilisateur(s) anonyme(s))
0 membre(s) :

 



Nous sommes le : 13th October 2019 - 22:10