IPB

Bienvenue invité ( Connexion | Inscription )

 
Reply to this topicStart new topic
> [RESOLU] Spotlight n'indexe pas mes disques serveurs...
Options
mobil12
posté 9 Apr 2015, 15:26
Message #1


Adepte de Macbidouille
*

Groupe : Membres
Messages : 97
Inscrit : 28 Jun 2005
Membre no 41 635



bonjour

Je possède un serveur osx server 10,6,2 qui roucoule avec bonheur. Il ne me sert qu'en filesharing, j'active parfois d'autres trucs mais c'est pour jouer. donc je n'ai pas l'intention de l'upgrader pour l'instant car.... if it works... don't fix it.
Je bosse dans le son, j'ai une grande partie de mes sons pour soundesign (bruitage donc, pas mes banques de son musique) sur un share de ce serveur. c''est très pratique car je bosse sur plusieurs ordis dans différents endroits (tout en local)

j'ai noté que spotlight n'indexait pas justement ce disque. D'abord en réseau donc j'ai pensé a une mauvaise config des droits d'acces de spotlight via afp. J'ai vérifié, ca m'a l'air cohérent....

du coup j'ai vérifié egalement sur le serveur lui même et il refuse d'indexer le disque.... pourtant tous les autres disques sont correctement indéxés... c'est ballo heiin... c'est le seul où j'en ai besoin...

Donc avez vous une idée de pourquoi il n'indexe pas spécifiquement ce disque? Dans les options de spotlight de system préférences, il n'est pas dans la liste des disques ou folders à exclure....

Vous avez une idée de pourquoi? ca m'embète vraiment..

Merci

Ce message a été modifié par mobil12 - 28 Apr 2015, 14:27.
Go to the top of the page
 
+Quote Post
yponomeute
posté 9 Apr 2015, 19:27
Message #2


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 4 969
Inscrit : 26 Jan 2011
Lieu : Pollachius virens
Membre no 164 083



Dans le terminal avec la commande suivante tu peux voir si l'indexation est activée sur le volume

Code
mdutil -s /Volumes/nom_du_volume_reseau


Tu dois pouvoir activier l'indexation avec la commande

Code
sudo mdutil -i on /Volumes/nom_du_volume_reseau


et pour désactiver

Code
sudo mdutil -i off /Volumes/nom_du_volume_reseau


Détails ici : https://developer.apple.com/library/mac/doc...1/mdutil.1.html

Ce message a été modifié par yponomeute - 9 Apr 2015, 19:28.


--------------------
MBP 2017 15" avec clavier pourri et touchbar inutile
Go to the top of the page
 
+Quote Post
trouspinette
posté 9 Apr 2015, 19:38
Message #3


Macbidouilleur d'Or !
*****

Groupe : Rédacteurs
Messages : 5 065
Inscrit : 19 Feb 2002
Lieu : BZH
Membre no 2 083



Il faut commencer par refaire la base sur le serveur.

http://forum.macbidouille.com/index.php?sh...mp;hl=Spotlight


1) Using the mdutil command-line utility in Terminal, turn off indexing for each of your drives. Example:

* sudo mdutil -i off /Volumes/your_hard_drive_name_1
* sudo mdutil -i off /Volumes/your_hard_drive_name_2

2) Then use mdutil to remove the indexes from each drive

* sudo mdutil -E /Volumes/your_hard_drive_name_1
* sudo mdutil -E /Volumes/your_hard_drive_name_2

3) Physically remove the .Spotlight directories from the root of each drive.

* cd /Volumes/your_hard_drive_name_1
* sudo rm -fr .Spotlight-V100

(do the same for your second or third drive)

Make sure to carefully type the "rm" command -- a typo could result in deletion of critical files.

4) Use mdutil again to turn indexing back on for each drive

* sudo mdutil -i on /Volumes/your_hard_drive_name_1
* sudo mdutil -i on /Volumes/your_hard_drive_name_2


--------------------
Quis custodiet ipsos custodes ? - Lorsqu'un sujet est résolu, merci d'indiquer [Résolu] dans le titre de votre post !

Luttons contre le style SMS !!!

iPhone 14Pro Max 256 Go iOS 17• MacBook Pro 16 2019 Core i9 - macOS 12.7.2 - 32 GB RAM - 2 TB • @Orange
Linux • OPNSense / pfSense • Une pointe de Windows aussi • Enfocus Switch Expert • callas pdfToolBox
Go to the top of the page
 
+Quote Post
mobil12
posté 26 Apr 2015, 17:50
Message #4


Adepte de Macbidouille
*

Groupe : Membres
Messages : 97
Inscrit : 28 Jun 2005
Membre no 41 635



Merci pour les réponses, j'entends bien qu'il est en train de re-indexer les disques, ca gratouille et ca papouille en masse... il y en a pour des heures je pense vu le volume des volumes...

Ensuite il faudra voir comment cela se répercute sur les shares....

affaire en cours, et à suivre.
Go to the top of the page
 
+Quote Post
mobil12
posté 28 Apr 2015, 14:27
Message #5


Adepte de Macbidouille
*

Groupe : Membres
Messages : 97
Inscrit : 28 Jun 2005
Membre no 41 635



voila
joie bonheur et félicité.
merci
Go to the top of the page
 
+Quote Post
trouspinette
posté 29 Apr 2015, 21:08
Message #6


Macbidouilleur d'Or !
*****

Groupe : Rédacteurs
Messages : 5 065
Inscrit : 19 Feb 2002
Lieu : BZH
Membre no 2 083



Citation (mobil12 @ 28 Apr 2015, 15:27) *
voila
joie bonheur et félicité.
merci

U welcome Sir !


--------------------
Quis custodiet ipsos custodes ? - Lorsqu'un sujet est résolu, merci d'indiquer [Résolu] dans le titre de votre post !

Luttons contre le style SMS !!!

iPhone 14Pro Max 256 Go iOS 17• MacBook Pro 16 2019 Core i9 - macOS 12.7.2 - 32 GB RAM - 2 TB • @Orange
Linux • OPNSense / pfSense • Une pointe de Windows aussi • Enfocus Switch Expert • callas pdfToolBox
Go to the top of the page
 
+Quote Post
ccciolll
posté 23 Sep 2015, 09:01
Message #7


Macbidouilleur de bronze !
**

Groupe : Membres
Messages : 262
Inscrit : 10 Mar 2005
Membre no 34 861



Je viens de tester les commandes indiquées pour remettre l'indexation en marche, il m'a indiqué indexation enabled, ça semble encourageant.

maintenant j'imagine qu'il va falloir attendre des heures, voire des jours, avant de pouvoir vérifier que ça a fonctionné. Ou il y a un moyen de constater le travail d'indexation en cours (depuis mon mac, si possible, je préfère éviter de trop toucher au serveur, en plus il fait frisquet là où il se trouve).


--------------------
En famille
Hackintosh : intel core i5 3570K "Ivy Bridge" - Memoire 1*8 Go DDR3 1333 Mhz (1 empl. vide) - DD SSD 256 Go - Carte Mère Gigabyte GA-Z77N-WIFI > Codec ALC892 - late 2012 - AMD HD 6870 - OSX Sierra 10.12.6 + Ubuntu 16.04
MacMini3,1 : 2.0 Ghz core 2 duo "Penryn" - early 2009 - A1283 - RAM : 2* 4 Go DDR3 1333 Mhz - DD 320 Go 5400 rpm - MacOS X 10.11.6 El Capitan
PowerMac7,3 : G5 2 Ghz - early 2005- A1047 - RAM : 2*512 Mo DDR pc3200 400 Mhz (2 empl. vides) - DD 80 Go 7200 rpm - MacOS X 10.5.8 Leopard
--
Au travail
MacPro1,1 : 2x2.66 Ghz Dual Core intel Xeon "Woodcrest" - Mac Pro - mid 2006 - A1186 - MacOS X 10.6.8 Snow Leopard
iMac12,1 : 2,5 Ghz Intel Core i5 "Sandy Bridge"- 21,5 inch - mid 2011 - A1311 - Mac OSX 10.7.5 Lion

Apple, Paye tes impôts !
Go to the top of the page
 
+Quote Post
trouspinette
posté 23 Sep 2015, 13:10
Message #8


Macbidouilleur d'Or !
*****

Groupe : Rédacteurs
Messages : 5 065
Inscrit : 19 Feb 2002
Lieu : BZH
Membre no 2 083



Citation (ccciolll @ 23 Sep 2015, 10:01) *
Je viens de tester les commandes indiquées pour remettre l'indexation en marche, il m'a indiqué indexation enabled, ça semble encourageant.

maintenant j'imagine qu'il va falloir attendre des heures, voire des jours, avant de pouvoir vérifier que ça a fonctionné. Ou il y a un moyen de constater le travail d'indexation en cours (depuis mon mac, si possible, je préfère éviter de trop toucher au serveur, en plus il fait frisquet là où il se trouve).

Bonjour,

Tu regardes quelle charge CPU utilise mds : en temps normal, il ne mange que moins de 1% de CPU. Si il consomme plus de 10/20%, tu peux être sûr qu'il n'a pas fini son boulot.


--------------------
Quis custodiet ipsos custodes ? - Lorsqu'un sujet est résolu, merci d'indiquer [Résolu] dans le titre de votre post !

Luttons contre le style SMS !!!

iPhone 14Pro Max 256 Go iOS 17• MacBook Pro 16 2019 Core i9 - macOS 12.7.2 - 32 GB RAM - 2 TB • @Orange
Linux • OPNSense / pfSense • Une pointe de Windows aussi • Enfocus Switch Expert • callas pdfToolBox
Go to the top of the page
 
+Quote Post
ccciolll
posté 24 Sep 2015, 10:26
Message #9


Macbidouilleur de bronze !
**

Groupe : Membres
Messages : 262
Inscrit : 10 Mar 2005
Membre no 34 861



Je suppose que c'est une vérification à faire dans moniteur d'activité ?

Sur mon poste, je ne trouve aucun MDS (je suis en snow leo)

Faut-il aller voir sur le serveur directement ?

En tout cas, ce matin, aucune recherche possible sur ce serveur de mon poste (c'est un serveur mac, je précise, mais paramétré pour être partagé aussi avec des utilisateurs Windows, ça peut expliquer des choses).


--------------------
En famille
Hackintosh : intel core i5 3570K "Ivy Bridge" - Memoire 1*8 Go DDR3 1333 Mhz (1 empl. vide) - DD SSD 256 Go - Carte Mère Gigabyte GA-Z77N-WIFI > Codec ALC892 - late 2012 - AMD HD 6870 - OSX Sierra 10.12.6 + Ubuntu 16.04
MacMini3,1 : 2.0 Ghz core 2 duo "Penryn" - early 2009 - A1283 - RAM : 2* 4 Go DDR3 1333 Mhz - DD 320 Go 5400 rpm - MacOS X 10.11.6 El Capitan
PowerMac7,3 : G5 2 Ghz - early 2005- A1047 - RAM : 2*512 Mo DDR pc3200 400 Mhz (2 empl. vides) - DD 80 Go 7200 rpm - MacOS X 10.5.8 Leopard
--
Au travail
MacPro1,1 : 2x2.66 Ghz Dual Core intel Xeon "Woodcrest" - Mac Pro - mid 2006 - A1186 - MacOS X 10.6.8 Snow Leopard
iMac12,1 : 2,5 Ghz Intel Core i5 "Sandy Bridge"- 21,5 inch - mid 2011 - A1311 - Mac OSX 10.7.5 Lion

Apple, Paye tes impôts !
Go to the top of the page
 
+Quote Post
trouspinette
posté 24 Sep 2015, 11:20
Message #10


Macbidouilleur d'Or !
*****

Groupe : Rédacteurs
Messages : 5 065
Inscrit : 19 Feb 2002
Lieu : BZH
Membre no 2 083



Citation (ccciolll @ 24 Sep 2015, 11:26) *
En tout cas, ce matin, aucune recherche possible sur ce serveur de mon poste

Quelle version Mac OS X le poste Client ?


--------------------
Quis custodiet ipsos custodes ? - Lorsqu'un sujet est résolu, merci d'indiquer [Résolu] dans le titre de votre post !

Luttons contre le style SMS !!!

iPhone 14Pro Max 256 Go iOS 17• MacBook Pro 16 2019 Core i9 - macOS 12.7.2 - 32 GB RAM - 2 TB • @Orange
Linux • OPNSense / pfSense • Une pointe de Windows aussi • Enfocus Switch Expert • callas pdfToolBox
Go to the top of the page
 
+Quote Post
ccciolll
posté 24 Sep 2015, 12:25
Message #11


Macbidouilleur de bronze !
**

Groupe : Membres
Messages : 262
Inscrit : 10 Mar 2005
Membre no 34 861



par contre GROOOOS problème dont je viens de m'apercevoir : plus de recherche spotlight possible non plus sur mon poste en local (en tout cas sur des fichiers récents)

Citation (trouspinette @ 24 Sep 2015, 11:20) *
Citation (ccciolll @ 24 Sep 2015, 11:26) *
En tout cas, ce matin, aucune recherche possible sur ce serveur de mon poste

Quelle version Mac OS X le poste Client ?


MacOSX server 10.5.2

EDIT : et lui affiche bien un MDS dans sa liste du moniteur d'activité 0,0 % proc / 15 fils / 3,5 Mo reelle
Pas énorme, non ?

Ce message a été modifié par ccciolll - 24 Sep 2015, 12:29.


--------------------
En famille
Hackintosh : intel core i5 3570K "Ivy Bridge" - Memoire 1*8 Go DDR3 1333 Mhz (1 empl. vide) - DD SSD 256 Go - Carte Mère Gigabyte GA-Z77N-WIFI > Codec ALC892 - late 2012 - AMD HD 6870 - OSX Sierra 10.12.6 + Ubuntu 16.04
MacMini3,1 : 2.0 Ghz core 2 duo "Penryn" - early 2009 - A1283 - RAM : 2* 4 Go DDR3 1333 Mhz - DD 320 Go 5400 rpm - MacOS X 10.11.6 El Capitan
PowerMac7,3 : G5 2 Ghz - early 2005- A1047 - RAM : 2*512 Mo DDR pc3200 400 Mhz (2 empl. vides) - DD 80 Go 7200 rpm - MacOS X 10.5.8 Leopard
--
Au travail
MacPro1,1 : 2x2.66 Ghz Dual Core intel Xeon "Woodcrest" - Mac Pro - mid 2006 - A1186 - MacOS X 10.6.8 Snow Leopard
iMac12,1 : 2,5 Ghz Intel Core i5 "Sandy Bridge"- 21,5 inch - mid 2011 - A1311 - Mac OSX 10.7.5 Lion

Apple, Paye tes impôts !
Go to the top of the page
 
+Quote Post
trouspinette
posté 25 Sep 2015, 11:20
Message #12


Macbidouilleur d'Or !
*****

Groupe : Rédacteurs
Messages : 5 065
Inscrit : 19 Feb 2002
Lieu : BZH
Membre no 2 083



Citation (ccciolll @ 24 Sep 2015, 13:25) *
par contre GROOOOS problème dont je viens de m'apercevoir : plus de recherche spotlight possible non plus sur mon poste en local (en tout cas sur des fichiers récents)

Citation (trouspinette @ 24 Sep 2015, 11:20) *
Citation (ccciolll @ 24 Sep 2015, 11:26) *
En tout cas, ce matin, aucune recherche possible sur ce serveur de mon poste

Quelle version Mac OS X le poste Client ?


MacOSX server 10.5.2

EDIT : et lui affiche bien un MDS dans sa liste du moniteur d'activité 0,0 % proc / 15 fils / 3,5 Mo reelle
Pas énorme, non ?

Si gros problème, soit tu as mal suivi la procédure, soit tu as mal suivi la procédure -)

0,0 % proc / 15 fils / 3,5 Mo reelle => normal


--------------------
Quis custodiet ipsos custodes ? - Lorsqu'un sujet est résolu, merci d'indiquer [Résolu] dans le titre de votre post !

Luttons contre le style SMS !!!

iPhone 14Pro Max 256 Go iOS 17• MacBook Pro 16 2019 Core i9 - macOS 12.7.2 - 32 GB RAM - 2 TB • @Orange
Linux • OPNSense / pfSense • Une pointe de Windows aussi • Enfocus Switch Expert • callas pdfToolBox
Go to the top of the page
 
+Quote Post
ccciolll
posté 25 Sep 2015, 12:44
Message #13


Macbidouilleur de bronze !
**

Groupe : Membres
Messages : 262
Inscrit : 10 Mar 2005
Membre no 34 861



Aujourd'hui ça remarche, mais par contre tj rien sur le serveur.


--------------------
En famille
Hackintosh : intel core i5 3570K "Ivy Bridge" - Memoire 1*8 Go DDR3 1333 Mhz (1 empl. vide) - DD SSD 256 Go - Carte Mère Gigabyte GA-Z77N-WIFI > Codec ALC892 - late 2012 - AMD HD 6870 - OSX Sierra 10.12.6 + Ubuntu 16.04
MacMini3,1 : 2.0 Ghz core 2 duo "Penryn" - early 2009 - A1283 - RAM : 2* 4 Go DDR3 1333 Mhz - DD 320 Go 5400 rpm - MacOS X 10.11.6 El Capitan
PowerMac7,3 : G5 2 Ghz - early 2005- A1047 - RAM : 2*512 Mo DDR pc3200 400 Mhz (2 empl. vides) - DD 80 Go 7200 rpm - MacOS X 10.5.8 Leopard
--
Au travail
MacPro1,1 : 2x2.66 Ghz Dual Core intel Xeon "Woodcrest" - Mac Pro - mid 2006 - A1186 - MacOS X 10.6.8 Snow Leopard
iMac12,1 : 2,5 Ghz Intel Core i5 "Sandy Bridge"- 21,5 inch - mid 2011 - A1311 - Mac OSX 10.7.5 Lion

Apple, Paye tes impôts !
Go to the top of the page
 
+Quote Post
ccciolll
posté 28 Sep 2015, 09:26
Message #14


Macbidouilleur de bronze !
**

Groupe : Membres
Messages : 262
Inscrit : 10 Mar 2005
Membre no 34 861



En fait, fausse levée d'alerte, silverlight spotlight est bien totalement hors jeu, même en local, depuis ma dernière intervention (qui n'a pourtant consisté qu'à entrer le code sudo mdutil -i on /Volumes/nom_du_volume_reseau pour activer l'indexation sur un disque réseau.

Depuis, rien sur le disque réseau, mais par contre en local il a pété les plombs, il ne trouve plus que qqes bribes d'éléments.
C'est la cata.

EDIT : 5 minutes plus tard, le temps de poster cette réponse, le voilà qui semble remarcher…
Bizarre.

Ce message a été modifié par ccciolll - 29 Sep 2015, 09:32.


--------------------
En famille
Hackintosh : intel core i5 3570K "Ivy Bridge" - Memoire 1*8 Go DDR3 1333 Mhz (1 empl. vide) - DD SSD 256 Go - Carte Mère Gigabyte GA-Z77N-WIFI > Codec ALC892 - late 2012 - AMD HD 6870 - OSX Sierra 10.12.6 + Ubuntu 16.04
MacMini3,1 : 2.0 Ghz core 2 duo "Penryn" - early 2009 - A1283 - RAM : 2* 4 Go DDR3 1333 Mhz - DD 320 Go 5400 rpm - MacOS X 10.11.6 El Capitan
PowerMac7,3 : G5 2 Ghz - early 2005- A1047 - RAM : 2*512 Mo DDR pc3200 400 Mhz (2 empl. vides) - DD 80 Go 7200 rpm - MacOS X 10.5.8 Leopard
--
Au travail
MacPro1,1 : 2x2.66 Ghz Dual Core intel Xeon "Woodcrest" - Mac Pro - mid 2006 - A1186 - MacOS X 10.6.8 Snow Leopard
iMac12,1 : 2,5 Ghz Intel Core i5 "Sandy Bridge"- 21,5 inch - mid 2011 - A1311 - Mac OSX 10.7.5 Lion

Apple, Paye tes impôts !
Go to the top of the page
 
+Quote Post
trouspinette
posté 28 Sep 2015, 21:53
Message #15


Macbidouilleur d'Or !
*****

Groupe : Rédacteurs
Messages : 5 065
Inscrit : 19 Feb 2002
Lieu : BZH
Membre no 2 083



Citation (ccciolll @ 28 Sep 2015, 10:26) *
.../... silverlight est bien totalement hors jeu, .../...


??? Silverlight ou Spotlight ?

Citation (ccciolll @ 28 Sep 2015, 10:26) *
.../... qu'à entrer le code sudo mdutil -i on /Volumes/nom_du_volume_reseau pour activer l'indexation sur un disque réseau.

Je crois que tu fais une grosse boulette : ce n'est pas sur le volume réseau que tu dois faire les actions de turn ON/OFF et Cie, mais en LOCAL sur le serveur !

Rassure moi, tu n'as pas fait tout ça depuis un poste Client sur un des tes volumes AFP/Samba ?

Citation (yponomeute @ 9 Apr 2015, 20:27) *
Dans le terminal avec la commande suivante tu peux voir si l'indexation est activée sur le volume

Code
mdutil -s /Volumes/nom_du_volume_reseau


Tu dois pouvoir activier l'indexation avec la commande

Code
sudo mdutil -i on /Volumes/nom_du_volume_reseau


et pour désactiver

Code
sudo mdutil -i off /Volumes/nom_du_volume_reseau


Détails ici : https://developer.apple.com/library/mac/doc...1/mdutil.1.html


@yponomeute => corrige ta réponse, on ne fait pas un mdutil -i ON/FF sur le volume réseau monté sur un poste Client mais SUR le serveur lui même.


Citation (ccciolll @ 24 Sep 2015, 13:25) *
MacOSX server 10.5.2

Mets le à jour en 10.5.8


--------------------
Quis custodiet ipsos custodes ? - Lorsqu'un sujet est résolu, merci d'indiquer [Résolu] dans le titre de votre post !

Luttons contre le style SMS !!!

iPhone 14Pro Max 256 Go iOS 17• MacBook Pro 16 2019 Core i9 - macOS 12.7.2 - 32 GB RAM - 2 TB • @Orange
Linux • OPNSense / pfSense • Une pointe de Windows aussi • Enfocus Switch Expert • callas pdfToolBox
Go to the top of the page
 
+Quote Post
ccciolll
posté 29 Sep 2015, 09:31
Message #16


Macbidouilleur de bronze !
**

Groupe : Membres
Messages : 262
Inscrit : 10 Mar 2005
Membre no 34 861



Citation (trouspinette @ 28 Sep 2015, 21:53) *
?? Silverlight ou Spotlight ?


Oui oui, SPOT.
à force de parler de silverlight à longueur de journée dans mon boulot…

Citation (trouspinette @ 28 Sep 2015, 21:53) *
Je crois que tu fais une grosse boulette : ce n'est pas sur le volume réseau que tu dois faire les actions de turn ON/OFF et Cie, mais en LOCAL sur le serveur !
Rassure moi, tu n'as pas fait tout ça depuis un poste Client sur un des tes volumes AFP/Samba ?


Je ne vais pas te rassurer, j'ai bien utilisé ce code terminal depuis mon poste perso, pas sur le serveur.
Comment dois-je faire pour réparer cette erreur ?

Citation (trouspinette @ 28 Sep 2015, 21:53) *
Mets le à jour en 10.5.8


If it don't bugs, don't fix it…

On a déjà perdu un serveur cet été avec 1 an de données dessus (tout mon boulot de développement de 2014-2015), donc je vais éviter de toucher au dernier qui tient encore debout tant que les informaticiens du groupe ne seront pas ENFIN venu nous installer une solution solide… Ce qui peut encore prendre quelques mois vu l'intérêt qu'ils portent à notre minuscule agence… (plus de responsable informatique depuis 18 mois, serveurs à l'abandon…)


--------------------
En famille
Hackintosh : intel core i5 3570K "Ivy Bridge" - Memoire 1*8 Go DDR3 1333 Mhz (1 empl. vide) - DD SSD 256 Go - Carte Mère Gigabyte GA-Z77N-WIFI > Codec ALC892 - late 2012 - AMD HD 6870 - OSX Sierra 10.12.6 + Ubuntu 16.04
MacMini3,1 : 2.0 Ghz core 2 duo "Penryn" - early 2009 - A1283 - RAM : 2* 4 Go DDR3 1333 Mhz - DD 320 Go 5400 rpm - MacOS X 10.11.6 El Capitan
PowerMac7,3 : G5 2 Ghz - early 2005- A1047 - RAM : 2*512 Mo DDR pc3200 400 Mhz (2 empl. vides) - DD 80 Go 7200 rpm - MacOS X 10.5.8 Leopard
--
Au travail
MacPro1,1 : 2x2.66 Ghz Dual Core intel Xeon "Woodcrest" - Mac Pro - mid 2006 - A1186 - MacOS X 10.6.8 Snow Leopard
iMac12,1 : 2,5 Ghz Intel Core i5 "Sandy Bridge"- 21,5 inch - mid 2011 - A1311 - Mac OSX 10.7.5 Lion

Apple, Paye tes impôts !
Go to the top of the page
 
+Quote Post
trouspinette
posté 29 Sep 2015, 11:43
Message #17


Macbidouilleur d'Or !
*****

Groupe : Rédacteurs
Messages : 5 065
Inscrit : 19 Feb 2002
Lieu : BZH
Membre no 2 083



Citation (ccciolll @ 29 Sep 2015, 10:31) *
Je ne vais pas te rassurer, j'ai bien utilisé ce code terminal depuis mon poste perso, pas sur le serveur.
Comment dois-je faire pour réparer cette erreur ?

If it don't bugs, don't fix it…

On a déjà perdu un serveur cet été avec 1 an de données dessus (tout mon boulot de développement de 2014-2015), donc je vais éviter de toucher au dernier qui tient encore debout tant que les informaticiens du groupe ne seront pas ENFIN venu nous installer une solution solide… Ce qui peut encore prendre quelques mois vu l'intérêt qu'ils portent à notre minuscule agence… (plus de responsable informatique depuis 18 mois, serveurs à l'abandon…)


Pour refaire les index/base de données Spotlight, tu reprends le message #3 de ce fil du discussion, en faisant ces opérations sur le serveur.

ATTENTION lors du passage de commande rm -rf : il faut te placer dans /Volumes/Mon_disque_kivabien, et faire le rm -rf .Spotlight-V100

Tiens nous au courant.

Pour la MàJ en 10.5.8, ce n'est pas critique en effet : si tu effectues un clone système de ton serveur avant, il n'y que peu de risques.


--------------------
Quis custodiet ipsos custodes ? - Lorsqu'un sujet est résolu, merci d'indiquer [Résolu] dans le titre de votre post !

Luttons contre le style SMS !!!

iPhone 14Pro Max 256 Go iOS 17• MacBook Pro 16 2019 Core i9 - macOS 12.7.2 - 32 GB RAM - 2 TB • @Orange
Linux • OPNSense / pfSense • Une pointe de Windows aussi • Enfocus Switch Expert • callas pdfToolBox
Go to the top of the page
 
+Quote Post
ccciolll
posté 29 Sep 2015, 12:09
Message #18


Macbidouilleur de bronze !
**

Groupe : Membres
Messages : 262
Inscrit : 10 Mar 2005
Membre no 34 861



Je viens de remarquer un truc.

Si je lance une recherche Spotlight sur ce fameux serveur depuis un autre poste que mon principal (ici depuis mon poste secondaire en Lion 10.7.5), ladite recherche produit un résultat à priori probant (521 fichiers comportant le terme PDF sur un dossier de juillet, par exemple).
La même recherche effectuée depuis mon poste principal en SnowLeo 10.6.8 ne donne absolument aucun résultat.

Donc il y a un bug qqpart sur mon poste principal.
Comment l'identifier ?


--------------------
En famille
Hackintosh : intel core i5 3570K "Ivy Bridge" - Memoire 1*8 Go DDR3 1333 Mhz (1 empl. vide) - DD SSD 256 Go - Carte Mère Gigabyte GA-Z77N-WIFI > Codec ALC892 - late 2012 - AMD HD 6870 - OSX Sierra 10.12.6 + Ubuntu 16.04
MacMini3,1 : 2.0 Ghz core 2 duo "Penryn" - early 2009 - A1283 - RAM : 2* 4 Go DDR3 1333 Mhz - DD 320 Go 5400 rpm - MacOS X 10.11.6 El Capitan
PowerMac7,3 : G5 2 Ghz - early 2005- A1047 - RAM : 2*512 Mo DDR pc3200 400 Mhz (2 empl. vides) - DD 80 Go 7200 rpm - MacOS X 10.5.8 Leopard
--
Au travail
MacPro1,1 : 2x2.66 Ghz Dual Core intel Xeon "Woodcrest" - Mac Pro - mid 2006 - A1186 - MacOS X 10.6.8 Snow Leopard
iMac12,1 : 2,5 Ghz Intel Core i5 "Sandy Bridge"- 21,5 inch - mid 2011 - A1311 - Mac OSX 10.7.5 Lion

Apple, Paye tes impôts !
Go to the top of the page
 
+Quote Post
trouspinette
posté 29 Sep 2015, 12:30
Message #19


Macbidouilleur d'Or !
*****

Groupe : Rédacteurs
Messages : 5 065
Inscrit : 19 Feb 2002
Lieu : BZH
Membre no 2 083



Citation (ccciolll @ 29 Sep 2015, 13:09) *
Je viens de remarquer un truc.

Si je lance une recherche Spotlight sur ce fameux serveur depuis un autre poste que mon principal (ici depuis mon poste secondaire en Lion 10.7.5), ladite recherche produit un résultat à priori probant (521 fichiers comportant le terme PDF sur un dossier de juillet, par exemple).
La même recherche effectuée depuis mon poste principal en SnowLeo 10.6.8 ne donne absolument aucun résultat.

Donc il y a un bug qqpart sur mon poste principal.
Comment l'identifier ?

C'est normal : la recherche Spotlight réseau n'est possible que pour ≥ Mac OS X 10.7


--------------------
Quis custodiet ipsos custodes ? - Lorsqu'un sujet est résolu, merci d'indiquer [Résolu] dans le titre de votre post !

Luttons contre le style SMS !!!

iPhone 14Pro Max 256 Go iOS 17• MacBook Pro 16 2019 Core i9 - macOS 12.7.2 - 32 GB RAM - 2 TB • @Orange
Linux • OPNSense / pfSense • Une pointe de Windows aussi • Enfocus Switch Expert • callas pdfToolBox
Go to the top of the page
 
+Quote Post
ccciolll
posté 29 Sep 2015, 12:52
Message #20


Macbidouilleur de bronze !
**

Groupe : Membres
Messages : 262
Inscrit : 10 Mar 2005
Membre no 34 861



Citation (trouspinette @ 29 Sep 2015, 12:30) *
C'est normal : la recherche Spotlight réseau n'est possible que pour ≥ Mac OS X 10.7


Et pourtant la recherche spotlight fonctionnait sur notre serveur Xserve avant que celui-ci ne calanche cet été.
Donc ceci tend à prouver que la recherche FONCTIONNE sous SnowLeo car je n'ai pas rétrogradé le système de mon poste principal entre temps…


--------------------
En famille
Hackintosh : intel core i5 3570K "Ivy Bridge" - Memoire 1*8 Go DDR3 1333 Mhz (1 empl. vide) - DD SSD 256 Go - Carte Mère Gigabyte GA-Z77N-WIFI > Codec ALC892 - late 2012 - AMD HD 6870 - OSX Sierra 10.12.6 + Ubuntu 16.04
MacMini3,1 : 2.0 Ghz core 2 duo "Penryn" - early 2009 - A1283 - RAM : 2* 4 Go DDR3 1333 Mhz - DD 320 Go 5400 rpm - MacOS X 10.11.6 El Capitan
PowerMac7,3 : G5 2 Ghz - early 2005- A1047 - RAM : 2*512 Mo DDR pc3200 400 Mhz (2 empl. vides) - DD 80 Go 7200 rpm - MacOS X 10.5.8 Leopard
--
Au travail
MacPro1,1 : 2x2.66 Ghz Dual Core intel Xeon "Woodcrest" - Mac Pro - mid 2006 - A1186 - MacOS X 10.6.8 Snow Leopard
iMac12,1 : 2,5 Ghz Intel Core i5 "Sandy Bridge"- 21,5 inch - mid 2011 - A1311 - Mac OSX 10.7.5 Lion

Apple, Paye tes impôts !
Go to the top of the page
 
+Quote Post
ccciolll
posté 30 Sep 2015, 08:30
Message #21


Macbidouilleur de bronze !
**

Groupe : Membres
Messages : 262
Inscrit : 10 Mar 2005
Membre no 34 861



Bon, donc me r'voilà.

J'ai fait un mdutil -i off sur le volumes réseau depuis mon poste perso (comme ça, c'est au moins clean de ce côté, vu que mes pb de recherches spotlight en local ont commencé après que j'aie activé mdutil sur le volume serveur depuis mon poste perso).

puis je suis allé dans la salle des serveurs, sur ce serveur « odystar »

Et là j'ai voulu vérifier si le volume DATA était enabled ou disabled.
Déjà je tente une recherche basique depuis spotlight, aucun résultat, même après avoir fait mine de chercher 10 secondes (notez tout de même que la même recherche, effectuée depuis un poste connecté à ce serveur en lion donne des résultats complets en moins de 2 secondes !)

Je tape mdutil -s et il me répond « no index ». Pas « disabled » auquel je m'attendais.
Tiens tiens…
Je me dis que c'est peut-être une différence de langage entre la 10.6 et la 10.5

Je tente une mdutil -i on
Encore « no index »
précédé de « unable to perform operation (-1) »



blink.gif

WTF ?

Le disque n'aurait pas d'index, c'est ça ?
Il me semble que c'est un disque en RAID (en tout cas il y a un utilitaire RAID ou un truc du même goût installé sur ce serveur). Ça pourrait expliquer les choses ?
Et si le disque n'a pas d'index, comment fait le poste en lion pour tout de même y trouver des choses ?


Et je re-pose ma question de tout à l'heure : si seul lion et supérieurs sont capables d'une recherche spotlight sur un serveur, comment expliquez-vous que mon poste en snowleo était capable de faire des recherches spotlight sur le serveur xserve qu'on avait avant (serveur qui a planté depuis, pour mon grand malheur).

Ce message a été modifié par ccciolll - 30 Sep 2015, 08:31.


--------------------
En famille
Hackintosh : intel core i5 3570K "Ivy Bridge" - Memoire 1*8 Go DDR3 1333 Mhz (1 empl. vide) - DD SSD 256 Go - Carte Mère Gigabyte GA-Z77N-WIFI > Codec ALC892 - late 2012 - AMD HD 6870 - OSX Sierra 10.12.6 + Ubuntu 16.04
MacMini3,1 : 2.0 Ghz core 2 duo "Penryn" - early 2009 - A1283 - RAM : 2* 4 Go DDR3 1333 Mhz - DD 320 Go 5400 rpm - MacOS X 10.11.6 El Capitan
PowerMac7,3 : G5 2 Ghz - early 2005- A1047 - RAM : 2*512 Mo DDR pc3200 400 Mhz (2 empl. vides) - DD 80 Go 7200 rpm - MacOS X 10.5.8 Leopard
--
Au travail
MacPro1,1 : 2x2.66 Ghz Dual Core intel Xeon "Woodcrest" - Mac Pro - mid 2006 - A1186 - MacOS X 10.6.8 Snow Leopard
iMac12,1 : 2,5 Ghz Intel Core i5 "Sandy Bridge"- 21,5 inch - mid 2011 - A1311 - Mac OSX 10.7.5 Lion

Apple, Paye tes impôts !
Go to the top of the page
 
+Quote Post
fmereo
posté 30 Sep 2015, 15:44
Message #22


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 2 497
Inscrit : 4 Oct 2002
Membre no 3 936



Citation (ccciolll @ 28 Sep 2015, 20:31) *
On a déjà perdu un serveur cet été avec 1 an de données dessus (tout mon boulot de développement de 2014-2015), donc je vais éviter de toucher au dernier qui tient encore debout tant que les informaticiens du groupe ne seront pas ENFIN venu nous installer une solution solide… Ce qui peut encore prendre quelques mois vu l'intérêt qu'ils portent à notre minuscule agence… (plus de responsable informatique depuis 18 mois, serveurs à l'abandon…)

Bonjour la sécurisation des données dis donc…
Go to the top of the page
 
+Quote Post
roseau
posté 30 Sep 2015, 16:12
Message #23


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 5 681
Inscrit : 11 Feb 2003
Lieu : Bagneux
Membre no 6 110



Citation (fmereo @ 30 Sep 2015, 16:44) *
Citation (ccciolll @ 28 Sep 2015, 20:31) *
On a déjà perdu un serveur cet été avec 1 an de données dessus (tout mon boulot de développement de 2014-2015), donc je vais éviter de toucher au dernier qui tient encore debout tant que les informaticiens du groupe ne seront pas ENFIN venu nous installer une solution solide… Ce qui peut encore prendre quelques mois vu l'intérêt qu'ils portent à notre minuscule agence… (plus de responsable informatique depuis 18 mois, serveurs à l'abandon…)

Bonjour la sécurisation des données dis donc…

blink.gif ça me fait penser qu'il faut que je réactive mon time machine sur le miens!! wub.gif


--------------------
Imac 2017 core I7 , 2*MBP2015 core I7, Macmini late 2014 core I5 16 go 10.11/maverick MBp , Mbp 15" late 2014 core i7 16 go 10.11; Macmini 2011 core i5 ( 10.9), , , Xserve/2008/ 1 2,8ghz quad-core xeon/osx server 10.9.4/mem 18 go/carte raid 3*1to raid 5,Antiquité fonctionelle :Imac debut 2010 10.5.8MBPRO 13" fin 2010 10.9, macbookpro 17" juin 2007 10.5.8, Macmini core 2 duo 1,8 /1024mo/10.5.8, Macmini 1,42/1024mo/10.4.11,G4 mono 1.25 (MDD 2003) /1500mo/10.4.11 server , 4400 200 upgrade g3/400,4400 240 , , 7100 80/,
antiquite 6320 lc 630, powerbook 180c,powerbook duo 210, Mac classic (panne vidéo) Mac SE...,os 10.4* , 10.3.9, os9.1/os8.1, os7.6,
NAS CS407 Synology 4*500go (raid 5),
Go to the top of the page
 
+Quote Post
ccciolll
posté 30 Sep 2015, 16:25
Message #24


Macbidouilleur de bronze !
**

Groupe : Membres
Messages : 262
Inscrit : 10 Mar 2005
Membre no 34 861



Citation (fmereo @ 30 Sep 2015, 15:44) *
Bonjour la sécurisation des données dis donc…


J'ai alerté et questionné à plusieurs reprise depuis plus d'un an, ça n'a jamais bougé ni répondu.
Ça a fini par claquer, que voulez-vous… Toute la logique d'un groupe Européen, quoi.
Je n'ai jamais connu autant de mauvaise qualité quand je bossais dans une boîte de moins de 10 employés.
Ce qui déconnait, je le prenais en main, et ça roulait.
Ici, je ne sais parfois même pas à qui je dois adresser une demande.


--------------------
En famille
Hackintosh : intel core i5 3570K "Ivy Bridge" - Memoire 1*8 Go DDR3 1333 Mhz (1 empl. vide) - DD SSD 256 Go - Carte Mère Gigabyte GA-Z77N-WIFI > Codec ALC892 - late 2012 - AMD HD 6870 - OSX Sierra 10.12.6 + Ubuntu 16.04
MacMini3,1 : 2.0 Ghz core 2 duo "Penryn" - early 2009 - A1283 - RAM : 2* 4 Go DDR3 1333 Mhz - DD 320 Go 5400 rpm - MacOS X 10.11.6 El Capitan
PowerMac7,3 : G5 2 Ghz - early 2005- A1047 - RAM : 2*512 Mo DDR pc3200 400 Mhz (2 empl. vides) - DD 80 Go 7200 rpm - MacOS X 10.5.8 Leopard
--
Au travail
MacPro1,1 : 2x2.66 Ghz Dual Core intel Xeon "Woodcrest" - Mac Pro - mid 2006 - A1186 - MacOS X 10.6.8 Snow Leopard
iMac12,1 : 2,5 Ghz Intel Core i5 "Sandy Bridge"- 21,5 inch - mid 2011 - A1311 - Mac OSX 10.7.5 Lion

Apple, Paye tes impôts !
Go to the top of the page
 
+Quote Post
trouspinette
posté 30 Sep 2015, 18:56
Message #25


Macbidouilleur d'Or !
*****

Groupe : Rédacteurs
Messages : 5 065
Inscrit : 19 Feb 2002
Lieu : BZH
Membre no 2 083



Citation (ccciolll @ 30 Sep 2015, 09:30) *
Bon, donc me r'voilà.

J'ai fait un mdutil -i off sur le volumes réseau depuis mon poste perso

Non, non et re-non : tu dois le faire SUR le serveur.

Si ton serveur contient :

/Volumes/SYSTEME
/Volumes/DATAS
/Volumes/BACKUP_OS_DATA

par exemple,

tu fais mdutil -i et Cie sur /Volumes/DATAS, si ce dernier est le volume des points de partage.

Tu n'as pas envie de virer ton Odystar ?


--------------------
Quis custodiet ipsos custodes ? - Lorsqu'un sujet est résolu, merci d'indiquer [Résolu] dans le titre de votre post !

Luttons contre le style SMS !!!

iPhone 14Pro Max 256 Go iOS 17• MacBook Pro 16 2019 Core i9 - macOS 12.7.2 - 32 GB RAM - 2 TB • @Orange
Linux • OPNSense / pfSense • Une pointe de Windows aussi • Enfocus Switch Expert • callas pdfToolBox
Go to the top of the page
 
+Quote Post
ccciolll
posté 30 Sep 2015, 19:04
Message #26


Macbidouilleur de bronze !
**

Groupe : Membres
Messages : 262
Inscrit : 10 Mar 2005
Membre no 34 861



Citation (trouspinette @ 30 Sep 2015, 18:56) *
Non, non et re-non : tu dois le faire SUR le serveur.


Oui mais là je le faisais pour « réparer » le fait d'avoir fait un mdutil -i on sur le disque de ce serveur depuis mon poste perso (et à priori ça a marché car mon poste avait retrouvé un focntionnement spotlight normal en local après ça).

Citation (trouspinette @ 30 Sep 2015, 18:56) *
Si ton serveur contient :

/Volumes/SYSTEME
/Volumes/DATAS
/Volumes/BACKUP_OS_DATA

par exemple,

tu fais mdutil -i et Cie sur /Volumes/DATAS, si ce dernier est le volume des points de partage.


C'est ce que j'ai fait ensuite, et comme j'ai indiqué, ça m'a fait un erreur no index.

Citation (trouspinette @ 30 Sep 2015, 18:56) *
Tu n'as pas envie de virer ton Odystar ?


Je ne comprends pas la question.


--------------------
En famille
Hackintosh : intel core i5 3570K "Ivy Bridge" - Memoire 1*8 Go DDR3 1333 Mhz (1 empl. vide) - DD SSD 256 Go - Carte Mère Gigabyte GA-Z77N-WIFI > Codec ALC892 - late 2012 - AMD HD 6870 - OSX Sierra 10.12.6 + Ubuntu 16.04
MacMini3,1 : 2.0 Ghz core 2 duo "Penryn" - early 2009 - A1283 - RAM : 2* 4 Go DDR3 1333 Mhz - DD 320 Go 5400 rpm - MacOS X 10.11.6 El Capitan
PowerMac7,3 : G5 2 Ghz - early 2005- A1047 - RAM : 2*512 Mo DDR pc3200 400 Mhz (2 empl. vides) - DD 80 Go 7200 rpm - MacOS X 10.5.8 Leopard
--
Au travail
MacPro1,1 : 2x2.66 Ghz Dual Core intel Xeon "Woodcrest" - Mac Pro - mid 2006 - A1186 - MacOS X 10.6.8 Snow Leopard
iMac12,1 : 2,5 Ghz Intel Core i5 "Sandy Bridge"- 21,5 inch - mid 2011 - A1311 - Mac OSX 10.7.5 Lion

Apple, Paye tes impôts !
Go to the top of the page
 
+Quote Post
trouspinette
posté 30 Sep 2015, 20:11
Message #27


Macbidouilleur d'Or !
*****

Groupe : Rédacteurs
Messages : 5 065
Inscrit : 19 Feb 2002
Lieu : BZH
Membre no 2 083



Citation (ccciolll @ 30 Sep 2015, 20:04) *
Citation (trouspinette @ 30 Sep 2015, 18:56) *
Tu n'as pas envie de virer ton Odystar ?


Je ne comprends pas la question.

"C'est simple" ;-) Remplacer Odystar par autre chose, sur une machine bien calée, qui fait du Spotlight réseau sans broncher ;-)


--------------------
Quis custodiet ipsos custodes ? - Lorsqu'un sujet est résolu, merci d'indiquer [Résolu] dans le titre de votre post !

Luttons contre le style SMS !!!

iPhone 14Pro Max 256 Go iOS 17• MacBook Pro 16 2019 Core i9 - macOS 12.7.2 - 32 GB RAM - 2 TB • @Orange
Linux • OPNSense / pfSense • Une pointe de Windows aussi • Enfocus Switch Expert • callas pdfToolBox
Go to the top of the page
 
+Quote Post
ccciolll
posté 1 Oct 2015, 09:16
Message #28


Macbidouilleur de bronze !
**

Groupe : Membres
Messages : 262
Inscrit : 10 Mar 2005
Membre no 34 861



Citation (trouspinette @ 30 Sep 2015, 20:11) *
"C'est simple" ;-) Remplacer Odystar par autre chose, sur une machine bien calée, qui fait du Spotlight réseau sans broncher ;-)

Ben, comme je l'ai indiqué par ailleurs, je ne suis déjà pas décisionnaire pour les achats de matériel, premier problème. Et ensuite je ne suis pas non plus compétent pour installer un serveur (c'est peut-être à ma portée, je l'ignore, je ne l'ai jamais fait à part un petit serveur NAS chez moi).

Donc pour l'heure, faudra faire avec, du coup je cherche toute solution « légère » qui pourrait m'aider.

Ce message a été modifié par ccciolll - 1 Oct 2015, 09:16.


--------------------
En famille
Hackintosh : intel core i5 3570K "Ivy Bridge" - Memoire 1*8 Go DDR3 1333 Mhz (1 empl. vide) - DD SSD 256 Go - Carte Mère Gigabyte GA-Z77N-WIFI > Codec ALC892 - late 2012 - AMD HD 6870 - OSX Sierra 10.12.6 + Ubuntu 16.04
MacMini3,1 : 2.0 Ghz core 2 duo "Penryn" - early 2009 - A1283 - RAM : 2* 4 Go DDR3 1333 Mhz - DD 320 Go 5400 rpm - MacOS X 10.11.6 El Capitan
PowerMac7,3 : G5 2 Ghz - early 2005- A1047 - RAM : 2*512 Mo DDR pc3200 400 Mhz (2 empl. vides) - DD 80 Go 7200 rpm - MacOS X 10.5.8 Leopard
--
Au travail
MacPro1,1 : 2x2.66 Ghz Dual Core intel Xeon "Woodcrest" - Mac Pro - mid 2006 - A1186 - MacOS X 10.6.8 Snow Leopard
iMac12,1 : 2,5 Ghz Intel Core i5 "Sandy Bridge"- 21,5 inch - mid 2011 - A1311 - Mac OSX 10.7.5 Lion

Apple, Paye tes impôts !
Go to the top of the page
 
+Quote Post
Saxobar
posté 3 Feb 2024, 03:24
Message #29


Nouveau Membre


Groupe : Membres
Messages : 2
Inscrit : 7 Dec 2013
Membre no 188 173



Citation (yponomeute @ 9 Apr 2015, 19:27) *
Dans le terminal avec la commande suivante tu peux voir si l'indexation est activée sur le volume

Code
mdutil -s /Volumes/nom_du_volume_reseau


Tu dois pouvoir activier l'indexation avec la commande

Code
sudo mdutil -i on /Volumes/nom_du_volume_reseau


et pour désactiver

Code
sudo mdutil -i off /Volumes/nom_du_volume_reseau


Détails ici : https://developer.apple.com/library/mac/doc...1/mdutil.1.html


MERCI infiniment !
Tout le monde parle d'ajouter le disque aux preferences de confidentialité de spotlight et de le retirer. Voir d'en profiter pour redémarrer 3 fois et supprimer les preferences dans la bibliothèque.
Ce qui évidement ne fonctionne que quand tout vas bien, mais quand quelque chose de plus profond bloque... rien n'y fais.
Alors qu'une bonne vielle commande terminal et hop ! ça roule.
Simple, efficace et satisfaisant.

Merci
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 utilisateur(s) sur ce sujet (1 invité(s) et 0 utilisateur(s) anonyme(s))
0 membre(s) :

 



Nous sommes le : 19th June 2024 - 22:01