IPB

Bienvenue invité ( Connexion | Inscription )

 
Reply to this topicStart new topic
> BRIX GB-BRi5H-8250, Problème finalisation installation
Options
athos0512
posté 30 May 2020, 15:45
Message #1


Nouveau Membre


Groupe : Membres
Messages : 4
Inscrit : 23 Apr 2020
Membre no 211 400



Bonjour à tous,

Tout d'abord merci pour ce forum qui m'a beaucoup aidé.

Cependant, cela fait 1 semaine (plusieurs heures par jour) que je me casse la tête pour une installation de certains éléments.

J'ai vraiment besoin d'aide car je veux aboutir à une config complète et ensuite posterai un tutoriel complet pour tout ceux qui voudrait une sorte de Mac mini fait maison.

Voici ce que j'ai fait jusque maintenant:

INSTALLATION:
-----------------
avec Clover fourni dans le forum (Skylake et supérieur). Cela m'a permis de booter et installer. Je n'ai pas touché au config.plist et dans les kexts ajouter IntelMausi.kext (pour avoir le réseau) en plus de FakeSMC.kext

GRAPHIQUE:
--------------
- rajout de Lilu.kext et WhateverGreen.kext et ajout dans Clover Device sur le bon PCI add properties AAPL,ig-platform-id 00001659 et device-id 16590000 conformément aux instructions whatevergreen sur GitHub.
----> Résultat: carte graphique OK

SON:
------

- rajout de AppleALC.kext et conformément à ce que j'ai lu sur le forum et GitHub ajout du layout-id 15 (celui fait pour cet appareil sur le site GitHub apple-alc) dans add properties sur le PCI son.

----> Résultat: son ok MAIS !!!!

j'ai constaté que le son passait par les écouteurs et il n'y avait pas de possibilité de choix pour la sortie du son dans les paramètres (seule possibilité était d'enlever le câble HDMI et de le remettre et cela permettait de le faire apparaître.
Bon j'ai passé 3 jours dessus (en cherchant comment patcher des connecteurs, etc.. je vous passe tout ce que j'ai lu mais sans succès.

Du coup, j'ai installé FakePCIID.kext et FakePCIID_Intel_HDMI_Audio.kext et maintenant la possibilité de choix du son par écran est OK sans être obligé d'enlever et remettre le câble hdmi.
Si quelqu'un a une idée pour faire autrement et éviter de rajouter ces kext, je suis toujours preneur car je souhaite être le plus proche d'un mac original. Cependant, cela fonctionne maintenant et je dirai OK pour l'instant.

RESTE A FAIRE ET JE N'Y ARRIVE PAS DONC J'AI BESOIN D'AIDE:
-------------------------------------------------------------------------

1° BLUETOOTH:

je sais que cela est possible de l'activer car au début j'ai utilisé l'EFI de mon nuc et magie j'avais du bluetooth mais impossible de le faire apparaître maintenant. Enfin si en faisant quelque chose de très bizarre et non conseillé (injecter ce qu'il ne faut pas faire d'ailleurs un kext expérimental appleintelwifi.kext) et là ok mais faut plus trop remanier l'EFI car sinon perte de la connexion Bluetooth et l'icône est ensuite grisée sans pouvoir la faire réapparaître. Ce kext est en réalité utilisé pour essayer de faire fonctionner le wifi intel sur hackintosh. J'ai pas réussi à faire fonctionner le wifi mais par contre il m'a activé le Bluetooth de la carte combo. Et çà marchait bien jusqu'à ce que çà casse. Du coup je ne le mets plus pour l'instant, d'autant plus que je sais que c'est possible de faire autrement puisque comme dit au-dessus au début j'ai utilisé l'EFI de mon nuc et le Bluetooth apparaissait mais beaucoup de choses ne fonctionnait pas évidemment raison d'une installation fraiche sur cet appareil.

2° REVEIL ECRAN APRES MISE EN VEILLE

impossible sauf à enlever et remettre le câble HDMI. J'ai lu beaucoup sur ce forum mais je n'y arrive pas et j'ai essayé p as mal de choses. Par ailleurs je pense que la config.plist d'installation d'origine nécessite probablement des changements mais je ne sais pas lesquels. Il n'y a aucun auto expliquant tous les points existants dans Clover.

3° PORTS USB:

Quand je ne mets pas USBInjectAll.kext mes ports sont reconnus en 5GB/s. Quand je mets ce kext, ils ne sont plus reconnus qu'en 480MB/s. Je dois encore essayer de comprendre un peu le tutoriel pour un injecteur personnalisé. Je ne m'y suis pas lancé par contre car j'ai vu quand j'avais réussi à activer le bluetooth selon la technique impropre avec ce kext expérimental qua le bluetooth était reconnu dans les ports USB?

Bref un peu d'aide m'aiderait vraiment beaucoup surtout pour le point 2 de ce qui me reste à faire.
Dès que j'aurais un BRIX full fonctionnel, je ferai un tutoriel pour toux ceux qui souhaiterait acheter cet appareil.

MERCI D'AVANCE POUR VOTRE AIDE et voici un lien (apparemment car en direct çà passe pas) pour mon EFI en pièce jointe: http://gofile.me/6up2r/Yt0NIKnrY

Sinon juste ma config.plist en annexe (heu non pas possible je sais pas pourquoi)

Ce message a été modifié par athos0512 - 30 May 2020, 15:55.


--------------------
GB-BRi5H-8250:
------------------
Processeur: Intel® Core™ Quad core i5-8250U
Carte graphique: Intel® UHD Graphics 620
Audio: Realtek ALC255
Mémoire vive: SO-DIMM DDR4 slots 2400MHz - 16G
Réseau: Gigabit LAN (Intel i219V)
Wifi d'origine: Intel® Dual Band Wireless-AC 3168 (je sais je changerai ensuite..:-) )
Ports: 2 x USB 3.1 (dont 1 x USB Type-C™) + 2 x USB 3.0 - Asmedia 3142
Sorties videos: 1 x HDMI(2.0a) 1 x Mini DisplayPort (1.2)
Go to the top of the page
 
+Quote Post
mbournau
posté 30 May 2020, 16:04
Message #2


Macbidouilleur de vermeil !
****

Groupe : Membres
Messages : 1 266
Inscrit : 28 Aug 2002
Lieu : En vadrouille en Bretagne
Membre no 3 321



Bonjour à toi,

Peux tu indiquer dans ta signature, s'il te plait, la carte mère dont il s'agit ?

EDIT : j'avais pas vu le titre du sujet (GB-BRi5H-8250), désolé, mais indique le quand même en signature smile.gif

Ton EFI est sur un NAS, mais, en ce qui me concerne, je ne peux pas y accéder !

Ce message a été modifié par mbournau - 30 May 2020, 16:08.


--------------------
1) Gigabyte Z170X-Gaming 5 (08/2016) : Core i7-6700K 4GHz; Sapphire Radeon RX580 Pulse; 16Go RAM; iMacPro 1,1;10.13.6; 10.14.6 (18G1012)(SSD); 10.15.6 ß2 (Nvme); Windows X (SSD)
2) Gigabyte Z390 Designare (09/2019) : Core i9-9900K 3.6GHz;Asus Radeon RX 5700 XT; 32Go RAM; iMac 19,1; 10.14.6 (18G1012), 10.15.5 (Nvme); TB3; Windows X (Nvme);
3) Nuc7i5BNH (11/2017) : 16Go RAM; iMacPro 1,1; 10.14.6 (SSD); Windows X (SSD); dongles Wifi & BT; TB3
4) Gigabyte Z390M Gaming (08/2019) : Core i3; 16 Go RAM; Sapphire Radeon RX580 4G Nitro; iMacPro 1,1; 10.15.4 (SSD); Windows X (SSD);
: iMac 27" 2013, Mac SE (!), MacBook Air 2011 (11")...MBP 16"


Pas à pas installation Catalina 10.15.4 & suivants (et autres fantaisies !!) sur Gigabyte Z390 Designare (MàJ : 19/05/2020)----Comparatif z490 - z390
Go to the top of the page
 
+Quote Post
athos0512
posté 30 May 2020, 16:20
Message #3


Nouveau Membre


Groupe : Membres
Messages : 4
Inscrit : 23 Apr 2020
Membre no 211 400



Bonjour

Oui désolé. Je l'ai rajouté dans la signature. Sinon, j'ai vu un script qui fournit un rapport macbidouille zippé.
Je viens de le lancer et voici le lien de ce fichier:

http://gofile.me/6up2r/HIA6Mipi7

@mbournau

Merci d'avance de ton aide

Voici un lien qui n'est pas sur mon nas (faudrait que j'aille vérifier mes ports de sortie sur le nas :-)

https://we.tl/t-owTmPKCrje

Ce message a été modifié par athos0512 - 30 May 2020, 16:21.


--------------------
GB-BRi5H-8250:
------------------
Processeur: Intel® Core™ Quad core i5-8250U
Carte graphique: Intel® UHD Graphics 620
Audio: Realtek ALC255
Mémoire vive: SO-DIMM DDR4 slots 2400MHz - 16G
Réseau: Gigabit LAN (Intel i219V)
Wifi d'origine: Intel® Dual Band Wireless-AC 3168 (je sais je changerai ensuite..:-) )
Ports: 2 x USB 3.1 (dont 1 x USB Type-C™) + 2 x USB 3.0 - Asmedia 3142
Sorties videos: 1 x HDMI(2.0a) 1 x Mini DisplayPort (1.2)
Go to the top of the page
 
+Quote Post
mbournau
posté 30 May 2020, 18:37
Message #4


Macbidouilleur de vermeil !
****

Groupe : Membres
Messages : 1 266
Inscrit : 28 Aug 2002
Lieu : En vadrouille en Bretagne
Membre no 3 321



Je ne te garantis rien, c'est évident, d'autres que moi, qui connaissent ce matériel t'aideront plus efficacement !
Dans ton config.plist, enlève le bootarg : nv_disable=1 (dans boot), coche Apple RTC dans kernel & kexts patches déjà pour voir, mais bon... Peut être aussi en mettant emuvariable dans drivers... (sauvegarde ton dossier Clover avant ces modifs !)


--------------------
1) Gigabyte Z170X-Gaming 5 (08/2016) : Core i7-6700K 4GHz; Sapphire Radeon RX580 Pulse; 16Go RAM; iMacPro 1,1;10.13.6; 10.14.6 (18G1012)(SSD); 10.15.6 ß2 (Nvme); Windows X (SSD)
2) Gigabyte Z390 Designare (09/2019) : Core i9-9900K 3.6GHz;Asus Radeon RX 5700 XT; 32Go RAM; iMac 19,1; 10.14.6 (18G1012), 10.15.5 (Nvme); TB3; Windows X (Nvme);
3) Nuc7i5BNH (11/2017) : 16Go RAM; iMacPro 1,1; 10.14.6 (SSD); Windows X (SSD); dongles Wifi & BT; TB3
4) Gigabyte Z390M Gaming (08/2019) : Core i3; 16 Go RAM; Sapphire Radeon RX580 4G Nitro; iMacPro 1,1; 10.15.4 (SSD); Windows X (SSD);
: iMac 27" 2013, Mac SE (!), MacBook Air 2011 (11")...MBP 16"


Pas à pas installation Catalina 10.15.4 & suivants (et autres fantaisies !!) sur Gigabyte Z390 Designare (MàJ : 19/05/2020)----Comparatif z490 - z390
Go to the top of the page
 
+Quote Post
athos0512
posté 30 May 2020, 19:25
Message #5


Nouveau Membre


Groupe : Membres
Messages : 4
Inscrit : 23 Apr 2020
Membre no 211 400



Citation (mbournau @ 30 May 2020, 18:37) *
Je ne te garantis rien, c'est évident, d'autres que moi, qui connaissent ce matériel t'aideront plus efficacement !
Dans ton config.plist, enlève le bootarg : nv_disable=1 (dans boot), coche Apple RTC dans kernel & kexts patches déjà pour voir, mais bon... Peut être aussi en mettant emuvariable dans drivers... (sauvegarde ton dossier Clover avant ces modifs !)


Je vais déjà essayer de créer un injecteur USB personnalisé en suivant le tuto du forum, voir aussi si cela arrange quelque chose. Pour le wifi-bt je peux changer la carte en interne (non soudé): c’est un peu ce qui m’a poussé à prendre le brix à la place du nuc que j’avais et qui fonctionnait nickel mais avec dongle bt; du coup pas de continuity et handoff

Je vais essayer aussi ce que tu proposes et reviens sur le sujet.

Si d’autres ont ce type de matériel, n’hésitez pas!! J’ai besoin de votre aide wink.gif

Ce message a été modifié par athos0512 - 30 May 2020, 19:26.


--------------------
GB-BRi5H-8250:
------------------
Processeur: Intel® Core™ Quad core i5-8250U
Carte graphique: Intel® UHD Graphics 620
Audio: Realtek ALC255
Mémoire vive: SO-DIMM DDR4 slots 2400MHz - 16G
Réseau: Gigabit LAN (Intel i219V)
Wifi d'origine: Intel® Dual Band Wireless-AC 3168 (je sais je changerai ensuite..:-) )
Ports: 2 x USB 3.1 (dont 1 x USB Type-C™) + 2 x USB 3.0 - Asmedia 3142
Sorties videos: 1 x HDMI(2.0a) 1 x Mini DisplayPort (1.2)
Go to the top of the page
 
+Quote Post
mbournau
posté 30 May 2020, 20:05
Message #6


Macbidouilleur de vermeil !
****

Groupe : Membres
Messages : 1 266
Inscrit : 28 Aug 2002
Lieu : En vadrouille en Bretagne
Membre no 3 321



Et puis tu pourras, par la suite essayer ce Fichier joint  config.plist.zip ( 2.54 Ko ) Nombre de téléchargements : 2
(toujours en mettant le tien actuel à l'abri !!)


--------------------
1) Gigabyte Z170X-Gaming 5 (08/2016) : Core i7-6700K 4GHz; Sapphire Radeon RX580 Pulse; 16Go RAM; iMacPro 1,1;10.13.6; 10.14.6 (18G1012)(SSD); 10.15.6 ß2 (Nvme); Windows X (SSD)
2) Gigabyte Z390 Designare (09/2019) : Core i9-9900K 3.6GHz;Asus Radeon RX 5700 XT; 32Go RAM; iMac 19,1; 10.14.6 (18G1012), 10.15.5 (Nvme); TB3; Windows X (Nvme);
3) Nuc7i5BNH (11/2017) : 16Go RAM; iMacPro 1,1; 10.14.6 (SSD); Windows X (SSD); dongles Wifi & BT; TB3
4) Gigabyte Z390M Gaming (08/2019) : Core i3; 16 Go RAM; Sapphire Radeon RX580 4G Nitro; iMacPro 1,1; 10.15.4 (SSD); Windows X (SSD);
: iMac 27" 2013, Mac SE (!), MacBook Air 2011 (11")...MBP 16"


Pas à pas installation Catalina 10.15.4 & suivants (et autres fantaisies !!) sur Gigabyte Z390 Designare (MàJ : 19/05/2020)----Comparatif z490 - z390
Go to the top of the page
 
+Quote Post
Highmac
posté 31 May 2020, 07:31
Message #7


Macbidouilleur de bronze !
**

Groupe : Membres
Messages : 539
Inscrit : 31 Mar 2003
Lieu : Haute-Vienne
Membre no 6 914



Si tu veux être tranquille pour ton combo wifi/BT, change ta carte Intel par une Broadcom.
Ca a l'air sympa comme NUC !


--------------------
Actuel: Hackintosh (iMac19,1) CoffeLake Refresh Gigabyte Z390I AORUS PRO WIFI (BIOS F8c). Intel i5 9500. Sapphire Radeon RX 5500 XT. Ram Corsair Vengeance 32 Go. SSD Crucial P1 (Clover_v2.5k_r5118+Catalina 10.15.5(19F101)). Alimentation Enermax Revolution SFX 650W. Boitier Fractal Design Node 202. Carte M2 wifi/BT DW1560. MagicMouse 2 gris sidéral. Clavier Apple Magic Keyboard gris sideral. Ecran BenQ EW3270U.
Réglages du BIOS F8c
Rapport MacBidouille
Go to the top of the page
 
+Quote Post
polyzargone
posté 31 May 2020, 12:38
Message #8


Macbidouilleur d'Or !
*****

Groupe : Modérateurs
Messages : 12 313
Inscrit : 11 May 2006
Membre no 60 938



Citation (athos0512 @ 30 May 2020, 19:25) *
Je vais déjà essayer de créer un injecteur USB personnalisé en suivant le tuto du forum, voir aussi si cela arrange quelque chose.


Il manque les patches USB pour Catalina dans ton config.plist.

Mais…

Citation (athos0512 @ 30 May 2020, 19:25) *
Pour le wifi-bt je peux changer la carte en interne (non soudé)


C'est quand même la meilleure solution d'autant qu'elle est possible sur ton BRIX.


--------------------
Un MacmacOS 10.15 MacBook Air mi-2012 Core i5 1,7 GHz Intel HD 4000 SSD 64 Go
Des Hacks Asus Z170-P - Core i7 6700 3,40 GHz - Sapphire RX 580 8 Go - 16 Go DDR4 - macOS 10.15/Win 10 Gigabyte H110M-S2H - Core i5 6600 3,30 GHz - Zotac GTX 750 Ti 2 Go - 16 Go DDR4 - macOS 10.15/macOS 10.14.6/macOS 10.13.6/Win 10 Gigabyte GA-H97-HD3 - Core i5 4570 3,20 GHz - Zotac Geforce GTX 1060 6 Go - 16 Go DDR3 - macOS 10.14/macOS 10.13.6/macOS 10.12/OS X 10.11.6/Win 10/Mint 18 Acer Aspire V3 772G Core i5 4210M 2,60 GHz - Intel HD 4600 + GTX 850M 2 Go (désactivée) - 16 Go DDR3 - macOS 10.15/macOS 10.14.6/macOS 10.13.6/Win 10/Mint 18 Dell Latitude e7440 Core i7 4600U 2,10 GHz - Intel HD 4400 - 16 Go DDR3 - macOS 10.15/macOS 10.14.6/macOS 10.13.6/Win 10 HP Elite 8300 USFF - Core i7 3770S 3,90 GHz - Intel HD 4000 - macOS 10.12/Win 10 - Clover (+ quelques autres...)

Politique vis à vis des outils automatisés et des distributions - Guide d'installation - Tutoriels - Lexique et utilité des Kexts - FAQ Générale du Hackintosh - FAQ des Bootloaders - FAQ des Bootflags - FAQ des problèmes les plus courants - FAQ sur les Mises à jour Majeures sur Hackintosh
Go to the top of the page
 
+Quote Post
Sebinouse
posté 31 May 2020, 13:39
Message #9


Macbidouilleur de vermeil !
****

Groupe : Membres
Messages : 864
Inscrit : 7 Jan 2007
Membre no 77 534



Pour le BT cela passe BRCMPatchRAM3 : https://github.com/acidanthera/BrcmPatchRAM
Le WiFi Intel est prometteur mais pas de AirDrop, Continuity, HandOff possible ...

Tu as essayé avec « hda-gfx » pour le son HDMI : https://github.com/acidanthera/WhateverGree...o-hdmi--dvi--dp

Pour la veille, mes NUCs ne se réveillent pas bien non plus du coup j’ai supprimé la veille ... ça consomme que dalle c’est trucs là !


--------------------
MacMini (Early 2006)
MacMini1,1>MacMini2,1 / C2D 2.33 GHz / 4 Go / 1 To / BluRay / MacOSX Lion 10.7

Nuc D54250WYK (Late 2014) avec Audirvana sur un DAC ifi iDSD nano
MacMini7,1 / i5-4250u / HD5000 / 16 Go / SSD 480 Go / Fanless / macOS 10.15

Nuc NUC5i5MYBE (Late 2015)
MacMini7,1 / i5-53000u / HD5500 / 16 Go / SSD 1 To + HDD 1,5 To / Blu-Ray / Fanless / macOS 10.15
Go to the top of the page
 
+Quote Post
athos0512
posté 3 Jun 2020, 16:48
Message #10


Nouveau Membre


Groupe : Membres
Messages : 4
Inscrit : 23 Apr 2020
Membre no 211 400



Citation (Sebinouse @ 31 May 2020, 13:39) *
Pour le BT cela passe BRCMPatchRAM3 : https://github.com/acidanthera/BrcmPatchRAM
Le WiFi Intel est prometteur mais pas de AirDrop, Continuity, HandOff possible ...

Tu as essayé avec « hda-gfx » pour le son HDMI : https://github.com/acidanthera/WhateverGree...o-hdmi--dvi--dp

Pour la veille, mes NUCs ne se réveillent pas bien non plus du coup j’ai supprimé la veille ... ça consomme que dalle c’est trucs là !


@Sebinouse

Essaye igfxonlan1 dans le boot argument du nuc: chez moi cela fonctionnait bien. J’ai bien avancé dans le Brix. Oui pour la carte Wifi/bt je vais en commander une mais pour l’instant j’ai activé le bt Intel et çà fonctionne super Bien: pas de handoff...mais très bien pour l’instant. Même le wifi peut se lancer mais avec petit script au démarrage mais çà je n’ai pas gardé car suis en ethernet et j’attends quand même la nouvelle carte.

J’ai fait un injecteur personnalisé pour les ports usb. Enfin j’ai commencé à le faire mais trouvé sur un autre site pour un autre brix dont la configuration des ports était tout à fait identique. Du coup j’ai pris celui-là

Reste:

1) mon problème de veille. En fait il se met en veille avec témoin qui clignote (donc on dirait un soft veille) et se réveille bien au mouvement de souris ou frappe de clavier mais ne réveille pas l’écran. Un peu ennuyant quand même car je dois relancer l’écran en appuyant sur le bouton stand by (je sais je suis paresseux...😂)
2) parfois quand j’éteins, il fait un redémarrer au lieu d’éteindre.

Un peu d’aide serait super. Voici mon rapport macbidouille actualisé

http://gofile.me/6up2r/p9Khls2Zn

Au plaisir de vous lire


Citation (polyzargone @ 31 May 2020, 12:38) *
Citation (athos0512 @ 30 May 2020, 19:25) *
Je vais déjà essayer de créer un injecteur USB personnalisé en suivant le tuto du forum, voir aussi si cela arrange quelque chose.


Il manque les patches USB pour Catalina dans ton config.plist.

Mais…

Citation (athos0512 @ 30 May 2020, 19:25) *
Pour le wifi-bt je peux changer la carte en interne (non soudé)


C'est quand même la meilleure solution d'autant qu'elle est possible sur ton BRIX.


@polyzargone

Merci pour tes conseils, je viens de poster une réponse à Sebinouse qui explique où j’en suis au stade actuel. Si quelqu’un a une idée?


--------------------
GB-BRi5H-8250:
------------------
Processeur: Intel® Core™ Quad core i5-8250U
Carte graphique: Intel® UHD Graphics 620
Audio: Realtek ALC255
Mémoire vive: SO-DIMM DDR4 slots 2400MHz - 16G
Réseau: Gigabit LAN (Intel i219V)
Wifi d'origine: Intel® Dual Band Wireless-AC 3168 (je sais je changerai ensuite..:-) )
Ports: 2 x USB 3.1 (dont 1 x USB Type-C™) + 2 x USB 3.0 - Asmedia 3142
Sorties videos: 1 x HDMI(2.0a) 1 x Mini DisplayPort (1.2)
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 utilisateur(s) sur ce sujet (1 invité(s) et 0 utilisateur(s) anonyme(s))
0 membre(s) :

 



Nous sommes le : 15th July 2020 - 19:34