Aide - Recherche - Membres - Calendrier
Version complète : Probleme envois via MAIL et reception sur PC
Forums MacBidouille > Général > Software > Logiciels Apple
Pages : 1, 2, 3, 4, 5, 6, 7
guiliam
EDIT 13/11/05 : pour ceux qui n'avaient pas lu tout l'ancien topic, au départ le probleme était lié à des copier/coller de Word vers Mail, mais finallement le soucis est lié à Mail uniquement (apparement). Désormais dans mon cas, presque tous les mails envoyés depuis MAIL via un PC ont des caratères "daubé" style carré, caractères chinois et autres... cela semble venir de Mail car sous Entourage, tout fonctionne parfaitement... La suite en PAGE 2 smile.gif




Debut de l'ancien topic

Bonjour,

Il m'arrive de tapper du texte dans word bien mis en page (justifié ect...)
Ca me permet aussi d'avoir un correcteur d'orthographe un peu plus poussé que Mail.

Le soucis c'est quand je fais un copié collé vers Mail, j'ai un bug.
C'est depuis le passage a Tiger et le nouveau Mail 2.0, la mise en page et tout bizarre, il saute des double ligne entre chaque phrase, quand je veux selectionner un mot pour le modifier, en placant la souris au bon endroit, il selectionne quelques caractères plus loin et décallage...

Le soucis, c'est que dernièrement on m'a renvoyé un mail me disant qu'il etait illisible...
effectivement, il etait trufé de "?" et de caractères chinois "?, ?, ?"... sans qu'il y ai de "normes" genre : un remplacement de chaque acent par un caratere spécial...etc.
C'etait plutot aléatoire.

une idée ? Bug, virus... ?

Le gros probleme c'est que je peux pas savoir avant, commment le mail va arriver chez le destinataire... ca craind un peu.. sad.gif


Merci de votre aide ! ;-)
Lindir
Je n'ai ni l'un ni l'autre sous la main mais si tu n'utilises Word que pour l'orthographe fais plutôt un collage spécial "Texte brut". Il doit se mélanger les pinceaux entre différents jeux de caractères.
Bernard Rey
QUOTE(guiliam @ 22 Sep 2005, 13:46)
Le soucis, c'est que dernièrement on m'a renvoyé un mail me disant qu'il etait illisible...
effectivement, il etait trufé de "?" et de caractères chinois "?, ?, ?"... sans qu'il y ai de "normes" genre : un remplacement de chaque acent par un caratere spécial...etc.
C'etait plutot aléatoire.

Manifestement, la dernière version de Mail a un souci dans l'encodage des fichiers. Et certains caractères semblent provoquer un encodage dans un système peu répandu, d'où les soucis. J'ai eu quelques échanges avec un correspondant qui avait ce genre de trucs, mais je ne me souviens plus des détails. Je crois que tu peux ponctuellement contrôler l'encodage choisi pour un message (une fois que tu as collé ton texte, donc). Mais c'est assez fastidieux.

Ceci dit, si tu as Word, je pense que tu aurais meilleur compte à utiliser Entourage, qui est bien plus souple au niveau des paramétrages (valable aussi pour les pièces jointes). Sinon, Thunderbird n'est pas mal non plus...
macmacmac
peut-être ne pas laisser l'encodage du texte sur automatique non?
à tester!!

(sur mail.app->tu fais ton nouveau mail->menu message->Encodage du texte)

Guy
guiliam
QUOTE(macmacmac @ 22 Sep 2005, 20:07)
peut-être ne pas laisser l'encodage du texte sur automatique non?
à tester!!

(sur mail.app->tu fais ton nouveau mail->menu message->Encodage du texte)

[right][snapback]1333623[/snapback][/right]


J'avais pas vu cette option, du coup je coche quoi ? Y'a plein d'option.

Je m'en fout de l'aspect du texte, ce que je veux c'est que ca passe de partout sans "?" et autre "#" a tout les caractere spéciaux wink.gif
macmacmac
regarde avec occidental latin 1
je ne sais pas si c'est LE bon, mais il y a de grande chance!

Guy
guiliam
QUOTE(macmacmac @ 23 Sep 2005, 06:30)
regarde avec occidental latin 1
je ne sais pas si c'est LE bon, mais il y a de grande chance!

Guy
[right][snapback]1334043[/snapback][/right]



C'est pareil ca change rien...

Par contre j'ei du envoyé un mail important ce matin, au cas ou je me le suis envoyé sur hotmail pour testé c'etait nickel ! Du coup j'ai envoyé mon message via mail sans inquietude?
Quand j'ai reçu la réponse de mon contact, la sitation de mon message en bas du siens etait toute daubé !...

C'est quoi c'est histoire. Ca marché trés bien avant Tiger.... ca me gonfle... un virus ?

PS: j'ai pas envie de passer sur une autre logiciel que Mail.
macmacmac
Je ne sais pas, mais arrête de parler de virus stp…

Je veux bien recevoir un mail de toi pour voir la gueule qu'il a comme tu dis… histoire de voir ta daube ohmy.gif

Guy
guiliam
je viens de décocher toute les langues dans le menu "international" du systeme...
Tout etait coché (depuis tiger)... est-ce que c'etait peut-être ca ?

Je sais que normalement y'a pas de virus sur mac, mais je pensais a un truc recu par mail...peut-être. wink.gif si tu dis que c'est pas possible tant mieux.
macmacmac
Salut,

Je ne pense pas que ça vienne de ça… je ne suis pas expert, mais ça ne me semble pas logique.
si tu te fais un mail, c'est bon chez toi non?

Sinon, ton mail, n'est pas modifié avec des correspondants pc uniquement?

Guy
guiliam
Oui chez moi le texte en parfait, sur un envois Hotmail ca marche, si je m'envois un mail ca marche aussi.

Apparement ca ne touche pas tout le monde.

je pensais aux options internationales car si je decoche tout, normalement (a priori) les caracteres jap et chinois ne devraient pas pouvoir être gérés dans mes mails ?
Et donc s'afficher ensuite chez les autres.

Pour les PC effectivement je crois que ca vient d'eux uniquement.
Le truc c'est que je sais pas pourquoi certains... et pas d'autre apparement. ni vers où chercher.

y'a pleins d'options en rapport au texte dans mail.
j'ai déjà tout mis en Arial (c'etait helvetica d'origine).

Sinon dans "redaction", y'a une option de format de message : RTF ou format Texte là je suis en RTF c'est quoi la différence ?

Je pense qu'ils ont dû changer un truc avec le nouveau mail (passage tiger) car avant tiger, quand je tappais un texte dans word et que l'affichais dans mail par copié/collé, y'avait aucun soucis.
Le texte etait justifié, bien callé sans bug...

Merci en tout cas pour ton aide wink.gif
macmacmac
Je ne pense pas t'aider réellement, mais j'essai de comprendre pour peut-être ensuite t'aider. biggrin.gif

Je me demande si la cause ne serait pas dans le presse-papier?
Tu devrais essayer (puisque tu ne veux pas faire tes mails dans mail.pp) de faire la même chose mais en utilisant TextEdit plutôt que word pour voir…
Il est possible que le presse-papier contient de l'encodage ou je ne sais quoi qui perturbe un pue.
Je ne suis pas connaisseur et mes propros sont peut-être mal exprimés ou faux, mais mon raisonnement ne doit pas être totalement faux.

Guy
guiliam
oui possible en effet,

Le soucis c'est que text Edit ne corrige pas forcement les fautes et les syntaxes comme word wink.gif
A tester en effet.

A+ wink.gif
macmacmac
QUOTE(guiliam @ 23 Sep 2005, 12:04)
oui possible en effet,

Le soucis c'est que text Edit ne corrige pas forcement les fautes et les syntaxes comme word wink.gif
A tester en effet.

A+ wink.gif
[right][snapback]1334467[/snapback][/right]
heuuuuu… tu en as aussi besoin? biggrin.gif
en ce qu'il me concerne, mail est suffisant pourtant…

mais passe par texedit pour voir si ça change qqchose…

Guy
Bernard Rey
QUOTE(guiliam @ 23 Sep 2005, 12:57)
y'a pleins d'options en rapport au texte dans mail. j'ai déjà tout mis en Arial (c'etait helvetica d'origine).

Sinon dans "redaction", y'a une option de format de message : RTF ou format Texte là je suis en RTF c'est quoi la différence ?

Non, le format "RTF" de Mail est une sorte de pseudo HTML qui ne donne pas de résultats très probants en dehors des Macs. L'ennui, c'est qu'on ne correspond pas forcément qu'avec des utilisateurs de Mac...

Pas de rapport non plus avec la police employée. Si tu veux voir ce qui cause le problème, tu vas dans les en-têtes des messages. Et tu verras que Mail, au lieu des encodages standards (habituellement charset="iso-8859-1", pour le plus courant) Mail s'obstine à mettre un encodage particulier dès qu'on utilise autre chose que du texte brut (et encore, je crois bien que l'utilisation du symbole euro suffit à mettre la zone).

Bref, Mail est un logiciel mal fini (ou mal localisé) comme pas mal d'autres. Après, c'est une question de choix et de compromis. Soit tu le gardes et tu acceptes ses défauts, soit tu en changes (et trouveras sûrement d'autres défauts à d'autres logiciels).

QUOTE(guiliam @ 23 Sep 2005, 12:57)
Je pense qu'ils ont dû changer un truc avec le nouveau mail (passage tiger) car avant tiger, quand je tapais un texte dans word et que l'affichais dans mail par copié/collé, y'avait aucun soucis.
Le texte etait justifié, bien callé sans bug...

Oui, dans les échanges que j'avais eu, j'avais pu constater aussi que c'était un problème nouveau, apparu avec la nouvelle version de Mail (et Tiger, donc).
Lindir
C'est probablement un problème d'encodage du texte. Que tu lises tes propres E-mails correctement est la moindre des choses, le problème vient du type d'encodage utilisé par ton correspondant. Le standard qui devrait être utilisé est l'ISO 8859-1 plus poétiquement appellé Latin-1 ou Occidental. Tu peux rencontrer les problèmes si ton correspondant utilise plutôt l'encodage Windows par exemple. Le fond du problème est le traitement des caractères accentués ou spéciaux, c'est à dire hors ASCII 7 bits.
La différence entre Texte ou texte brut et RTF est que le texte brut ne supporte aucune instruction de mise en forme et en page, alors que le RTF permet une mise en forme relativement indépendante des applications utilisées pour lire ou écrire un document. Une sorte de HTML pour le papier si tu veux. À moins que le HTML ne soit du RTF pour écran... En tout cas tu peux très probablement oublier l'hypothèse du virus.

[Edit] Je vois que Bernard Rey est intervenu juste avant. petite précision après mes propos ironiques : Le RTF est un format assez ancien qui a connu des évolutions, il est effectivement relativement comparable à du HTML.
Quant aux problèmes d'échange liés à l'encodage des caractères, c'est un vrai serpent de mer qui ne touche pas que le monde Mac.

Si tu pouvais mettre des morceaux choisis en ligne, ça nous permettrait d'indentifier le problème, les différents Charset sont assez identifiables.
guiliam
Voilà un exemple tiré d'un de mes mails.
C'est quand j'ai recu la reponse de la personne que j'ai vu que mon texte ne dessous était comme ça...


"En effet, c'est tr?bizarre, je viens de voir ?dans votre mail, je n'avais jamais encore eu le probl?. Il faut que je v?fie tout ?..."

d'autre exemples :

"quantit?e pi? pr?e" pour quantité de pièce prévue
"e reste ?otre disposition" pour je reste à votre disposition...

ect ect...


Si ca parle a quelqu'un ;-)


EDIT : le passage de mon mail au forum en faison copié coller a encore changé les caracteres...sad.gif
Normalement ce ne sont pas des point d'interrogation mais des signes chinois... comme ca ?, ?...

EDIT AGAIN... bon apparement depuis que j'ai décocher les autrs langue dans les pref syseme tiger... les caractere chinois s'affichent plus dans mon safari...


Je suis paumé là... blink.gif
Bernard Rey
QUOTE(guiliam @ 23 Sep 2005, 14:05)
Je suis paumé là...  blink.gif

Je m'excuse d'insiter, mais regarde dans les en-têtes des messages, c'est là que tu auras ta réponse. Comme l'a dit Lindir également, un courrier "normalement constitué" de base indique charset="iso-8859-1" dans son en-tête. En principe c'est un format communément reconnu par tous les logiciels de messsagerie. Dès qu'on s'en écarte, on prend le risque de tomber sur des destinataires dont le logiciel ne sait pas interpréter correctement l'encodage, ce qui donne des résultats "hazardeux".

Le problème, c'est que Mail tend à n'en faire qu'à sa tête (ce qui se traduit par l'option "Automatique" dans "Messages" > "Encodage du texte") et que du coup il envoie les messages dans un format qui lui est personnel et qui n'est pas toujours reçu correctement par d'autres logiciels. Voilà. Ce n'est hélas pas plus compliqué que ça.
guiliam
j'ai pas trouvé ou ce trouve cette indication ?

huh.gif
Bernard Rey
Dans Mail : "Présentation" > "Message" > "En-têtes longs"

Dans les autres applications, c'est généralement similaire, un menu de type "Affichage" et c'est souvent plutôt proposé sous le terme "Source" ou "Fichier source", faut fouiner un peu (mais je pense que l'aide doit pouvoir indiquer ça).

Mais attention, ce n'est réellement utilisable que pour les messages que tu reçois, pas vraiment pour ceux que tu as envoyés.
guiliam
je ne vois nul par marqué Charset...ect blink.gif

En tout cas pas une seule fois dans toutes les infos qu'affiche "en-tête long".

C'est quand meme bien compliqué ces histoire, pour pas grand chose...

On peut pas installer Mail 1.0 sur Tiger ? ce serait plus simple... dry.gif
macmacmac
Si tu n'utilises pas word pour rédiger tes mails et les coller ensuite dans mail.app et que tu utilises mail.app pour faire ce dont il est faire, tu n'as pas de problème non?

moi, à ta place, il y a longtemps que j'aurai arrêté de me prendre la tête avec ça…
D'ailleurs, je rédige mes mails dans mail.app et ça va très bien!

pourquoi tiens-tu tellement a passé depuis word sur mail?
As-tu un exemple concret?

Guy
manzanares
En tout cas, ne te turlupine pas outre mesure si tu dois renoncer au correcteur orthographique de Word, car il est bien nul et introduit même des fautes de syntaxe et de grammaire. Celui du système est plus sommaire, mais sans risque. Tu peux utiliser en complément Cocoaspell qui est multilangues et pas mal du tout. (gratuit aussi)

Perso, je me contente de Mail (et Eudora quend j'envoie une lettre en anglais, car son correcteur orthographique anglais est nickel) et quand j'ai un courrier très long j'utilise TexEdit.

Sinon, si tu veux rétablir le bon aspect d'un message mal encodé et hérissé de signes cabalistiques, tu peux installer l'irremplaçable Wordservices de Devon Technologies (ça s'installe dans les Services), qui reconvertit à la volée les encodages windows en mac et inversement, plus plein d'autres fonctionnalités bien utiles, comme de changer d'un clic d'horribles mots tout en majuscules à la sauce windows en minuscules - ou encore mettre une majuscule au début de tous les mots - ou encore supprimer le « wrapping » des bouts de ligne (les coupes au bout de chaque ligne dans la fenêtre : bien fastidieux à faire à la mano...)
Bref que du bonheur : Ici

D'ailleurs c'est fait par les auteurs de DevonthinkPro c'est tout dire...
apprenti bidouille
Sinon si tu tiens absolument à tout rédiger dans Word... Quand j'avais des problèmes d'encodage comme ça, je collais mon texte dans TextEdit, et ensuite je le recopiais/collais dans Mail.... C'est pas encore le pied mais c'est pas trop trop long à faire...
Bernard Rey
QUOTE(macmacmac @ 24 Sep 2005, 00:29)
Si tu n'utilises pas word pour rédiger tes mails et les coller ensuite dans mail.app et que tu utilises mail.app pour faire ce dont il est faire, tu n'as pas de problème non ?

Ben non. Le problème ne vient pas de Word mais de Mail. La personne avec qui j'avais constaté et diagnostiqué le problème n'utilisait nullement ni Word ni aucun autre logiciel pour préparer les textes. Ce qui posait problème c'était juste le fait d'utiliser certains caractères dans Mail. Je ne suis plus trop sûr, mais je crois que c'était le sygma (= Option-Majuscule-S) qui suffisait à tout casser. Bref, il semble que n'importe quel caractère sortant un peu de l'ASCII de base suffise à mettre la zone dans Mail 2 (et ça ne le faisait pas, ou pas de la même façon, avec la version 1)

Tiens, d'ailleurs la démonstration est encore plus facile que je ne le pensais : ça marche même en enregistrant un message en brouillon. Dès qu'on tape le sygma, Mail (pourtant même pas en rtf mais bien en texte brut) bascule en encodage MACINTOSH (voir image jointe). Quand on tape le symbole euro, c'est en WINDOWS-1252 que ça bascule. Bravo le standard wink.gif

Vous en concluez ce que vous voulez...

[MàJ] : ne reculant devant rien, j'ai même fait l'essai de copier coller un bout de texte mis en forme depuis Word vers Mail (voir deuxième image jointe) : pour le coup, j'ai un encodage ISO-8859-1 de bon aloi (mais pas de caractère inhabituel, j'aurais pu ruser un peu plus probablement)...
macmacmac
je ne mets pas ta parole en doute, mais tu fais comment pour avoir ce problème?

regarde ma capture, que ce soit lors de la saisie, de l'ouverture de mon brouillon, de la lecture de mon message expédié ou de la lecture de mon message en réception, j'ai bien toujours la même chose.

Que dois-je faire pour retrouver ton problème poru voir si ça se reproduit?

Guy
guiliam
J'utilise word quand j'ai des longs courriers à tapper.
Ca me permets de mettre en page mon texte, et d'avoir un correcteur plus performant que mail.
Un exemple simple, si je fais un coquille de grammaire, mail ne corrigera rien.

Sinon effectivement je pense que si je n'utilise QUE mail, il ne doit pas y avoir de soucis (sinon on m'aurait fais la remarque depuis longtemps wink.gif )

L'autre fois j'ai répondu depuis Mail, a un mail qui contenait mon ancien message (foireux) en citation, ma réponse a donc elle aussi était transformée alors que je l'avais tappé uniquement dans Mail.

Bref, je vais trouvé une solution alternative, c'est pas bien grave, je pensais au départ en postant ici que le soucis était simplement une option mal cochée...apparement c'est plus complexe et aléatoire que ca donc bon...

Merci beaucoup pour vos réponses biggrin.gif
macmacmac
ah non non, je veux une réponse moi!!! tongue.gif je veux comprendre, je veux apprendre!!!!
on n'est pas là pour te faire changer de méthode, on est là pour lire, apprendre et surtout comprendre!!!

qui ne voit pas la même chose ci-dessous que dans capture de mon post précédent?

#$®©™€?æÀÃ


Je pourrais te faire un mail et tu pourrais mele retourner poru voir…

Guy

En tout cas, si dans mail je n'arrive pas à reproduire un problème, j'en vois un ici, aprs validation de mon message mon signe omega se transforme en ?
j'ai donc le problème dans l'affichage de safari après la validation du pst en lecture dans la page smile.gif)

Bon, je n'ai rien trouvé d'autre comme problème, mais les chances d'avoir le signe omega dans un post… biggrin.gif
Bernard Rey
QUOTE(macmacmac @ 24 Sep 2005, 09:58)
regarde ma capture, que ce soit lors de la saisie, de l'ouverture de mon brouillon, de la lecture de mon message expédié ou de la lecture de mon message en réception, j'ai bien toujours la même chose.
Ben oui, un monde où tout le monde utilise le même logiciel en expédition, en réception serait un monde certainement parfait. L'ennui, c'est que dans le monde réel, tout le monde n'utilise pas Apple Mail.app. C'est en principe pour ça qu'existent les standards, permettant à des logiciels de messagerie différents d'échanger avec un minimum de soucis. Il est bien dommage qu'Apple (pourtant pas en situation d'imposer ses formats) s'affranchisse des standards (et il y aurait aussi à dire sur l'encodage des pièces jointes). Ce qui est apparemment une régression par rapport à Mail 1.

Mais bon, pour résumer, il n'est pas étonnant qu'il y ait des problèmes avec des messages composés dans Mail (problème initial de ce fil) et ça n'a rien à voir avec le fait que Word ou une autre application ait été utilisée en cours de route (comme certains l'ont suggéré, sans analyse ou test). C'est tout. Et du coup, il faut que guiliam choisisse entre les différents compromis possibles : accepter que certains destinataires ne puissent pas lire ses messages, filtrer le contenu de ses messages pour être sûr que Mail veuille bien rester sur un encodage plus standard, choisir un logiciel de messagerie qui pose moins de problèmes, peut-être d'autres encore...


QUOTE(macmacmac @ 24 Sep 2005, 09:58)
Que dois-je faire pour retrouver ton problème poru voir si ça se reproduit ?
Ben, il suffit de regarder dans les en-têtes ("Présentation " > "Message" > "En-têtes longs"), rien de très compliqué... Personnellement, en retapant ton message en texte brut, j'obtiens un encodage MACINTOSH (voir image jointe) quoi que je fasse, pas toi ? Du coup on peut facilement imaginer que ça ne passera pas partout. Dans Mail ça sera lu correctement (encore heureux) comme tu l'as constaté. Mais dans d'autres logiciels ? Sur un PC (on ne peut tout de même pas totalement ignorer que dans le monde qui nous entoure, un certain nombre de dissidents persistent à utiliser des PC Windows) avec Outlook Express ?
macmacmac
moi, j'ai
Content-Type: multipart/alternative; boundary=Apple-Mail-9-1064860067

EFFECTIVEMENT:
si je fais mon mail en format txt, j'ai
Content-Type: text/plain; charset=MACINTOSH; format=flowed
macmacmac
je recherche quelqu'un avec un pc pour recevoir 2 mails de moi et me les retourner avec mon message d'origine évidement…

Guy
apprenti bidouille
xxxxxxxx {at} yahoo {dot} fr
apprenti bidouille
voilà je t'ai répondu à tes mails... c'est un peu le bazar parce que pour chaque t'as une version standard et une version UNICODE, mais bon j'éspère que ça fera avancer le schmilblick biggrin.gif
Bernard Rey
QUOTE(macmacmac @ 24 Sep 2005, 11:11)
moi, j'ai
Content-Type: multipart/alternative; boundary=Apple-Mail-9-1064860067

C'est probablement parce que tu as collé une image dans le message. En quel cas, l'en-tête ne suffit plus à tout voir : elle indique seulement que le message contient plusieurs parties (pour faire simple : du texte et une image).

Il faut alors avoir accès au véritable message source (Dans"Présentation" > "Message" demander "Contenu brut") pour voir chacune des composantes. Tu auras du coup une première partie avec le texte et une seconde avec l'image. Et chacune des partie a ses propres indications d'encodage. Le texte étant (chez moi en tout cas) en MACINTOSH...
macmacmac
effetivement, c'est le bronx, mais, mais, mais,…

il n'y a qu'un seul cas où le je vois mon texte pourri,
c'est celui où mon envoi était en TXT et ton retour en UNICODE

En tout cas, pour moi, j'en conclu que si je reste en RTF, je n'ai rien d'anormal que ce soit chez moi, et mon mail en retour dans une réponse.

Donc, ma fi… je peux me dire que je n'ai pas de quesiton à me poser finalement (en ce qu'il concerne mes mails en tout cas).

Et chez toi sinon; il y a un cas où c'est mauvais?
(prend exemple avec le omega qui est d'office à la rue)

Je te refais les mêmes mail avec juste le signe

Guy
macmacmac
QUOTE(Bernard Rey @ 24 Sep 2005, 11:29)
C'est probablement parce que tu as collé une image dans le message.
[right][snapback]1335826[/snapback][/right]
négatif, rien d'autre que trois lignes de texte.
à moins que ce ne soit la petite image que l'on voit en haut à droite qui est l'image de l'utilisateur
guiliam
Aprés lecture de tous les nouveaux messages, j'ai regardé un peu plus prés de mon coté.

J'ai une signature sur laquelle j'ai un logo jpeg. Cette signature a été enregistré en faisant copié/coller vers la pref/signatures de Mail (pour garder la mise en forme du texte, les graisses et la couleur d'un des mot. Plus, bien sur, le jpeg au dessus).

Quand j'ecrie un mail qui a besoin de la signature, je le tape soit dans Mail directement, soit via Word (si il est long) puis copier/coller. Ensuite je selectionne ma signature dans l'onglet en haut du message.

Quoi qu'il en soit, j'ai l'impresssion que ce ne sont QUE les messages qui comprenent la signature (via word ou pas) qui "merdouilles"...

Ai-je fait une erreur a un moment au niveau de la signature... c'est pourtant qu'un simple petit jpeg...

Est-ce que je peux avoir un moyen simple pour savoir si oui ou non mon message à des chance de planter chez l'utilisateur (avant de l'envoyer, et une fois mise en forme) ?...
Le soucis c'est surtout quand ce sont des mails de prospection ou d'information... je vais pas renvoyer un mail pour savoir si ils ont bien reçu le prédecent sans "merdouilles" des caractères... ;-)

Merci en tout cas smile.gif
guiliam
EDIT : si des fois je passe par Entourage pour certains envois "importants" et-ce que je suis sur qu'il n'y aura aucun soucis de ce type ?... rolleyes.gif
Bernard Rey
QUOTE(guiliam)
j'ai l'impresssion que ce ne sont QUE les messages qui comprenent la signature (via word ou pas) qui "merdouilles"...[right][snapback]1338400[/snapback][/right]

Fort possible, dans la mesure où la présence d'une image fait automatiquement "basculer" l'encodage, comme nous l'avons vu dans les épisodes précédents. La présence de caractères comme le sygma (je sais, ce n'est pas si courant) suffirait aussi.

QUOTE(guiliam)
EDIT : si des fois je passe par Entourage pour certains envois "importants" et-ce que je suis sur qu'il n'y aura aucun soucis de ce type ?
Non, comme déjà dit, a priori pas ce genre de soucis.

Et ce serait même beaucoup plus simple s'il s'agit de Word 2004 / Entourage 2004, puisque dans ce cas-là tu as même une option dans le menu "Fichier" de Word qui te permet d'envoyer un document comme page Web. Le code n'est certes pas de toute beauté (pour ceux qui s'intéressent à cet aspect) mais le résultat est très satisfaisant pour un envoi de type prospection, etc.
guiliam
Oui, en effet j'ai office 2004...

Je vois pas a quoi ce ressemble "type web" pour un mail c'est comme les mail publicitaire ? qui s'affiche quand on est en ligne ?

Y'a aucun soucis avec Mac/PC.. ?
Bernard Rey
QUOTE(guiliam @ 26 Sep 2005, 15:22)
Je vois pas a quoi ce ressemble "type web" pour un mail c'est comme les mail publicitaire ? qui s'affiche quand on est en ligne ?

Non, pas nécessairement. Si tu veux, dès que tu as autre chose que du texte brut (par exemple quand tu mets de la couleur ou de l'italique, des tailles différentes, etc.) ton message est "de type web" (en HTML). Et c'est exactement ce que tu fais lorsque tu copies de Word dans Mail pour garder la mise en page... Mais ce l'est aussi lorsque tu choisis directement dans Mail de mettre de la couleur.

Pour les images ou photos "en ligne", c'est une possibilité (un peu plus complexe, puisqu'il faut du coup mettre les images sur un site, créer un lien "absolu" au lieu de "relatif"...) mais ce n'est pas obligatoire d'aller jusque là. Fais quelques essais en t'envoyant des messages à toi-même, je pense que tu verras vite comment faire (c'est assez simple).

QUOTE(guiliam @ 26 Sep 2005, 15:22)
Y'a aucun soucis avec Mac/PC.. ?

Non. C'est justement à ça que servent les standards (voir plus haut). Il n'y a pas ce genre de problème que tu rencontres avec l'encodage dans Mail 2. Donc tu peux utiliser ta technique actuelle dans Entourage sans souci (et pas de poblème particulier pour mettre une image dans la signature). Et tu peux donc aussi envoyer directement depuis Word (voir plus haut). Le tout sera reçu sans difficulté particulière par les différents logiciels de messagerie, Mac ou PC. Du moins n'ai-je pas vu de remarque à ce sujet jusqu'à ce jour...
guiliam
Bon c'est cool smile.gif

Je vais utiliser Entourage pour les mails importants ou "de prospections" (histoire de pas passer pour un gros nase avec des textes en chinois ;-) et garder Mail pour la gestion de mon courrier au jour le jour wink.gif

Je vais tester tout ca.

Merci encore :-)
guiliam
Je viens de faire des essais avec entourrage, pour l'instant ca marche bien que je recois sur Mail (par exemple).

Le content-type d'un message reçu (via Outlook vers Mail) est :
multipart/related; boundary="B_3210668496_376927"

Sinon y'a plusieurs option d'encodage pour les pièces jointes...

Coder pour : "Tout ordinateur (AppleDouble)" (ce que j'ai mis d'origine)
"Macintosh (BinHex)"
"Windows (MIME/Base64)"
"UNIX (UUEncode)"

Format de courriers, j'ai mis HTML (sinon c'est TexteBrut et c'est nase).

Qu'en pensez vous ?



Autre chose, quand je crée un message, pour rajouter une pièces jointe il semble y avoir deux possibilités. Soit passer par l'îcone trombone, soit passer pas l'icone "insérer"...
Pour cette dernière l'image apparait donc dans le mail.

Quel est la différence en gros ?

Si je me fait une signature sur un jpeg et que j'utlise "insérerer" pour la mettre en fin de mail ca fonctionne correctement ?

Merci d'avance pour vos remarques wink.gif
Bernard Rey
QUOTE(guiliam @ 27 Sep 2005, 12:36)
y'a plusieurs option d'encodage pour les pièces jointes...

Coder pour : "Tout ordinateur (AppleDouble)" (ce que j'ai mis d'origine)
Non !!! Tu mets "Windows (MIME/Base64)" et tu n'y touches plus jamais wink.gif Le codage AppleDouble ne sert à rien : heureusement ça fait longtemps que les logiciels de messagerie sur Mac savent lire les messages au format Windows. Par contre l'inverse n'est pas vrai (!) et l'AppleDouble leur donnera le classique coup des fichiers illisibles (aux utilisateurs de Windows). Et pas de compression non plus, tant que tu es dans les réglages...

QUOTE(guiliam @ 27 Sep 2005, 12:36)
Format de courriers, j'ai mis HTML (sinon c'est TexteBrut et c'est nase).

Question d'avis, de goût et de couleur. Bon, il est clair que, dans ton cas, puisque c'est pour faire des envois en HTML, autant mettre ce format par défaut wink.gif

QUOTE(guiliam @ 27 Sep 2005, 12:36)
Autre chose, quand je crée un message, pour rajouter une pièces jointe il semble y avoir deux possibilités. Soit passer par l'îcone trombone, soit passer pas l'icone "insérer"... Pour cette dernière l'image apparait donc dans le mail.

Quel est la différence en gros ?

Exactement celle que tu vois. Tu peux aussi passer par "glisser-déposer". Quand tu es en format "texte brut", les deux méthodes donnent le même résultat (pièce jointe) mais quand tu es en format HTML, le fait de glisser l'image l'incorpore directement dans le message à l'endroit où se trouve le curseur si tu le déposes dans le message, ou en PJ si tu le dépose dans la zone prévue pour ça en haut. A l'affichage, la différence est facile à voir puisqu'en PJ, elle s'affichera en fin de message à la réception, et non dans le corps du message.

QUOTE(guiliam @ 27 Sep 2005, 12:36)
Si je me fait une signature sur un jpeg et que j'utlise "insérerer" pour la mettre en fin de mail ca fonctionne correctement ?

Oui, mais tu peux aussi te créer une "Signature" (menu "Outils") comportant l'image et ensuite, dans le "Compte" tu peux choisir d'associer automatiquement ta signature aux message envoyés via ce compte (quitte à éventuellement la modifier ensuite). C'est tout de même plus pratique (et c'est fait pour).
guiliam
Heureusement que je pose la question wink.gif

L'encodage AppleDouble etait coché d'origine... huh.gif
Bernard Rey
QUOTE(guiliam @ 27 Sep 2005, 13:31)
Heureusement que je pose la question wink.gif
L'encodage AppleDouble etait coché d'origine... huh.gif
[right][snapback]1339850[/snapback][/right]

Oh, ce n'est pas si grave non plus. Mais c'est un cas classique de souci avec le Windowsiens en moins. C'est vrai que l'AppleDouble était utile dans le temps, quand les Macs ne savaient pas lire les documents s'ils n'avaient pas leur fichier "ressource" joint. Mais c'est bien loin, ça... je crois que c'est au moins depuis Mac OS 8 (peut-être même 7) que les Macs savent se débrouiller (plus ou moins facilement dans les premiers temps, il est vrai) avec les fichiers au format Windows...
guiliam
Je relance le débat.

Le probleme est toujours là sur Mail, et depuis Tiger.

Presque tous mes mail envoyé avec le logiciel APPLE arrive sur PC avec des bug d'affichage (caractères chinois, carré et autres sur certains caractères).

Du coup j'utilise Entourage pour les mails important mais bon... je dois pas être le seul ?
Meme avec une installation de l'OS neuve il y a le probleme.
Cela voudrait dire que tous ceux qui envoient des mails avec MAIL vers un PC envoient des documents "daubés" ? blink.gif (en tout cas, ceux avec des pièces jointes ou des signatures, je suis presque certains à 90%)

Est-ce que cela pourrait provenir d'une police foireuse installé par un logiciel (office par exemple).
Il me semble qu'il y avait déjà eu des soucis de ce style sous OS9...

J'ai remarqué aussi que quand je démarre windows media player, le mot "prêt" sur le barre de lexture ne s'affiche pas correctement, l'accent est zapé j'ai un rectangle vertical à la place...

Je viens de faire une clean install de mon systeme, c'est le moment de faire des tests... ;-)
Si quelqu'un à un PC pour que lui envoie des mails...(en MP).

A+
drakeramore
C'est simple : si tu veux être sûr d'être lu, il faut envoyer au format texte (pas RTF), sans mise en forme.
C'est valable quelque soit le soft d'envoi, quelle que soit la plate forme d'envoi.
guiliam
Non puisque tout fonctionne parfaitement sous Entourage... rolleyes.gif

Le soucis avec ton astuce c'est que cela interdit les pieces jointes et les signatures (avec image ou autre mise en forme)... donc vraiment un peu trop "brut de décoffrage" à mon gouts... sad.gif

Pourquoi cela fonctionne sous Entourage et pas sous Mails...


Je pourrais utiliser uniquement Entourage, mais je suis pas très fan, j'ai tous mais anciens mails bien archivés sous MAIL donc, avoir 2 logiciels c'est moyen...

D'autant que je vois pas pourquoi, ca ne marche pas nickel comme un envoie depuis un PC !
mad.gif c'est le comble...
Bernard Rey
Ce problème a déjà été traité plusieurs fois depuis la sortie de Mail 2. Comme décrit plus haut, dès qu'on passe en "pseudo-HTML" (curieusement baptisé RTF) ou dès qu'on met une pièce jointe ou certains caractères dans un message, Mail 2 bascule automatiquement dans un encodage en "charset=MACINTOSH" qui est tout ce qu'on veut sauf standard (voir les copies d'écran dans ce message plus haut dans ce fil). Il n'y a rien de surprenant à ce que ça pose du coup des problèmes d'affichage dans le reste du monde (je veux dire ceux qui n'utilisent pas Mail d'Apple, en particulier chez les Windowsiens wink.gif)

Comme indiqué, tu peux même faire les tests toi-même, puisque c'est directement visible dans les en-têtes du message, même pas besoin de les envoyer wink.gif

On peut contourner apparemment le problème au coup par coup en forçant l'encodage dans un format standard (ISO-Latin 1) mais c'est fastidieux et il ne faut pas oublier de le faire avant l'envoi... Il y avait une piste intéressante dans ce fil là, avec la proposition de modifier un truc dans le fichier des préférences. Reste à voir si ça suffit...
Ceci est une version "bas débit" de notre forum. Pour voir la version complète avec plus d'informations, la mise en page et les images, veuillez cliquer ici.
Invision Power Board © 2001-2014 Invision Power Services, Inc.