IPB

Bienvenue invité ( Connexion | Inscription )

 
Reply to this topicStart new topic
> Debian sur un ancien MacPro et deuxième HD, l'iso ne monte pas / installer Debian et OSX sur deux disques diff
Options
BoumBoumBoum
posté 13 Mar 2016, 02:47
Message #1


Nouveau Membre


Groupe : Membres
Messages : 26
Inscrit : 28 Feb 2016
Lieu : Manneken-Pis City
Membre no 198 206



Editus moderatus : Le lecteur curieux trouvera un résumé au message #15.


Bonjour,

de retour sur Debian avec ma nouvelle machine, Mac Pro 1.1 ;b, comme sur mon (tout juste décédé)
G5 bi-pro watercoolé (!!!!!), je veux lui ajouter un Debian dans le ventre.
Surprise, télé-chargé d'ici (page officielle):
http://cdimage.debian.org/debian-cd/8.3.0/amd64/iso-dvd/
Le Debian .iso (DVD-1) refuse de monter sur OS X, donc je ne puis le graver.
- [ouvrir avec : DiskImageMounter >> "pas de système de fichiers montable"]
- L'.iso fait bien ses 3,99 Go
Un autre télé-chargement, deux jours plus tard, ne me mène qu'au même résultat.

Les autres DVDs du système (DVD 2/3 + updates) montent et se gravent sans problème.
(md5 vérifies).

Ai-je raté quelque chose ?

[EDIT]
et de 3 télé-chargements de l'.iso n°1, rien de mieux !
J'imagine que c'est chez "debian.org" que la version originale est publiée, un miroir me sauverait-il de la partie (oui et lequel)?
Merci de votre attention.

[EDIT 2]
Fichtre, zut, ...:wtf:
Petite idée, je passe par le fichier Torrent , et téléchargement de l'.iso....
Même résultat, il ne monte pas

Que l'on m'explique ce qu'il se passe Please !!!!!!
Ou la page sur le site Debian où signifier cette m.....

sad.gif sad.gif sad.gif

Ce message a été modifié par baron - 13 Feb 2017, 20:43.
Raison de l'édition : Ajout du lien interne + précisions dans le titre


--------------------
Mac Pro 1.1 XEON DualCore 2 x 2,66
4 DD int (250-250-250-500 Go) -1 DD ext (1T)
Nvidia geForce 7300GT 256 Mb
6 Go DDR2 FB-DIMM
Cinema display HD Apple 30'
OS 10.7.5 (11G63), Adobe CS5.1, FinalCut 10.0.8
DEBIAN 8.7.1 i386
Go to the top of the page
 
+Quote Post
poissonfree
posté 13 Mar 2016, 09:34
Message #2


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 1 941
Inscrit : 4 Jun 2007
Membre no 87 884



Je viens de télécharger le DVD 1.
Testé sous VirtualBox, j'ai fait une installation.

Mais tu n'as pas besoin de monter l'image pour la graver.
Avec ton logiciel de gravure, tu sélectionnes ton fichier iso et tu lances la gravure.


--------------------
Go to the top of the page
 
+Quote Post
blueG3
posté 13 Mar 2016, 11:53
Message #3


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 3 735
Inscrit : 20 Nov 2001
Lieu : vitry sur seine (94)
Membre no 1 346



bonjour ,

Apple a modifié l'application diskmounter pour ne prendre en charge que les .dmg et certains .iso CD sous format iso9660,
pas les autres formats ...

peux tu démarrer sur une clé USB ?

si oui ,
pour le copier sur une clé USB , on utilise la commande
dd if vers of
attention il ne faut absolument pas se tromper sur l'unité cible , DD a pour surnom destruction disque.

pour cela , tu met la clé USB et tu ignore s'il demande formatter la clé
tu vas sous le terminal
Code
sudo diskutil list

--> la liste de tous DD , CD , DVD et USB apparait
c'est l'info /dev/diskn de la clé USB qu'il faut utiliser

--> demontage logique
Code
sudo diskutil UnmountDisk /dev/diskn


puis copie iso
Code
sudo DD if=<chemin/nom.iso> of=/dev/diskn bs=2m


nb : certains peuvent utiliser /dev/rdiskn , et bs pour la taille de transfert

pour suivre sous top dans une autre fenetre terminal sous top la quantité ecrite
à la fin tu aura le message de demande pour partition , reponds ignorer

et redémarre avec ALT enfoncé au démarrage ( tous les points EFI de démarrage doivent être proposer )

Ce message a été modifié par blueG3 - 27 Mar 2016, 19:39.


--------------------
macpro 2008 quad core +8Go + 8800GT merci Nvidia & Apple pour la qualité et le choix de la carte! => ATI 5770 Apple + 2 DD WD 640Go + 2 SSD M4 Crucial 512Go(Raid 0) et Snow Leopard 10.6.8 + LG IPS235 flatron + Manjaro Linux sur DD interne - 16.10 xfce
Desktop - CPU : Intel® i7-6700K @ 4,2GHz - RAM 16 Go - CM: Gygabyte Z170X-UD5-TH CG : GeForce GTX 970- Audio: Intel® Sunrise Point-H HD Manjaro 16.10 xfce
Go to the top of the page
 
+Quote Post
BoumBoumBoum
posté 18 Apr 2016, 19:14
Message #4


Nouveau Membre


Groupe : Membres
Messages : 26
Inscrit : 28 Feb 2016
Lieu : Manneken-Pis City
Membre no 198 206



BlueG3 et poissonfree,

merci.
J'ai omis d'activer " la notification par courriel des réponses", et ai donc raté vos réponses.
J'en suis fort confus !

Je suis néanmoins entre temps parvenu à graver l'.iso avec DiskUtility après avoir découvert (ce jour) que même non monté, ce dernier apparaissait dans la liste des éléments gravables.

A vrai dire, démarrer depuis le DVD me mène à "
"1"
"2"
"select CDRom Boot Type :"
Et un clavier qui ne donne rien...

Bon, on a l'air assez loin d'une installation sur G5....
Je cherche, je cherche...

(à vrai dire l'installation sur un deuxième DD interne n'a pas l'air de simplifier les choses)


--------------------
Mac Pro 1.1 XEON DualCore 2 x 2,66
4 DD int (250-250-250-500 Go) -1 DD ext (1T)
Nvidia geForce 7300GT 256 Mb
6 Go DDR2 FB-DIMM
Cinema display HD Apple 30'
OS 10.7.5 (11G63), Adobe CS5.1, FinalCut 10.0.8
DEBIAN 8.7.1 i386
Go to the top of the page
 
+Quote Post
blueG3
posté 19 Apr 2016, 07:17
Message #5


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 3 735
Inscrit : 20 Nov 2001
Lieu : vitry sur seine (94)
Membre no 1 346



bonjour ,
pour le macpro1,1
passe plutôt par une clé USB ( ce que j'ai indiqué auparavant )
==> prends une clé USB 2.0 de taille 4 a 8Go
tu n'as besoin que de l'image iso 1

tu démarrage avec la clé USB et ALT enfoncé pour sélectionner la cle USB par EFI ( elle doit apparaitre )

Ce message a été modifié par blueG3 - 19 Apr 2016, 07:26.


--------------------
macpro 2008 quad core +8Go + 8800GT merci Nvidia & Apple pour la qualité et le choix de la carte! => ATI 5770 Apple + 2 DD WD 640Go + 2 SSD M4 Crucial 512Go(Raid 0) et Snow Leopard 10.6.8 + LG IPS235 flatron + Manjaro Linux sur DD interne - 16.10 xfce
Desktop - CPU : Intel® i7-6700K @ 4,2GHz - RAM 16 Go - CM: Gygabyte Z170X-UD5-TH CG : GeForce GTX 970- Audio: Intel® Sunrise Point-H HD Manjaro 16.10 xfce
Go to the top of the page
 
+Quote Post
BoumBoumBoum
posté 20 Apr 2016, 09:45
Message #6


Nouveau Membre


Groupe : Membres
Messages : 26
Inscrit : 28 Feb 2016
Lieu : Manneken-Pis City
Membre no 198 206



BlueG3

j'ai donc suivi à le lettre ta procédure.
Tout se déroule à la lettre pour la copie.
Merci

Le redémarrage sous "Alt" ne me propose que "ReFit et "RecoveryHD"
"Refit" me propose (ou un démarrage simple), le système et une icône qui ressemble à Bootcamp"

Cliquer sur cette icône me donne
"Not found from LocateDivice Path"
"the firmwear refused to boot from the selected volume"
Ayant lu :
http://refit.sourceforge.net/help/usb_disk.html (limitations au firmwear), je l'ai proprement désinstallé, et installé "Refind".
Pour un résultat identique.
Donc un souci firmwear Apple je présume (je suis à jour).

Je navigue à l'aveugle, et ne trouve pas de doc idoine.
Donc, bien dans l'embarras à devoir encore faire appel ici pour trouver quelques pistes.

EDIT : j'ai bien utilisé bootcamp pour une install, tout aussi avortée de WIN7, je pensais avoir nettoyé correctement mon ordi)
Le DD voué à Win étant démonté j'ai :
DD Apple
DD pro Debian
Clef USB montée

Ce message a été modifié par BoumBoumBoum - 20 Apr 2016, 10:02.
Fichier(s) joint(s)
Fichier joint  Capture_d_____cran_2016_04_20____10.49.56.jpg ( 200.61 Ko ) Nombre de téléchargements : 7
 


--------------------
Mac Pro 1.1 XEON DualCore 2 x 2,66
4 DD int (250-250-250-500 Go) -1 DD ext (1T)
Nvidia geForce 7300GT 256 Mb
6 Go DDR2 FB-DIMM
Cinema display HD Apple 30'
OS 10.7.5 (11G63), Adobe CS5.1, FinalCut 10.0.8
DEBIAN 8.7.1 i386
Go to the top of the page
 
+Quote Post
blueG3
posté 20 Apr 2016, 20:59
Message #7


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 3 735
Inscrit : 20 Nov 2001
Lieu : vitry sur seine (94)
Membre no 1 346



de mon côté je n'ai pas eu besoin de de Refit/Refind
==> Reset PRAM , et réassigne le DD de démarrage
extinction
remet la clé USB et démarre avec ALT enfoncé
une icône doit apparaître pour la clé USB , indiquant un démarrage sur EFI USB


--------------------
macpro 2008 quad core +8Go + 8800GT merci Nvidia & Apple pour la qualité et le choix de la carte! => ATI 5770 Apple + 2 DD WD 640Go + 2 SSD M4 Crucial 512Go(Raid 0) et Snow Leopard 10.6.8 + LG IPS235 flatron + Manjaro Linux sur DD interne - 16.10 xfce
Desktop - CPU : Intel® i7-6700K @ 4,2GHz - RAM 16 Go - CM: Gygabyte Z170X-UD5-TH CG : GeForce GTX 970- Audio: Intel® Sunrise Point-H HD Manjaro 16.10 xfce
Go to the top of the page
 
+Quote Post
BoumBoumBoum
posté 3 May 2016, 09:12
Message #8


Nouveau Membre


Groupe : Membres
Messages : 26
Inscrit : 28 Feb 2016
Lieu : Manneken-Pis City
Membre no 198 206



Merci Blue G3
(
ai donc procédé comme prescrit.
"Refind" à bien disparu au démarrage.

Mais la clef n'apparait pas sous "restart+alt" (seul 'HD et "Recovery")

Pour me prémunir d'un éventuel souci avec la clef USB, j'ai recopié, après formatage, et comme prescrit par toi plus haut , un tout nouveau téléchargement d'un .iso Debian(pro intall en ligne) sur cette dernière.

Même résultat...elle n'apparaît pas.
J'ai monté la clef sur un port USB au dos de ma machine, idem...
La gravure de l'iso sur un CD, puis un démarrage sous "C", donne le même choix à l'écran "1... 2... Chose..." (et un clavier sans effet) décrit plus haut.

Je tourne en rond, n'y comprend rien et me trouve bien ennuyeux pour les autres Mbidouilleurs.
En attendant mieux, je vais faire une petite enquête du côté Fedora, voir si leur distrib est plus adaptée (j'ai dû lire sur le net que je risque encore de soucis avec la version du noyau Linux sous Débian)
Si d'autres idées vous viennent.

Merci (dans tous les cas)
EDIT :
mon clavier est bien un clavier Apple

Ce message a été modifié par BoumBoumBoum - 3 May 2016, 09:45.


--------------------
Mac Pro 1.1 XEON DualCore 2 x 2,66
4 DD int (250-250-250-500 Go) -1 DD ext (1T)
Nvidia geForce 7300GT 256 Mb
6 Go DDR2 FB-DIMM
Cinema display HD Apple 30'
OS 10.7.5 (11G63), Adobe CS5.1, FinalCut 10.0.8
DEBIAN 8.7.1 i386
Go to the top of the page
 
+Quote Post
BoumBoumBoum
posté 1 Feb 2017, 12:11
Message #9


Nouveau Membre


Groupe : Membres
Messages : 26
Inscrit : 28 Feb 2016
Lieu : Manneken-Pis City
Membre no 198 206



Editus moderatus : Début d'un nouveau sujet "Debian sur Macpro, comment faire sur 2 HD différents?" qui a été combiné avec celui qui précède.

Tout est dans le titre.
Un DD dévoué à OS 10.7
Un pour Debian 8.7
(Le dernier pour Win (par Virtualbox), partition d'échange entre systèmes, Edrive etc...)

Fichtre sur un G5 cela est en comparaison, d'une simplicité enfantine !
mon Bootcamp ne me permet pas de travailler sur autre chose que le DD Mac


Impossible de trouver sur le net, un How too !

Merci de votre aide


--------------------
Mac Pro 1.1 XEON DualCore 2 x 2,66
4 DD int (250-250-250-500 Go) -1 DD ext (1T)
Nvidia geForce 7300GT 256 Mb
6 Go DDR2 FB-DIMM
Cinema display HD Apple 30'
OS 10.7.5 (11G63), Adobe CS5.1, FinalCut 10.0.8
DEBIAN 8.7.1 i386
Go to the top of the page
 
+Quote Post
BoumBoumBoum
posté 7 Feb 2017, 16:04
Message #10


Nouveau Membre


Groupe : Membres
Messages : 26
Inscrit : 28 Feb 2016
Lieu : Manneken-Pis City
Membre no 198 206



bonjour,

toujours dans la même mélasse pour installer Debian en DualBoot sur un deuxième disque dur.
Impossible de faire apparaitre la clef .iso pour l'installation du Linux (restart +option)

Si je m'en réfère à ma tentative antérieure
http://forum.macbidouille.com/index.php?sh...view=getnewpost
je viens de ré-efflecteur avec Debian 8.07
les opérations :
message #3
message #5
Le tout sans accros

au moins j'ai découvert une petite chose :

-la clef est illisible par le Mac lorsque je suis sur OS X blink.gif

"diskutill" me donne cela pour la clef :

/dev/disk3
#: TYPE NAME SIZE IDENTIFIER
0: Apple_partition_scheme *8.0 GB disk3
1: Apple_partition_map 4.1 KB disk3s1
2: Apple_HFS 426.0 KB disk3s2

Où est le problème ?
"Size identifier" ????

Je voudrais enfin pouvoir m'en sortir.
J'en ai plein le dos, et les logiciels propriétaires...

merci de votre aide (et particulièrement à ceux si actifs ici smile.gif )



Ce message a été modifié par BoumBoumBoum - 7 Feb 2017, 16:07.


--------------------
Mac Pro 1.1 XEON DualCore 2 x 2,66
4 DD int (250-250-250-500 Go) -1 DD ext (1T)
Nvidia geForce 7300GT 256 Mb
6 Go DDR2 FB-DIMM
Cinema display HD Apple 30'
OS 10.7.5 (11G63), Adobe CS5.1, FinalCut 10.0.8
DEBIAN 8.7.1 i386
Go to the top of the page
 
+Quote Post
BoumBoumBoum
posté 7 Feb 2017, 16:35
Message #11


Nouveau Membre


Groupe : Membres
Messages : 26
Inscrit : 28 Feb 2016
Lieu : Manneken-Pis City
Membre no 198 206



Bon, j'ai trouvé cela :

https://discussions.apple.com/thread/5132196
et
http://forum.macbidouille.com/index.php?sh...=version+debian

Pour moi c'es plutôt compliqué de m'y retrouver....

J'ai aussi tenté de "flash le .iso sur la clef par :
Unetbottin,
mais il crache au démarrage.
Exception Type: EXC_BAD_ACCESS (SIGBUS)
Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000000000000

(compatibilité avec X.7 ?)
J'ai bien une version amd64 de Debian.

pffff


--------------------
Mac Pro 1.1 XEON DualCore 2 x 2,66
4 DD int (250-250-250-500 Go) -1 DD ext (1T)
Nvidia geForce 7300GT 256 Mb
6 Go DDR2 FB-DIMM
Cinema display HD Apple 30'
OS 10.7.5 (11G63), Adobe CS5.1, FinalCut 10.0.8
DEBIAN 8.7.1 i386
Go to the top of the page
 
+Quote Post
BoumBoumBoum
posté 7 Feb 2017, 17:32
Message #12


Nouveau Membre


Groupe : Membres
Messages : 26
Inscrit : 28 Feb 2016
Lieu : Manneken-Pis City
Membre no 198 206



Pour suivre :

j'ai donc tenté la conversion / gravure de l'iso en .cdr
cf : https://discussions.apple.com/thread/5132196

Gravure OK.
Mais disque non reconnu par OS X.7
Restart +"C" >>
écran noir avec :
1
2
Select CD_ROM Boot type : -

Je ne sais rien écrire au clavier.
Ce qui nous ramène à
http://forum.macbidouille.com/index.php?sh...view=getnewpost
#8
Restart + option >>
-fait apparaitre un disque Windows
puis comme suite comme si dessus.

Pour le moins j'espère que cela éclaire votre lanterne, moi pas.





--------------------
Mac Pro 1.1 XEON DualCore 2 x 2,66
4 DD int (250-250-250-500 Go) -1 DD ext (1T)
Nvidia geForce 7300GT 256 Mb
6 Go DDR2 FB-DIMM
Cinema display HD Apple 30'
OS 10.7.5 (11G63), Adobe CS5.1, FinalCut 10.0.8
DEBIAN 8.7.1 i386
Go to the top of the page
 
+Quote Post
BoumBoumBoum
posté 7 Feb 2017, 18:57
Message #13


Nouveau Membre


Groupe : Membres
Messages : 26
Inscrit : 28 Feb 2016
Lieu : Manneken-Pis City
Membre no 198 206



re, re , et re

et pour vous ennuyer encore, je n'ai pas encore trouvé le moyen d'installer le Debian sur un disque virtuel, qui se trouverait sur ce deuxième disque ?
Peut-êrte trop usé et frustré de tant d'échecs, je ne trouve pas de liens.

Même si je trouve ridicule de faire tourner deux OS en même temps quand cela n'a aucune utilité.
Bien entendu mon rêve est de pouvoir faire les deux, en OS unique comme en virtualisé sur OS X

Pffff

merci de votre lecture


--------------------
Mac Pro 1.1 XEON DualCore 2 x 2,66
4 DD int (250-250-250-500 Go) -1 DD ext (1T)
Nvidia geForce 7300GT 256 Mb
6 Go DDR2 FB-DIMM
Cinema display HD Apple 30'
OS 10.7.5 (11G63), Adobe CS5.1, FinalCut 10.0.8
DEBIAN 8.7.1 i386
Go to the top of the page
 
+Quote Post
blueG3
posté 8 Feb 2017, 23:56
Message #14


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 3 735
Inscrit : 20 Nov 2001
Lieu : vitry sur seine (94)
Membre no 1 346



bonsoir ,
question utile , as tu simplement testé d'autres images isos sur clé USB ( 32 ou 64 bits )
et qui auraient réussi à démarrer ?

autre point concernant les clé USB:
-normalement os X ne les reconnait pas , il faut toujours ignorer dans ce cas la clé
-DiskUtil devrait afficher les partitions sans HFS

certaines clés peuvent être hybride pour gérer le démarrage bios/EFI , dans ce cas le menu informe souvent si c'est EFI

essaye avec des iso 32bits , si au moins tu parviens à afficher l'icone de laclé pour démarrage , cela serait pas plus mal.
il faut toujours faire un reset PRAM pour etre sur de ne pas avoir
- un DD de demarrage qui contient HFS+ ET un os X bootable

sinon il va scanner tous les périphériques et éliminer ceux qui respectent pas ce critère , d'ou un démarrage avec Alt

proposition : essaye linuxmint Xfce 32 bits ou manjaro Xfce 32 bits si le live / install démarre
je pense que dans l'immédiat le 64 bits ne peux pas demarrer

essaye aussi coté Ubuntu
http://old-releases.ubuntu.com/releases/14.04.2/

le but étant à partir de la première iso qui se lance d'avoir un début installé avec Grub

Ce message a été modifié par blueG3 - 9 Feb 2017, 00:12.


--------------------
macpro 2008 quad core +8Go + 8800GT merci Nvidia & Apple pour la qualité et le choix de la carte! => ATI 5770 Apple + 2 DD WD 640Go + 2 SSD M4 Crucial 512Go(Raid 0) et Snow Leopard 10.6.8 + LG IPS235 flatron + Manjaro Linux sur DD interne - 16.10 xfce
Desktop - CPU : Intel® i7-6700K @ 4,2GHz - RAM 16 Go - CM: Gygabyte Z170X-UD5-TH CG : GeForce GTX 970- Audio: Intel® Sunrise Point-H HD Manjaro 16.10 xfce
Go to the top of the page
 
+Quote Post
BoumBoumBoum
posté 11 Feb 2017, 17:46
Message #15


Nouveau Membre


Groupe : Membres
Messages : 26
Inscrit : 28 Feb 2016
Lieu : Manneken-Pis City
Membre no 198 206



MESSAGE ÉVOLUTIF

Blue G3

Châpo et merci !!

J'avais déjà tâté du Ubuntu il y a un an, j'ai donc un peu fureté, à partir de tes remarques et conseils.

J'ai fini par trouver cela (dernière version du Debian) :
http://cdimage.debian.org/debian-cd/8.7.1/multi-arch/iso-dvd/

Citation
The files in this directory are designed to work on both 32-bit and 64-bit PCs (i386 and amd64)
.

et suis arrivé à bon port, il tourne !!!
Il est donc fort probable que cela tourne en 32 bits.

Merci à tout ceux qui ont suivi, et aidé dans mes différents posts !!

Pour les membres qui se trouveraient dans la même difficulté, je fais un petit récapitulatif
INSTALLER UN DEBIAN SUR UN DEUXIEME DISQUE DUR, SUR UN MACPRO ANCIEN

Pour une meilleure lecture :
en bleu, les étapes principales
en vert, mes édits successifs
en rouge, messages importants
EN BRUN MES QUESTIONS EN COURS

EDIT : quelques source
Utilisation de la commande "man" (manuel) dans terminal :
Support Apple : "man"

Utilisation de "dd" (10.9)
ici "Support Apple ; "dd"
- téléchargez le .iso


ici le Debian
- sous réserve de changement d'adresse suite à de nouvelles versions
> téléchargez l'iso (3,5 Go)
>le MD5SUMS

- vérifiez le checksum sous 'Terminal"

EDIT : pour éviter de vous mélanger les pinceaux éjectez CD, DVD et autres clef USB autres que celle qui vous servira à l'install

- flachez l'.iso sur une clef USB (4Go min pour la version du jour) :

lancer "Utilitaire disque"
> formatez (effacez) le contenu de votre clef
> prenez note du disque sur lequel vous désirez installer votre Linux :
>> taille, nom (celui que vous lui avez attribué), fabriquant et n° de série, partitionnement, etc... <<
Une mauvaise gestion des HD c'est courir à la catastrophe


lancez "Terminal"
- pour copier l'.iso sur une clé USB , on utilise la commande dd if vers of
-attention il ne faut absolument pas se tromper sur l'unité cible , dd a pour surnom destruction disque.
Code
sudo diskutil list

> la liste de tous DD , et de l'USB apparaît
- prenez note de toutes les données DD (tailles, partitions)
- prenez note du n° de votre cfef [/dev/diskn] (n = n°)

> demontage logique
Code
sudo diskutil UnmountDisk /dev/diskn

- " ignorez" lorsque X10 vous demande de formater la clef USB
>puis copie de l'.iso
- pour "<chemin..>" faites un glissez-déposez de votre .iso
- "n" étant votre n° de disque cible (USB où flasher le Debian)
Code
sudo dd if=<chemin/nom.iso> of=/dev/diskn bs=2m

EDIT : soyez patients ! Cela à duré pas loin d'une heure chez moi, et rien n'est visible dans "Terminal" avant la fin du processus.


Installation du Linux
Nettoyez la PRAM et démarrez sur la cléf
- redémarrer avec "POMME" + "ALT" + "p" +"r"
- attendez 3 "BOING", relâchez
- puis enfoncez "ALT"
> Apparaissent tous les disques de votre machine

Lancez l'installation
> sur mon Mac, en plus des disques habituels (MacOs..), apparaissent deux disques "EFI" (points de montage)
- j'ai choisi le plus à gauche
- coup de bol, c'était la version i386 compatible avec mes processeurs (Xenon)
- référez vous à la Docu Debian pour l'install

NOTEZ CEPENDANT :
>lors de la création des partitions (c'est à dire aussi le choix du disque cible)
> outil "partman"
- choisissez "Manual"
- puis sélectionnez votre disque cible (vous avez vos notes antérieures)
> choix du mode de partition :
EDIT : c'est à ce stade que le choix de chiffrement doit se faire, il ne pourra se faire dans Debian même
- perso, j'ai choisi, partition assistée
- puis partitions /home/var/ .... séparées
>à "choix de l'environnement de bureau"
- j'ai choisi "bureau Debian" (ici, pas de soucis avec)
EDIT : c'est donc "Gnome"
>> fin de l'Installation

Les deux systèmes tournent.

A chaque démarrage de OSX, une alerte appariait, "disque illisible " >> choisissez "IGNORER"
En effet, le format de fichiers de Linux est illisible par Mac.

EDIT : ne PAS préciser le disque de démarrage par défaut sous OS X (Préférences système)

EDIT :
chez moi :
• le démarrage par défaut se fait sous Linux
RM : toutes les partition de démarrage EFI sont en Fat32, ce qui permet à la machine de monter dessus
• démarrer sous "ALT" pour lancer OSX
RM : alors EFI cherche les partitions bootables avec un OSX et Hfs+ (ainsi que DVD et CD en iso9660)
>>Ce n'est pas toujours le cas (voir message #18) <<


EDIT : sous Debian avant le choix des sessions
-se lance "Grub" qui vous permet
> soit de poursuivre le chargement de Debian
> soit de redémarrer sur OSX
NB : chez moi, il n'apparaissait qu'une fraction de seconde, depuis que j'ai enfoncé la flèche vers le bas (pour une sélection) lors de son apparition, à chaque chargement, Grub me laisse tout loisir de faire ma sélection

EDIT (évolutif) :
- j'ai donc tenté de mettre un Bootloader dans le ventre du MacPro
>"rEFInd" bin-0.10.4 ici

-il a fonctionné une fois (souris non active)
- depuis rien ...
- ou quelques blocage sous "Alt"...

Une question de version du rEFInd, ou autre problème ?
>> ses messages à l'install

Fichier joint  CPT_refind_install.jpg ( 36 Ko ) Nombre de téléchargements : 4

L’arborescence des partitions me semble correcte :
Fichier joint  CPT_diskutil_list.jpg ( 96.3 Ko ) Nombre de téléchargements : 3

Autre question :
- sous Debian, le clavier numérique n'est pas reconnu (clavier Apple)





si vous avez des remarques, je puis compléter ce "how to"

Ce message a été modifié par BoumBoumBoum - 17 Feb 2017, 19:58.


--------------------
Mac Pro 1.1 XEON DualCore 2 x 2,66
4 DD int (250-250-250-500 Go) -1 DD ext (1T)
Nvidia geForce 7300GT 256 Mb
6 Go DDR2 FB-DIMM
Cinema display HD Apple 30'
OS 10.7.5 (11G63), Adobe CS5.1, FinalCut 10.0.8
DEBIAN 8.7.1 i386
Go to the top of the page
 
+Quote Post
baron
posté 11 Feb 2017, 18:11
Message #16


Macbidouilleur d'Or !
*****

Groupe : Modérateurs
Messages : 10 029
Inscrit : 22 Jul 2004
Lieu : Louvain-la-Neuve (Gaule Gelbique)
Membre no 21 291



Merci pour le récapitulatfif. thumb.gif

Editus moderatus : je joins tes deux sujets…

Citation (BoumBoumBoum @ 11 Feb 2017, 17:46) *
Merci à tout ceux qui ont suivi, et aide dans mes différents posts !!



--------------------
MacBook Pro 15’’ Core i5 2.53 GHz, 4 Go/500 Go – Mac OSX 10.6.8
MacOS 9.1 — G3 beige de bureau, rev.1 @ 233MHz, 288 Mo/4Go + carte PCI IDE/ATA Tempo 66 Acard 6260 avec HD interne Maxtor 80 Go + graveur interne CDRW/DVD LG GCC-4520B + tablette A4 Wacom UD-0608-A + LaCie ElectronBlueIV 19"+ modem Olitech SelfMemory 56k + HP ScanJet 6100C
Routeur/modem ADSL Trendnet TW100-BRM504 + HP LaserJet 4000 N
¶ La recherche dans MacBidouille vous paraît obscure ? J'ai rédigé une proposition de FAQ. Le moteur logiciel a un peu changé depuis mais ça peut aider quand même.
Les corsaires mettent en berne…


Firefox en occitan…
Go to the top of the page
 
+Quote Post
BoumBoumBoum
posté 12 Feb 2017, 13:10
Message #17


Nouveau Membre


Groupe : Membres
Messages : 26
Inscrit : 28 Feb 2016
Lieu : Manneken-Pis City
Membre no 198 206



Citation (baron @ 11 Feb 2017, 19:11) *
Editus moderatus : je joins tes deux sujets…


Bon tu ne vas pas m'arracher les oreilles, wink.gif
cela partait tellement dans toutes les directions : USB ou disque, distribution, amd ou i386, .iso ou.cdr , version Debian, rEFIt ou rEFInd,...
De devoir apprendre sur le tas....
Il y a un an, (cf :anciens posts) j'avais, échecs après échecs, abandonné de guerre lasse.
De tout reprendre maintenant, Bingo !

EDIT : bonjour à LLN !
On lui met quoi comme titre ?
- Debian sur un ancien MacPro et deuxième HD
- résumé en #15

Je te laisse la main.
smile.gif

Ce message a été modifié par BoumBoumBoum - 12 Feb 2017, 15:11.


--------------------
Mac Pro 1.1 XEON DualCore 2 x 2,66
4 DD int (250-250-250-500 Go) -1 DD ext (1T)
Nvidia geForce 7300GT 256 Mb
6 Go DDR2 FB-DIMM
Cinema display HD Apple 30'
OS 10.7.5 (11G63), Adobe CS5.1, FinalCut 10.0.8
DEBIAN 8.7.1 i386
Go to the top of the page
 
+Quote Post
thblt
posté 13 Feb 2017, 17:26
Message #18


Nouveau Membre


Groupe : Membres
Messages : 6
Inscrit : 6 Oct 2015
Membre no 196 700



Merci pour le tutorial, quelques remarques,

Citation
- notez l'info : /dev/diskn de votre disque où installer le Linux ("n"= n°)
- notez l'info : /dev/diskn de la clé USB


La première étape est inutile est rend les suivantes ambigues:

- Toutes les opérations suivantes (démontage et copie avec dd) se font vers la clef. Ça serait chouette de le préciser, un dd mal maîtrisé étant une machine à catastrophes;
- Il est inutile de noter le numéro du disque sur lequel sera installé Linux, parce qu'absolument rien ne garantit que la numération sera la même dans l'installeur. C'est aussi un coup à faire des catastrophes. Il faut identifier le disque autrement, d'une manière ou d'une autre (par sa capacité, sa marque, son modèle, son schéma de partitions... n'importe quoi qui le rende unique)
- Un détail: la commande, c'est "dd", pas "DD". Possible que les deux marchent sous OSX (je n'en ai plus aucun d'installé, et ne peux pas tester), mais si le système de fichiers est sensible à la casse, "DD" ne marchera pas.

On peut aussi noter que:

- C'est lors de la création des partitions qu'il faut choisir le chiffrement disque entier (“FileVault”) si on souhaite en bénéficier. Contrairement à ce qui se fait sur OSX, ça ne peut pas se faire a posteriori (enfin si, mais c'est la croix et la bannière, vaut mieux s'abstenir)

Sinon, je suis tout à fait admiratif du fait que le système démarre Debian par défaut, et OSX en secondaire. Dans mon expérience, les EFI Apple tendent à chercher désespérément un truc qui ressemble à OSX et à se rabattre, avec un air un peu triste et un petit gémissement à vous fendre le cœur sur ce qu'il reste seulement si vraiment, vraiment, ils n'en trouvent pas. Mon Mac Pro (2008, Debian en système unique) préfère démarrer sur une clé USB s'il la trouve bootable que sur le disque principal, c'est dire.
Go to the top of the page
 
+Quote Post
baron
posté 13 Feb 2017, 20:45
Message #19


Macbidouilleur d'Or !
*****

Groupe : Modérateurs
Messages : 10 029
Inscrit : 22 Jul 2004
Lieu : Louvain-la-Neuve (Gaule Gelbique)
Membre no 21 291



Citation (BoumBoumBoum @ 12 Feb 2017, 13:10) *
EDIT : bonjour à LLN !
On lui met quoi comme titre ?
- Debian sur un ancien MacPro et deuxième HD
- résumé en #15

Je te laisse la main.
smile.gif

Voilà qui est fait.

Bonjour à Bruxelles ! smile.gif


--------------------
MacBook Pro 15’’ Core i5 2.53 GHz, 4 Go/500 Go – Mac OSX 10.6.8
MacOS 9.1 — G3 beige de bureau, rev.1 @ 233MHz, 288 Mo/4Go + carte PCI IDE/ATA Tempo 66 Acard 6260 avec HD interne Maxtor 80 Go + graveur interne CDRW/DVD LG GCC-4520B + tablette A4 Wacom UD-0608-A + LaCie ElectronBlueIV 19"+ modem Olitech SelfMemory 56k + HP ScanJet 6100C
Routeur/modem ADSL Trendnet TW100-BRM504 + HP LaserJet 4000 N
¶ La recherche dans MacBidouille vous paraît obscure ? J'ai rédigé une proposition de FAQ. Le moteur logiciel a un peu changé depuis mais ça peut aider quand même.
Les corsaires mettent en berne…


Firefox en occitan…
Go to the top of the page
 
+Quote Post
blueG3
posté 13 Feb 2017, 23:22
Message #20


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 3 735
Inscrit : 20 Nov 2001
Lieu : vitry sur seine (94)
Membre no 1 346



alors je dirai qu'il est Normal de pouvoir démarrer sur autre chose que HFS+ :
1 - la partition EFI est toujours en Fat32 , ce qui permet de pouvoir démarrer dessus pour la suite
2 - la seule chose qu'il ne faut pas faire , c'est soit de préciser le disque de démarrage par défaut sous os x ,
soit d'oublier de démarrer sur Alt , car EFI va alors chercher uniquement les partition bootable avec un systeme os x et Hfs+
3 - par exemple les CD ou DVD qui si sont en iso9660 ...

si j'oublie Alt au démarrage , il va démarrer sur la partition os X.

si je démarre sur le linux , Grub montre la partition os X , tant qu'il y a pas le moindre volume logique créé , sinon il n'est pas géré par linux.


--------------------
macpro 2008 quad core +8Go + 8800GT merci Nvidia & Apple pour la qualité et le choix de la carte! => ATI 5770 Apple + 2 DD WD 640Go + 2 SSD M4 Crucial 512Go(Raid 0) et Snow Leopard 10.6.8 + LG IPS235 flatron + Manjaro Linux sur DD interne - 16.10 xfce
Desktop - CPU : Intel® i7-6700K @ 4,2GHz - RAM 16 Go - CM: Gygabyte Z170X-UD5-TH CG : GeForce GTX 970- Audio: Intel® Sunrise Point-H HD Manjaro 16.10 xfce
Go to the top of the page
 
+Quote Post
BoumBoumBoum
posté 14 Feb 2017, 09:28
Message #21


Nouveau Membre


Groupe : Membres
Messages : 26
Inscrit : 28 Feb 2016
Lieu : Manneken-Pis City
Membre no 198 206



Citation (blueG3 @ 13 Feb 2017, 23:22) *
alors je dirai qu'il est Normal de pouvoir démarrer sur autre chose que HFS+ :
1 - la partition EFI est toujours en Fat32 , ce qui permet de pouvoir démarrer dessus pour la suite
2 - la seule chose qu'il ne faut pas faire , c'est soit de préciser le disque de démarrage par défaut sous os x ,
soit d'oublier de démarrer sur Alt , car EFI va alors chercher uniquement les partition bootable avec un systeme os x et Hfs+
3 - par exemple les CD ou DVD qui si sont en iso9660 ...

si j'oublie Alt au démarrage , il va démarrer sur la partition os X.

si je démarre sur le linux , Grub montre la partition os X , tant qu'il y a pas le moindre volume logique créé , sinon il n'est pas géré par linux.


merci !!

de ts lumières !
Je vais devoir me pencher un peu plus sur Grub !
J'édite

Ce message a été modifié par BoumBoumBoum - 14 Feb 2017, 09:32.


--------------------
Mac Pro 1.1 XEON DualCore 2 x 2,66
4 DD int (250-250-250-500 Go) -1 DD ext (1T)
Nvidia geForce 7300GT 256 Mb
6 Go DDR2 FB-DIMM
Cinema display HD Apple 30'
OS 10.7.5 (11G63), Adobe CS5.1, FinalCut 10.0.8
DEBIAN 8.7.1 i386
Go to the top of the page
 
+Quote Post
BoumBoumBoum
posté 15 Feb 2017, 07:44
Message #22


Nouveau Membre


Groupe : Membres
Messages : 26
Inscrit : 28 Feb 2016
Lieu : Manneken-Pis City
Membre no 198 206



Thb,

Citation (thblt @ 13 Feb 2017, 17:26) *
Merci pour le tutorial, quelques remarques,

j'espère avoir fait les corrections nécessaires :
• Pour la question de n° des DD, je venais de découvrir un peu tard, que l'ordre de montage changeait après chaque boot
• Pour les données du DD cible( par sa capacité, sa marque, son modèle, son schéma de partitions etc...), on les retrouve dans l'étape "Utilitaire de disque"
• Quant au n° de cible USB, ne quittant ni session ni l'App UtilitaireDisque; elle ne change pas
• Oui chez moi "DD" passe, mais je suis en Htfs+ (sans plus, même un DiskUtil passe)/

Merci de ton aide cool.gif

Ce message a été modifié par BoumBoumBoum - 15 Feb 2017, 07:46.


--------------------
Mac Pro 1.1 XEON DualCore 2 x 2,66
4 DD int (250-250-250-500 Go) -1 DD ext (1T)
Nvidia geForce 7300GT 256 Mb
6 Go DDR2 FB-DIMM
Cinema display HD Apple 30'
OS 10.7.5 (11G63), Adobe CS5.1, FinalCut 10.0.8
DEBIAN 8.7.1 i386
Go to the top of the page
 
+Quote Post
BoumBoumBoum
posté 15 Feb 2017, 08:20
Message #23


Nouveau Membre


Groupe : Membres
Messages : 26
Inscrit : 28 Feb 2016
Lieu : Manneken-Pis City
Membre no 198 206



Je suis toujours coincé avec rEFInd, et il me fait des caprices (voir #15)
des idées ?
Ne serait-ce que pouvoir le désinstaller, afin de descendre de version, ou rEFIt

merci


--------------------
Mac Pro 1.1 XEON DualCore 2 x 2,66
4 DD int (250-250-250-500 Go) -1 DD ext (1T)
Nvidia geForce 7300GT 256 Mb
6 Go DDR2 FB-DIMM
Cinema display HD Apple 30'
OS 10.7.5 (11G63), Adobe CS5.1, FinalCut 10.0.8
DEBIAN 8.7.1 i386
Go to the top of the page
 
+Quote Post
thblt
posté 15 Feb 2017, 13:48
Message #24


Nouveau Membre


Groupe : Membres
Messages : 6
Inscrit : 6 Oct 2015
Membre no 196 700



Citation (BoumBoumBoum @ 15 Feb 2017, 08:20) *
Je suis toujours coincé avec rEFInd, et il me fait des caprices (voir #15)
des idées ?
Ne serait-ce que pouvoir le désinstaller, afin de descendre de version, ou rEFIt


La seule fois où j'ai utilisé refind, c'était avec ArchLinux, en monoboot, sur mon MacPro 3,1 (donc pas la même archi du tout). Mais ça marchait très bien, y compris la détection à chaud des périphériques de démarrage. Mais je n'ai que des machines 64 bits avec des systèmes 64 bits et un EFI 64 bits. Si je ne dis pas de conneries, le MacPro 1,1 est une architecture 64 bits avec un EFI 32 bits. Il me *semble* que Refind ne peut lancer qu'une architecture identique à la sienne. Autrement dit, ReFind sur un EFI 32 bits ne peut démarrer qu'un OS 32 bits. Dans un terminal Linux, que dit "uname -a" ?

Autre question: quel est l'intérêt de refind si de toutes façons tout démarre correctement, et quel intérêt de le désinstaller? Les systèmes de démarrage Apple relevant de la plus noire des magies noires, j'ai tendance à penser que "If it ain't broken, don't fix it".

Si vraiment vous voulez démarrer sur ReFind, vous pouvez essayer:

1. de le réinstaller, depuis OSX de préférence, avec le SIP désactivé (= mode rootless). Je pense qu'il faudra le réinstaller à chaque mise à jour d'OSX, mais pas certain.
2. D'éventuellement “bénir” sa partition avec bless, toujours depuis OSX. Mais dans tous les cas, il ne pourra pas démarrer un OS 32 bits. (et de toutes façons, je pense qu'il le fait tout seul)

Sinon pour aider plus avant, il faudrait le schéma de partition complet (fdisk -l depuis Linux) avec le détail des diverses partitions EFI. Il y a aussi une discussion ici à propos d'un MacPro 2,1 donc pas essentiellement différent, me semble.
Go to the top of the page
 
+Quote Post
BoumBoumBoum
posté 17 Feb 2017, 16:12
Message #25


Nouveau Membre


Groupe : Membres
Messages : 26
Inscrit : 28 Feb 2016
Lieu : Manneken-Pis City
Membre no 198 206



Citation (thblt @ 15 Feb 2017, 13:48) *
Autre question: quel est l'intérêt de refind si de toutes façons tout démarre correctement, et quel intérêt de le désinstaller? Les systèmes de démarrage Apple relevant de la plus noire des magies noires, j'ai tendance à penser que "If it ain't broken, don't fix it".


merci de votre réponse !
Parfaitement sur le c...
L'EFi 32 bits sur une machine 64 serrait (?) donc la réponse à toutes mes galères !

A éviter les interminables messages, j'ai donc omis quelques précisions, les voici :
• REFInd à bien fonctionné une fois (après l'install).
• De mes "expériences" de mi-2016 il devait encore traîner un rEFInd, version antérieure (il y plus d'un an, je n'en sais plus trop où j'en étais).
• Au démarrage du Linux, un message en faisant mention apparaît fugacement quelque fois (booting rEfFInd me semble-t-il (?).
• Il m'arrive de me retrouver au démarrage +"ALT", dans l'impossibilité de lancer OSX (s/ fenêtre des HD), pour pouvoir le relancer, je dois forcer l'arrêt (bouton de mise en marche), laisser Debian se charger, puis redémarrer sous "ALT'.
Tout cela ne respire pas le propre (et j'ai ma part de responsabilité).

•D'autre part, j'ai toujours des vieux programmes Nikon (argentique) à faire tourner sur du Win (récup. données de prise de vues, édition de profils, etc..).
Donc un Win à installer ou faire tourner en émulation.
• Dans mon travail, même si ce n'est pas ma spécialité, et dans le cadre de "Coopération avec les Pays en développement", je me trouve à devoir installer, ou "suivre" des portables sur place.
Si Linux est la solution logique (coût et aspect politique), Win devient difficilement évitable (tout au moins pour tester les compatibilités de formats de documents, équivalences des programmes, pilotes etc...).
Emulation ou triple-boot devient une grosse question.

Toujours à vous faire part de mon admiration pour l'investissement, la qualité de vos messages (j'en apprend beaucoup, et cela m'ouvre des portes), j'édite ici les résultats, de vos procédures proposées.

EDIT :

- d'après mes lectures, le mode "rootless" n'est pas accessible sous OS X.7
sauf à faire ceci : enable-root
- mon rEFInd c'est remis en fonction pour +- 8 Restart ou Start, puis plus rien.
- mon "Grub" m'a tout l'air d'être capricieux ( 2.02 beta 2)
> si je lui demande de lancer OS X en 64 bits, l'ordi plante (je n'ai pas relevé le message)
> si je lui demande de lancer OS X en 32 bits, apparait "64 bits enable, puis le ce dernier se démarre

Pour tes questions
>"uname -a"< donne :
@debian:~$ uname -a
Linux debian 3.16.0-4-686-pae #1 SMP Debian 3.16.39-1 (2016-12-30) i686 GNU/Linux
> fdisk -l donne :
Fichier joint  DB__fdisk__l.jpg ( 148.88 Ko ) Nombre de téléchargements : 2


Ce message a été modifié par BoumBoumBoum - 17 Feb 2017, 20:00.


--------------------
Mac Pro 1.1 XEON DualCore 2 x 2,66
4 DD int (250-250-250-500 Go) -1 DD ext (1T)
Nvidia geForce 7300GT 256 Mb
6 Go DDR2 FB-DIMM
Cinema display HD Apple 30'
OS 10.7.5 (11G63), Adobe CS5.1, FinalCut 10.0.8
DEBIAN 8.7.1 i386
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 utilisateur(s) sur ce sujet (1 invité(s) et 0 utilisateur(s) anonyme(s))
0 membre(s) :

 



Nous sommes le : 23rd February 2017 - 21:57