IPB

Bienvenue invité ( Connexion | Inscription )

 
Reply to this topicStart new topic
> changer le php utilisé par apache... (Os X Server 10.11), (plusieurs versions installées, semble t'il ??)
Options
tojar
posté 25 Jun 2017, 13:28
Message #1


Macbidouilleur de vermeil !
****

Groupe : Membres
Messages : 864
Inscrit : 6 May 2004
Lieu : under ze couette
Membre no 18 500



Hello

voilà mon souci: j'ai un Mac Os El Capitan Server...

je souhaite configurer un NextCloud dessus... je l'ai déjà fait moult fois sans le moindre souci sous Sierra, sauf que là: NextCloud me dit que j'utilise toujours php 5.5.38 ...

sauf que j'ai upgrade mon php en version 7.1 via cli et, ensuite, devant le resultat sans effet, via homebrew.

D'ailleurs, php -v me renvoie bien que je suis sous php 7.1 ... et est bien localisé au bon endroit validé par homebrew (/usr/local/bin/ qui renvoie bien dans /usr/local/Cellar/php71 .. etc..)

mais NextCloud continue à me dire que je n'ai que php 5.5.38 et refuse donc de s'installer...

J'ai viré le nextcloud et réinstallé... même résultat.


et évidemment, faire une mise à jour en Sierra de cette machine n'est pas à l'ordre du jour....

au final: help !

Ce message a été modifié par tojar - 25 Jun 2017, 14:52.


--------------------
<= attention, cet individu est énervant, exécrable, hautain, prétentieux, professoral, d'un humour douteux et, de surcroit, disciple de courants de pensées qui sont dangeureuses pour notre bonne société francaise. hop.
Go to the top of the page
 
+Quote Post
Jaypee
posté 26 Jun 2017, 21:04
Message #2


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 2 315
Inscrit : 29 Aug 2002
Membre no 3 340



N'importe quel utilisateur d'un sytème sous Unix (et macOS est un Unix) "trouve" ses fichiers grâce à une variable d'environnement appelée PATH qui contient la liste des endroits où il faut regarder. Selon qu'elle contient tel ou tel répertoire, l'un avant l'autre, ou dans l'ordre inverse, la recherche aboutira dans différents endroits pour différents utilisateurs.

- Quelle identité est utilisée par NextCloud? comment son environnement et son PATH sont-ils configurés?
- Au niveau système il y a aussi une configuration partagée par tous les utilisateurs, un PATH hérité du système.
- Lorsqu'un utilisateur se connecte sur son compte, implicitement ou explicitement, un script de démarrage est exécuté et peut modifier le PATH. .profile, .login, .bashrc...

Donc, il faut examiner toutes les variations possibles et toutes les customisations. Chaque Shell a son propre script de démarrage ksh, zsh, bash, ont tous les trois des scripts différents.

Voilà quelques pistes de recherche.

J-P
Go to the top of the page
 
+Quote Post
No6
posté 9 Jul 2017, 13:10
Message #3


Oui ?
*****

Groupe : Membres
Messages : 3 708
Inscrit : 24 Jun 2003
Lieu : BZH
Membre no 8 224



Depuis que j'ai découvert Docker, j'en ai fini avec les problèmes de versionning, de machines virtuelles, et autres trucs à bidouiller dans le système et qui m'éloignent de mon activité principale (le codage).

D'ailleurs NextCloud est disponible directement sur Docker => https://hub.docker.com/_/nextcloud/ alors pourquoi se prendre la tête ??

En plus ils énormément simplifié l'interface pour les mac >= yosemite https://www.docker.com/docker-mac


un vieux tuto de présentation : https://www.grafikart.fr/tutoriels/docker/docker-intro-634 (mais toujours bon à prendre)


--------------------
"Je sais que vous croyez comprendre ce que vous pensez que j'ai dit, mais je ne suis pas sûr que vous réalisiez que ce que vous avez entendu n'est pas ce que je pense."
(Alan Greenspan)
Go to the top of the page
 
+Quote Post
tojar
posté 26 Jul 2017, 14:42
Message #4


Macbidouilleur de vermeil !
****

Groupe : Membres
Messages : 864
Inscrit : 6 May 2004
Lieu : under ze couette
Membre no 18 500



Citation (Jaypee @ 26 Jun 2017, 22:04) *
N'importe quel utilisateur d'un sytème sous Unix (et macOS est un Unix) "trouve" ses fichiers grâce à une variable d'environnement appelée PATH qui contient la liste des endroits où il faut regarder. Selon qu'elle contient tel ou tel répertoire, l'un avant l'autre, ou dans l'ordre inverse, la recherche aboutira dans différents endroits pour différents utilisateurs.

- Quelle identité est utilisée par NextCloud? comment son environnement et son PATH sont-ils configurés?
- Au niveau système il y a aussi une configuration partagée par tous les utilisateurs, un PATH hérité du système.
- Lorsqu'un utilisateur se connecte sur son compte, implicitement ou explicitement, un script de démarrage est exécuté et peut modifier le PATH. .profile, .login, .bashrc...

Donc, il faut examiner toutes les variations possibles et toutes les customisations. Chaque Shell a son propre script de démarrage ksh, zsh, bash, ont tous les trois des scripts différents.

Voilà quelques pistes de recherche.

J-P


TOUS les tutos du net, sans exception, mène a ce problème... AUCUN ne le prends en compte. J'ai lu plus de 50 tutos, visité une 20 aine de forums, avec des milliers de gens sous os X avec le même souci...

tu peux upgrader ton php via homebrew ou via curl ou macport, ca mène systématiquement au même résultat: le php -v te dit 7.x mais le server continue à utiliser le php 5.x

J'ai soumis la question à un ami qui gère un des plus gros parc informatique d'autriche... il a posé la question à tout son réseau... et a fini par s'énerver avec un mail titrant "is there a php/dev guy without a big mouth here ?" ... ca te donne le ton. j'y croyais pas.

il est parfois précisé de modifier
~/.bash_profile
ou
~/.profile

en ajoutant dedans:
export PATH="$(brew --prefix homebrew/php/php71)/bin:$PATH"
(pour homebrew)

ou bien, comme le conseille le tuto de https://php-osx.liip.ch/ (globalement le plus référencé)
y ajouter:
export PATH=/usr/local/php5/bin:$PATH

aucun de ces cas ne fonctionnent, ni ne changent rien... et ce n'est pas spécifique à NextCloud, car un simple phpinfo renverra la meme info: php 5.x alors que le terminal donne php 7.x

et évidemment aucun moyen de questionner les créateurs des divers tutos: pour ce faire, il faut s'enregistrer sur moult bouzins et espérer une réponse... hypothétique.

(oui, je suis un peu sur les nerfs, au bout de plus de 10 jours à tourner en rond sur le sujet)

Citation (No6 @ 9 Jul 2017, 14:10) *
Depuis que j'ai découvert Docker, j'en ai fini avec les problèmes de versionning, de machines virtuelles, et autres trucs à bidouiller dans le système et qui m'éloignent de mon activité principale (le codage).

D'ailleurs NextCloud est disponible directement sur Docker => https://hub.docker.com/_/nextcloud/ alors pourquoi se prendre la tête ??

En plus ils énormément simplifié l'interface pour les mac >= yosemite https://www.docker.com/docker-mac


un vieux tuto de présentation : https://www.grafikart.fr/tutoriels/docker/docker-intro-634 (mais toujours bon à prendre)



hello

je déduis de ton message que ce truc est sympa... mais c'est pas super simple de bien comprendre, meme avec le tuto, en quoi ca va m'aider: c'est basé sur le principe de la machine virtuelle ?

[EDIT]: et une démonstration de plus du manque cruel de tests de nos jours... je télécharge Docker, le lance et ...: Incompatible CPU detected.
Docker requires a processor with virtualization capabilities.

Sur un mac pro 2011, ca la fous mauvaise... je n'ai aucun souci de virtualisation avec VM Ware ou autre... bref... encore du rêve.

Ce message a été modifié par tojar - 26 Jul 2017, 14:46.


--------------------
<= attention, cet individu est énervant, exécrable, hautain, prétentieux, professoral, d'un humour douteux et, de surcroit, disciple de courants de pensées qui sont dangeureuses pour notre bonne société francaise. hop.
Go to the top of the page
 
+Quote Post
No6
posté 26 Jul 2017, 16:15
Message #5


Oui ?
*****

Groupe : Membres
Messages : 3 708
Inscrit : 24 Jun 2003
Lieu : BZH
Membre no 8 224



Citation (tojar @ 26 Jul 2017, 15:42) *
Citation (No6 @ 9 Jul 2017, 14:10) *
Depuis que j'ai découvert Docker, j'en ai fini avec les problèmes de versionning, d...)



hello

je déduis de ton message que ce truc est sympa... mais c'est pas super simple de bien comprendre, meme avec le tuto, en quoi ca va m'aider: c'est basé sur le principe de la machine virtuelle ?

[EDIT]: et une démonstration de plus du manque cruel de tests de nos jours... je télécharge Docker, le lance et ...: Incompatible CPU detected.
Docker requires a processor with virtualization capabilities.

Sur un mac pro 2011, ca la fous mauvaise... je n'ai aucun souci de virtualisation avec VM Ware ou autre... bref... encore du rêve.



Bon, alors calmement...

1) Docker ce n'est pas de la virtualisation, c'est un systeme de conteneur que tu active ou désactive à ton gré.
Par exemple tu peux avoir un conteneur en PHP4, un autre en PHP5, et encore un autre en PHP7, avoir un autre conteneur avec MySQL dans une version ou une autre, Pareil si tu en veux une Base en Prosgre SQL, et même avoir un conteneur avec NodeJS...

Bref tu peux avoir des conteneur de tas de trucs, et tu active celui ou ceux que tu désire, selon tes besoins.
Docker se démerde pour ne pas dupliquer tout ce qui peut être en commun pour tes différents conteneurs, il est capable de lier 2 conteneurs entre eux, ex: un conteneur gérant une base SQL avec un autre conteneur gérant du PHP...

Au début c'est peu déroutant, mais on finit par s'y faire, et on comprends tres vite qu'on peut devenir le roi du monde avecc ce truc, avoir 3 versions de Linux, 4 types de SGBD, 3 versions de PHP avec les option qu'on désire, tester un CMS et passer à un autre
Et tout ça se passe assez rapidement...


2) Docker est basé sur des technos purement Linux, et donc ne fonctionne pas sur un Mac ou un PC de maniere directe.
Ca veux dire qu'il faut le faire fonctionner à l'intérieur d'une machine vituelle pour ces deux environnements.

Comme tu es sur un Mac, il y a 2 systemes de virtualisation tout prests avec Docker à l'intérieur, et tu dois choisir en fonction de la version de ton MAC OS.

3) tu n'a pas pris le temps de regarder le lien Grafikart que je t'ai donné, et qui explique très bien la marche à suivre pour utiliser Docker...

https://www.grafikart.fr/tutoriels/docker/docker-intro-634
il y a plusieurs tutos sur Docker sur ce site, et d'autre sur Youtube, c'est loin d'être un truc confidentiel ou une sorte de chimère comme tu veux le croire, c'est très largement utilisé, à tel point que Docker est en train de suplanter tout ce qui est virtualisation; j'ai cru comprendre que Microsoft allait "Implanter" Docker directement sous Windows 10, avec des librairies équivalentes à celles utilisées sous Linux, j'imagine??








--------------------
"Je sais que vous croyez comprendre ce que vous pensez que j'ai dit, mais je ne suis pas sûr que vous réalisiez que ce que vous avez entendu n'est pas ce que je pense."
(Alan Greenspan)
Go to the top of the page
 
+Quote Post
tojar
posté 26 Jul 2017, 17:11
Message #6


Macbidouilleur de vermeil !
****

Groupe : Membres
Messages : 864
Inscrit : 6 May 2004
Lieu : under ze couette
Membre no 18 500



j'ia téléchargé la version de Docker pour mac... et ca parle bien de virtualisation dans les infos et l'aide....


quoiqu'il en soit, il faut une machine après 2012 minimum dans les faits.


--------------------
<= attention, cet individu est énervant, exécrable, hautain, prétentieux, professoral, d'un humour douteux et, de surcroit, disciple de courants de pensées qui sont dangeureuses pour notre bonne société francaise. hop.
Go to the top of the page
 
+Quote Post
No6
posté 26 Jul 2017, 17:28
Message #7


Oui ?
*****

Groupe : Membres
Messages : 3 708
Inscrit : 24 Jun 2003
Lieu : BZH
Membre no 8 224



Citation (tojar @ 26 Jul 2017, 18:11) *
j'ia téléchargé la version de Docker pour mac... et ca parle bien de virtualisation dans les infos et l'aide....


quoiqu'il en soit, il faut une machine après 2012 minimum dans les faits.

quelle est ta version de mac os ?

Sur ton Mac pro tu dois avoir un Intel Core i5 ou i7, en principe c'est largement suffisant pour faire tourner virtual box avec Docker,

Et la virtualisation elle est juste pour Docker, ou plutôt pour un linux minimalisé à l’extrême pour Docker, et elle sera la seule et unique virtualisation utile, quelque soit le nombre de conteneurs que tu utilisera.


--------------------
"Je sais que vous croyez comprendre ce que vous pensez que j'ai dit, mais je ne suis pas sûr que vous réalisiez que ce que vous avez entendu n'est pas ce que je pense."
(Alan Greenspan)
Go to the top of the page
 
+Quote Post
No6
posté 26 Jul 2017, 18:50
Message #8


Oui ?
*****

Groupe : Membres
Messages : 3 708
Inscrit : 24 Jun 2003
Lieu : BZH
Membre no 8 224



Effectivement, il semblerai que la VM fournie par docker ne sois pas compatible avec les anciens mac dépourvu d'une gestion MMU...

https://forums.docker.com/t/fatal-error-inc...detected/9162/4

https://docs.docker.com/docker-for-mac/inst...ore-you-install

En revanche, et puisque tu écris que tu peux faire tourner sans problème VM Ware sur ta machine, dans ce cas tu devrai pouvoir utiliser VM Ware pour y faire tourner un Ubuntu ou tout autre Linux, dans lequel tu pourra installer Docker ??

https://pubs.vmware.com/fusion-5/index.jsp?...90DFAFC7F7.html




--------------------
"Je sais que vous croyez comprendre ce que vous pensez que j'ai dit, mais je ne suis pas sûr que vous réalisiez que ce que vous avez entendu n'est pas ce que je pense."
(Alan Greenspan)
Go to the top of the page
 
+Quote Post
audionuma
posté 27 Jul 2017, 07:15
Message #9


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 1 846
Inscrit : 27 Apr 2004
Membre no 18 176



Citation
aucun de ces cas ne fonctionnent, ni ne changent rien... et ce n'est pas spécifique à NextCloud, car un simple phpinfo renverra la meme info: php 5.x alors que le terminal donne php 7.x

Il semble donc que c'est ton serveur Apache qui ne charge pas la version désirée de php. Et Apache n'utilise pas le $PATH pour charger ses modules.

Je n'ai pas de Mac OS Server sous la main, mais sous Yosemite, le module libphp5.so du serveur Apache fourni par Apple est dans :
Code
/usr/libexec/apache2/

et le fichier de config httpd.conf est dans :
Code
/private/etc/apache2


Suggestion (sans garantie) :

- identifier le module libphp7.so produit par homebrew (le trouver dans ton disque, peut-être dans /usr/local/opt/php70/libexec/apache2/)
- le copier dans /usr/libexec/apache2/
- éditer httpd.conf, commenter la ligne qui charge php5 et remplacer par php7 :
Code
#LoadModule php5_module libexec/apache2/libphp5.so
LoadModule php7_module libexec/apache2/libphp7.so

- redémarrer Apache
- tester avec phpinfo()


--------------------
Membre du club des AIPBP (Anciens Inscrits Pas Beaucoup de Posts) Voir la liste
Go to the top of the page
 
+Quote Post
tojar
posté 28 Jul 2017, 23:34
Message #10


Macbidouilleur de vermeil !
****

Groupe : Membres
Messages : 864
Inscrit : 6 May 2004
Lieu : under ze couette
Membre no 18 500



Citation (audionuma @ 27 Jul 2017, 08:15) *
- le copier dans /usr/libexec/apache2/
- éditer httpd.conf, commenter la ligne qui charge php5 et remplacer par php7 :


Bon les emplacements ne sont pas exactement ceux là mais j'ai retrouvé aisément....

par contre, copier dans apache2, bah niet. Permission Denied, même via le terminal en SUDO !!!

j'ai déjà commenté/décommenté les bonnes lignes dans httpd.conf, mais je pense que le souci vient du fait qu'il devrait y avoir un libphp7.so dans apache2/ mais il n'y est pas... car en fait, meme en sudo, le système refuse ?!

P.S: je l'ai franchement réinstallé from scratch y'a deux jours... !!! depuis le site d'apple et même pas avec une clé usb d'install (qui aurait pu se corrompre)... je nage en pleine incompréhension.


--------------------
<= attention, cet individu est énervant, exécrable, hautain, prétentieux, professoral, d'un humour douteux et, de surcroit, disciple de courants de pensées qui sont dangeureuses pour notre bonne société francaise. hop.
Go to the top of the page
 
+Quote Post
Jaypee
posté 30 Jul 2017, 10:02
Message #11


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 2 315
Inscrit : 29 Aug 2002
Membre no 3 340



Le temps est venu de faire une revue par le menu des droits et permissions des répertoires et des fichiers:
Code
[jaypee:~]$ ls -ld /usr/libexec/apache2
drwxr-xr-x  110 root  wheel  3740 29 avr 02:29 /usr/libexec/apache2


Puis le contenu du répertoires:
Code
[jaypee:~]$ ls -l /usr/libexec/apache2
total 12592
-rw-r--r--  1 root  wheel     15103  7 fév 05:01 httpd.exp
-rwxr-xr-x  1 root  wheel  13059168 29 avr 02:29 libphp5.so
-rwxr-xr-x  1 root  wheel     23344 29 avr 02:27 mod_access_compat.so
-rwxr-xr-x  1 root  wheel     23104 29 avr 02:28 mod_actions.so
-rwxr-xr-x  1 root  wheel     32800 29 avr 02:29 mod_alias.so
...
-rwxr-xr-x  1 root  wheel     34928 29 avr 02:27 mod_watchdog.so
-rwxr-xr-x  1 root  wheel     46304 29 avr 02:28 mod_xml2enc.so

Comme on voit que root est le propriétaire et le mode du répertoire apache2 est 755.
Dans ce cas précis, il serait bon de devenir super user, dans d'autres cas ça peut être nocif, par exemple si root démarre un service appartenant à un utilisateur et crée des .log .tmp et autres fichiers de travail non modifiables par l'utilisateur propriétaire du service, donc prudence avec le changement en root, rarement indispensable:
Code
[jaypee:~]$ sudo su -
Password: <celui de jaypee>
MacMiniJP:~ root#


Il faut ajuster le propriétaire:
Code
chown root:wheel nom_de_fichier_avec_mauvais_propriétaire


Il faut ajuster le mode (droits et permissions): chaque caractère du mode est un bit: -rw-r--r-- = 0110100100 = 644 si on convertit de binaire à octal (on convertit par groupe de 3 bits, et sautant le tout premier -)

Pour rendre un fichier lisible par tous, mais remplaçable seulement par le propriétaire (le premier rw)
Code
chmod 644 fichier_lisible_par_tous_remplaçable_par_propriétaire


Les fichiers .so ont un mode -rwxr-xr-x = 0111101101 = 755 en octal, qui veut dire exécutable par tous, remplaçante par le propriétaire seulement.
Code
chmod 755 le_module_point_so_ajouté_éxécutable_par_tous_remplaçable_par_propriétaire


Avec ces contrôles de base on minimise les risques d' incohérence dans le modèle des permissions, cause fréquente des erreurs sous Unix.

J-P

Ce message a été modifié par Jaypee - 30 Jul 2017, 10:06.
Go to the top of the page
 
+Quote Post
tojar
posté 30 Jul 2017, 23:23
Message #12


Macbidouilleur de vermeil !
****

Groupe : Membres
Messages : 864
Inscrit : 6 May 2004
Lieu : under ze couette
Membre no 18 500



voui mais justement, même en sudo ou en étant root, la machine refuse que je puisse copier quoi que ce soit dans libexec/apache2 .....

alors que le dossier appartient bien au root et tout.... ainsi que le libphp7.so .....


--------------------
<= attention, cet individu est énervant, exécrable, hautain, prétentieux, professoral, d'un humour douteux et, de surcroit, disciple de courants de pensées qui sont dangeureuses pour notre bonne société francaise. hop.
Go to the top of the page
 
+Quote Post
Jaypee
posté 31 Jul 2017, 05:59
Message #13


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 2 315
Inscrit : 29 Aug 2002
Membre no 3 340



Il este la protection SIP d'Apple:
https://developer.apple.com/library/content...Protection.html
Depuis El Capitan les répertoires système sont protégés en écriture.

J-P
Go to the top of the page
 
+Quote Post
tojar
posté 3 Aug 2017, 01:12
Message #14


Macbidouilleur de vermeil !
****

Groupe : Membres
Messages : 864
Inscrit : 6 May 2004
Lieu : under ze couette
Membre no 18 500



Hello

bieeeen, j'ai donc trouvé la solution à force de me manger des tutos.... et d'être têtu.

Je résume... pour installer php 71 avec, sur un macOS Server (capitan ou sierra...):

Dans le terminal, on écrit:
CODE


Ce qui permet d'installer php71 dans /local/

modifier le .conf utilisé par le server Apache de macOS server qui n'est PAS celui de macOS tout court, via:
CODE
sudo nano /Library/Server/Web/Config/apache2/httpd_server_app.conf


Avec Ctrl+W chercher php5_module, par exemple

commenter (cad rajouter un #)
CODE
#LoadModule php5_module libexec/apache2/libphp5.so


rajouter, en dessous, la ligne:
CODE
LoadModule php7_module /usr/local/php5-7.1.4-20170506-100436/libphp7.so

(changer le chemin /usr/local/ en fonction de l’emplacement réel de libphp7.so , surtout si la version de php 7.1 n’est pas pile poil la meme que ci dessus... ce qui arrivera très vite puisque php71 est régulièrement mis à jour)

puis, en bas du .conf, après le block qui démarre par: iFModule php5_module

mettre le handler pour le php7 (qui n'est pas le même que php5, bé non)
CODE
<IfModule php7_module>  
    AddType application/x-httpd-php .php  
    <FilesMatch .php$>  
        SetHandler application/x-httpd-php  
    </FilesMatch>  
    <IfModule dir_module>  
        DirectoryIndex index.php index.html  
    </IfModule>  
</IfModule>  

sauvegarder avec Ctrl+O, fermer avec Ctrl+X, puis rebooter (oui, certaines choses ne marchent bien qu'avec un reboot de la machine et pas uniquement du server apache.

Dans l’appli Web sharing de Server, ne pas activer php (sinon ca dé-commente le module php5), lancer et vérifier son phpinfo…

attention, le
CODE
php -v
dans le terminal peut donner une autre valeur (surtout si comme moi, on a bidoullé pendant des semaines) mais on s’en bat les c’…


Nota: si on installe avec homebrew, je pense qu'il suffit de pointer vers le php7 de homebrew... soit probablement un truc du genre /usr/local/Cellar/php71/7.x.x.x/libexec/apache2/libphp7.so
au lieu de pointer vers celui installé par curl ...

Nota 2: vérifiez bien quel php.ini se lance ! Via phpinfo, parce que derechef ce n'est absolument pas celui qui semblait logique, ni prévu dans moult tutos... Pour activer OPCache, par exemple (:

Ce message a été modifié par tojar - 9 Aug 2017, 22:43.


--------------------
<= attention, cet individu est énervant, exécrable, hautain, prétentieux, professoral, d'un humour douteux et, de surcroit, disciple de courants de pensées qui sont dangeureuses pour notre bonne société francaise. hop.
Go to the top of the page
 
+Quote Post
baron
posté 3 Aug 2017, 03:41
Message #15


Macbidouilleur d'Or !
*****

Groupe : Modérateurs
Messages : 10 497
Inscrit : 22 Jul 2004
Lieu : Louvain-la-Neuve (Gaule Gelbique)
Membre no 21 291



N.B. Pour une meilleure lisibilité, je t'invite à éditer ton message ci-dessus en faisant usage des balises
Code
[code] (/code]
(dans l'éditeur complet).
wink.gif


--------------------
MacBook Pro 15’’ 2010 Core i5 2,53 GHz, 4 Go/500 Go – Mac OSX 10.6.8
MacOS 9.1 — G3 beige de bureau, rev.1 @ 233MHz, 288 Mo/4Go + carte PCI IDE/ATA Tempo 66 Acard 6260 avec HD interne Maxtor 80 Go + graveur interne CDRW/DVD LG GCC-4520B + tablette A4 Wacom UD-0608-A + LaCie ElectronBlueIV 19" + HP ScanJet 6100C
Routeur/modem ADSL Trendnet TW100-BRM504 B-Box 3 + HP LaserJet 4000 N
¶ La recherche dans MacBidouille vous paraît obscure ? J'ai rédigé une proposition de FAQ. Le moteur logiciel a un peu changé depuis mais ça peut aider quand même.
Les corsaires mettent en berne…


Firefox en occitan…
Go to the top of the page
 
+Quote Post
No6
posté 3 Aug 2017, 17:52
Message #16


Oui ?
*****

Groupe : Membres
Messages : 3 708
Inscrit : 24 Jun 2003
Lieu : BZH
Membre no 8 224



Bravo, thumb.gif
Patience et longueur de temps
Font plus que force ni que rage.
happy.gif


--------------------
"Je sais que vous croyez comprendre ce que vous pensez que j'ai dit, mais je ne suis pas sûr que vous réalisiez que ce que vous avez entendu n'est pas ce que je pense."
(Alan Greenspan)
Go to the top of the page
 
+Quote Post
tojar
posté 9 Aug 2017, 22:44
Message #17


Macbidouilleur de vermeil !
****

Groupe : Membres
Messages : 864
Inscrit : 6 May 2004
Lieu : under ze couette
Membre no 18 500



Citation (No6 @ 3 Aug 2017, 18:52) *
Bravo, thumb.gif
Patience et longueur de temps
Font plus que force ni que rage.
happy.gif


pour le coup, patience et longueur de temps, tu crois pas si bien dire !!!


--------------------
<= attention, cet individu est énervant, exécrable, hautain, prétentieux, professoral, d'un humour douteux et, de surcroit, disciple de courants de pensées qui sont dangeureuses pour notre bonne société francaise. hop.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 utilisateur(s) sur ce sujet (1 invité(s) et 0 utilisateur(s) anonyme(s))
0 membre(s) :

 



Nous sommes le : 17th August 2017 - 04:53