IPB

Bienvenue invité ( Connexion | Inscription )

> Programmation

Il est interdit de poster directement à la racine de ce forum.
Veuillez créer votre topic dans le sous-forum approprié.

 
Reply to this topicStart new topic
> [résolu] Alerte java pour Netscape 4, pas pour Safari...
Options
cyberbelette
posté 19 Nov 2003, 16:08
Message #1


Adepte de Macbidouille
*

Groupe : Membres
Messages : 48
Inscrit : 30 Sep 2002
Lieu : Paris 20e
Membre no 3 859



Bonjour,
un petit coup de main serait le bienvenu. Je passe au système X et je viens donc de tester le navigateur SAFARI pour visiter mon site perso.
Horreur et consternation ... L'alerte Javascript destinée aux utilisateurs de Netscape 4 se déclenche hors de propos . Que faire ?
(J'ai essayé le signe != pour exclure Safari mais ça ne fonctionne pas).

Mon site:
http://elisabeth.deravignan.free.fr/

Mon script :

<script language="JavaScript">
<!--
nav=navigator.appName;
ver=navigator.appVersion;
if(nav!='Safari')
if(nav=='Netscape')
if(ver=3)
if(ver=3.5)
if(ver=4)
if(ver=4.5)
{
alert('Votre version de Netscape est trop ancienne pour vous permettre de visionner ce site correctement.\nMerci de télécharger une version plus récente ou d\'utiliser Internet Explorer.');
}
//-->
</script>

Merci d'avance.

Ce message a été modifié par cyberbelette - 22 Jan 2006, 18:46.
Go to the top of the page
 
+Quote Post
nucleus
posté 20 Nov 2003, 13:34
Message #2


Macbidouilleur de vermeil !
****

Groupe : Membres
Messages : 1 351
Inscrit : 17 May 2001
Lieu : Paris
Membre no 256



Hum..
Il n'est pas conseillé de tester le type de navigateur par le nom ou la version..

Il vaut mieux tester l'existance des possibilités que la page utilise, ca évite de devoir mettre à jour sa page à chaque fois qu'une nouvelle sorte une version de navigateur sort, et d'interdire l'accès à ceux qu'on n'a pas prévu..

Ce message a été modifié par nucleus - 20 Nov 2003, 13:35.
Go to the top of the page
 
+Quote Post
cyberbelette
posté 20 Nov 2003, 22:14
Message #3


Adepte de Macbidouille
*

Groupe : Membres
Messages : 48
Inscrit : 30 Sep 2002
Lieu : Paris 20e
Membre no 3 859



Ce qui veut dire, concrètement ?... huh.gif
Mon principal problème étant de signaler aux utilisateurs de Netscape 4 et versions anterieures qu'ils ne pourront visionner mon site (en Flash) correctement.
Go to the top of the page
 
+Quote Post
nucleus
posté 20 Nov 2003, 23:32
Message #4


Macbidouilleur de vermeil !
****

Groupe : Membres
Messages : 1 351
Inscrit : 17 May 2001
Lieu : Paris
Membre no 256



Donc le problème serait la version de Flash installée plutôt que le navigateur?
Go to the top of the page
 
+Quote Post
cyberbelette
posté 22 Jan 2006, 18:45
Message #5


Adepte de Macbidouille
*

Groupe : Membres
Messages : 48
Inscrit : 30 Sep 2002
Lieu : Paris 20e
Membre no 3 859



Après avoir bricolé avec la syntaxe, problème résolu avec :

<script language="JavaScript">
<!--
if(navigator.appName=="Netscape")
if(navigator.appVersion.substring(0,1) <= "4.5")
{
alert('Votre version de Netscape est trop ancienne pour vous permettre de visionner ce site correctement.\nMerci de télécharger une version plus récente ou d\'utiliser Internet Explorer.');
}
//-->
</script>

Comme je ne m'y connais pas trop en javascript, je ne saurai pas vous expliquer ce que "substring(0,1)" signifie, même si tout le reste parait logique, en tout cas ça fonctionne.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 utilisateur(s) sur ce sujet (1 invité(s) et 0 utilisateur(s) anonyme(s))
0 membre(s) :

 



Nous sommes le : 22nd September 2017 - 18:10