IPB

Bienvenue invité ( Connexion | Inscription )

> Programmation

Il est interdit de poster directement à la racine de ce forum.
Veuillez créer votre topic dans le sous-forum approprié.

2 Pages V   1 2 >  
Reply to this topicStart new topic
> inclure ffmpeg à un projet cocoa
Options
Maconnect
posté 20 Aug 2003, 11:45
Message #1


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 3 295
Inscrit : 18 Dec 2002
Membre no 5 203



Bonjour! Je souhaite utiliser des fonctions de ffmpeg. Comme il y a les sources, je souhaite les intégrer à un projet cocoa et utiliser directement les fonctions au lieu de compiler ffmpeg puis utiliser des NSTasks (plus lent, pas pratique,...)

On m'a dit qu'il fallait changer le nom de la fonction "main" pour que ça marche.

Voici ce que j'ai réussi à faire:
--------------------------------------------------------------
•Ajouté les sources ffmpeg à mon projet. C'est-à-dire que j'ai fait un drag'n'drop de:
-les 3 fichiers ".h" (berrno.h,...) qui sont dans le dossier principal, et les 2 fichiers ".c" (ffmpeg.c et ffserver.c)
-le dossier "libavcodec"
-le dossier "libavformat"
-le dosier "vhook"

•J'ai compilé. Mais: erreur dans "ff.server.c": le fichier "<sys/poll.h>" n'existe pas alors qu'il est "includé". Je supprimer ffserver.c de mon projet

•Je compile, mais là il faut ajouter ceci:
-"#include <math.h>" dans un des fichiers (sais plus lequel)
-"#include <string.h>" et "#include <stdio.h>" dans "a52dec.c"

•Je compile, et ça demande le fichier "libac3/ac3.h" qui effectivement n'existe pas. En plus j'ai 138errors et 115warnings
--------------------------------------------------------------

Quelqu'un a-t-il déjà fait la manip' ? un p'tit coup de pouce serait le bienvenu...

D'avance, merci!
jap.gif


--------------------
MBP unibody 2.53GHz 15''
Go to the top of the page
 
+Quote Post
Maconnect
posté 20 Aug 2003, 13:50
Message #2


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 3 295
Inscrit : 18 Dec 2002
Membre no 5 203



heu... j'y connais pas grand chose... Faut-il compiler les library ("libavformat et "libavcodec") puis seulement les inclure au projet?

EDIT: j'ai réussi à compiler "libavcodec":
CODE
cd ~/Desktop/ffmpeg

./configure

cd ~/Desktop/ffmpeg/libavcodec

make
Tout est ok. Par contre, impossible de compiler "libavformat":
QUOTE
cc: cannot specify -o with -c or -S and multiple compilations
make: *** [utils.o] Error 1


EDIT2:
bon j'ai ajouté la library compilée a un projet vide, ensuite je met "common.h" et "avcodec.h"
Ensuite il faut mettre les headers des formats qui nous intéressent? (ex: "mpegaudio.h"?) ça se complique pour appeler les fonction...
Par sécurité, j'ajoute tous les headers de "libavcodec"...

EDIT3:
c'est vraiment pas facile tout ça. Le seul exemple que j'aie trouvé c'est celui du codec QT pour les DIVX, qui n'est pas très parlant.
Je n'arrive pas a compiler "vhook" et "libavformats" qui sont nécessaires si on veut utiliser la fonction "main" (plus simple). Sinon faut faire appel directement aux fonctions, et là c'est pas gagné sad.gif

EDIT4:
j'ai réussi a compiler "libavformats":
CODE
cd /ffmpeg

./configure --prefix=/usr

cd /ffmpeg/libavformats

make

Par contre impossible de compiler "vhook"


--------------------
MBP unibody 2.53GHz 15''
Go to the top of the page
 
+Quote Post
Maconnect
posté 20 Aug 2003, 21:07
Message #3


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 3 295
Inscrit : 18 Dec 2002
Membre no 5 203



alors voici le résultat de mes recherches, peut-être cela servira-t-il pour quelqu'un plus tard...

Il faut mettre ceci dans les Linker Settings (dans PB:Target:linker settings:other mach-o...)
QUOTE
-ldl -flat_namespace -read_only_relocs suppress

Et en suite, le seul moyen que j'aie trouvé pour linké la library "libgcc.a" c'est de la glisser-déposer dans le projet. Elle se trouve ici:
/usr/lib/gcc/darwin/3.1/libgcc.a

Et ensuite quand on compile, ça marche
Ouf, plusieurs heures pour ce résultat!! :fou: :fou: :fou:

Note: j'ai toujours pas réussi à compiler "vhook". Donc seules les 2 autres libraries sont ajoutées à mon projet


--------------------
MBP unibody 2.53GHz 15''
Go to the top of the page
 
+Quote Post
syno
posté 9 Nov 2006, 13:30
Message #4


Nouveau Membre


Groupe : Membres
Messages : 39
Inscrit : 9 Nov 2006
Membre no 72 508



Hello,

me voici 3 ans plus tard confronté à la librairie libavcodec.

Mon but est d'utiliser certaines fonctions de cette librairie pour tester quelques codecs vidéos.
Je compile ainsi la librairie ainsi que libavutil et libavformat, fournies avec le package ffmpeg. La compilation par le terminal génère libvavutil.a, libavcodec.a et libavformat.a.

Je crée donc une nouvelle application dans Xcode et ajoute les trois librairies statiques correspondantes dans le projet. Dans un premier temps, le main contient uniquement une seule fonction de la librairie libavcodec, afin de m'assurer que tout fonctionne bien. Pourtant la compilation génère l'erreur suivante:

Processing /Users/etudiants/test13/build/test13.build/Debug/test13.build/Objects-normal/ppc/libavcodec.ab
libavcodec.a(bitstream.o) has local relocation entries in non-writable section (__TEXT,__text)
Command /usr/bin/gcc-4.0 failed with exit code 1

J'avoue ne pas saisir d'où vient le problème (pourtant le main contient l'inclusion du header correspondant)

Merci pour votre aide

Syno

Go to the top of the page
 
+Quote Post
chombier
posté 9 Nov 2006, 13:39
Message #5


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 5 705
Inscrit : 20 Mar 2003
Membre no 6 765



CITATION(syno @ 9 Nov 2006, 13:30) [snapback]1971909[/snapback]

Processing /Users/etudiants/test13/build/test13.build/Debug/test13.build/Objects-normal/ppc/libavcodec.ab
libavcodec.a(bitstream.o) has local relocation entries in non-writable section (__TEXT,__text)
Command /usr/bin/gcc-4.0 failed with exit code 1

J'avoue ne pas saisir d'où vient le problème (pourtant le main contient l'inclusion du header correspondant)

Merci pour votre aide

Syno

Comment as-tu compilé tes librairies ffmpeg ?
Il manque peut-être l'option -fPIC


--------------------
késtananafout' (:
Go to the top of the page
 
+Quote Post
syno
posté 9 Nov 2006, 13:48
Message #6


Nouveau Membre


Groupe : Membres
Messages : 39
Inscrit : 9 Nov 2006
Membre no 72 508



Voici les commandes exécutées à partir du dossier ffmpeg:

./configure
make
sudo make install
Go to the top of the page
 
+Quote Post
syno
posté 9 Nov 2006, 14:19
Message #7


Nouveau Membre


Groupe : Membres
Messages : 39
Inscrit : 9 Nov 2006
Membre no 72 508



Où faut-il insérer cette option de compilation?
J'ai testé après le make mais l'option de compilation est inconnue...
Go to the top of the page
 
+Quote Post
chombier
posté 9 Nov 2006, 15:09
Message #8


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 5 705
Inscrit : 20 Mar 2003
Membre no 6 765



Tu peux faire ./configure CFLAGS=-fPIC ./configure --extra-cflags=-fPIC

Mais en fait, cette option n'est pas nécessaire dans une librairie statique (.a), et elle est par défaut activée dans gcc donc cela ne devrait pas gêner.
Ceci dit, je viens de récupérer les sources de ffmpeg, ça compile, et je vois dans les arguments passés à cc une option "-mdynamic-no-pic" qui justement désactive le mode PIC.

Ce message a été modifié par chombier - 9 Nov 2006, 15:15.


--------------------
késtananafout' (:
Go to the top of the page
 
+Quote Post
syno
posté 9 Nov 2006, 15:27
Message #9


Nouveau Membre


Groupe : Membres
Messages : 39
Inscrit : 9 Nov 2006
Membre no 72 508



Une erreur survient lors de la configuration avec cette option:

Creating config.mak and config.h...
mv: config.h: set owner/group (was: 502/0): Operation not permitted

Est-ce normal?


j'ai ajouté la commande sudo, la compilation de la lib a réussi.

Par contre cela n'a rien changé au niveau de la compilation de mon programme.

Mon but futur est de compiler le code source example "apiexample.c" fournit dans le package ffmpeg.
Go to the top of the page
 
+Quote Post
chombier
posté 9 Nov 2006, 15:28
Message #10


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 5 705
Inscrit : 20 Mar 2003
Membre no 6 765



Je n'ai pas eu cette erreur !?
quelle version de ffmpeg as-tu récupéré ?
J'ai pour ma part pris la dernière version dispo via svn:
CODE
$ svn checkout svn://svn.mplayerhq.hu/ffmpeg/trunk ffmpeg

Mais bon de toutes façons, cela ne change rien, j'ai comme warning lors du make:
CODE
warning: -mdynamic-no-pic overrides -fpic or -fPIC


--------------------
késtananafout' (:
Go to the top of the page
 
+Quote Post
chombier
posté 9 Nov 2006, 15:57
Message #11


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 5 705
Inscrit : 20 Mar 2003
Membre no 6 765



Peut-être une autre piste: essaies de cocher l'option "Generate Position Dependant Code" dans les options de ton projet Xcode.


--------------------
késtananafout' (:
Go to the top of the page
 
+Quote Post
syno
posté 9 Nov 2006, 16:14
Message #12


Nouveau Membre


Groupe : Membres
Messages : 39
Inscrit : 9 Nov 2006
Membre no 72 508



Toujours rien!!

De ton côté as-tu essayé de créer un projet et d'utiliser cette librairie?
Go to the top of the page
 
+Quote Post
chombier
posté 9 Nov 2006, 16:29
Message #13


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 5 705
Inscrit : 20 Mar 2003
Membre no 6 765



Je viens de tester avec une appli carbon qui appelle juste avcodec_init(), aucun problème ici.
Tu as la dernière version de Xcode ?


--------------------
késtananafout' (:
Go to the top of the page
 
+Quote Post
syno
posté 9 Nov 2006, 20:37
Message #14


Nouveau Membre


Groupe : Membres
Messages : 39
Inscrit : 9 Nov 2006
Membre no 72 508



Oui j'ai la dernière version de Xcode.

Voici le détail de ma procédure:

-téléchargement de la dernière version de ffmpeg via svn
-compilation et installation de ffmep (à partir du dossier ffmpeg):
./configure
make
sudo make install
-Ceci génère les trois librairies suivantes:
libvavutil.a
libavcodec.a
libavformat.a
-J'ouvre alors une nouvelle application Carbon C
-Je modifie le main.c en lui ajoutant la fonction avcodec_init() et en spécifiant le header correspondant (#include 'avcodec.h')
-Je glisse alors les trois librairies.a dans le projet à partir de leur dossier respectif
-Je spécifie encore dans les builder settings/header path le chemin d'accès du dossier contenant le .h utilisé

Voilà, et après ceci la compilation échoue avec l'erreur décrite auparavant.

La partie que je ne maîtrise pas concerne l'insertion de la librairie. Faut-il vraiment inclure les .a dans le projet? Faut il lui spécifier un chemin d'accès pour ces librairies?Si oui où?

De ton côté, quel est ta façon de procéder?

Go to the top of the page
 
+Quote Post
chombier
posté 9 Nov 2006, 20:44
Message #15


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 5 705
Inscrit : 20 Mar 2003
Membre no 6 765



CITATION(syno @ 9 Nov 2006, 20:37) [snapback]1972562[/snapback]

La partie que je ne maîtrise pas concerne l'insertion de la librairie. Faut-il vraiment inclure les .a dans le projet? Faut il lui spécifier un chemin d'accès pour ces librairies?Si oui où?

De ton côté, quel est ta façon de procéder?

Quasiment pareil, si ce n'est que j'ai ajouté les librairies en passant par les options du projet.
Dans Header Search Path: /usr/local/include -> dans le main: #include <ffmpeg/avcodec.h>
Dans Library Search Path: /usr/local/lib
Dans Other Link Flags: -lavcodec -lavformat -lavutil


--------------------
késtananafout' (:
Go to the top of the page
 
+Quote Post
syno
posté 9 Nov 2006, 21:06
Message #16


Nouveau Membre


Groupe : Membres
Messages : 39
Inscrit : 9 Nov 2006
Membre no 72 508



Merci pour les infos, j'essaierai tout ça demain.

Par contre pourrais-tu m'en dire un peu plus sur les flags? Je ne connais pas ces notions.
Go to the top of the page
 
+Quote Post
chombier
posté 9 Nov 2006, 21:13
Message #17


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 5 705
Inscrit : 20 Mar 2003
Membre no 6 765



Ce sont les options standard de gcc, ou plutôt de ld. Il faut que tu lises la man page de ld ("man ld" dans le terminal). Pour rechercher une expression dans une man page, tu peux te servir de "/" comme dans vi.
CODE
-lx    This  option  is  an abbreviation for the library name `libx.a',
       where x is a string.  If -dynamic is specified the  abbreviation
       for  the  library  name is first search as `libx.dylib' and then
       `libx.a' is searched for.  ld searches for  libraries  first  in
       any  directories specified with -L options, then in any directo-
       ries specified in the colon separated set of paths in the  envi-
       ronment  variable LD_LIBRARY_PATH, then the standard directories
       /lib, /usr/lib, and /usr/local/lib.  A library is searched  when
       its name is encountered, so the placement of the -l flag is sig-
       nificant.  If string x is of the form x.o,  then  that  file  is
       searched for in the same places, but without prepending `lib' or
       appending `.a' or `.dylib' to the filename.



--------------------
késtananafout' (:
Go to the top of the page
 
+Quote Post
syno
posté 10 Nov 2006, 08:57
Message #18


Nouveau Membre


Groupe : Membres
Messages : 39
Inscrit : 9 Nov 2006
Membre no 72 508



J'ai tout essayé mais toujours la même erreur.....???????!!!!!!!
Go to the top of the page
 
+Quote Post
syno
posté 10 Nov 2006, 10:49
Message #19


Nouveau Membre


Groupe : Membres
Messages : 39
Inscrit : 9 Nov 2006
Membre no 72 508



EUREKA!!!!
Après trois jours d'intenses recherches, je me rends compte qu'il suffisait de décocher l'option "Build/Allow Zero Link".

Si qqn en sait un peu plus sur cette option.....

Encore merci, Chombier pour ton dévouement.

Syno
Go to the top of the page
 
+Quote Post
chombier
posté 10 Nov 2006, 11:47
Message #20


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 5 705
Inscrit : 20 Mar 2003
Membre no 6 765



Content que tu t'en sois sorti ! smile.gif

L'option ZeroLink permet de gagner du temps lors du build de la version Debug. L'édition de liens n'est pas effectuée dans la phase de build, mais lors de l'exécution via Xcode.


--------------------
késtananafout' (:
Go to the top of the page
 
+Quote Post
syno
posté 10 Nov 2006, 11:50
Message #21


Nouveau Membre


Groupe : Membres
Messages : 39
Inscrit : 9 Nov 2006
Membre no 72 508



Par contre est-il normal que le build échoue en mode release???
Go to the top of the page
 
+Quote Post
chombier
posté 10 Nov 2006, 11:51
Message #22


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 5 705
Inscrit : 20 Mar 2003
Membre no 6 765



Euh... non. Quelle erreur as-tu ?


--------------------
késtananafout' (:
Go to the top of the page
 
+Quote Post
syno
posté 13 Nov 2006, 09:33
Message #23


Nouveau Membre


Groupe : Membres
Messages : 39
Inscrit : 9 Nov 2006
Membre no 72 508



Voici l'erreur que j'obtiens lors de la compilation(et trois warning):

Building target “VideoCodec” of project “VideoCodec” with configuration “Release” — (1 error, 3 warnings)
cd /Volumes/Divers/Jean_Mabillard/Projet_Master/Codec/Projet/VideoCodec
/usr/bin/g++-4.0 -o /Volumes/Divers/Jean_Mabillard/Projet_Master/Codec/Projet/VideoCodec/build/VideoCodec.build/Release/VideoCodec.build/Objects-normal/i386/VideoCodec\ Release -L/Volumes/Divers/Jean_Mabillard/Projet_Master/Codec/Projet/VideoCodec/build/Release -L/usr/local/lib -F/Volumes/Divers/Jean_Mabillard/Projet_Master/Codec/Projet/VideoCodec/build/Release -filelist /Volumes/Divers/Jean_Mabillard/Projet_Master/Codec/Projet/VideoCodec/build/VideoCodec.build/Release/VideoCodec.build/Objects-normal/i386/VideoCodec\ Release.LinkFileList -framework Carbon -lavcodec -lavformat -lavutil -arch i386 -Wl,-Y,1455 -mmacosx-version-min=10.4 -Wl,-dead_strip -no_dead_strip_inits_and_terms -isysroot /Developer/SDKs/MacOSX10.4u.sdk
/usr/bin/ld: warning /usr/local/lib/libavcodec.a archive's cputype (18, architecture ppc) does not match cputype (7) for specified -arch flag: i386 (can't load from it)
/usr/bin/ld: warning /usr/local/lib/libavformat.a archive's cputype (18, architecture ppc) does not match cputype (7) for specified -arch flag: i386 (can't load from it)
/usr/bin/ld: warning /usr/local/lib/libavutil.a archive's cputype (18, architecture ppc) does not match cputype (7) for specified -arch flag: i386 (can't load from it)
/usr/bin/ld: Undefined symbols:
_avcodec_init
/Volumes/Divers/Jean_Mabillard/Projet_Master/Codec/Projet/VideoCodec/build/VideoCodec.build/Release/VideoCodec.build/Objects-normal/i386/main.o reference to undefined _avcodec_init
collect2: ld returned 1 exit status
/usr/bin/ld: warning /usr/local/lib/libavcodec.a archive's cputype (18, architecture ppc) does not match cputype (7) for specified -arch flag: i386 (can't load from it)
/usr/bin/ld: warning /usr/local/lib/libavformat.a archive's cputype (18, architecture ppc) does not match cputype (7) for specified -arch flag: i386 (can't load from it)
/usr/bin/ld: warning /usr/local/lib/libavutil.a archive's cputype (18, architecture ppc) does not match cputype (7) for specified -arch flag: i386 (can't load from it)
/usr/bin/ld: Undefined symbols:
_avcodec_init
/Volumes/Divers/Jean_Mabillard/Projet_Master/Codec/Projet/VideoCodec/build/VideoCodec.build/Release/VideoCodec.build/Objects-normal/i386/main.o reference to undefined _avcodec_init
collect2: ld returned 1 exit status
Build failed (1 error, 3 warnings)
Go to the top of the page
 
+Quote Post
chombier
posté 13 Nov 2006, 11:02
Message #24


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 5 705
Inscrit : 20 Mar 2003
Membre no 6 765



CITATION(syno @ 13 Nov 2006, 09:33) [snapback]1977503[/snapback]

Voici l'erreur que j'obtiens lors de la compilation(et trois warning):

/usr/bin/ld: Undefined symbols:
_avcodec_init
reference to undefined _avcodec_init
collect2: ld returned 1 exit status
/usr/bin/ld: warning /usr/local/lib/libavcodec.a archive's cputype (18, architecture ppc) does not match cputype (7) for specified -arch flag: i386 (can't load from it)
/usr/bin/ld: warning /usr/local/lib/libavformat.a archive's cputype (18, architecture ppc) does not match cputype (7) for specified -arch flag: i386 (can't load from it)
/usr/bin/ld: warning /usr/local/lib/libavutil.a archive's cputype (18, architecture ppc) does not match cputype (7) for specified -arch flag: i386 (can't load from it)
/usr/bin/ld: Undefined symbols:
_avcodec_init

J'ai eu le même problème, bien que j'aie choisi comme architecture PPC uniquement dans le projet Xcode, il essayait tout de même de générer la version x86.
J'ai résolu ça en éditant le fichier du projet manuellement: Contrôle clic sur le paquet xcodeproj, afficher le contenu du paquet, editer le fichier project.pbxproj, et supprimer tout ce qui concerne x86 dans les architectures (variables "ARCHS").


--------------------
késtananafout' (:
Go to the top of the page
 
+Quote Post
syno
posté 17 Nov 2006, 09:18
Message #25


Nouveau Membre


Groupe : Membres
Messages : 39
Inscrit : 9 Nov 2006
Membre no 72 508



Voici un nouveau problème que je peine à résoudre.
Si j'appelle la fonction avcodec_init(), tout se passe bien. Par contre lors de l'appel de la fonction avcodec_register_all(), le message d'erreur suivant apparaît:

Building target “VideoCodec” of project “VideoCodec” with configuration “Debug” — (1 error)
cd /Volumes/Divers/Jean_Mabillard/Projet_Master/Codec/Projet/VideoCodec
/usr/bin/g++-4.0 -o /Volumes/Divers/Jean_Mabillard/Projet_Master/Codec/Projet/VideoCodec/build/Debug/VideoCodec\ Debug.app/Contents/MacOS/VideoCodec\ Debug -L/Volumes/Divers/Jean_Mabillard/Projet_Master/Codec/Projet/VideoCodec/build/Debug -L/usr/local/lib -F/Volumes/Divers/Jean_Mabillard/Projet_Master/Codec/Projet/VideoCodec/build/Debug -filelist /Volumes/Divers/Jean_Mabillard/Projet_Master/Codec/Projet/VideoCodec/build/VideoCodec.build/Debug/VideoCodec.build/Objects-normal/ppc/VideoCodec\ Debug.LinkFileList -framework Carbon -lavcodec -lavformat -lavutil -arch ppc -Wl,-Y,1455 -mmacosx-version-min=10.4 -isysroot /Developer/SDKs/MacOSX10.4u.sdk
/usr/bin/ld: Undefined symbols:
_uncompress
_inflate
_inflateEnd
_inflateInit_
_inflateReset
_inflateSync
_deflate
_deflateEnd
_deflateInit_
_deflateReset
_crc32
_deflateInit2_
/usr/local/lib/libavcodec.a(cscd.o) reference to undefined _uncompress
/usr/local/lib/libavcodec.a(flashsv.o) reference to undefined _inflate
/usr/local/lib/libavcodec.a(flashsv.o) reference to undefined _inflateEnd
/usr/local/lib/libavcodec.a(flashsv.o) reference to undefined _inflateInit_
/usr/local/lib/libavcodec.a(flashsv.o) reference to undefined _inflateReset
/usr/local/lib/libavcodec.a(flashsv.o) reference to undefined _inflateSync
/usr/local/lib/libavcodec.a(lcl.o) reference to undefined _deflate
/usr/local/lib/libavcodec.a(lcl.o) reference to undefined _deflateEnd
/usr/local/lib/libavcodec.a(lcl.o) reference to undefined _deflateInit_
/usr/local/lib/libavcodec.a(lcl.o) reference to undefined _deflateReset
/usr/local/lib/libavcodec.a(lcl.o) reference to undefined _inflate
/usr/local/lib/libavcodec.a(lcl.o) reference to undefined _inflateEnd
/usr/local/lib/libavcodec.a(lcl.o) reference to undefined _inflateInit_
/usr/local/lib/libavcodec.a(lcl.o) reference to undefined _inflateReset
/usr/local/lib/libavcodec.a(png.o) reference to undefined _crc32
/usr/local/lib/libavcodec.a(png.o) reference to undefined _deflate
/usr/local/lib/libavcodec.a(png.o) reference to undefined _deflateEnd
/usr/local/lib/libavcodec.a(png.o) reference to undefined _deflateInit2_
/usr/local/lib/libavcodec.a(png.o) reference to undefined _inflate
/usr/local/lib/libavcodec.a(png.o) reference to undefined _inflateEnd
/usr/local/lib/libavcodec.a(png.o) reference to undefined _inflateInit_
/usr/local/lib/libavcodec.a(tiff.o) reference to undefined _uncompress
/usr/local/lib/libavcodec.a(tscc.o) reference to undefined _inflate
/usr/local/lib/libavcodec.a(tscc.o) reference to undefined _inflateEnd
/usr/local/lib/libavcodec.a(tscc.o) reference to undefined _inflateInit_
/usr/local/lib/libavcodec.a(tscc.o) reference to undefined _inflateReset
/usr/local/lib/libavcodec.a(zmbv.o) reference to undefined _inflate
/usr/local/lib/libavcodec.a(zmbv.o) reference to undefined _inflateEnd
/usr/local/lib/libavcodec.a(zmbv.o) reference to undefined _inflateInit_
/usr/local/lib/libavcodec.a(zmbv.o) reference to undefined _inflateReset
collect2: ld returned 1 exit status
/usr/bin/ld: Undefined symbols:
_uncompress
_inflate
_inflateEnd
_inflateInit_
_inflateReset
_inflateSync
_deflate
_deflateEnd
_deflateInit_
_deflateReset
_crc32
_deflateInit2_
/usr/local/lib/libavcodec.a(cscd.o) reference to undefined _uncompress
/usr/local/lib/libavcodec.a(flashsv.o) reference to undefined _inflate
/usr/local/lib/libavcodec.a(flashsv.o) reference to undefined _inflateEnd
/usr/local/lib/libavcodec.a(flashsv.o) reference to undefined _inflateInit_
/usr/local/lib/libavcodec.a(flashsv.o) reference to undefined _inflateReset
/usr/local/lib/libavcodec.a(flashsv.o) reference to undefined _inflateSync
/usr/local/lib/libavcodec.a(lcl.o) reference to undefined _deflate
/usr/local/lib/libavcodec.a(lcl.o) reference to undefined _deflateEnd
/usr/local/lib/libavcodec.a(lcl.o) reference to undefined _deflateInit_
/usr/local/lib/libavcodec.a(lcl.o) reference to undefined _deflateReset
/usr/local/lib/libavcodec.a(lcl.o) reference to undefined _inflate
/usr/local/lib/libavcodec.a(lcl.o) reference to undefined _inflateEnd
/usr/local/lib/libavcodec.a(lcl.o) reference to undefined _inflateInit_
/usr/local/lib/libavcodec.a(lcl.o) reference to undefined _inflateReset
/usr/local/lib/libavcodec.a(png.o) reference to undefined _crc32
/usr/local/lib/libavcodec.a(png.o) reference to undefined _deflate
/usr/local/lib/libavcodec.a(png.o) reference to undefined _deflateEnd
/usr/local/lib/libavcodec.a(png.o) reference to undefined _deflateInit2_
/usr/local/lib/libavcodec.a(png.o) reference to undefined _inflate
/usr/local/lib/libavcodec.a(png.o) reference to undefined _inflateEnd
/usr/local/lib/libavcodec.a(png.o) reference to undefined _inflateInit_
/usr/local/lib/libavcodec.a(tiff.o) reference to undefined _uncompress
/usr/local/lib/libavcodec.a(tscc.o) reference to undefined _inflate
/usr/local/lib/libavcodec.a(tscc.o) reference to undefined _inflateEnd
/usr/local/lib/libavcodec.a(tscc.o) reference to undefined _inflateInit_
/usr/local/lib/libavcodec.a(tscc.o) reference to undefined _inflateReset
/usr/local/lib/libavcodec.a(zmbv.o) reference to undefined _inflate
/usr/local/lib/libavcodec.a(zmbv.o) reference to undefined _inflateEnd
/usr/local/lib/libavcodec.a(zmbv.o) reference to undefined _inflateInit_
/usr/local/lib/libavcodec.a(zmbv.o) reference to undefined _inflateReset
collect2: ld returned 1 exit status
Go to the top of the page
 
+Quote Post
chombier
posté 17 Nov 2006, 10:57
Message #26


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 5 705
Inscrit : 20 Mar 2003
Membre no 6 765



Il manque zlib, essaie d'ajouter "-lz" dans Other Link Flags.


--------------------
késtananafout' (:
Go to the top of the page
 
+Quote Post
syno
posté 17 Nov 2006, 11:45
Message #27


Nouveau Membre


Groupe : Membres
Messages : 39
Inscrit : 9 Nov 2006
Membre no 72 508



Cette option ne fonctionne pas chez moi. Par contre j'ai ajouté la librairie dynamique libz.dylib.1.1.4 dans mon projet et la compilation fonctionne. Par contre l'erreur suivante apparaît dans la console:

[Session started at 2006-11-17 11:41:56 +0100.]
dyld: Library not loaded: ../../bin/mac/libz.dylib.1.1.4
Referenced from: /Volumes/Divers/Jean_Mabillard/Projet_Master/Codec/Projet/VideoCodec/build/Debug/VideoCodec Debug.app/Contents/MacOS/VideoCodec Debug
Reason: image not found

VideoCodec has exited due to signal 5 (SIGTRAP).
Go to the top of the page
 
+Quote Post
chombier
posté 17 Nov 2006, 11:51
Message #28


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 5 705
Inscrit : 20 Mar 2003
Membre no 6 765



CITATION(syno @ 17 Nov 2006, 11:45) [snapback]1983972[/snapback]

Cette option ne fonctionne pas chez moi.

Tu n'as pas de fichier /usr/lib/libz.dylib ? huh.gif


--------------------
késtananafout' (:
Go to the top of the page
 
+Quote Post
syno
posté 17 Nov 2006, 14:24
Message #29


Nouveau Membre


Groupe : Membres
Messages : 39
Inscrit : 9 Nov 2006
Membre no 72 508



Si, le fichier existe. J'ai ajouté libz.dylib au projet mais la même erreur survient????
Go to the top of the page
 
+Quote Post
chombier
posté 17 Nov 2006, 14:34
Message #30


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 5 705
Inscrit : 20 Mar 2003
Membre no 6 765



Il n'est pas normal que tu ne puisses pas te servir de l'option "-lz"
Que répond la commande suivante dans le terminal:
CODE
$ locate /usr/lib/libz.dylib


--------------------
késtananafout' (:
Go to the top of the page
 
+Quote Post

2 Pages V   1 2 >
Reply to this topicStart new topic
1 utilisateur(s) sur ce sujet (1 invité(s) et 0 utilisateur(s) anonyme(s))
0 membre(s) :

 



Nous sommes le : 21st September 2017 - 08:02