IPB

Bienvenue invité ( Connexion | Inscription )

2 Pages V  < 1 2  
Reply to this topicStart new topic
> Hack Asus X99 5820K GTX980ti 10.11.6
Options
jeanchrijaz
posté 17 Feb 2017, 12:45
Message #31


Macbidouilleur d'Or !
*****

Groupe : Modérateurs
Messages : 1 649
Inscrit : 22 Sep 2015
Lieu : Aix-en-Provence (France)
Membre no 196 549



Citation (jeanba3000 @ 17 Feb 2017, 01:01) *
Jeanchrijaz, pour l'instant j'ai suivi à la lettre le long post #725 que mfc88 t'a écrit sur le insanelymac, sans progrès notable. Je continue la lecture demain… smile.gif

bon courage.... comme toi j'ai galéré au début
surtout que mon 1er disque n'était pas compatible
c'est d'ailleurs pour ca que j'ai pris le 950 (et j'ai eut de la chance que la boutique ou l'ai pris a bien voulu me le reprendre)
mais avec le 950 pro tu devrais avoir moins de difficultés pour le faire reconnaitre en interne

sinon tu peux essayer le patch de Pike Alpha
démarres sur ton autre disque (pas le Nvme), sauvegarde ton fichier config.list
supprime NVMeGeneric.kext (ou HackrNVMeFamily-10_11_6_supp2016-003.kext)
il te faut un fichier IONVMEFamily.kext non modifié, sinon récupère le d'une autre installation (a mettre dans System/Library/Extention)
reconstruit le cache et redémarre l'ordi

ensuite ajoute ces codes dans kextsToPatch et KernelToPatch en éditant ton fichier config.plist
redémarre ton ordi toujours sur l'autre disque et logiquement ton disque Nvme devrait apparaitre en interne
si c'est bon tu peux mettre le code dans le config.plist du Nvme
si ce n'est pas bon remet le fichier config que tu as sauvegardé et utilise le patch de Rehabman

kextsToPatch

CODE
<dict>
<key>Comment</key>
<string>IONVMeFamily Pike R. Alpha Patch#External</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>
SIXAdAeAiwgBAAAQ
</data>
<key>Name</key>
<string>IONVMeFamily</string>
<key>Replace</key>
<data>
kJCQkJCAiwgBAAAQ
</data>
</dict>


KernelToPatch

CODE
<key>KernelToPatch</key>
<array>
<dict>
<key>Comment</key>
<string>IONVMeFamily Pike R. Alpha Patch#3</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>
AMeDpAAAAAAQAABIi0gISA==
</data>
<key>Replace</key>
<data>
AMeDpAAAAAACAABIi0gISA==
</data>
</dict>
<dict>
<key>Comment</key>
<string>IONVMeFamily Pike R. Alpha Patch#1</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>
ibPoAgAAweAMBQAQAACJgw==
</data>
<key>Replace</key>
<data>
ibPoAgAAweAJBQAQAACJgw==
</data>
</dict>
<dict>
<key>Comment</key>
<string>IONVMeFamily Pike R. Alpha Patch#6_7</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>
icGB4f8PAABIAdFIgfn/DwAAdzs=
</data>
<key>Replace</key>
<data>
icGB4f8BAABIAdFIgfn/AQAAdzs=
</data>
</dict>
<dict>
<key>Comment</key>
<string>IONVMeFamily Pike R. Alpha Patch#2</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>
D7aMiIIAAACD+QwPhTIBAA==
</data>
<key>Replace</key>
<data>
D7aMiIIAAACD+QkPhTIBAA==
</data>
</dict>
<dict>
<key>Comment</key>
<string>IONVMeFamily Pike R. Alpha Patch#8</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>
SYHF/w8AAEnB7QxJiwQkSA==
</data>
<key>Replace</key>
<data>
SYHF/w8AAEnB7QlJiwQkSA==
</data>
</dict>
<dict>
<key>Comment</key>
<string>IONVMeFamily Pike R. Alpha Patch#9_10</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>
BgIAAEyNuAAQAABMiflIgeEA8P//SYmGGgEAAEmJjiIB
AABBvAAQAABJKfQ=
</data>
<key>Replace</key>
<data>
BgIAAEyNuAACAABMiflIgeEA8P//SYmGGgEAAEmJjiIB
AABBvAACAABJKfQ=
</data>
</dict>
<dict>
<key>Comment</key>
<string>IONVMeFamily Pike R. Alpha Patch#5</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>
hv8PAABIwegMD7cPgeH/Dw==
</data>
<key>Replace</key>
<data>
hv8PAABIwegJD7cPgeH/Dw==
</data>
</dict>
<dict>
<key>Comment</key>
<string>IONVMeFamily Pike R. Alpha Patch#11</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>
AABJiY4iAQAAugAQAABIKQ==
</data>
<key>Replace</key>
<data>
AABJiY4iAQAAugACAABIKQ==
</data>
</dict>
<dict>
<key>Comment</key>
<string>IONVMeFamily Pike R. Alpha Patch#14</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>
iWTY+EmBxAAQAABJgccA8A==
</data>
<key>Replace</key>
<data>
iWTY+EmBxAACAABJgccA8A==
</data>
</dict>
<dict>
<key>Comment</key>
<string>IONVMeFamily IONameMatch</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>
PHN0cmluZz5wY2kxNDRkLGE4MDQ8L3N0cmluZz4=
</data>
<key>Replace</key>
<data>
PHN0cmluZz5wY2kxNDRkLGE4MDI8L3N0cmluZz4=
</data>
</dict>
<dict>
<key>Comment</key>
<string>IONVMeFamily Pike R. Alpha Patch#12</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>
yAAAAEkp17gAEAAATYskJA==
</data>
<key>Replace</key>
<data>
yAAAAEkp17gAAgAATYskJA==
</data>
</dict>
<dict>
<key>Comment</key>
<string>IONVMeFamily Pike R. Alpha Patch#16</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>
weIIQQ+2wcHgDEQJ0EQJwA==
</data>
<key>Replace</key>
<data>
weIIQQ+2wcHgCUQJ0EQJwA==
</data>
</dict>
<dict>
<key>Comment</key>
<string>IONVMeFamily Pike R. Alpha Patch#17</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>
RYTJD5XAD7bAweAMRAnYRA==
</data>
<key>Replace</key>
<data>
RYTJD5XAD7bAweAJRAnYRA==
</data>
</dict>
<dict>
<key>Comment</key>
<string>IONVMeFamily Pike R. Alpha Patch#4</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>
SYnGTYX2dGFBwecMSWP/vg==
</data>
<key>Replace</key>
<data>
SYnGTYX2dGFBwecJSWP/vg==
</data>
</dict>
<dict>
<key>Comment</key>
<string>IONVMeFamily Pike R. Alpha Patch#15</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>
Bf8PAABIwegMZvfB/w8PlQ==
</data>
<key>Replace</key>
<data>
Bf8PAABIwegJZvfB/w8PlQ==
</data>
</dict>
<dict>
<key>Comment</key>
<string>IONVMeFamily Pike R. Alpha Patch#13</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>
4b+AQBUGTYnWugAQAABFMQ==
</data>
<key>Replace</key>
<data>
4b+AQBUGTYnWugACAABFMQ==
</data>
</dict>


Ce message a été modifié par jeanchrijaz - 17 Feb 2017, 13:05.


--------------------
iPhone XS 256 Go Apple TV 4 32 Go Macbook Pro Touch Bar 13" | 2017 | Core i5 | SSD NVme 512 Go | 16 Go de Ram | macOS High Sierra 10.13.6 |

Hackintosh : SMBIOS iMac 14,2 |
🍀 Clover r4700 | macOS Sierra 10.12.6 (16G1510) | Présentation ici |
__Carte mère : Asus Z97-Pro (wifi-ac) • CPU : Core i7 4790K • Ram : 32 Go (4 x 8 Go) 2133Mhz • CG : EVGA GTX 1080 FTW
__• 2 x moniteurs 27" WQHD (2560 x 1440) • Carte combo PCI-E
BCM94360CSAX
Carte son : AVID Pro Tools Quartet (Apogee)
Disque Système : 960 EVO 250 Go NVme | Disque de Rendus : 950 PRO 256 Go NVme | Disque Cache : 850 EVO 500 Go | Stockage interne : 3 x 3 To en Raid 0

_ NO WINDOWS BOOT... Only


Politique vis à vis des outils automatisés - FAQ Générale du Hackintosh - FAQ des Bootloaders - FAQ des Bootflags - FAQ des problèmes les plus courants - Guide d'installation

Go to the top of the page
 
+Quote Post
jeanba3000
posté 19 Feb 2017, 23:12
Message #32


Macbidouilleur de bronze !
**

Groupe : Membres
Messages : 370
Inscrit : 23 Apr 2002
Lieu : paname 20e rules !
Membre no 2 321



Jean, me confirmes-tu que dans le 2e code « KernelToPatch », il manque tout à la fin la balise fermante </array> ?

En tout cas ça ne marche pas chez moi, après redémarrage sur le second volume, le ssd nvme ne monte plus, il est tout juste listé dans l'arborescence dans IORegistryExplorer mais plus identifié comme auparavant et pas vu par Information Système.
Le code ajouté dans config.plist apparait correctement dans Clover Configurator donc j'imagine qu'il ne comporte pas d'erreur de syntaxe (en ayant ajouté la balise array fermante)


--------------------
::: jeanba ::: work ::: photo :::

Il existe une malédiction qui dit : « Puisses-tu vivre des moments passionnants. »
Go to the top of the page
 
+Quote Post
jeanchrijaz
posté 20 Feb 2017, 00:20
Message #33


Macbidouilleur d'Or !
*****

Groupe : Modérateurs
Messages : 1 649
Inscrit : 22 Sep 2015
Lieu : Aix-en-Provence (France)
Membre no 196 549



Citation (jeanba3000 @ 19 Feb 2017, 23:12) *
Jean, me confirmes-tu que dans le 2e code « KernelToPatch », il manque tout à la fin la balise fermante </array> ?

En tout cas ça ne marche pas chez moi, après redémarrage sur le second volume, le ssd nvme ne monte plus, il est tout juste listé dans l'arborescence dans IORegistryExplorer mais plus identifié comme auparavant et pas vu par Information Système.
Le code ajouté dans config.plist apparait correctement dans Clover Configurator donc j'imagine qu'il ne comporte pas d'erreur de syntaxe (en ayant ajouté la balise array fermante)

oui il manque la balise a la fin
je ne l'ai pas mise au cas ou tu aurais déjà des patch pour éviter de la répéter 2 fois

concernant le fait qu'il n'apparaisse toujours pas interne je sèche un peu
j'ai eut exactement le même problème sur mon 1er NVme et c'est suite a ca qu'on a conclus que le contrôleur du ssd n'était pas compatible
logiquement sur un 950 pro il n'y a aucun soucis, d'ailleurs même sur ma config ca a fonctionné de suite après en avoir mis un
je pense qu'il te manque un paramètre ou un oubli quelque part car il est déjà détecté
ca doit être 2 fois rien sinon ca te planterait le système au démarrage

donc il ne te reste que la solution du patch de Rehabman + un SSDT dans ACPI patched
a l'occasion envoies moi ton fichier config.plist que je regarde si tu n'as pas oublié un truc
je ne te garanti pas que je vais trouver car mes compétences sont assez limitées mais on ne sait jamais

Ce message a été modifié par jeanchrijaz - 20 Feb 2017, 00:22.


--------------------
iPhone XS 256 Go Apple TV 4 32 Go Macbook Pro Touch Bar 13" | 2017 | Core i5 | SSD NVme 512 Go | 16 Go de Ram | macOS High Sierra 10.13.6 |

Hackintosh : SMBIOS iMac 14,2 |
🍀 Clover r4700 | macOS Sierra 10.12.6 (16G1510) | Présentation ici |
__Carte mère : Asus Z97-Pro (wifi-ac) • CPU : Core i7 4790K • Ram : 32 Go (4 x 8 Go) 2133Mhz • CG : EVGA GTX 1080 FTW
__• 2 x moniteurs 27" WQHD (2560 x 1440) • Carte combo PCI-E
BCM94360CSAX
Carte son : AVID Pro Tools Quartet (Apogee)
Disque Système : 960 EVO 250 Go NVme | Disque de Rendus : 950 PRO 256 Go NVme | Disque Cache : 850 EVO 500 Go | Stockage interne : 3 x 3 To en Raid 0

_ NO WINDOWS BOOT... Only


Politique vis à vis des outils automatisés - FAQ Générale du Hackintosh - FAQ des Bootloaders - FAQ des Bootflags - FAQ des problèmes les plus courants - Guide d'installation

Go to the top of the page
 
+Quote Post
jeanba3000
posté 20 Feb 2017, 00:50
Message #34


Macbidouilleur de bronze !
**

Groupe : Membres
Messages : 370
Inscrit : 23 Apr 2002
Lieu : paname 20e rules !
Membre no 2 321



Merci, tu as mon config.plist dans le dernier post de la page précédente ;-)


--------------------
::: jeanba ::: work ::: photo :::

Il existe une malédiction qui dit : « Puisses-tu vivre des moments passionnants. »
Go to the top of the page
 
+Quote Post
jeanchrijaz
posté 20 Feb 2017, 01:44
Message #35


Macbidouilleur d'Or !
*****

Groupe : Modérateurs
Messages : 1 649
Inscrit : 22 Sep 2015
Lieu : Aix-en-Provence (France)
Membre no 196 549



Citation (jeanba3000 @ 20 Feb 2017, 00:50) *
Merci, tu as mon config.plist dans le dernier post de la page précédente ;-)

exact... surtout qu'en plus c'est comme ca que j'ai remarqué que tu avais NVmeGeneric
je télécharge ca et je jette un oeil demain a tête reposée, je suis déjà sur un soucis lol

d'ailleurs si tu as la solution elle est la bienvenue (on ne sait jamais... lol)
j'ai changé de carte vidéo, et quand j'active les web drivers Nvidia je perds 1mo de mémoire sur la carte, et je perds le monitoring de son ventilo dans Istat menus et HWMonitor


--------------------
iPhone XS 256 Go Apple TV 4 32 Go Macbook Pro Touch Bar 13" | 2017 | Core i5 | SSD NVme 512 Go | 16 Go de Ram | macOS High Sierra 10.13.6 |

Hackintosh : SMBIOS iMac 14,2 |
🍀 Clover r4700 | macOS Sierra 10.12.6 (16G1510) | Présentation ici |
__Carte mère : Asus Z97-Pro (wifi-ac) • CPU : Core i7 4790K • Ram : 32 Go (4 x 8 Go) 2133Mhz • CG : EVGA GTX 1080 FTW
__• 2 x moniteurs 27" WQHD (2560 x 1440) • Carte combo PCI-E
BCM94360CSAX
Carte son : AVID Pro Tools Quartet (Apogee)
Disque Système : 960 EVO 250 Go NVme | Disque de Rendus : 950 PRO 256 Go NVme | Disque Cache : 850 EVO 500 Go | Stockage interne : 3 x 3 To en Raid 0

_ NO WINDOWS BOOT... Only


Politique vis à vis des outils automatisés - FAQ Générale du Hackintosh - FAQ des Bootloaders - FAQ des Bootflags - FAQ des problèmes les plus courants - Guide d'installation

Go to the top of the page
 
+Quote Post
jeanba3000
posté 20 Feb 2017, 10:45
Message #36


Macbidouilleur de bronze !
**

Groupe : Membres
Messages : 370
Inscrit : 23 Apr 2002
Lieu : paname 20e rules !
Membre no 2 321



Pas banal ça, je compatis, ça m'énerverait bien…


--------------------
::: jeanba ::: work ::: photo :::

Il existe une malédiction qui dit : « Puisses-tu vivre des moments passionnants. »
Go to the top of the page
 
+Quote Post
jeanchrijaz
posté 21 Feb 2017, 16:46
Message #37


Macbidouilleur d'Or !
*****

Groupe : Modérateurs
Messages : 1 649
Inscrit : 22 Sep 2015
Lieu : Aix-en-Provence (France)
Membre no 196 549



Citation (jeanba3000 @ 20 Feb 2017, 10:45) *
Pas banal ça, je compatis, ça m'énerverait bien…

j'ai posé la question dans le forum et m'a répondu qu'apparemment ca serait normal... (voir ici)
le problème très certainement lié à FakeSMC.kext

concernant ta configuration j'ai téléchargé "EFI2016-10-09" et j'ai jeté un oeil mais je n'ai rien vu qui m'aurait choqué
le seul truc qui m'a un peu interpelé c'est l’arborescence de ton dossier EFI
pourquoi avoir mis tes kext dans "other" alors que tu es comme moi en 10.11?
bon ce n'est pas grave puisque ca fonctionne
et ensuite tu n'as pas pas de fichiers aml" dans ACPI/origin pour que je puisse regarder plus en détail et voir éventuellement pourquoi ca plante quand tu mets SSDT-NVME dans patched


--------------------
iPhone XS 256 Go Apple TV 4 32 Go Macbook Pro Touch Bar 13" | 2017 | Core i5 | SSD NVme 512 Go | 16 Go de Ram | macOS High Sierra 10.13.6 |

Hackintosh : SMBIOS iMac 14,2 |
🍀 Clover r4700 | macOS Sierra 10.12.6 (16G1510) | Présentation ici |
__Carte mère : Asus Z97-Pro (wifi-ac) • CPU : Core i7 4790K • Ram : 32 Go (4 x 8 Go) 2133Mhz • CG : EVGA GTX 1080 FTW
__• 2 x moniteurs 27" WQHD (2560 x 1440) • Carte combo PCI-E
BCM94360CSAX
Carte son : AVID Pro Tools Quartet (Apogee)
Disque Système : 960 EVO 250 Go NVme | Disque de Rendus : 950 PRO 256 Go NVme | Disque Cache : 850 EVO 500 Go | Stockage interne : 3 x 3 To en Raid 0

_ NO WINDOWS BOOT... Only


Politique vis à vis des outils automatisés - FAQ Générale du Hackintosh - FAQ des Bootloaders - FAQ des Bootflags - FAQ des problèmes les plus courants - Guide d'installation

Go to the top of the page
 
+Quote Post
polyzargone
posté 27 Feb 2017, 13:16
Message #38


Macbidouilleur d'Or !
*****

Groupe : Modérateurs
Messages : 9 884
Inscrit : 11 May 2006
Membre no 60 938



Citation (jeanchrijaz @ 21 Feb 2017, 16:46) *
pourquoi avoir mis tes kext dans "other" alors que tu es comme moi en 10.11?


Peut-être en vue de l'arrivée future de macOS 10.13 smile.gif.

En procédant ainsi, on a pas besoin de faire attention dans le cas du passage d'une version majeure à une autre. Si tout est bien configuré (càd en mettant tous les kexts additionnels dans l'EFI), il reste juste à lancer l'installeur depuis le dossier Applications.

Comme sur un Mac biggrin.gif !

Citation (jeanchrijaz @ 21 Feb 2017, 16:46) *
et ensuite tu n'as pas pas de fichiers aml" dans ACPI/origin pour que je puisse regarder plus en détail et voir éventuellement pourquoi ca plante quand tu mets SSDT-NVME dans patched


Ce n'est pas systématique. Il faut appuyer sur F4 dans le menu de boot de Clover pour que celui-ci génère les fichiers ACPI (DSDT.aml, SSDTx.aml etc.).


--------------------
Un MacmacOS 10.13 MacBook Air mi-2012 Core i5 1,7 GHz Intel HD 4000 SSD 64 Go
Des Hacks Gigabyte GA-H97-HD3 - Core i5 4570 3,20 GHz - Zotac Geforce GTX 1060 6 Go - 16 Go DDR3 - macOS 10.14/macOS 10.13.6/macOS 10.12/OS X 10.11.6/Win 10/Mint 18 Acer Aspire V3 772G Core i5 4210M 2,60 GHz - Intel HD 4600 + GTX 850M 2 Go (désactivée) - 16 Go DDR3 - macOS 10.14/macOS 10.13.6/macOS 10.12/Win 10/Mint 18 Dell Latitude e7440 Core i7 4600U 2,10 GHz - Intel HD 4400 - 16 Go DDR3 - macOS 10.14/macOS 10.13.6/Win 10 Medion MS-7616 - Core i5 650 3,20 GHz - Gainward GTX 650 Ti 2 Go - 8 Go DDR3 - macOS 10.14/macOS 10.13.6/Win 10 HP Elite 8300 USFF - Core i7 3770S 3,90 GHz - Intel HD 4000 - macOS 10.12/Win 10 - Clover (+ quelques autres...)

Politique vis à vis des outils automatisés et des distributions - Guide d'installation - Tutoriels - Lexique et utilité des Kexts - FAQ Générale du Hackintosh - FAQ des Bootloaders - FAQ des Bootflags - FAQ des problèmes les plus courants
Go to the top of the page
 
+Quote Post
jeanchrijaz
posté 27 Feb 2017, 17:17
Message #39


Macbidouilleur d'Or !
*****

Groupe : Modérateurs
Messages : 1 649
Inscrit : 22 Sep 2015
Lieu : Aix-en-Provence (France)
Membre no 196 549



Citation (polyzargone @ 27 Feb 2017, 13:16) *
Peut-être en vue de l'arrivée future de macOS 10.13 smile.gif.

En procédant ainsi, on a pas besoin de faire attention dans le cas du passage d'une version majeure à une autre. Si tout est bien configuré (càd en mettant tous les kexts additionnels dans l'EFI), il reste juste à lancer l'installeur depuis le dossier Applications.

Comme sur un Mac biggrin.gif !

oui je sais... mais a moins d'avoir mal lu, il me semble qu'il est toujours sur 10.11.x
et a moins qu'il veuille passer sur Sierra ce n'était pas utile... mais bon ce n'est pas grave tant que ca fonctionne

Citation (polyzargone @ 27 Feb 2017, 13:16) *
Ce n'est pas systématique. Il faut appuyer sur F4 dans le menu de boot de Clover pour que celui-ci génère les fichiers ACPI (DSDT.aml, SSDTx.aml etc.).

oui je sais aussi... mais pour vérifier, modifier ou même créer un fichier DSDT sans ceux d'origine c'est un peu difficile
a moins qu'il y ait une autre solution?


--------------------
iPhone XS 256 Go Apple TV 4 32 Go Macbook Pro Touch Bar 13" | 2017 | Core i5 | SSD NVme 512 Go | 16 Go de Ram | macOS High Sierra 10.13.6 |

Hackintosh : SMBIOS iMac 14,2 |
🍀 Clover r4700 | macOS Sierra 10.12.6 (16G1510) | Présentation ici |
__Carte mère : Asus Z97-Pro (wifi-ac) • CPU : Core i7 4790K • Ram : 32 Go (4 x 8 Go) 2133Mhz • CG : EVGA GTX 1080 FTW
__• 2 x moniteurs 27" WQHD (2560 x 1440) • Carte combo PCI-E
BCM94360CSAX
Carte son : AVID Pro Tools Quartet (Apogee)
Disque Système : 960 EVO 250 Go NVme | Disque de Rendus : 950 PRO 256 Go NVme | Disque Cache : 850 EVO 500 Go | Stockage interne : 3 x 3 To en Raid 0

_ NO WINDOWS BOOT... Only


Politique vis à vis des outils automatisés - FAQ Générale du Hackintosh - FAQ des Bootloaders - FAQ des Bootflags - FAQ des problèmes les plus courants - Guide d'installation

Go to the top of the page
 
+Quote Post
polyzargone
posté 27 Feb 2017, 17:51
Message #40


Macbidouilleur d'Or !
*****

Groupe : Modérateurs
Messages : 9 884
Inscrit : 11 May 2006
Membre no 60 938



Citation (jeanchrijaz @ 27 Feb 2017, 17:17) *
oui je sais... mais a moins d'avoir mal lu, il me semble qu'il est toujours sur 10.11.x
et a moins qu'il veuille passer sur Sierra ce n'était pas utile... mais bon ce n'est pas grave tant que ca fonctionne


Justement.

Puisque ça fonctionne pourquoi s'embêter à mettre des kexts dans des dossiers différents alors qu'un seul suffit. Si on met de côté le fait qu'il soit sur El Capitan, mettre tous ses kexts dans Other permet de démarrer n'importe quelle version d'OS X.

Je sais que tout le monde n'en utilise pas 36 en même temps ou que tout le monde ne prévoit pas de faire de MÀJ majeure mais bon, ça peut servir et surtout, ça simplifie la gestion. C'est une chose de moins à prendre en compte. Et accessoirement, ça allège le dossier EFI puisqu'il devient inutile de copier chaque kext dans chaque dossier 10.x.

Et crois moi, ça arrive souvent que quelqu'un n'arrive plus à démarrer parce que ses kexts sont restés dans un dossier 10.x wink.gif.

Citation (jeanchrijaz @ 27 Feb 2017, 17:17) *
oui je sais aussi... mais pour vérifier, modifier ou même créer un fichier DSDT sans ceux d'origine c'est un peu difficile
a moins qu'il y ait une autre solution?


C'était juste une précision tongue.gif.

Il y a effectivement d'autres solutions mais elles sont beaucoup moins simples (utiliser Windows ou extraire les tables ACPI depuis Linux ohmy.gif) ou déconseillées (lancer MaciASL et faire save as… tout bêtement).

Dans le dernier cas, il vaut mieux éviter parce que le bootloader (et particulièrement Clover) risque d'avoir déjà injecté des valeurs ce qui donnera probablement des fichiers biaisés.


--------------------
Un MacmacOS 10.13 MacBook Air mi-2012 Core i5 1,7 GHz Intel HD 4000 SSD 64 Go
Des Hacks Gigabyte GA-H97-HD3 - Core i5 4570 3,20 GHz - Zotac Geforce GTX 1060 6 Go - 16 Go DDR3 - macOS 10.14/macOS 10.13.6/macOS 10.12/OS X 10.11.6/Win 10/Mint 18 Acer Aspire V3 772G Core i5 4210M 2,60 GHz - Intel HD 4600 + GTX 850M 2 Go (désactivée) - 16 Go DDR3 - macOS 10.14/macOS 10.13.6/macOS 10.12/Win 10/Mint 18 Dell Latitude e7440 Core i7 4600U 2,10 GHz - Intel HD 4400 - 16 Go DDR3 - macOS 10.14/macOS 10.13.6/Win 10 Medion MS-7616 - Core i5 650 3,20 GHz - Gainward GTX 650 Ti 2 Go - 8 Go DDR3 - macOS 10.14/macOS 10.13.6/Win 10 HP Elite 8300 USFF - Core i7 3770S 3,90 GHz - Intel HD 4000 - macOS 10.12/Win 10 - Clover (+ quelques autres...)

Politique vis à vis des outils automatisés et des distributions - Guide d'installation - Tutoriels - Lexique et utilité des Kexts - FAQ Générale du Hackintosh - FAQ des Bootloaders - FAQ des Bootflags - FAQ des problèmes les plus courants
Go to the top of the page
 
+Quote Post
jeanba3000
posté 24 Jul 2017, 19:31
Message #41


Macbidouilleur de bronze !
**

Groupe : Membres
Messages : 370
Inscrit : 23 Apr 2002
Lieu : paname 20e rules !
Membre no 2 321



Salut les gens !

Un petit coucou pour signaler que j'ai profité du relâchement estival pour passer à 10.12.6, un peu laborieusement mais j'y suis arrivé : installation propre du système sur un ssd depuis un Mac, pas mal de tâtonnements pour la configuration de Clover et arriver à démarrer ce système, puis migration du compte utilisateur et applis, tests sur quelques boulots, enfin une fois convaincu que ça tourne, migration de l'ensemble sur mon ssd M2..

Un grand merci à jeanchrijaz dont le blog m'a été encore une fois très utile !

En négatif :
- Malgré l'application scrupuleuse des méthodes dont on a parlé, le SSD M2 est toujours reconnu comme externe.. Bon ce n'est pas très grave et il semblerait que le futur 10.13 améliore les choses, à suivre donc. Avec ma prudence habituelle, je me repencherai sur la question lorsque 10.13.6 sortira ! :-D
- Messages est toujours un peu capricieux, peut-être moins mais il arrive encore qu'il refuse d'envoyer des messages ou tente parfois de les passer en SMS :-/

En positif :
- le bruit dans mes enceintes apparu avec 10.11.6 a disparu, je peux enfin profiter de mes moniteurs, plus obligé de bosser au casque.
- la machine m'a semblé un poil plus réactive, mais c'est peut-être dans ma tête… J'ai bien plus gagné en agrément de travail en passant de After Effects CC2015 à CC2017 dont les prévisualisations sont redevenues normales.


--------------------
::: jeanba ::: work ::: photo :::

Il existe une malédiction qui dit : « Puisses-tu vivre des moments passionnants. »
Go to the top of the page
 
+Quote Post
jeanchrijaz
posté 25 Jul 2017, 04:14
Message #42


Macbidouilleur d'Or !
*****

Groupe : Modérateurs
Messages : 1 649
Inscrit : 22 Sep 2015
Lieu : Aix-en-Provence (France)
Membre no 196 549



si ce n'est pas déjà fait, ajoute ces lignes dans ton fichier config.plist pour que ton SSDT se charge
c'est peut être pour ca que ton disque n'est toujours pas reconnu comme interne

CODE
<key>DropTables</key>
<array>
<dict>
<key>Signature</key>
<string>SSDT</string>
<key>TableId</key>
<string>CpuPm</string>
</dict>
<dict>
<key>Signature</key>
<string>SSDT</string>
<key>TableId</key>
<string>Cpu0Ist</string>
</dict>
</array>


il faut que tu aies ca dans l'onglet ACPI de clover configurator



et concernant macOS je suis toujours sur El capitan (10.11.6)...
et je n'ai aucun bruit parasite sur mes monitoring tongue.gif



--------------------
iPhone XS 256 Go Apple TV 4 32 Go Macbook Pro Touch Bar 13" | 2017 | Core i5 | SSD NVme 512 Go | 16 Go de Ram | macOS High Sierra 10.13.6 |

Hackintosh : SMBIOS iMac 14,2 |
🍀 Clover r4700 | macOS Sierra 10.12.6 (16G1510) | Présentation ici |
__Carte mère : Asus Z97-Pro (wifi-ac) • CPU : Core i7 4790K • Ram : 32 Go (4 x 8 Go) 2133Mhz • CG : EVGA GTX 1080 FTW
__• 2 x moniteurs 27" WQHD (2560 x 1440) • Carte combo PCI-E
BCM94360CSAX
Carte son : AVID Pro Tools Quartet (Apogee)
Disque Système : 960 EVO 250 Go NVme | Disque de Rendus : 950 PRO 256 Go NVme | Disque Cache : 850 EVO 500 Go | Stockage interne : 3 x 3 To en Raid 0

_ NO WINDOWS BOOT... Only


Politique vis à vis des outils automatisés - FAQ Générale du Hackintosh - FAQ des Bootloaders - FAQ des Bootflags - FAQ des problèmes les plus courants - Guide d'installation

Go to the top of the page
 
+Quote Post
polyzargone
posté 25 Jul 2017, 07:14
Message #43


Macbidouilleur d'Or !
*****

Groupe : Modérateurs
Messages : 9 884
Inscrit : 11 May 2006
Membre no 60 938



Citation (jeanchrijaz @ 25 Jul 2017, 05:14) *
si ce n'est pas déjà fait, ajoute ces lignes dans ton fichier config.plist pour que ton SSDT se charge
c'est peut être pour ca que ton disque n'est toujours pas reconnu comme interne

CODE
<key>DropTables</key>
<array>
<dict>
<key>Signature</key>
<string>SSDT</string>
<key>TableId</key>
<string>CpuPm</string>
</dict>
<dict>
<key>Signature</key>
<string>SSDT</string>
<key>TableId</key>
<string>Cpu0Ist</string>
</dict>
</array>


il faut que tu aies ca dans l'onglet ACPI de clover configurator



C'est pour la gestion d'énergie du CPU ça… Je doute que ça change quelque chose pour l'histoire des icônes.

Tu peux toujours essayer ça même si je ne suis pas persuadé que ça marche :

Name : AppleAHCIPort
Find : 45787465726E616C
Replace : 496E7465726E616C
Comment : External icons patch


--------------------
Un MacmacOS 10.13 MacBook Air mi-2012 Core i5 1,7 GHz Intel HD 4000 SSD 64 Go
Des Hacks Gigabyte GA-H97-HD3 - Core i5 4570 3,20 GHz - Zotac Geforce GTX 1060 6 Go - 16 Go DDR3 - macOS 10.14/macOS 10.13.6/macOS 10.12/OS X 10.11.6/Win 10/Mint 18 Acer Aspire V3 772G Core i5 4210M 2,60 GHz - Intel HD 4600 + GTX 850M 2 Go (désactivée) - 16 Go DDR3 - macOS 10.14/macOS 10.13.6/macOS 10.12/Win 10/Mint 18 Dell Latitude e7440 Core i7 4600U 2,10 GHz - Intel HD 4400 - 16 Go DDR3 - macOS 10.14/macOS 10.13.6/Win 10 Medion MS-7616 - Core i5 650 3,20 GHz - Gainward GTX 650 Ti 2 Go - 8 Go DDR3 - macOS 10.14/macOS 10.13.6/Win 10 HP Elite 8300 USFF - Core i7 3770S 3,90 GHz - Intel HD 4000 - macOS 10.12/Win 10 - Clover (+ quelques autres...)

Politique vis à vis des outils automatisés et des distributions - Guide d'installation - Tutoriels - Lexique et utilité des Kexts - FAQ Générale du Hackintosh - FAQ des Bootloaders - FAQ des Bootflags - FAQ des problèmes les plus courants
Go to the top of the page
 
+Quote Post
jeanchrijaz
posté 25 Jul 2017, 10:20
Message #44


Macbidouilleur d'Or !
*****

Groupe : Modérateurs
Messages : 1 649
Inscrit : 22 Sep 2015
Lieu : Aix-en-Provence (France)
Membre no 196 549



houps autant pour moi....
effectivement je n'ai pas copié la bonne partie

bon j'ai des circonstances atténuantes, je rentrai de soirée et c'était 5h du matin...

@polyzargone
son disque est un NVme et il est reconnu comme externe dans le gestionnaire de disque (ou dans les informations système)
mais son icone est bonne
je regarderai ce soir quand je rentrerai chez moi ce que j'ai mis comme patch/code pour qu'il soit reconnu en interne


--------------------
iPhone XS 256 Go Apple TV 4 32 Go Macbook Pro Touch Bar 13" | 2017 | Core i5 | SSD NVme 512 Go | 16 Go de Ram | macOS High Sierra 10.13.6 |

Hackintosh : SMBIOS iMac 14,2 |
🍀 Clover r4700 | macOS Sierra 10.12.6 (16G1510) | Présentation ici |
__Carte mère : Asus Z97-Pro (wifi-ac) • CPU : Core i7 4790K • Ram : 32 Go (4 x 8 Go) 2133Mhz • CG : EVGA GTX 1080 FTW
__• 2 x moniteurs 27" WQHD (2560 x 1440) • Carte combo PCI-E
BCM94360CSAX
Carte son : AVID Pro Tools Quartet (Apogee)
Disque Système : 960 EVO 250 Go NVme | Disque de Rendus : 950 PRO 256 Go NVme | Disque Cache : 850 EVO 500 Go | Stockage interne : 3 x 3 To en Raid 0

_ NO WINDOWS BOOT... Only


Politique vis à vis des outils automatisés - FAQ Générale du Hackintosh - FAQ des Bootloaders - FAQ des Bootflags - FAQ des problèmes les plus courants - Guide d'installation

Go to the top of the page
 
+Quote Post
polyzargone
posté 25 Jul 2017, 10:36
Message #45


Macbidouilleur d'Or !
*****

Groupe : Modérateurs
Messages : 9 884
Inscrit : 11 May 2006
Membre no 60 938



Citation (jeanchrijaz @ 25 Jul 2017, 11:20) *
@polyzargone
son disque est un NVme et il est reconnu comme externe dans le gestionnaire de disque (ou dans les informations système)
mais son icone est bonne


Ah OK !

En plus, j'imagine qu'il ne passe pas par l'AppleAHCIPort.kext donc ça n'aurait probablement servi à rien.

Citation (jeanchrijaz @ 25 Jul 2017, 11:20) *
je regarderai ce soir quand je rentrerai chez moi ce que j'ai mis comme patch/code pour qu'il soit reconnu en interne


Oui, c'est probablement un bout de code dans la SSDT unsure.gif.


--------------------
Un MacmacOS 10.13 MacBook Air mi-2012 Core i5 1,7 GHz Intel HD 4000 SSD 64 Go
Des Hacks Gigabyte GA-H97-HD3 - Core i5 4570 3,20 GHz - Zotac Geforce GTX 1060 6 Go - 16 Go DDR3 - macOS 10.14/macOS 10.13.6/macOS 10.12/OS X 10.11.6/Win 10/Mint 18 Acer Aspire V3 772G Core i5 4210M 2,60 GHz - Intel HD 4600 + GTX 850M 2 Go (désactivée) - 16 Go DDR3 - macOS 10.14/macOS 10.13.6/macOS 10.12/Win 10/Mint 18 Dell Latitude e7440 Core i7 4600U 2,10 GHz - Intel HD 4400 - 16 Go DDR3 - macOS 10.14/macOS 10.13.6/Win 10 Medion MS-7616 - Core i5 650 3,20 GHz - Gainward GTX 650 Ti 2 Go - 8 Go DDR3 - macOS 10.14/macOS 10.13.6/Win 10 HP Elite 8300 USFF - Core i7 3770S 3,90 GHz - Intel HD 4000 - macOS 10.12/Win 10 - Clover (+ quelques autres...)

Politique vis à vis des outils automatisés et des distributions - Guide d'installation - Tutoriels - Lexique et utilité des Kexts - FAQ Générale du Hackintosh - FAQ des Bootloaders - FAQ des Bootflags - FAQ des problèmes les plus courants
Go to the top of the page
 
+Quote Post
jeanba3000
posté 27 Jul 2017, 16:25
Message #46


Macbidouilleur de bronze !
**

Groupe : Membres
Messages : 370
Inscrit : 23 Apr 2002
Lieu : paname 20e rules !
Membre no 2 321



Citation (jeanchrijaz @ 25 Jul 2017, 05:14) *
si ce n'est pas déjà fait, ajoute ces lignes dans ton fichier config.plist pour que ton SSDT se charge
c'est peut être pour ca que ton disque n'est toujours pas reconnu comme interne

Ces lignes y sont déjà, merci :-)

Citation (jeanchrijaz @ 25 Jul 2017, 05:14) *
et concernant macOS je suis toujours sur El capitan (10.11.6)...
et je n'ai aucun bruit parasite sur mes monitoring tongue.gif

Pas de bruit du tout sous 10.9, insupportable sous 10.11, tolérable sous 10.12… bref les voiesx de l'informatique sont impénétrables… ;-)

Citation (polyzargone @ 25 Jul 2017, 08:14) *
Tu peux toujours essayer ça même si je ne suis pas persuadé que ça marche :

Name : AppleAHCIPort
Find : 45787465726E616C
Replace : 496E7465726E616C
Comment : External icons patch

Je le mettrais où dans Clover Configurator ? DSDT patches ?

Citation (jeanchrijaz @ 25 Jul 2017, 11:20) *
son disque est un NVme et il est reconnu comme externe dans le gestionnaire de disque (ou dans les informations système)
mais son icone est bonne

En fait elle ne l'est actuellement plus, j'ai l'icône jaune d'un disque externe

Citation (polyzargone @ 25 Jul 2017, 11:36) *
En plus, j'imagine qu'il ne passe pas par l'AppleAHCIPort.kext donc ça n'aurait probablement servi à rien.


Bon, pour détailler un peu les choses, j'ai :
dans ACPI/patched/
- SSDT.aml

dans driver64UEFI
- AppleImageCodec-64.efi
- AppleKeyAggregator-64.efi
- AppleUITheme-64.efi
- DataHubDxe-64.efi
- FirmwareVolume-64.efi
- FSInject-64.efi
- HFSPlus.efi
- OsxAptioFixDrv-64.efi
- OsxFatBinaryDrv-64.efi
- SMCHelper-64.efi
- VBoxHfs-64.efi

dans kexts/Other :
- AppleALC.kext
- FakeSMC.kext
- HackrNVMeFamily-10_12_6.kext
- IntelMausiEthernet.kext
- Lilu.kext
- NvidiaGraphicsFixup.kext
- X99_Injector USB 3.kext

Et je vous ai mis un zip avec mes fichiers config.plist et ssdt.aml.
Manque-t-il quelque chose pour que votre information soit complète ?
Merci en tout cas pour votre aide !


--------------------
::: jeanba ::: work ::: photo :::

Il existe une malédiction qui dit : « Puisses-tu vivre des moments passionnants. »
Go to the top of the page
 
+Quote Post
jeanchrijaz
posté 28 Jul 2017, 22:08
Message #47


Macbidouilleur d'Or !
*****

Groupe : Modérateurs
Messages : 1 649
Inscrit : 22 Sep 2015
Lieu : Aix-en-Provence (France)
Membre no 196 549



rapidement...
déjà dans ACPI/patched il te manque un fichier SSDT : SSDT-NVMe-Pcc.aml
le fichier qui te sert pour faire reconnaitre ton M.2 NVme sur les bonnes lignes ACPI ... je pense que ton erreur vient de la...
tu as juste le kext mais ca ne suffit pas

pour le code donné un peu plus haut je me suis trompé... (en plus il y est déjà dans ton config.plist)
je rentrai de soirée et j'ai copié n'importe quoi (en vrac lol)
et celui que t'a donné polyzargone n'a aucun effet sur les NVme
mais bon tu devrais quand même mettre ton dossier CLOVER complet sur un serveur pour qu'on puisse y jeter un œil (même 2)

pour tes moniteurs, je pense que c'est plutot ta carte son qui déconne un peu....
tu utilises quoi comme carte, interne ou USB?

Ce message a été modifié par jeanchrijaz - 28 Jul 2017, 22:25.


--------------------
iPhone XS 256 Go Apple TV 4 32 Go Macbook Pro Touch Bar 13" | 2017 | Core i5 | SSD NVme 512 Go | 16 Go de Ram | macOS High Sierra 10.13.6 |

Hackintosh : SMBIOS iMac 14,2 |
🍀 Clover r4700 | macOS Sierra 10.12.6 (16G1510) | Présentation ici |
__Carte mère : Asus Z97-Pro (wifi-ac) • CPU : Core i7 4790K • Ram : 32 Go (4 x 8 Go) 2133Mhz • CG : EVGA GTX 1080 FTW
__• 2 x moniteurs 27" WQHD (2560 x 1440) • Carte combo PCI-E
BCM94360CSAX
Carte son : AVID Pro Tools Quartet (Apogee)
Disque Système : 960 EVO 250 Go NVme | Disque de Rendus : 950 PRO 256 Go NVme | Disque Cache : 850 EVO 500 Go | Stockage interne : 3 x 3 To en Raid 0

_ NO WINDOWS BOOT... Only


Politique vis à vis des outils automatisés - FAQ Générale du Hackintosh - FAQ des Bootloaders - FAQ des Bootflags - FAQ des problèmes les plus courants - Guide d'installation

Go to the top of the page
 
+Quote Post
polyzargone
posté 10 Aug 2017, 18:31
Message #48


Macbidouilleur d'Or !
*****

Groupe : Modérateurs
Messages : 9 884
Inscrit : 11 May 2006
Membre no 60 938



Pour l'icône, va voir ici : https://pikeralpha.wordpress.com/2016/07/01...up-as-external/


--------------------
Un MacmacOS 10.13 MacBook Air mi-2012 Core i5 1,7 GHz Intel HD 4000 SSD 64 Go
Des Hacks Gigabyte GA-H97-HD3 - Core i5 4570 3,20 GHz - Zotac Geforce GTX 1060 6 Go - 16 Go DDR3 - macOS 10.14/macOS 10.13.6/macOS 10.12/OS X 10.11.6/Win 10/Mint 18 Acer Aspire V3 772G Core i5 4210M 2,60 GHz - Intel HD 4600 + GTX 850M 2 Go (désactivée) - 16 Go DDR3 - macOS 10.14/macOS 10.13.6/macOS 10.12/Win 10/Mint 18 Dell Latitude e7440 Core i7 4600U 2,10 GHz - Intel HD 4400 - 16 Go DDR3 - macOS 10.14/macOS 10.13.6/Win 10 Medion MS-7616 - Core i5 650 3,20 GHz - Gainward GTX 650 Ti 2 Go - 8 Go DDR3 - macOS 10.14/macOS 10.13.6/Win 10 HP Elite 8300 USFF - Core i7 3770S 3,90 GHz - Intel HD 4000 - macOS 10.12/Win 10 - Clover (+ quelques autres...)

Politique vis à vis des outils automatisés et des distributions - Guide d'installation - Tutoriels - Lexique et utilité des Kexts - FAQ Générale du Hackintosh - FAQ des Bootloaders - FAQ des Bootflags - FAQ des problèmes les plus courants
Go to the top of the page
 
+Quote Post
jeanba3000
posté 12 Jul 2018, 12:24
Message #49


Macbidouilleur de bronze !
**

Groupe : Membres
Messages : 370
Inscrit : 23 Apr 2002
Lieu : paname 20e rules !
Membre no 2 321



Salut les gens !

J'ai profité d'un creux en ce début d'été pour me replonger dans le projet de passer à High Sierra pour voir si l'herbe y serait plus verte…

Grâce à ce remarquable tuto et quelques ajustements en partant encore d'un système pré-installé depuis un autre Mac sur un SSD dédié, ça s'est fait sans trop de difficultés et en une soirée (contrairement à toutes mes précédentes tentatives avortées de l'année passée).
J'ai donc enfin mon SSD M2 qui est reconnu comme interne avec les débits qui vont bien (AJA oscille entre 2000 et 3000 MB/s en lecture), l'audio qui fonctionne parfaitement sans bruit parasite. J'ai même tâté de l'overclock, qui plafonne avec mon exemplaire à 4,4 GHz.

Chose curieuse : sur Geekbench j'obtiens des scores inférieurs en single-core et supérieurs en multi-core aux résultats que j'avais initialement publiés :
4720 / 22495 et maintenant 4098 / 25904. On avait vu que le seul passage de 10.9.5 à 10.11.6 avait bien changé la donne, se pourrait-il que ce soit la même chose avec le passage à 10.13.5 ? Le changement d'identification de machine (iMac14,2 => iMacPro1,1) aurait-il également joué ?
Interrogation toute rhétorique car en pratique ça ne devrait pas me changer la vie.

En attendant la machine me semble plus stable qu'avant, mais ce n'est qu'un ressenti. Je vais être attentif à la manière dont tournent mes outils quotidiens, After Effect en tête, et désormais Cinema 4D pour lequel je viens de terminer une formation.

Au chapitre des désagréments sur lesquels je dois me pencher un peu plus et fureter le net pour les solutionner :
- J'ai deux écrans connectés à ma carte graphique, un 27" en display port et un 17" en DVI ; depuis un moment si je ne débranche pas le câble DP au démarrage, j'obtiens un écran noir. Heureusement je ne redémarre pas souvent dans l'année.
- J'avais un souci occasionnel mais récurrent d'impossibilité de sortie d'économiseur d'écran qui m'obligeait à forcer le redémarrage de la machine, je vais vérifier si ça le fait encore ou pas, et le cas échéant chercher une solution.


--------------------
::: jeanba ::: work ::: photo :::

Il existe une malédiction qui dit : « Puisses-tu vivre des moments passionnants. »
Go to the top of the page
 
+Quote Post

2 Pages V  < 1 2
Reply to this topicStart new topic
1 utilisateur(s) sur ce sujet (1 invité(s) et 0 utilisateur(s) anonyme(s))
0 membre(s) :

 



Nous sommes le : 19th October 2018 - 06:51