IPB

Bienvenue invité ( Connexion | Inscription )

 
Reply to this topicStart new topic
> OptiPlex 780 SFF - High Sierra 10.13.4, Un hackintosh fonctionnel à très très petit prix
Options
PandaStirling
posté 5 Apr 2018, 05:34
Message #1


Nouveau Membre


Groupe : Membres
Messages : 15
Inscrit : 6 Oct 2015
Membre no 196 708



Salut !
Alors mon hackintosh...
Un Dell OptiPlex 780 SFF acheté à 60€ pour remplacer mon Mac Mini Fin 2009, qui lui a été vendu pour 150€.
Donc, les specs:
Intel Core 2 Duo E8400@3,00GHz (que je vais probablement upgrader en Core 2 Quad)
ATI Radeon HD 5450 1Go (je l'avais déjà de base)
6Go de RAM DDR3 1600MHz (Venais avec 4Go de base, supporte jusqu'a 16Go de RAM)
HDD 1To Seagate 7200 trs/min (pris d'une tour Packard Bell qui a fini ko)
OS X El Capitan (j'ai essayé d'installer Sierra avec un guide sur InsanelyMac, mais n'ayant pas réussi, j'ai remis ça a plus tard, et puis je suis pas sur que la 5450 fonctionne sous Sierra)
SMBIOS: iMac10,1
Donc, pour 60€, j'ai un hackintosh, certes peu performant comparé aux machines d'aujourd'hui, mais pour mon usage (Navigation, écriture, bureautique, edition légère sur Photoshop, montage léger sur Final Cut Pro X, et création Tekno sur Logic Pro X), ça marche étonnement bien !
C'est un ordi de fin 2009/début 2010 qui venais avec Windows 7, mais qui supporte l'EFI (ça parait évident, pourtant mes précedent Optiplex n'avais qu'un BIOS classique)
OS X fonctionne presque nativement dessus, avec Clover, les kext de base (FakeSMC, ect)+un kext pour l'ethernet, et après avoir configuré Clover pour faire passé la carte comme suportée nativement (en spoofant le DeviceID) j'ai un hackintosh fonctionnel !
Il est super stable, j'ai jamais eu aucun plantage ou kernel panic avec (sous OS X une fois installé), en utilisation quotidienne (18h par jours: de 12h à 6h, presque tout les jours, ceci dit avec des temps d'idle puis-que je ne passe pas toute mes journée sur mon PC, mais je l'allume quand je me lève, et l'éteint quand je me couche)
Je dirais que la gamme Optiplex est un très bon moyen d'avoir un Hackintosh pour un très petit coût (pour ceux voulant découvrir OS X sans pour autant switcher), pour moi, n'ayant que 16 ans (donc le financement peut être un problème), c'est parfait.
Voilà le guide que j'ai utilisé (avec les même kext, ect): https://www.insanelymac.com/forum/forums/to...60-755-790-990/
Si ça vous intéresse (et parce-que j'aime bien raconter ma vie héhé), je peut faire un historique de tout mes hackintosh au fil du temps x)
Le seul problème que j'ai eu c'est avec mon SSD (que j'ai mis dans mon MacBook Pro a cause de ce problème), il fonctionne une fois sur 30, en gros une fois démarré, soit il va être détecté dans le BIOS, donc il va démarrer, soit il ne va pas être détecté, je crois que c'est un problème avec le controlleur du SSD qui envoi la commande SATA (pour montrer qu'il est présent) trop tard, lorsque le contrôleur SATA du PC a fini sa recherche de périphérique, ceci dit aucun problème dans mon MacBook, donc bon)
Voilà voilà biggrin.gif


Ce message a été modifié par PandaStirling - 6 Apr 2018, 07:56.


--------------------
OptiPlex 780 SFF, BIOS A14, C2D E8400 3.00GHz, 8Go DDR3-1600, Sapphire Radeon HD 5450 1GB, 1To Seagate Barracuda HDD, Samsung 40" TV 1920x1080, El Capitan 10.11.6
HP Pavilion dv9700, C2D 2,0GHz, 4Go DDR2-800, Nvidia GeForce 8600M GS, 320Go Hitachi HDD, 17,3" 1600x900, Windows 7
Xiaomi Redmi Note 3 Pro - Android 8.1 (PixelExperience ROM, basé sur AOSP)
iPad 2 Blanc 16Go - iOS 9.3.5
Go to the top of the page
 
+Quote Post
PandaStirling
posté 6 Apr 2018, 02:40
Message #2


Nouveau Membre


Groupe : Membres
Messages : 15
Inscrit : 6 Oct 2015
Membre no 196 708



UPDATE:
Upgrade sous High Sierra 10.13.4 réussie !
Tout fonctionne (après l'installation des kexts graphiques de Sierra pour la 5450), même l'audio à travers l'HDMI (fonctionne OOB avec les kexts)


--------------------
OptiPlex 780 SFF, BIOS A14, C2D E8400 3.00GHz, 8Go DDR3-1600, Sapphire Radeon HD 5450 1GB, 1To Seagate Barracuda HDD, Samsung 40" TV 1920x1080, El Capitan 10.11.6
HP Pavilion dv9700, C2D 2,0GHz, 4Go DDR2-800, Nvidia GeForce 8600M GS, 320Go Hitachi HDD, 17,3" 1600x900, Windows 7
Xiaomi Redmi Note 3 Pro - Android 8.1 (PixelExperience ROM, basé sur AOSP)
iPad 2 Blanc 16Go - iOS 9.3.5
Go to the top of the page
 
+Quote Post
polyzargone
posté 8 Apr 2018, 10:31
Message #3


Macbidouilleur d'Or !
*****

Groupe : Modérateurs
Messages : 9 825
Inscrit : 11 May 2006
Membre no 60 938



Salut et merci pour ton retour !

En effet, les Optiplex 7xx/9xx sont de très bon candidats au "Hackintoshing" et bien configurés, ils fonctionnent à 100% !

Mon premier Hackintosh, ça a été un 760 SFF et il continue toujours de fonctionner sans aucun problème (hormis l'alimentation qui a lâché mais que j'ai pu remplacer facilement).

Par curiosité, est-ce que tu pourrais poster ton dossier EFI/CLOVER ?


--------------------
Un MacmacOS 10.13 MacBook Air mi-2012 Core i5 1,7 GHz Intel HD 4000 SSD 64 Go
Des Hacks Gigabyte GA-H97-HD3 - Core i5 4570 3,20 GHz - Zotac Geforce GTX 1060 6 Go - 16 Go DDR3 - macOS 10.14/macOS 10.13.6/macOS 10.12/OS X 10.11.6/Win 10/Mint 18 Acer Aspire V3 772G Core i5 4210M 2,60 GHz - Intel HD 4600 + GTX 850M 2 Go (désactivée) - 16 Go DDR3 - macOS 10.14/macOS 10.13.6/macOS 10.12/Win 10/Mint 18 Dell Latitude e7440 Core i7 4600U 2,10 GHz - Intel HD 4400 - 16 Go DDR3 - macOS 10.14/macOS 10.13.6/Win 10 Medion MS-7616 - Core i5 650 3,20 GHz - Gainward GTX 650 Ti 2 Go - 8 Go DDR3 - macOS 10.14/macOS 10.13.6/Win 10 HP Elite 8300 USFF - Core i7 3770S 3,90 GHz - Intel HD 4000 - macOS 10.12/Win 10 - Clover (+ quelques autres...)

Politique vis à vis des outils automatisés et des distributions - Guide d'installation - Tutoriels - Lexique et utilité des Kexts - FAQ Générale du Hackintosh - FAQ des Bootloaders - FAQ des Bootflags - FAQ des problèmes les plus courants
Go to the top of the page
 
+Quote Post
PandaStirling
posté 12 Apr 2018, 16:32
Message #4


Nouveau Membre


Groupe : Membres
Messages : 15
Inscrit : 6 Oct 2015
Membre no 196 708



Salut !
Effectivement, je suis passé par des Optiplex 740 (DT/AMD), 745 (DT), 755 (DT et MT) et 780 (SFF), tous facilement hackintoshable biggrin.gif
Mais pour ma part, mon premier hackintosh fut un vieux HP Pavilion avec un Core 2 Duo, a tourné de 10.5 à 10.10 ceci dit, avec une GT610 (GMA 950 sous 10.5/10.6)
Voilà, avec kext pour 10.11, 10.12, 10.13, le DSDT pour le 780/HD5450, SMBIOS iMac10,1 et j'ajoute à ça les kext a installer (à partir d'une autre version de macOS, car HS boot sur un écran noir après installation sans ces kexts, peut-être que ça fonctionne en les mettant dans /EFI/Clover/kexts/10.13, mais j'ai pas essayé ceci dit) pour la HD5450
https://drive.google.com/open?id=1BL2ur3qTp...fgYDjR7kesTrkO4
Tuto utilisé: https://www.insanelymac.com/forum/forums/to...60-755-790-990/
Ceci dit je previens, la 5450 fonctionne, mais glitch un peu sur HS, rien de bien gênant, l'interface est fluide et tout, mais à l'écran de login, il arrive que l'arrière plan soit rouge au lieu du fond d'écran, et quand je maximise une vidéo YouTube, j'ai un écran rouge au lieu de l'animation (qui dure qu'une demi seconde), et dans l'appli photo, il arrive que j'ai un carré rouge/bleu sur une partie de la photo, voir toute la photo, mais ça disparait en changeant de photo et en y revenant (si j'arrive a me faire comprendre)

Ce message a été modifié par PandaStirling - 12 Apr 2018, 16:59.


--------------------
OptiPlex 780 SFF, BIOS A14, C2D E8400 3.00GHz, 8Go DDR3-1600, Sapphire Radeon HD 5450 1GB, 1To Seagate Barracuda HDD, Samsung 40" TV 1920x1080, El Capitan 10.11.6
HP Pavilion dv9700, C2D 2,0GHz, 4Go DDR2-800, Nvidia GeForce 8600M GS, 320Go Hitachi HDD, 17,3" 1600x900, Windows 7
Xiaomi Redmi Note 3 Pro - Android 8.1 (PixelExperience ROM, basé sur AOSP)
iPad 2 Blanc 16Go - iOS 9.3.5
Go to the top of the page
 
+Quote Post
Patrice Broussea...
posté 13 Apr 2018, 03:03
Message #5


Macbidouilleur de bronze !
**

Groupe : Membres
Messages : 269
Inscrit : 18 Jan 2015
Membre no 193 846



Les couleurs "hallucinogènes " sont bien documentées sur certaines cartes AMD depuis 10.12.4. Impossible de les faire disparaître à l'écran de login (question de 10 bits vs 8 bits je crois...). Mais tout de même bravo pour un Hackintosh à petit prix!


--------------------
Hackintosh • Gigabyte GA-Z97X-UD3H Core i7 4790 3,6Ghz - GTX 950 - 16 Go DDR3 - OS X 10.12.6 (2 partitions)/Win 10 - Clover
Hackintosh dédié MAO • Dell Optiplex 9020 mini-tour i7 4770 3,4GHz - GT 710 - 16 Go DDR3 - OS X 10.12.6/Win 10 - Clover
Go to the top of the page
 
+Quote Post
polyzargone
posté 14 Apr 2018, 13:26
Message #6


Macbidouilleur d'Or !
*****

Groupe : Modérateurs
Messages : 9 825
Inscrit : 11 May 2006
Membre no 60 938



Citation (PandaStirling @ 5 Apr 2018, 06:34) *
C'est un ordi de fin 2009/début 2010 qui venais avec Windows 7, mais qui supporte l'EFI (ça parait évident, pourtant mes précedent Optiplex n'avais qu'un BIOS classique)


Euh non tongue.gif !

Les Optiplex 780 ne supportent pas l'UEFI. Sauf erreur de ma part et grosse différence avec les Optiplex 7xx précédents, c'est aussi un Bios classique.

Peut-être que tu crois que c'est le cas parce que Clover permet de simuler un bios UEFI complet alors qu'en fait, c'est bien un Bios Legacy traditionnel unsure.gif.

Citation (PandaStirling @ 5 Apr 2018, 06:34) *
Si ça vous intéresse (et parce-que j'aime bien raconter ma vie héhé), je peut faire un historique de tout mes hackintosh au fil du temps x)


Pourquoi pas !

C'est à ça que sert la section Votre Hackintosh biggrin.gif.

Ceci dit, il vaudra mieux faire 1 sujet par Hackintosh wink.gif.

Citation (PandaStirling @ 12 Apr 2018, 17:32) *
Voilà, avec kext pour 10.11, 10.12, 10.13, le DSDT pour le 780/HD5450, SMBIOS iMac10,1 et j'ajoute à ça les kext a installer (à partir d'une autre version de macOS, car HS boot sur un écran noir après installation sans ces kexts, peut-être que ça fonctionne en les mettant dans /EFI/Clover/kexts/10.13, mais j'ai pas essayé ceci dit) pour la HD5450
https://drive.google.com/open?id=1BL2ur3qTp...fgYDjR7kesTrkO4


Il y a quelques petites "erreurs" (rien de méchant) dans ton dossier CLOVER. Je te propose d'essayer celui-ci à partir d'une clé de boot pour démarrer macOS :

https://drive.google.com/open?id=1nEE0RZvZn...FJ4Q6I9ijclESnc

Citation (PandaStirling @ 12 Apr 2018, 17:32) *
Ceci dit je previens, la 5450 fonctionne, mais glitch un peu sur HS, rien de bien gênant, l'interface est fluide et tout, mais à l'écran de login, il arrive que l'arrière plan soit rouge au lieu du fond d'écran, et quand je maximise une vidéo YouTube, j'ai un écran rouge au lieu de l'animation (qui dure qu'une demi seconde), et dans l'appli photo, il arrive que j'ai un carré rouge/bleu sur une partie de la photo, voir toute la photo, mais ça disparait en changeant de photo et en y revenant (si j'arrive a me faire comprendre)


Pour High Sierra, le mieux est de changer la Radeon HD 5450 par une NVIDIA pas trop chère. Une GT 710 par exemple.


--------------------
Un MacmacOS 10.13 MacBook Air mi-2012 Core i5 1,7 GHz Intel HD 4000 SSD 64 Go
Des Hacks Gigabyte GA-H97-HD3 - Core i5 4570 3,20 GHz - Zotac Geforce GTX 1060 6 Go - 16 Go DDR3 - macOS 10.14/macOS 10.13.6/macOS 10.12/OS X 10.11.6/Win 10/Mint 18 Acer Aspire V3 772G Core i5 4210M 2,60 GHz - Intel HD 4600 + GTX 850M 2 Go (désactivée) - 16 Go DDR3 - macOS 10.14/macOS 10.13.6/macOS 10.12/Win 10/Mint 18 Dell Latitude e7440 Core i7 4600U 2,10 GHz - Intel HD 4400 - 16 Go DDR3 - macOS 10.14/macOS 10.13.6/Win 10 Medion MS-7616 - Core i5 650 3,20 GHz - Gainward GTX 650 Ti 2 Go - 8 Go DDR3 - macOS 10.14/macOS 10.13.6/Win 10 HP Elite 8300 USFF - Core i7 3770S 3,90 GHz - Intel HD 4000 - macOS 10.12/Win 10 - Clover (+ quelques autres...)

Politique vis à vis des outils automatisés et des distributions - Guide d'installation - Tutoriels - Lexique et utilité des Kexts - FAQ Générale du Hackintosh - FAQ des Bootloaders - FAQ des Bootflags - FAQ des problèmes les plus courants
Go to the top of the page
 
+Quote Post
Patrice Broussea...
posté 14 Apr 2018, 16:08
Message #7


Macbidouilleur de bronze !
**

Groupe : Membres
Messages : 269
Inscrit : 18 Jan 2015
Membre no 193 846



Je plussoie pour la GT710, bon petit GPU de base qui fonctionne avec ou sans les webdrivers.


--------------------
Hackintosh • Gigabyte GA-Z97X-UD3H Core i7 4790 3,6Ghz - GTX 950 - 16 Go DDR3 - OS X 10.12.6 (2 partitions)/Win 10 - Clover
Hackintosh dédié MAO • Dell Optiplex 9020 mini-tour i7 4770 3,4GHz - GT 710 - 16 Go DDR3 - OS X 10.12.6/Win 10 - Clover
Go to the top of the page
 
+Quote Post
jeanchrijaz
posté 14 Apr 2018, 17:28
Message #8


Macbidouilleur d'Or !
*****

Groupe : Modérateurs
Messages : 1 645
Inscrit : 22 Sep 2015
Lieu : Aix-en-Provence (France)
Membre no 196 549



Citation (Patrice Brousseau @ 14 Apr 2018, 17:08) *
Je plussoie pour la GT710, bon petit GPU de base qui fonctionne avec ou sans les webdrivers.

personnellement pour le même prix en occasion, quitte à choisir je préfère une GTX 285
ok elle consomme beaucoup plus (204w contre 27w)
mais elle est aussi 20 fois plus performante que la GT710 (oui oui 20 fois)


--------------------
iPhone 6s 64 Go Apple TV 4 32 Go Macbook Pro Touch Bar 13" | 2017 | Core i5 | SSD NVme 512 Go | 16 Go de Ram | macOS High Sierra 10.13.6 |

Hackintosh : SMBIOS iMac 14,2 |
🍀 Clover r4674 | macOS Sierra 10.12.6 (16G1510) | Présentation ici |
__Carte mère : Asus Z97-Pro (wifi-ac) • CPU : Core i7 4790K • Ram : 32 Go (4 x 8 Go) 2133Mhz • CG : EVGA GTX 1080 FTW
__• 2 x moniteurs 27" WQHD (2560 x 1440) • Carte combo PCI-E
BCM94360CSAX
Carte son : AVID Pro Tools Quartet (Apogee)
Disque Système : 960 EVO 250 Go NVme | Disque de Rendus : 950 PRO 256 Go NVme | Disque Cache : 850 EVO 500 Go | Stockage interne : 3 x 3 To en Raid 0

_ NO WINDOWS BOOT... Only


Politique vis à vis des outils automatisés - FAQ Générale du Hackintosh - FAQ des Bootloaders - FAQ des Bootflags - FAQ des problèmes les plus courants - Guide d'installation

Go to the top of the page
 
+Quote Post
polyzargone
posté 14 Apr 2018, 18:01
Message #9


Macbidouilleur d'Or !
*****

Groupe : Modérateurs
Messages : 9 825
Inscrit : 11 May 2006
Membre no 60 938



Citation (jeanchrijaz @ 14 Apr 2018, 18:28) *
personnellement pour le même prix en occasion, quitte à choisir je préfère une GTX 285


Elle ne rentrera pas dans un Optiplex 780 SFF (Small Form Factor) tongue.gif !

Le boîtier, c'est ça à l'intérieur :



Et je doute que l'alimentation suive de toute manière…


--------------------
Un MacmacOS 10.13 MacBook Air mi-2012 Core i5 1,7 GHz Intel HD 4000 SSD 64 Go
Des Hacks Gigabyte GA-H97-HD3 - Core i5 4570 3,20 GHz - Zotac Geforce GTX 1060 6 Go - 16 Go DDR3 - macOS 10.14/macOS 10.13.6/macOS 10.12/OS X 10.11.6/Win 10/Mint 18 Acer Aspire V3 772G Core i5 4210M 2,60 GHz - Intel HD 4600 + GTX 850M 2 Go (désactivée) - 16 Go DDR3 - macOS 10.14/macOS 10.13.6/macOS 10.12/Win 10/Mint 18 Dell Latitude e7440 Core i7 4600U 2,10 GHz - Intel HD 4400 - 16 Go DDR3 - macOS 10.14/macOS 10.13.6/Win 10 Medion MS-7616 - Core i5 650 3,20 GHz - Gainward GTX 650 Ti 2 Go - 8 Go DDR3 - macOS 10.14/macOS 10.13.6/Win 10 HP Elite 8300 USFF - Core i7 3770S 3,90 GHz - Intel HD 4000 - macOS 10.12/Win 10 - Clover (+ quelques autres...)

Politique vis à vis des outils automatisés et des distributions - Guide d'installation - Tutoriels - Lexique et utilité des Kexts - FAQ Générale du Hackintosh - FAQ des Bootloaders - FAQ des Bootflags - FAQ des problèmes les plus courants
Go to the top of the page
 
+Quote Post
jeanchrijaz
posté 14 Apr 2018, 20:24
Message #10


Macbidouilleur d'Or !
*****

Groupe : Modérateurs
Messages : 1 645
Inscrit : 22 Sep 2015
Lieu : Aix-en-Provence (France)
Membre no 196 549



outch effectivement....
je ne voyais pas ça si petit


--------------------
iPhone 6s 64 Go Apple TV 4 32 Go Macbook Pro Touch Bar 13" | 2017 | Core i5 | SSD NVme 512 Go | 16 Go de Ram | macOS High Sierra 10.13.6 |

Hackintosh : SMBIOS iMac 14,2 |
🍀 Clover r4674 | macOS Sierra 10.12.6 (16G1510) | Présentation ici |
__Carte mère : Asus Z97-Pro (wifi-ac) • CPU : Core i7 4790K • Ram : 32 Go (4 x 8 Go) 2133Mhz • CG : EVGA GTX 1080 FTW
__• 2 x moniteurs 27" WQHD (2560 x 1440) • Carte combo PCI-E
BCM94360CSAX
Carte son : AVID Pro Tools Quartet (Apogee)
Disque Système : 960 EVO 250 Go NVme | Disque de Rendus : 950 PRO 256 Go NVme | Disque Cache : 850 EVO 500 Go | Stockage interne : 3 x 3 To en Raid 0

_ NO WINDOWS BOOT... Only


Politique vis à vis des outils automatisés - FAQ Générale du Hackintosh - FAQ des Bootloaders - FAQ des Bootflags - FAQ des problèmes les plus courants - Guide d'installation

Go to the top of the page
 
+Quote Post
PandaStirling
posté 15 Apr 2018, 00:21
Message #11


Nouveau Membre


Groupe : Membres
Messages : 15
Inscrit : 6 Oct 2015
Membre no 196 708



Salut !
Alors @polyzargone je m'en vais de ce pas tester ton dossier patché, mais j'ai remarqué qu'il n'y a pas des kext FakeSMC, ect.. dans les dossiers 10.11/10.12/10.13, normal ? Est-ce que Clover n'a besoin de les patcher qu'une seule fois ou à chaque démarrage ?
Il ne supporte pas l'EFI ? Etrange, je t'avoue que j'installe CloverEFI sur la partition EFI de mon SSD/HDD/USB, il démarre bien dessus sans soucis. Je pensais surtout ça à cause du Setup qui est un peu plus "graphique" et peut-être utilisé avec une souris, mais je viens de vérifier sur un forum Dell, ils disent que l'EFI n'a été introduit qu'a partir des 390/790. Enfin bon, EFI ou pas, peut-importe, tant que ça fonctionne x)

En attendant d'investir dans une meilleure carte graphique, j'ai foutu le SSD du MacBook (bien qu'il a du mal a se faire détecté, deux/trois essai ou un arrêt au secteur permet d'être détecté, et là je le laisse allumé) c'est fou la fluidité que ça apporte quand même..
Et j'ai downgrader à Sierra du coup, les glitches graphique était assez embêtant (peu esthétique), la sortie de veille complètement foireuse, et aussi la lenteur, Google Chrome crashais tout le temps, en faisant freeze tout l'OS en même temps (plus rien ne répond, "Forcer à quitter" complètement inefficace, reboot de force)

C'est déjà mieux sous Sierra, pas de glitches ou quoi, alors je vais m'en "contenter" en attendant ^^

Ce message a été modifié par PandaStirling - 15 Apr 2018, 16:32.


--------------------
OptiPlex 780 SFF, BIOS A14, C2D E8400 3.00GHz, 8Go DDR3-1600, Sapphire Radeon HD 5450 1GB, 1To Seagate Barracuda HDD, Samsung 40" TV 1920x1080, El Capitan 10.11.6
HP Pavilion dv9700, C2D 2,0GHz, 4Go DDR2-800, Nvidia GeForce 8600M GS, 320Go Hitachi HDD, 17,3" 1600x900, Windows 7
Xiaomi Redmi Note 3 Pro - Android 8.1 (PixelExperience ROM, basé sur AOSP)
iPad 2 Blanc 16Go - iOS 9.3.5
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 utilisateur(s) sur ce sujet (1 invité(s) et 0 utilisateur(s) anonyme(s))
0 membre(s) :

 



Nous sommes le : 21st September 2018 - 17:17