IPB

Bienvenue invité ( Connexion | Inscription )

 
Reply to this topicStart new topic
> Shazam restera gratuit et n'aura plus de publicité, Réactions à la publication du 26/09/2018
Options
Lionel
posté 26 Sep 2018, 06:14
Message #1


BIDOUILLE Guru
*****

Groupe : Admin
Messages : 52 118
Inscrit : 14 Jan 2001
Lieu : Paris
Membre no 3



Les autorités ont donné leur feu vert pour qu'Apple puisse racheter Shazam pour la somme de 400 millions de dollars.
Apple a annoncé que dorénavant ce logiciel, toujours gratuit, sera expurgé de sa publicité.

La société n'en a pas besoin. Shazam va devenir un vecteur très efficace pour convaincre ses utilisateurs de s'abonner à Apple Music. On ignore la forme que prendra cette incitation mais elle devrait permettre à Apple de refaire rapidement son retard sur Spotify.

Lien vers le billet original



--------------------
C'est parce que la vitesse de la lumière est plus grande que celle du son que tant de gens paraissent brillants avant d'avoir l'air con
Go to the top of the page
 
+Quote Post
CAMEO172
posté 26 Sep 2018, 08:42
Message #2


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 2 857
Inscrit : 16 Oct 2004
Lieu : Istres (13)
Membre no 25 295



je suis probablement trop vieux ou trop loin du coeur de la cible mais j'ai du mal à voir l'avantage déterminant d'Apple avec Shazam

Shazam permet de découvrir l'artiste derrière une écoute. De cette connaissance, on peut en faire ce que l'on veut. Pourquoi donc ça favoriserait Apple Music même si j'imagine le bouton qui vient bien sur Shazam pour faire la bascule vers Apple Music. ça restera un bouton.

Perso ça me sert soit à ajouter l'artiste dans un prochain Cd à acheter soit à basculer sur Spotify, et le futur ne changera rien de cette utilisation.
Même itunes est resté neutre pour moi, on peut l'utiliser en ayant rien à voir d'apple music

Ce message a été modifié par CAMEO172 - 26 Sep 2018, 08:43.


--------------------
Mon site photos de concert : Concerts en boite
Go to the top of the page
 
+Quote Post
ericb2
posté 26 Sep 2018, 09:16
Message #3


Macbidouilleur d'argent !
***

Groupe : Membres
Messages : 796
Inscrit : 16 Nov 2003
Membre no 11 701



Pourquoi ne pas faire son propre " Shazam "? smile.gif

=> https://github.com/bmoquist/Shazam
Go to the top of the page
 
+Quote Post
marc_os
posté 26 Sep 2018, 11:09
Message #4


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 6 091
Inscrit : 21 Apr 2006
Membre no 59 799



Citation (ericb2 @ 26 Sep 2018, 10:16) *
Pourquoi ne pas faire son propre " Shazam "? smile.gif

Pourquoi réinventer la roue ?

En tout cas, Shazam marche toujours sous iOS 7.
Comme quoi, quand on veut on peut.
Ils n'ont pas coupé leur service web aux "vieilles" versions comme l'ont fait les feignasses qui développent l'appli SNCF par exemple. sad.gif


--------------------
-----------------
--JE-------SUIS--
--AHMED-CHARLIE--
--CLARISSA-YOAV--
-----------------
Go to the top of the page
 
+Quote Post
Lionel
posté 26 Sep 2018, 12:10
Message #5


BIDOUILLE Guru
*****

Groupe : Admin
Messages : 52 118
Inscrit : 14 Jan 2001
Lieu : Paris
Membre no 3



Citation (marc_os @ 26 Sep 2018, 12:09) *
Citation (ericb2 @ 26 Sep 2018, 10:16) *
Pourquoi ne pas faire son propre " Shazam "? smile.gif

Pourquoi réinventer la roue ?

En tout cas, Shazam marche toujours sous iOS 7.
Comme quoi, quand on veut on peut.
Ils n'ont pas coupé leur service web aux "vieilles" versions comme l'ont fait les feignasses qui développent l'appli SNCF par exemple. sad.gif

On verra dans un an si ça continue avec Apple.


--------------------
C'est parce que la vitesse de la lumière est plus grande que celle du son que tant de gens paraissent brillants avant d'avoir l'air con
Go to the top of the page
 
+Quote Post
SartMatt
posté 26 Sep 2018, 13:34
Message #6


Macbidouilleur d'Or !
*****

Groupe : Rédacteurs
Messages : 30 135
Inscrit : 15 Nov 2005
Membre no 49 996



Citation (ericb2 @ 26 Sep 2018, 10:16) *
Pourquoi ne pas faire son propre " Shazam "? smile.gif
C'est bien joli d'avoir le code qui calcule la signature, mais sans la grosse base de données faisant la correspondance entre les signatures et les titres, ça ne sert pas à grand chose...
Go to the top of the page
 
+Quote Post
marc_os
posté 26 Sep 2018, 13:34
Message #7


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 6 091
Inscrit : 21 Apr 2006
Membre no 59 799



Citation (Lionel @ 26 Sep 2018, 13:10) *
Citation (marc_os @ 26 Sep 2018, 12:09) *
Citation (ericb2 @ 26 Sep 2018, 10:16) *
Pourquoi ne pas faire son propre " Shazam "? smile.gif

Pourquoi réinventer la roue ?

En tout cas, Shazam marche toujours sous iOS 7.
Comme quoi, quand on veut on peut.
Ils n'ont pas coupé leur service web aux "vieilles" versions comme l'ont fait les feignasses qui développent l'appli SNCF par exemple. sad.gif

On verra dans un an si ça continue avec Apple.

Avec la SNCF (ou plutôt probablement la SSII qui a bossé pour eux) et d'autres, y a pas eu besoin d'attendre, visiblement c'était trop leur demander que de respecter leur clients et de permettre à leurs "vielles" apps installées sur de vieux OS de continuer à bénéficier de leurs services. mad.gif
Et d'ici un, j'espère bien quand même ne plus avoir besoin d'iOS 7.

Ce message a été modifié par marc_os - 26 Sep 2018, 13:35.


--------------------
-----------------
--JE-------SUIS--
--AHMED-CHARLIE--
--CLARISSA-YOAV--
-----------------
Go to the top of the page
 
+Quote Post
SartMatt
posté 26 Sep 2018, 13:36
Message #8


Macbidouilleur d'Or !
*****

Groupe : Rédacteurs
Messages : 30 135
Inscrit : 15 Nov 2005
Membre no 49 996



Citation (marc_os @ 26 Sep 2018, 12:09) *
Ils n'ont pas coupé leur service web aux "vieilles" versions comme l'ont fait les feignasses qui développent l'appli SNCF par exemple. sad.gif
Si les feignasses qui développent l'OS ne passaient pas leur temps à mettre des battons dans les roues des développeurs tiers, il y aurait bien moins de soucis de compatibilité...

https://www.youtube.com/watch?v=0hz2cwhX4TM
Go to the top of the page
 
+Quote Post
marc_os
posté 26 Sep 2018, 17:51
Message #9


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 6 091
Inscrit : 21 Apr 2006
Membre no 59 799



Citation (SartMatt @ 26 Sep 2018, 14:36) *
Citation (marc_os @ 26 Sep 2018, 12:09) *
Ils n'ont pas coupé leur service web aux "vieilles" versions comme l'ont fait les feignasses qui développent l'appli SNCF par exemple. sad.gif
Si les feignasses qui développent l'OS ne passaient pas leur temps à mettre des battons dans les roues des développeurs tiers, il y aurait bien moins de soucis de compatibilité...

https://www.youtube.com/watch?v=0hz2cwhX4TM

Vi vi c'est ça. C'est pas Apple qui les a obligé à supprimer le service web utilisé par leur vieilles Apps !!!!
"Avant" je recevais mes billets achetés sur Internet dans leur App, puis un jour plus rien, sauf une notification demandant de mettre à jour l'App. Clic sur la notif, ouverture de l'App Store pour tomber sur une mise à jour de leur app réclamant iOS 8. sad.gif
Même s'ils avaient besoin de nouvelles API web pour leur nouvelle App, rien ne les obligeait à couper les anciennes API côté serveur ! Mon iPhone n'a pas changé, ni leur App installée dessus, ce qui a changé c'est leur serveur. Et s'ils ont donc coupé le service nécessaire à leur vieille App, c'est un choix volontaire de leur part et en aucun cas imposé par Apple. Et ce choix démontre juste leur mépris de leurs clients, voire leur incompétence (si ça se trouve leur dev ne savait pas ce que c'est qu'une vue en SQL).
Si c'est une SSII qui a fait le bazar, ça ne m'étonnerait absolument pas, vu qu'un jour une SSII pour qui je travaillais en sous-traitance m'a demandé de bâcler le travail que je faisait pour eux, le client final étant la RATP... (« Le process http sur le serveur web demande 1Go de mémoire pour fonctionner ? Pas grave, pas la peine d'optimiser !» Y avait "blue" dans le nom de cette SSII.) Et je me suis vite fait virer par ces imposteurs pour "incompatibilité d'humeur avec le chef de projet", ce qu'a guère apprécié ma SSII... Mais j'ai ma conscience professionnelle moi, jamais on ne m'obligera à produire de la merde.

Ce message a été modifié par marc_os - 26 Sep 2018, 17:54.


--------------------
-----------------
--JE-------SUIS--
--AHMED-CHARLIE--
--CLARISSA-YOAV--
-----------------
Go to the top of the page
 
+Quote Post
obs
posté 26 Sep 2018, 18:09
Message #10


Macbidouilleur de bronze !
**

Groupe : Membres
Messages : 419
Inscrit : 19 Nov 2014
Membre no 192 953



Citation (Lionel @ 26 Sep 2018, 07:14) *
La société n'en a pas besoin. Shazam va devenir un vecteur très efficace pour convaincre ses utilisateurs de s'abonner à Apple Music. On ignore la forme que prendra cette incitation mais elle devrait permettre à Apple de refaire rapidement son retard sur Spotify.

Donc traduction : Apple va remplacer la publicité pour des tiers contre de la publicité pour Apple. Qui revêtira une forme incitative.
Go to the top of the page
 
+Quote Post
SartMatt
posté 26 Sep 2018, 18:19
Message #11


Macbidouilleur d'Or !
*****

Groupe : Rédacteurs
Messages : 30 135
Inscrit : 15 Nov 2005
Membre no 49 996



Citation (marc_os @ 26 Sep 2018, 18:51) *
Citation (SartMatt @ 26 Sep 2018, 14:36) *
Citation (marc_os @ 26 Sep 2018, 12:09) *
Ils n'ont pas coupé leur service web aux "vieilles" versions comme l'ont fait les feignasses qui développent l'appli SNCF par exemple.
Si les feignasses qui développent l'OS ne passaient pas leur temps à mettre des battons dans les roues des développeurs tiers, il y aurait bien moins de soucis de compatibilité...

https://www.youtube.com/watch?v=0hz2cwhX4TM
Vi vi c'est ça. C'est pas Apple qui les a obligé à supprimer le service web utilisé par leur vieilles Apps !!!!
C'est Apple qui rend très compliqué de faire des nouvelles applications pouvant fonctionner avec les anciens OS.

Quand il y a une nouvelle application avec un nouveau backend, les éditeurs tiers ne peuvent pas maintenir l'ancien juste pour quelques utilisateurs ayant un vieil OS. Ce serait la ruine. Surtout que le changement de backend, ça peut parfois être parce qu'il est techniquement impossible de continuer avec l'ancien : matériel obsolète, logiciel en fin de support, failles de sécurité, fin de contrat avec un prestataire technique, certificats expirés...

Après soit l'éditeur de l'OS fait en sorte qu'il soit aisé de faire des applications compatibles à la fois avec les anciens OS et les nouveaux, soit il ne le fait pas. Et en l'occurrence, le SEUL éditeur d'OS majeur qui ne soit pas fichu de le faire, c'est Apple (et quand je dis "pas fichu", je sais très bien que c'est un choix, pas une incapacité hein... ce n'est pas un hasard si le seul à ne pas assurer de la rétrocompatibilité est aussi celui dont les bénéfices essentiellement de la vente de matériel...). Aujourd'hui, n'importe qui peut développer et distribuer une application pouvant fonctionner aussi bien sur Android 1.6 que sur Android 9 et aussi bien sur Windows 10 que sur Windows 95. Sous iOS, c'est impossible.

Sur l'OS d'en face, où Google fait son boulot correctement niveau rétrocompatibilité, la toute dernière version de l'application SNCF (sortie il y a 6 jours à peine) est compatible jusqu'à Android 4.1, sortie plus d'un an avant iOS 7.



Accessoirement, tu es énervant à toujours taper et dénigrer sur les "feignasses de développeur" sur des sujets où ils ne sont absolument pas responsables. Si tu savais un minimum comment fonctionne le monde du développement logiciel dans des grosses boîtes (je parle bien entendu pas du cas du développeur indépendant qui développe sa propre application, ou des toutes petites boîtes où les développeurs ont réellement du pouvoir), que ça soit en interne ou que ça soit externalisé, tu saurais que ce n'est en aucun cas le développeur qui peut prendre la décision d'abandonner le support d'une ancienne version du système, et encore moins parce qu'il a la flemme.

Éventuellement, il peut suggérer ça aux décideurs, avec des arguments, mais au final, c'est toujours quelqu'un d'autre que le développeur qui va prendre la décision, en fonction du coût que ça représente et du bénéfice que ça rapporte. En l'occurrence, le coût de conservation d'un vieux backend pour assurer la compatibilité avec un OS qui représente 0.6% du marché iOS, qui représente lui même environ 20% du marché des OS mobiles en France, c'était sans doute bien trop élevé par rapport au bénéfice que ça apporte, surtout que l'application SNCF est gratuite (rien à voir par exemple avec ce que rapport iOS à Apple, et qui lui donnerait donc largement les moyens de faire un peu d'efforts sur la rétrocompatibilité... mais Apple sait que ses clients sont tellement captifs que si elle ne fait aucun effort sur la rétrocompatibilité, ça se traduit par des ventes en plus) n'est absolument pas indispensable pour les usagers. Surtout qu'en plus Apple ne leur offre même pas la possibilité de continuer à distribuer cette ancienne version de l'appli, donc c'est uniquement pour ceux qui sont bloqués en iOS 7 et ont déjà téléchargé l'application.

Ce dernier point peut paraitre un détail, mais en réalité, ça n'en est pas un du tout : il n'est pas rare qu'une application embarque des certificats de sécurité. Or, tout bon certificat de sécurité a une date d'expiration et doit donc régulièrement être renouvelé. Si tu ne peux plus continuer à distribuer une ancienne version de l'application, ça implique que tous ceux qui ne sont pas passés à la nouvelle version vont finir par voir leurs certificats expirer, et l'application ne pourra plus fonctionner, même si le backend a maintenu une rétrocompatibilité.

Citation (marc_os @ 26 Sep 2018, 18:51) *
(si ça se trouve leur dev ne savait pas ce que c'est qu'une vue en SQL)
Mouarf, le pseudo argument technique qui tombe comme un cheveu sur la soupe et qui n'a sans aucun doute absolument aucun lien avec la réalité de ce qui a mené à la décision d'abandonner iOS 7 (sérieusement, tu imagines quand même pas que l'appli mobile se connecte directement à un serveur SQL et qu'une simple view permettrait d'assurer la rétrocompatibilité quand le backend change ? ).

Pose toi plutôt la question de ce qui justifie qu'une appli aussi basique puisse nécessiter au minimum iOS 8. La réponse, c'est le SDK mal foutu d'Apple. Et c'est pour ça que la nouvelle version de l'application n'a pas pu être proposée pour iOS 7 et antérieurs. Et c'est pour ça qu'iOS 7 a été abandonné, parce que sa faible part de marché ne justifiait pas l'effort financier à réaliser pour garder dans le nouveau backend une compatibilité avec l'ancien (ou pour garder l'ancien backend complet en parallèle du nouveau).


Citation (marc_os @ 26 Sep 2018, 18:51) *
Même s'ils avaient besoin de nouvelles API web pour leur nouvelle App, rien ne les obligeait à couper les anciennes API côté serveur !
C'est très rigolo ça comme argument, venant de quelqu'un qui est toujours là pour défendre Apple quand elle coupe les vieilles API sans vergogne et sans rien proposer pour aider les développeurs à assurer la rétrocompatibilité rolleyes.gif
Go to the top of the page
 
+Quote Post
malloc
posté 26 Sep 2018, 18:27
Message #12


Macbidouilleur de bronze !
**

Groupe : Membres
Messages : 533
Inscrit : 5 Sep 2004
Membre no 23 103



Citation
Citation ( @ 26 Sep 2018, 18:51) *
Même s'ils avaient besoin de nouvelles API web pour leur nouvelle App, rien ne les obligeait à couper les anciennes API côté serveur !
C'est très rigolo ça comme argument, venant de quelqu'un qui est toujours là pour défendre Apple quand elle coupe les vieilles API sans vergogne et sans rien proposer pour aider les développeurs à assurer la rétrocompatibilité rolleyes.gif


Faut quand même reconnaitre qu'en l'occurrence, la SNCF fait TRES FORT côté mises à jour obligatoires pour son appli!

A chaque fois que je prends le train (quelques fois par an, certes), l'appli refuse de se lancer et demande un MaJ obligatoire pour pouvoir ne serait-ce qu'afficher les réservations faites depuis le site web.

Je veux bien qu'ils changent leur back-end, mais enfin, tout péter 3x par ans, même Apple n'ose pas! Je trouve ça assez nul de n'accepter que des connexions venant de la dernière version, surtout que les mises à jour n'apportent quand même pas souvent de nouveautés flagrantes pour l'utilisateur...
Go to the top of the page
 
+Quote Post
SartMatt
posté 26 Sep 2018, 18:33
Message #13


Macbidouilleur d'Or !
*****

Groupe : Rédacteurs
Messages : 30 135
Inscrit : 15 Nov 2005
Membre no 49 996



Citation (malloc @ 26 Sep 2018, 19:27) *
Je veux bien qu'ils changent leur back-end, mais enfin, tout péter 3x par ans, même Apple n'ose pas! Je trouve ça assez nul de n'accepter que des connexions venant de la dernière version, surtout que les mises à jour n'apportent quand même pas souvent de nouveautés flagrantes pour l'utilisateur...
Peut-être une question de certificats de sécurité qui expirent... Parce que les billets de train dématérialisés, c'est quand même quelque chose de relativement sensible.

Ces mises à jour fréquentes, ce n'est un problème que quand ça fait perdre la compatibilité avec un vieil OS... Et ça c'est avant tout un problème de SDK.
Go to the top of the page
 
+Quote Post
malloc
posté 26 Sep 2018, 18:43
Message #14


Macbidouilleur de bronze !
**

Groupe : Membres
Messages : 533
Inscrit : 5 Sep 2004
Membre no 23 103



Citation (SartMatt @ 26 Sep 2018, 19:33) *
Citation (malloc @ 26 Sep 2018, 19:27) *
Je veux bien qu'ils changent leur back-end, mais enfin, tout péter 3x par ans, même Apple n'ose pas! Je trouve ça assez nul de n'accepter que des connexions venant de la dernière version, surtout que les mises à jour n'apportent quand même pas souvent de nouveautés flagrantes pour l'utilisateur...
Peut-être une question de certificats de sécurité qui expirent... Parce que les billets de train dématérialisés, c'est quand même quelque chose de relativement sensible.

Ces mises à jour fréquentes, ce n'est un problème que quand ça fait perdre la compatibilité avec un vieil OS... Et ça c'est avant tout un problème de SDK.


Oui probablement... mais c'est la plaie pour les utilisateurs. Lutter contre la contrefaçon de billets, pourquoi pas (même si visiblement les vérifications de validité se font en temps réel lors du controle, j'ai vu un passager se faire attraper pour un billet annulé l'autre jour), mais l'époque où les billets de train étaient en papier et non nominatifs n'est pas si loin.

Le problème est peut être de mon côté, faut que j'arrête d'essayer d'importer mes billets dans l'appli 5 minutes avant de partir... mais j'ai du mal à voir le progrès là-dedans en tant qu'usager non-fraudeur wink.gif
Go to the top of the page
 
+Quote Post
shawnscott
posté 26 Sep 2018, 19:03
Message #15


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 1 734
Inscrit : 7 Mar 2005
Lieu : Brabant Wallon, Belgique
Membre no 34 620



Citation (Lionel @ 26 Sep 2018, 12:10) *
On verra dans un an si ça continue avec Apple.

Le pire, c'est que ça pourrait bien arriver. On ne compte plus les logiciels acquis par Apple et jetés aux oubliettes par la suite; raison pour laquelle je privilégie désormais autant que possible les applications non-Apple.


--------------------
Utilisateur Apple (IIgs puis Macintosh) depuis 1988. Been There, Done That / Think Different / Our margin: 30%...
Go to the top of the page
 
+Quote Post
bigmechantmou
posté 26 Sep 2018, 21:05
Message #16


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 10 439
Inscrit : 16 Jul 2010
Lieu : Paris, Montmartre
Membre no 156 738



Lorsqu'on lance Shazam la première fois il indique d'appuyer pour le lancer, ensuite il demande d'autoriser l'utilisation du micro et enfin il demande d'autoriser à enregistrer des fichiers audio.

Ok et si ça s'enregistre à votre insu en achat itune par défaut, plus d'un va se faire avoir, qui lit les CGU en détail et quel % s'en sort déjà nickel avec des sociétés comme FB Google etc. dans les paramètres comptes perso qui en plus changent de façon floue en générale dans le temps ?

Dernier exemple en date avec l'activation de compte auto sous Chrome il y a quelques jours:
https://www.cnetfrance.fr/news/chrome-googl...ur-39874099.htm

Et pour lequel sous le tollé ils ont mis en place ce TRUC:
https://www.developpez.com/actu/226287/Chro...ication-Google/


--------------------

"Les virus sur mac c'est comme les extra-terrestres, certains en ont vu..."

----------------------

Mac mini 2Ghz rév mars 2009, SSD, 8Go ram (Snow Leopard).
Macbook Pro mid 2009. 13" 2,53Ghz, SSD, 4Go ram (Snow Leopard).
Powermac G4 Quicksilver 800Mhz, 1.5Go ram, carte ATI Radeon 9200, carte 2x sata, carte 5x USB (Tiger).
Go to the top of the page
 
+Quote Post
martremblay
posté 27 Sep 2018, 06:42
Message #17


Adepte de Macbidouille
*

Groupe : Membres
Messages : 161
Inscrit : 20 Dec 2017
Membre no 204 056



Citation (ericb2 @ 26 Sep 2018, 10:16) *
Pourquoi ne pas faire son propre " Shazam "? smile.gif

=> https://github.com/bmoquist/Shazam

l'iphone se vend à n'importe quel prix simplement parce qu'il s'appelle iphone.
Shazam est connu, applefric bénéficiera de son nom.
Aujourd'hui, ce n'est plus "ce que fait" ou "ce qu'est" ce que l'on vend, mais sa notoriété et son aura.
Cela a fonctionné un temps avec beats, qui bénéficiait d'une bonne image chez une partie de la population, malgré une qualité médiocre. Finalement, flop !
Go to the top of the page
 
+Quote Post
djdoxy
posté 27 Sep 2018, 09:13
Message #18


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 1 767
Inscrit : 17 Apr 2002
Lieu : Entre Nîmes et Montpellier
Membre no 2 280



Citation (shawnscott @ 26 Sep 2018, 20:03) *
Citation (Lionel @ 26 Sep 2018, 12:10) *
On verra dans un an si ça continue avec Apple.

Le pire, c'est que ça pourrait bien arriver. On ne compte plus les logiciels acquis par Apple et jetés aux oubliettes par la suite; raison pour laquelle je privilégie désormais autant que possible les applications non-Apple.

Meme chose pour moi.
D'ailleurs je cherche toujours de quoi remplacer iPhoto.
Coup de bol il marche encore sous Mojave, mais ca risque de ne pas durer.


--------------------
Heureux switcher depuis le 18/02/2005 mais désormais apostat: (applostat :) )
Hack Pro Core i7 (2.8Ghz/12Go) sur EX58-UD5 avec une GTX660 sous Mac OS X 10.10
Go to the top of the page
 
+Quote Post
marc_os
posté 27 Sep 2018, 11:10
Message #19


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 6 091
Inscrit : 21 Apr 2006
Membre no 59 799



Citation (SartMatt @ 26 Sep 2018, 19:19) *
Pose toi plutôt la question de ce qui justifie qu'une appli aussi basique puisse nécessiter au minimum iOS 8.

Avec tes grands discours, tu es totalement hors sujet.
Poses-toi plutôt la question de ce qui justifie qu'une appli qui fonctionne parfaitement sous iOS 7 (ou un OS quelconque) ne fonctionne plus du jour au lendemain parce que le serveur lui répond "niet, je ne te donnerai plus rien à toi, t'es trop vieille, il faut te mettre à jour"; alors que la veille le serveur voulait bien lui envoyer la référence des tickets achetés sur le net.
Rien n'a changé côté App, elle tourne parfaitement sans planter.
Ce qui a changé, c'est uniquement côté serveur SNCF.
Et c'est de la responsabilité unique de la SNCF, Apple, ton bouc émissaire préféré n'y est pour rien.

Ce message a été modifié par marc_os - 27 Sep 2018, 11:14.


--------------------
-----------------
--JE-------SUIS--
--AHMED-CHARLIE--
--CLARISSA-YOAV--
-----------------
Go to the top of the page
 
+Quote Post
Lionel
posté 27 Sep 2018, 11:17
Message #20


BIDOUILLE Guru
*****

Groupe : Admin
Messages : 52 118
Inscrit : 14 Jan 2001
Lieu : Paris
Membre no 3



Citation (marc_os @ 27 Sep 2018, 12:10) *
Citation (SartMatt @ 26 Sep 2018, 19:19) *
Pose toi plutôt la question de ce qui justifie qu'une appli aussi basique puisse nécessiter au minimum iOS 8.

Avec tes grands discours, tu es totalement hors sujet.
Poses-toi plutôt la question de ce qui justifie qu'une appli qui fonctionne parfaitement sous iOS 7 (ou un OS quelconque) ne fonctionne plus du jour au lendemain parce que le serveur lui répond "niet, je ne te donnerai plus rien à toi, t'es trop vieille, il faut te mettre à jour"; alors que la veille le serveur voulait bien lui envoyer la référence des tickets achetés sur le net.
Rien n'a changé côté App, elle tourne parfaitement sans planter.
Ce qui a changé, c'est uniquement côté serveur SNCF.
Et c'est de la responsabilité unique de la SNCF, Apple, ton bouc émissaire préféré n'y est pour rien.

Attends, tu attaques la SNCF pour ça alors qu'Apple fait bien pire dans le genre depuis des années ?


--------------------
C'est parce que la vitesse de la lumière est plus grande que celle du son que tant de gens paraissent brillants avant d'avoir l'air con
Go to the top of the page
 
+Quote Post
divoli
posté 27 Sep 2018, 11:41
Message #21


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 10 178
Inscrit : 15 May 2005
Membre no 39 209



Citation (marc_os @ 26 Sep 2018, 18:51) *
(...)

Je ne suis pas sûr d'avoir compris. Tu utilises un vieil iPhone, plus mis à jour depuis des lustres, pour faire des achats sur le net, notamment pour acheter tes billet SNCF ? Ou alors l'app en question ne te sert (servait) qu'à réceptionner les billets sous forme numérique ?

Si l'application sert également à acheter des billets, ne serait-ce pour des questions de sécurité je ne vois pas pourquoi le SNCF (ou toute autre entreprise commerciale) serait obligée de continuer à accepter des transactions financières avec du matériel qui n'est plus à jour.

Ce message a été modifié par divoli - 27 Sep 2018, 13:17.


--------------------
Go to the top of the page
 
+Quote Post
SartMatt
posté 27 Sep 2018, 13:05
Message #22


Macbidouilleur d'Or !
*****

Groupe : Rédacteurs
Messages : 30 135
Inscrit : 15 Nov 2005
Membre no 49 996



Citation (marc_os @ 27 Sep 2018, 12:10) *
Poses-toi plutôt la question de ce qui justifie qu'une appli qui fonctionne parfaitement sous iOS 7 (ou un OS quelconque) ne fonctionne plus du jour au lendemain parce que le serveur lui répond "niet, je ne te donnerai plus rien à toi, t'es trop vieille, il faut te mettre à jour"; alors que la veille le serveur voulait bien lui envoyer la référence des tickets achetés sur le net.
Justement, je me suis posé la question, et j'ai déjà donné plus haut des éléments de réponse : "Surtout que le changement de backend, ça peut parfois être parce qu'il est techniquement impossible de continuer avec l'ancien : matériel obsolète, logiciel en fin de support, failles de sécurité, fin de contrat avec un prestataire technique, certificats expirés..."

Et "Et c'est pour ça qu'iOS 7 a été abandonné, parce que sa faible part de marché ne justifiait pas l'effort financier à réaliser pour garder dans le nouveau backend une compatibilité avec l'ancien (ou pour garder l'ancien backend complet en parallèle du nouveau).".

Mais ça, ce ne serait pas un problème si l'application exploitant le nouveau backend était disponible pour iOS 7. Et cette indisponibilité sous iOS 7 de la nouvelle application, je suis prêt à parier que c'est dû au fait qu'Apple ne fait strictement aucun effort pour maximiser la compatibilité.

Citation (marc_os @ 27 Sep 2018, 12:10) *
Rien n'a changé côté App, elle tourne parfaitement sans planter.
Ce qui a changé, c'est uniquement côté serveur SNCF.
Il est totalement faux de dire que rien a changé côté Apple. Il y a eu des changements côté Apple qui font que la SNCF n'est pas en mesure de reporter sous iOS 7 et à coût raisonnable les modifications qu'ils ont apporté à leur infrastructure. Parce que le SDK d'Apple n'est pas du tout fait pour permettre une compatibilité large.

C'est un défaut connu de tous ceux qui font du développement iOS, être compatible à la fois avec les vieilles et les nouvelles versions d'iOS est très compliqué, si ce n'est impossible.

Alors que sous d'autres OS, ça se fait quasiment les doigts dans le nez...
Go to the top of the page
 
+Quote Post
marc_os
posté 27 Sep 2018, 13:23
Message #23


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 6 091
Inscrit : 21 Apr 2006
Membre no 59 799



Citation (SartMatt @ 27 Sep 2018, 14:05) *
Citation (marc_os @ 27 Sep 2018, 12:10) *
Rien n'a changé côté App, elle tourne parfaitement sans planter.
Ce qui a changé, c'est uniquement côté serveur SNCF.
Il est totalement faux de dire que rien a changé côté Apple. Il y a eu des changements côté Apple qui font que la SNCF n'est pas en mesure de reporter sous iOS 7 et à coût raisonnable les modifications qu'ils ont apporté à leur infrastructure. Parce que le SDK d'Apple n'est pas du tout fait pour permettre une compatibilité large.

C'est un défaut connu de tous ceux qui font du développement iOS, être compatible à la fois avec les vieilles et les nouvelles versions d'iOS est très compliqué, si ce n'est impossible.

Rien à voir. Il suffit (au présent car d'autres témoignages plus haut montrent que leur pratique continue) à la SNCF de conserver leur "API web" précédente quand ils la font évoluer et ainsi permettre aux "vieilles" versions de leur appli de continuer à fonctionner.
Mais il y a un plan B "hyper sécurisé" : Acheter son billet sur le net (via un ordi), choisir d'imprimer le billet avec QR-code, l' "imprimer" en PDF, puis s'envoyer le PDF par mail ou tout moyen adéquat sur l'iPhone. Le contrôleur peut alors scanner le QR-code dans un mail sur l'iPhone. Vu la simplicité de la chose, je suis retourné à l'ancienne méthode ultra moderne, j'imprime mon billet sur une borne en gare.

Ce message a été modifié par marc_os - 27 Sep 2018, 13:25.


--------------------
-----------------
--JE-------SUIS--
--AHMED-CHARLIE--
--CLARISSA-YOAV--
-----------------
Go to the top of the page
 
+Quote Post
SartMatt
posté 27 Sep 2018, 14:16
Message #24


Macbidouilleur d'Or !
*****

Groupe : Rédacteurs
Messages : 30 135
Inscrit : 15 Nov 2005
Membre no 49 996



Citation (marc_os @ 27 Sep 2018, 14:23) *
Rien à voir. Il suffit (au présent car d'autres témoignages plus haut montrent que leur pratique continue) à la SNCF de conserver leur "API web" précédente quand ils la font évoluer et ainsi permettre aux "vieilles" versions de leur appli de continuer à fonctionner.
Et qu'est ce qui te permet d'affirmer que l'incompatibilité est due uniquement à une incompatibilité de l'API, et pas plutôt par exemple à une expiration de certificat ?
Et qu'est ce qui te dit que l'API existante pouvait être maintenue à l'identique ? Une API, ça peut contenir des failles...
Et qu'est ce qui te dit que l'application elle même ne contenait pas des failles de sécurité ?

Ensuite, je le répète, maintenir une API plus ancienne en parallèle de la nouvelle, si c'est possible, ça a forcément un coût. Et ce coût, il ne se justifie pas forcément pour un OS qui représente même pas 0.5% des utilisateurs. Mais si Apple avait fait un minimum d'effort pour la compatibilité, la SNCF aurait peut-être pu proposer la nouvelle appli sur iOS 7...

Citation (marc_os @ 27 Sep 2018, 14:23) *
Mais il y a un plan B "hyper sécurisé" : Acheter son billet sur le net (via un ordi), choisir d'imprimer le billet avec QR-code, l' "imprimer" en PDF, puis s'envoyer le PDF par mail ou tout moyen adéquat sur l'iPhone. Le contrôleur peut alors scanner le QR-code dans un mail sur l'iPhone. Vu la simplicité de la chose, je suis retourné à l'ancienne méthode ultra moderne, j'imprime mon billet sur une borne en gare.
L'art de chercher la complication...

Tu prends la carte voyageur (gratuite), et hop, tu n'as plus rien à faire, tu présentes ta carte au contrôleur et ça reconnait tous tes billets...

Pour quelqu'un qui visiblement utilise beaucoup la SNCF, pour être à ce point obnubilé par le fait que l'application ne marche plus avec iOS 7, je suis étonné que tu n'ai jamais entendu parler de ça...
Go to the top of the page
 
+Quote Post
marc_os
posté 27 Sep 2018, 15:20
Message #25


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 6 091
Inscrit : 21 Apr 2006
Membre no 59 799



Citation (SartMatt @ 27 Sep 2018, 15:16) *
Tu prends la carte voyageur (gratuite), et hop, tu n'as plus rien à faire, tu présentes ta carte au contrôleur et ça reconnait tous tes billets...

Pour quelqu'un qui visiblement utilise beaucoup la SNCF, pour être à ce point obnubilé par le fait que l'application ne marche plus avec iOS 7, je suis étonné que tu n'ai jamais entendu parler de ça...

Le hic, c'est que je n'ai jamais reçu la carte physique. Ouais, faudrait que je la réclame.

Sinon, ce qui m'énerve aussi à la SNCF, c'est qu'elle adopte de plus en plus un modèle économique "libéral" à la Tacher (on a vu ce que ça donné), avec:
- introduction de la 3ème classe : trains "lowcost" ouigo
- introduction de la 4ème classe : bus Macron (qui au passage sont une hérésie écologique)
Vive le retour au XIXième siècle !
- sabotage du ferroutage (hérésie écologique)
- prix "à la tête du client" avec des lignes vache à lait, comme par exemple Paris-Lille dont le prix moyen au kilomètre est largement le double d'ailleurs. C'est sûr, avec tous ces "cadres" de Lille qui utilisent le TGV comme un métro pour aller bosser à Paris, la tentation était grande pour les "économistes". Et tant pis pour les pauvres (ou pas) qui habitent à Roubaix ou Tourcoing qui ont vu disparaître les TGV de leurs gares, puis réapparaitre sous forme de "ouiGo", mais pas pour Paris, non, pour Charles-De-Gaulles. Les pauvres n'ont qu'à prendre le RER ensuite. (Paris - Lille en train aussi cher que moi tout seul dans ma voiture essence SP98 et péage, cherchez l'erreur. Il y a longtemps on disait que la voiture commençait à être moins cher que le train seulement à partir de deux personnes. Comme quoi !
- etc, etc.
Bref nos gouvernements continuent avec leur logiciel obsolète, jeunes en apparence mais vieux dans la tête, ils continuent la casse du service public au bénéfice de leurs potes du privé (Rotchild & co), mais c'est un autre sujet...

Bon ciao, je retourne à une vie normale.

Ce message a été modifié par marc_os - 27 Sep 2018, 15:27.


--------------------
-----------------
--JE-------SUIS--
--AHMED-CHARLIE--
--CLARISSA-YOAV--
-----------------
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 utilisateur(s) sur ce sujet (1 invité(s) et 0 utilisateur(s) anonyme(s))
0 membre(s) :

 



Nous sommes le : 23rd October 2018 - 08:52