IPB

Bienvenue invité ( Connexion | Inscription )

2 Pages V   1 2 >  
Reply to this topicStart new topic
> HPLIP sur MACOSX, ...?
Options
imoopsy
posté 3 Mar 2013, 13:55
Message #1


Adepte de Macbidouille
*

Groupe : Membres
Messages : 53
Inscrit : 10 Dec 2009
Membre no 146 866



Bonjour,
Depuis quelque jours maintenant j'ai installé le driver SANE TWAIN ( qui permet de scanné via processing ) seulement lorsque je tape dans le terminal " sane-find-scanner " , j'ai un message de type

Code
# sane-find-scanner will now attempt to detect your scanner. If the
  # result is different from what you expected, first make sure your
  # scanner is powered up and properly connected to your computer.

  # No SCSI scanners found. If you expected something different, make sure that
  # you have loaded a kernel SCSI driver for your SCSI adapter.

found USB scanner (vendor=0x03f0 [HP], product=0x5711 [Photosmart C4100 series]) at libusb:001:006-03f0-5711-00-00
  # Your USB scanner was (probably) detected. It may or may not be supported by
  # SANE. Try scanimage -L and read the backend's manpage.

  # Not checking for parallel port scanners.

  # Most Scanners connected to the parallel port or other proprietary ports
  # can't be detected by this program.

  # You may want to run this program as root to find all devices. Once you
  # found the scanner devices, be sure to adjust access permissions as
  # necessary.


En gros mon scanner n'a pas était trouvé, donc je dois téléchargé un genre de driver qu'ils appelent backend compatible sane pour une HP PHOTOSOMART all in one C4100... J'ai donc trouvé un driver qui conviendrai sur le site de sane , il s'apelle HPLIP ( http://hplipopensource.com/hplip-web/index.html )MALHEUREUSEMENT NON COMPATIBLE MAC OS X seulement LINUX ! mais j'ai trouvé un peu plus tard ces explications sur un site parlant de lancé HPLIP sur MACOS X apparament ca fonctionnerai !
Seulement il y a quelques infos que je n'ai pas compris ( celle souligné ) mais en tout cas j'ai tapé l'intégralité des commandes.
SEULE PROBLEME , la dernière partie souligné ou il dise de tapé :

Code
./configure -prefix=/usr -disable-pp-build LDFLAGS="-L/opt/local/lib"
CPPFLAGS="-/opt/local/include"
make
make install DESTDIR=/tmp/myhplip

Et bien quand je tape ca, le terminal ne reagi pas, il me dit " no such file or directory "

Code
macpook-bro-2:~ Nathalie$ ./configure -prefix=/usr -disable-pp-build LDFLAGS="-L/opt/local/lib" CPPFLAGS="-/opt/local/include"
-bash: ./configure: No such file or directory



Citation
INSTRUCTIONS

The next HPLIP release (0.9.9) will at least compile and install on Mac
OS
X 10.4.4. I did not test HPLIP on OS X, but this completes my goal for
this HPLIP release. The Mac community can test HPLIP and provide us
feedback.

In order to get HPLIP to compile I had to stub out USB
bulk_write/bulk_read calls since these calls do not go through libusb.
This means the current HPLIP USB support will be limited to device
discovery only. USB printing/scanning/hp-toolbox will not work. In
theory
all HPLIP JetDirect support should work.

In order to get full HPLIP USB support working on the Mac the
bulk_write/bulk_read calls need to be converted the Mac USB IOKit.


Here some notes on how and what was tested.

1. Download install xcode to get the GNU tools. Get *.dmg at
developer.apple.com/tools/xcode . Double click on dmg to install.

2. Download install darwinports a BSD rpm type tool. Don't bother with
the
dmg, do a tar ball install instead.

3. Get the latest autotools. "sudo port install autoconf", "sudo port
install automake", "sudo port install", "sudo port install libtool",
"sudo
port install pkgconfig"

4. Get libusb. "sudo port install libusb"

5. Get libjpeg. "sudo port install jpeg"

6. Now the we can build and install with following commands.

./configure -prefix=/usr -disable-pp-build LDFLAGS="-L/opt/local/lib"
CPPFLAGS="-/opt/local/include"
make
make install DESTDIR=/tmp/myhplip


J'aimerai beaucoup que quelqu'un puisse m'aidé car dans mon projet j'ai besoin de scanné sur processing , je suis sous macos X !
Je ne sais pas d'ou vient le problème étant un peu une newbie, mais cela fait 3 jours que je cherche des infos et a chaque fois ca bloque.

Merci

Ce message a été modifié par imoopsy - 3 Mar 2013, 13:59.
Go to the top of the page
 
+Quote Post
jfaime
posté 3 Mar 2013, 19:32
Message #2


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 2 241
Inscrit : 27 Oct 2006
Lieu : Toulouse
Membre no 71 475



Salut

Cela m'a l'air d'une compilation à partir des sources

Il faudrait t'assurer que tu as bien installé sur ton MAC, les outils pour la compilation.

En principe, mais peut-être je peux me tromper, si tu installes xcode, tu dois pourvoir accéder au compilateur gcc en mode commande.

Attention pour xcode, il faudra choisir pour le version de ton OS


--------------------
****** Mac Mini C2D 1.83 Ghz, 2.5Go RAM, DD 80Go/Iomega 750Go/Ecran Belinia 19" Vendu
(\__/) Mac Mini G4 1.25 Ghz, 1Go RAM, DD 120Go/Mini Partner 500Go/Ecran plat Philips 19"
(='.'=) Macbook Blanc C2D 2ghz,4Go ram,DD 500Go + Ecran Samsung 24"
(")_(") Ibook G4 1.33 Ghz, 1.25 Go RAM, DD 160Go Merci à Neuf50 pour m'avoir permis de le ressusciter
****** Shuffle 2g 1Go/Ipod Nono 8Go/Ipod 5g 30 Go Black/Ipod 5g 80 Go Black
Go to the top of the page
 
+Quote Post
imoopsy
posté 3 Mar 2013, 20:41
Message #3


Adepte de Macbidouille
*

Groupe : Membres
Messages : 53
Inscrit : 10 Dec 2009
Membre no 146 866



Citation (jfaime @ 3 Mar 2013, 19:32) *
Salut

Cela m'a l'air d'une compilation à partir des sources

Il faudrait t'assurer que tu as bien installé sur ton MAC, les outils pour la compilation.

En principe, mais peut-être je peux me tromper, si tu installes xcode, tu dois pourvoir accéder au compilateur gcc en mode commande.

Attention pour xcode, il faudra choisir pour le version de ton OS


Alors, j'ai bien télécharger Xcode , j'ai telechargé le tarball et dezipé , ensuite ouvert sur Xcode , j'ai ensuite cliqué sur compile mais a chaque fois ca fait une erreur de type "libusb 1.0 support error " Alors que j'ai bien installé liusb sur mon mac.


Go to the top of the page
 
+Quote Post
osnola
posté 4 Mar 2013, 08:20
Message #4


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 1 560
Inscrit : 21 Sep 2004
Lieu : Nancy
Membre no 23 949



Bonjour,
Citation (imoopsy @ 3 Mar 2013, 20:41) *
./configure -prefix=/usr -disable-pp-build LDFLAGS="-L/opt/local/lib" CPPFLAGS="-/opt/local/include"
-bash: ./configure: No such file or directory

la première chose à faire est de vérifier que tu sois bien dans le bon répertoire hplib... , ensuite regarder si il y a dedans un fichier configure. Sinon, il faudra le créer, probablement en lançant :
Code
aclocal
autoheader
autoconf
automake


osnola

Ce message a été modifié par osnola - 4 Mar 2013, 08:32.
Go to the top of the page
 
+Quote Post
imoopsy
posté 8 Mar 2013, 21:04
Message #5


Adepte de Macbidouille
*

Groupe : Membres
Messages : 53
Inscrit : 10 Dec 2009
Membre no 146 866



Citation (osnola @ 4 Mar 2013, 08:20) *
Bonjour,
Citation (imoopsy @ 3 Mar 2013, 20:41) *
./configure -prefix=/usr -disable-pp-build LDFLAGS="-L/opt/local/lib" CPPFLAGS="-/opt/local/include"
-bash: ./configure: No such file or directory

la première chose à faire est de vérifier que tu sois bien dans le bon répertoire hplib... , ensuite regarder si il y a dedans un fichier configure. Sinon, il faudra le créer, probablement en lançant :
Code
aclocal
autoheader
autoconf
automake


osnola


merci pour ta réponse , je vais essayer ca dès maintenant et je reviens vers toi.
Go to the top of the page
 
+Quote Post
imoopsy
posté 8 Mar 2013, 21:23
Message #6


Adepte de Macbidouille
*

Groupe : Membres
Messages : 53
Inscrit : 10 Dec 2009
Membre no 146 866



Citation (imoopsy @ 8 Mar 2013, 21:04) *
Citation (osnola @ 4 Mar 2013, 08:20) *
Bonjour,
Citation (imoopsy @ 3 Mar 2013, 20:41) *
./configure -prefix=/usr -disable-pp-build LDFLAGS="-L/opt/local/lib" CPPFLAGS="-/opt/local/include"
-bash: ./configure: No such file or directory

la première chose à faire est de vérifier que tu sois bien dans le bon répertoire hplib... , ensuite regarder si il y a dedans un fichier configure. Sinon, il faudra le créer, probablement en lançant :
Code
aclocal
autoheader
autoconf
automake


osnola


merci pour ta réponse , je vais essayer ca dès maintenant et je reviens vers toi.


En realité comment puis-je savoir si je suis dans le bon repertoire HPLIP ?

Quand je tape les commande ci dessus :
Code
Last login: Fri Mar  8 18:04:59 on console
Macpook-bro-2:~ Nathalie$ sudo port install libusb
Password:
--->  Cleaning libusb
--->  Scanning binaries for linking errors: 100.0%
--->  No broken files found.
Macpook-bro-2:~ Nathalie$ sudo port install autoconf
Password:
--->  Computing dependencies for autoconf
--->  Cleaning autoconf
--->  Scanning binaries for linking errors: 100.0%
--->  No broken files found.
Macpook-bro-2:~ Nathalie$ sudo port install automake
--->  Computing dependencies for automake
--->  Cleaning automake
--->  Scanning binaries for linking errors: 100.0%
--->  No broken files found.
Macpook-bro-2:~ Nathalie$ sude port install
-bash: sude: command not found
Macpook-bro-2:~ Nathalie$ sudo port install
Can't map the URL 'file://.' to a port description file ("Could not find Portfile in /Users/Nathalie").
Please verify that the directory and portfile syntax are correct.
To use the current port, you must be in a port's directory.

Go to the top of the page
 
+Quote Post
osnola
posté 9 Mar 2013, 09:36
Message #7


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 1 560
Inscrit : 21 Sep 2004
Lieu : Nancy
Membre no 23 949



Bonjour,
déjà pour le message d'erreur, dans le readme, il demande de continuer par :
Code
sudo port install libtool
sudo port install pkgconfig

( donc il faut rajouter libtool à la ligne de commande ).

Ensuite dans les instructions :
Citation
The next HPLIP release (0.9.9) will at least compile and install on Mac OS

signifie en lisant entre les lignes, qu'il faut commencer par récupérer les sources, probablement les décompresser avant de commencer à compiler :
Citation
En realité comment puis-je savoir si je suis dans le bon repertoire HPLIP ?

donc si tu as récupéré les sources sur sourceforge (dans http://sourceforge.net/projects/hplip/files/hplip/ ), tu dois avoir récupéré un fichier hplip-3.13.3.tar.gz , Safari a du le décompresser ( enlever le .gz ), donc il reste à le détarrer, ie aller dans le répertoire où Safari a mis le fichier hplip-3.13.3.tar est taper :
Code
tar xf hplip-3.13.3.tar
cd hplip-3.13.3
./configure -prefix=/usr -disable-pp-build LDFLAGS="-L/opt/local/lib" CPPFLAGS="-/opt/local/include"
make
sudo make install

( j'ai rajouté les commandes probables suivantes, descendre dans le répertoire et taper configure avec les options que tu indiquais... )
Go to the top of the page
 
+Quote Post
imoopsy
posté 9 Mar 2013, 11:34
Message #8


Adepte de Macbidouille
*

Groupe : Membres
Messages : 53
Inscrit : 10 Dec 2009
Membre no 146 866



Merci pour tes explications , j'y vois plus clair
J'ai bien lancé la ligne de commande que tu as dit en me placant dans le dossier pour sont regroupé tout mes fichiers sources mais quand je lance cette ligne :
Code
./configure -prefix=/usr -disable-pp-build LDFLAGS="-L/opt/local/lib" CPPFLAGS="-/opt/local/include"


Ca m'écris plein de truc mais a la fin ca capote a un moment :


Code
checking for libusb_init in -lusb-1.0... yes
checking libusb-1.0/libusb.h usability... no
checking libusb-1.0/libusb.h presence... no
checking for libusb-1.0/libusb.h... no
configure: error: cannot find libusb-1.0-devel support


Sachant que j'ai bien fait le

Code
macpook-bro-2:stuff Nathalie$ sudo port install libusb
--->  Cleaning libusb
--->  Scanning binaries for linking errors: 100.0%
--->  No broken files found.


Je te montre un apercu de mon dossier "stuff" qui contient tout les fichiers sources ci dessous .


Je me demande si le fait de tapé sudo port install libusb & autres , m'installe bien les fichiers sources ? Car apparament il ne trouve pas libusb ... Ce qui est fou c'est que je l'avais auparavant install en .pkg le libusb...

En fait j'ai reinstall de maniere normal libusb , avec ./configure make et sudo make install et ca ne me fait plus l'erreur pour l'instant . Je vais installé de la meme manière tout les autres sources et je reviens vers toi .

Merci encore
Go to the top of the page
 
+Quote Post
iMobile
posté 9 Mar 2013, 11:44
Message #9


Nouveau Membre


Groupe : Membres
Messages : 37
Inscrit : 21 Mar 2012
Membre no 175 442



Citation (imoopsy @ 9 Mar 2013, 11:34) *
Merci pour tes explications , j'y vois plus clair
J'ai bien lancé la ligne de commande que tu as dit en me placant dans le dossier pour sont regroupé tout mes fichiers sources mais quand je lance cette ligne :
Code
./configure -prefix=/usr -disable-pp-build LDFLAGS="-L/opt/local/lib" CPPFLAGS="-/opt/local/include"


Ca m'écris plein de truc mais a la fin ca capote a un moment :

Code
checking for libusb_init in -lusb-1.0... yes
checking libusb-1.0/libusb.h usability... no
checking libusb-1.0/libusb.h presence... no
checking for libusb-1.0/libusb.h... no
configure: error: cannot find libusb-1.0-devel support


Sachant que j'ai bien fait le

Code
macpook-bro-2:stuff Nathalie$ sudo port install libusb
--->  Cleaning libusb
--->  Scanning binaries for linking errors: 100.0%
--->  No broken files found.


Bonjour,

Il ne trouve pas la version de libusb installée car CPPFLAGS n'est pas correctement définie pour que 'configure' test les bibliothèques installées avec MacPorts, la correction :
Code
CPPFLAGS="-I/opt/local/include"


De tout réinstallé, n'est pas un problème, mais tu vas tout avoir en double, utilise soit MacPorts, soit la version standard...




--------------------
Go to the top of the page
 
+Quote Post
imoopsy
posté 9 Mar 2013, 11:59
Message #10


Adepte de Macbidouille
*

Groupe : Membres
Messages : 53
Inscrit : 10 Dec 2009
Membre no 146 866



J'ai tout installé manuellement mais je rencontre un probleme avec " PKG-config "

lorsque je met ./configure pour PKG config ca me met :

Code
configure: error: Either a previously installed pkg-config or "glib-2.0 >= 2.16" could not be found. Please set GLIB_CFLAGS and GLIB_LIBS to the correct values or pass --with-internal-glib to configure to use the bundled copy.


Je ne sais pas quoi faire
Go to the top of the page
 
+Quote Post
imoopsy
posté 9 Mar 2013, 12:22
Message #11


Adepte de Macbidouille
*

Groupe : Membres
Messages : 53
Inscrit : 10 Dec 2009
Membre no 146 866



j'ai install DBUS mais ca n'a rien changé alors sur le site de HPLIP j'ai trouvé ca ( http://hplipopensource.com/hplip-web/insta...ros/centos.html )
Code
./configure --prefix=/usr --with-hpppddir=/usr/share/cups/model/HP --libdir=/usr/lib64 --enable-qt3 --disable-qt4 --disable-hpcups-install --disable-cups-drv-install --disable-cups-ppd-install --enable-hpijs-install --enable-foomatic-drv-install --enable-foomatic-ppd-install --enable-foomatic-rip-hplip-install --disable-fax-build --disable-dbus-build --enable-network-build --enable-scan-build --disable-policykit --enable-libusb01_build --enable-udev_sysfs_rules --enable-doc-build


Je l'ai lancé puis j'ai fait sudo make install mais :
cela me fait ca a la fin
Code
collect2: ld returned 1 exit status
make: *** [libhpmud.la] Error 1
Go to the top of the page
 
+Quote Post
osnola
posté 9 Mar 2013, 12:28
Message #12


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 1 560
Inscrit : 21 Sep 2004
Lieu : Nancy
Membre no 23 949



Est-ce bien en tapant :
Code
./configure -prefix=/usr -disable-pp-build LDFLAGS="-L/opt/local/lib" CPPFLAGS="-I/opt/local/include"

que tu as cette erreur...

Si le message d'erreur qui précède est bien :
Citation
./configure for ... wanted pkg-config and ./configure for pkg-config died with the following:

il a visiblement un problème pour trouver la bonne version de pkgconfig. Si c'est le cas, la première chose à faire est de quitter puis de relancer l'application terminal ( ie. je crois que macport rajoute des variables d'environnement, donc en relançant le terminal, on sera sûr qu'elles sont bien prises en compte).


Si cela ne suffit pas, il faudra placer ces variables à la main, probablement en commençant par
Code
PATH=/opt/local/bin:$PATH
export PKG_CONFIG_PATH=/opt/local/lib/pkgconfig:$PKG_CONFIG_PATH
export DYLD_LIBRARY_PATH=/opt/local/lib:$DYLD_LIBRARY_PATH

( mais comme je n'utilise pas macports, ...)

Citation (imoopsy @ 9 Mar 2013, 12:22) *
j'ai install DBUS mais ca n'a rien changé alors sur le site de HPLIP j'ai trouvé ca ( http://hplipopensource.com/hplip-web/insta...ros/centos.html )
Code
./configure --prefix=/usr --with-hpppddir=/usr/share/cups/model/HP --libdir=/usr/lib64 --enable-qt3 --disable-qt4 --disable-hpcups-install --disable-cups-drv-install --disable-cups-ppd-install --enable-hpijs-install --enable-foomatic-drv-install --enable-foomatic-ppd-install --enable-foomatic-rip-hplip-install --disable-fax-build --disable-dbus-build --enable-network-build --enable-scan-build --disable-policykit --enable-libusb01_build --enable-udev_sysfs_rules --enable-doc-build

Cela a l'air d'être une ligne de commande pour une version bien précise de Linux, il faudrait au minimum rajouter sur cette ligne, LDFLAGS="-L/opt/local/lib" CPPFLAGS="-I/opt/local/include" ; après cette ligne fixe tant de choses qu'il est peu probable qu'elle puisse fonctionner...

Ce message a été modifié par osnola - 9 Mar 2013, 12:34.
Go to the top of the page
 
+Quote Post
imoopsy
posté 9 Mar 2013, 12:59
Message #13


Adepte de Macbidouille
*

Groupe : Membres
Messages : 53
Inscrit : 10 Dec 2009
Membre no 146 866



Citation (imoopsy @ 9 Mar 2013, 12:22) *
j'ai install DBUS mais ca n'a rien changé alors sur le site de HPLIP j'ai trouvé ca ( http://hplipopensource.com/hplip-web/insta...ros/centos.html )
Code
./configure --prefix=/usr --with-hpppddir=/usr/share/cups/model/HP --libdir=/usr/lib64 --enable-qt3 --disable-qt4 --disable-hpcups-install --disable-cups-drv-install --disable-cups-ppd-install --enable-hpijs-install --enable-foomatic-drv-install --enable-foomatic-ppd-install --enable-foomatic-rip-hplip-install --disable-fax-build --disable-dbus-build --enable-network-build --enable-scan-build --disable-policykit --enable-libusb01_build --enable-udev_sysfs_rules --enable-doc-build


Je l'ai lancé puis j'ai fait sudo make install mais :
cela me fait ca a la fin
Code
collect2: ld returned 1 exit status
make: *** [libhpmud.la] Error 1




Non en fait quand je tape

Code
./configure -prefix=/usr -disable-pp-build LDFLAGS="-L/opt/local/lib" CPPFLAGS="-I/opt/local/include"


J'ai ca comme erreur :

Code
configure: error: cannot find dbus-devel support: No package 'dbus-1' found


Ensuite j'ai install DBUS mais ca n'a rien changé toujours la meme erreur :

et quand je tape

Code
./configure --prefix=/usr --with-hpppddir=/usr/share/cups/model/HP --libdir=/usr/lib64 --enable-qt3 --disable-qt4 --disable-hpcups-install --disable-cups-drv-install --disable-cups-ppd-install --enable-hpijs-install --enable-foomatic-drv-install --enable-foomatic-ppd-install --enable-foomatic-rip-hplip-install --disable-fax-build --disable-dbus-build --enable-network-build --enable-scan-build --disable-policykit --enable-libusb01_build --enable-udev_sysfs_rules --enable-doc-build


j'ai l'erreur que je t'ai donné plus haut

Code
collect2: ld returned 1 exit status
make: *** [libhpmud.la] Error 1


C'est assez fastidieux tout ca , j'en suis désoler !





Je te met le message en entier pour
Code
./configure -prefix=/usr -disable-pp-build LDFLAGS="-L/opt/local/lib" CPPFLAGS="-I/opt/local/include"


Code
checking for path to Python.h... "using /System/Library/Frameworks/Python.framework/Versions/2.6/include/python2.6"
checking python2.6/Python.h usability... yes
checking python2.6/Python.h presence... yes
checking for python2.6/Python.h... yes
checking for sane_open in -lsane... yes
checking for pkg-config... /opt/local/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for DBUS... no
configure: error: cannot find dbus-devel support: No package 'dbus-1' found
macpook-bro-2:hplip-3.13.3 Nathalie$


Apparament le problème ne viendrai pas de pkg config mais bien de DBUS...
Go to the top of the page
 
+Quote Post
imoopsy
posté 9 Mar 2013, 13:42
Message #14


Adepte de Macbidouille
*

Groupe : Membres
Messages : 53
Inscrit : 10 Dec 2009
Membre no 146 866



J'ai tapé les commande dans le terminal que tu m'a dites pour PKG CONFIG
Toujours une erreur mais différente cette fois .
En meme temps dans le dossier hplip il n'y a pas de fichier DBUS... je ne sais pas si cela a un rapport

Code
checking pkg-config is at least version 0.9.0... dyld: Symbol not found: __cg_jpeg_resync_to_restart
  Referenced from: /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ImageIO.framework/Versions/A/Resources/libTIFF.dylib
  Expected in: /opt/local/lib/libJPEG.dylib
in /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ImageIO.framework/Versions/A/Resources/libTIFF.dylib
./configure: line 17423: 97367 Trace/BPT trap          $PKG_CONFIG --atleast-pkgconfig-version $_pkg_min_version
no
checking for DBUS... no
configure: error: cannot find dbus-devel support:
macpook-bro-2:hplip-3.13.1.3 Nathalie$


J'ai essayer de reinstallé pkg config et j'ai effectivement une erreur
Code
configure: error: pkg-config and "glib-2.0 >= 2.16" not found, please set GLIB_CFLAGS and GLIB_LIBS to the correct values or pass --with-internal-glib to configure
Macpook-bro-2:pkg-config-0.27 Nathalie$


Ce message a été modifié par imoopsy - 9 Mar 2013, 14:20.
Go to the top of the page
 
+Quote Post
imoopsy
posté 9 Mar 2013, 14:12
Message #15


Adepte de Macbidouille
*

Groupe : Membres
Messages : 53
Inscrit : 10 Dec 2009
Membre no 146 866



Je crois que Dbus sert a faxé , moi je n'ai pas de fax , ne pourrait t-on va evité ce dbus?
Go to the top of the page
 
+Quote Post
imoopsy
posté 9 Mar 2013, 15:14
Message #16


Adepte de Macbidouille
*

Groupe : Membres
Messages : 53
Inscrit : 10 Dec 2009
Membre no 146 866



A présent ce n'est plus ./ configure qui me fais une erreur mais make

Code
Macpook-bro-2:hplip-3.13.3 Nathalie$ make install DESTDIR=/tmp/myhplip
/bin/sh ./libtool  --tag=CC   --mode=compile gcc -DPACKAGE_NAME=\"HP\ Linux\ Imaging\ and\ Printing\" -DPACKAGE_TARNAME=\"hplip\" -DPACKAGE_VERSION=\"3.13.3\" -DPACKAGE_STRING=\"HP\ Linux\ Imaging\ and\ Printing\ 3.13.3\" -DPACKAGE_BUGREPORT=\"3.13.3\" -DPACKAGE_URL=\"\" -DPACKAGE=\"hplip\" -DVERSION=\"3.13.3\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DLT_OBJDIR=\".libs/\" -DHAVE_LIBDL=1 -DHAVE_PTHREAD_H=1 -DHAVE_JPEGLIB_H=1 -DHAVE_UINT32_T=1 -DHAVE_LIBHPIP=1 -DHAVE_LIBHPIP=1 -DHAVE_LIBCRYPTO=1 -DHAVE_LIBNETSNMP=1 -DHAVE_NET_SNMP_NET_SNMP_CONFIG_H=1 -DHAVE_CUPS_CUPS_H=1 -DHAVE_LIBUSB_1_0_LIBUSB_H=1 -DHAVE_PYTHON2_6_PYTHON_H=1 -DHAVE_DBUS=1 -I. -Iip -Iio/hpmud -Iscan/sane -Iprnt/hpijs -Icommon/  -I/opt/local/include -I/usr/include/libusb-1.0 -DMUDNAME=\"hpmud\" -DCONFDIR=\"/etc/hp\" -g -O2 -DCONFDIR=\"/etc/hp\" -MT libhpmud_la-musb.lo -MD -MP -MF .deps/libhpmud_la-musb.Tpo -c -o libhpmud_la-musb.lo `test -f 'io/hpmud/musb.c' || echo './'`io/hpmud/musb.c
libtool: compile:  gcc "-DPACKAGE_NAME=\"HP Linux Imaging and Printing\"" -DPACKAGE_TARNAME=\"hplip\" -DPACKAGE_VERSION=\"3.13.3\" "-DPACKAGE_STRING=\"HP Linux Imaging and Printing 3.13.3\"" -DPACKAGE_BUGREPORT=\"3.13.3\" -DPACKAGE_URL=\"\" -DPACKAGE=\"hplip\" -DVERSION=\"3.13.3\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DLT_OBJDIR=\".libs/\" -DHAVE_LIBDL=1 -DHAVE_PTHREAD_H=1 -DHAVE_JPEGLIB_H=1 -DHAVE_UINT32_T=1 -DHAVE_LIBHPIP=1 -DHAVE_LIBHPIP=1 -DHAVE_LIBCRYPTO=1 -DHAVE_LIBNETSNMP=1 -DHAVE_NET_SNMP_NET_SNMP_CONFIG_H=1 -DHAVE_CUPS_CUPS_H=1 -DHAVE_LIBUSB_1_0_LIBUSB_H=1 -DHAVE_PYTHON2_6_PYTHON_H=1 -DHAVE_DBUS=1 -I. -Iip -Iio/hpmud -Iscan/sane -Iprnt/hpijs -Icommon/ -I/opt/local/include -I/usr/include/libusb-1.0 -DMUDNAME=\"hpmud\" -DCONFDIR=\"/etc/hp\" -g -O2 -DCONFDIR=\"/etc/hp\" -MT libhpmud_la-musb.lo -MD -MP -MF .deps/libhpmud_la-musb.Tpo -c io/hpmud/musb.c  -fno-common -DPIC -o .libs/libhpmud_la-musb.o
In file included from io/hpmud/hpmudi.h:49,
                 from io/hpmud/musb.c:29:
io/hpmud/musb.h:33:20: error: libusb.h: No such file or directory
In file included from io/hpmud/hpmudi.h:49,
                 from io/hpmud/musb.c:29:
io/hpmud/musb.h:72: error: expected specifier-qualifier-list before 'libusb_device_handle'
io/hpmud/musb.c:118: error: expected '=', ',', ';', 'asm' or '__attribute__' before '*' token
io/hpmud/musb.c:119: error: expected '=', ',', ';', 'asm' or '__attribute__' before '*' token
io/hpmud/musb.c:120: error: expected '=', ',', ';', 'asm' or '__attribute__' before '*' token
io/hpmud/musb.c:125: error: expected ')' before '*' token
io/hpmud/musb.c: In function 'write_ecp_channel':
io/hpmud/musb.c:185: error: 'libusb_device_handle' undeclared (first use in this function)
io/hpmud/musb.c:185: error: (Each undeclared identifier is reported only once
io/hpmud/musb.c:185: error: for each function it appears in.)
io/hpmud/musb.c:185: error: 'hd' undeclared (first use in this function)
io/hpmud/musb.c:186: error: 'file_descriptor' has no member named 'interface'
io/hpmud/musb.c:190: error: 'file_descriptor' has no member named 'hd'
io/hpmud/musb.c:196: error: 'file_descriptor' has no member named 'hd'
io/hpmud/musb.c:199: error: 'LIBUSB_ENDPOINT_IN' undeclared (first use in this function)
io/hpmud/musb.c:199: error: 'LIBUSB_REQUEST_TYPE_VENDOR' undeclared (first use in this function)
io/hpmud/musb.c:199: error: 'LIBUSB_RECIPIENT_INTERFACE' undeclared (first use in this function)
io/hpmud/musb.c:200: error: 'LIBUSB_REQUEST_GET_STATUS' undeclared (first use in this function)
io/hpmud/musb.c: In function 'bridge_chip_up':
io/hpmud/musb.c:220: error: 'libusb_device_handle' undeclared (first use in this function)
io/hpmud/musb.c:220: error: 'hd' undeclared (first use in this function)
io/hpmud/musb.c:225: error: 'file_descriptor' has no member named 'hd'
io/hpmud/musb.c:231: error: 'file_descriptor' has no member named 'hd'
io/hpmud/musb.c:237: error: 'LIBUSB_ENDPOINT_IN' undeclared (first use in this function)
io/hpmud/musb.c:237: error: 'LIBUSB_REQUEST_TYPE_VENDOR' undeclared (first use in this function)
io/hpmud/musb.c:237: error: 'LIBUSB_RECIPIENT_DEVICE' undeclared (first use in this function)
io/hpmud/musb.c:238: error: 'LIBUSB_REQUEST_SET_FEATURE' undeclared (first use in this function)
io/hpmud/musb.c:253: error: 'LIBUSB_ENDPOINT_OUT' undeclared (first use in this function)
io/hpmud/musb.c:299: error: 'file_descriptor' has no member named 'fd'
io/hpmud/musb.c: In function 'bridge_chip_down':
io/hpmud/musb.c:318: error: 'libusb_device_handle' undeclared (first use in this function)
io/hpmud/musb.c:318: error: 'hd' undeclared (first use in this function)
io/hpmud/musb.c:321: error: 'file_descriptor' has no member named 'hd'
io/hpmud/musb.c:327: error: 'file_descriptor' has no member named 'hd'
io/hpmud/musb.c:330: error: 'LIBUSB_ENDPOINT_OUT' undeclared (first use in this function)
io/hpmud/musb.c:330: error: 'LIBUSB_REQUEST_TYPE_VENDOR' undeclared (first use in this function)
io/hpmud/musb.c:330: error: 'LIBUSB_RECIPIENT_DEVICE' undeclared (first use in this function)
io/hpmud/musb.c: In function 'write_phoenix_setup':
io/hpmud/musb.c:350: error: 'libusb_device_handle' undeclared (first use in this function)
io/hpmud/musb.c:350: error: 'hd' undeclared (first use in this function)
io/hpmud/musb.c:353: error: 'file_descriptor' has no member named 'hd'
io/hpmud/musb.c:359: error: 'file_descriptor' has no member named 'hd'
io/hpmud/musb.c:362: error: 'LIBUSB_ENDPOINT_OUT' undeclared (first use in this function)
io/hpmud/musb.c:362: error: 'LIBUSB_REQUEST_TYPE_CLASS' undeclared (first use in this function)
io/hpmud/musb.c:362: error: 'LIBUSB_RECIPIENT_OTHER' undeclared (first use in this function)
io/hpmud/musb.c: At top level:
io/hpmud/musb.c:381: error: expected ')' before '*' token
io/hpmud/musb.c:398: error: expected ')' before '*' token
io/hpmud/musb.c:438: error: expected ')' before '*' token
io/hpmud/musb.c:482: error: expected ')' before '*' token
io/hpmud/musb.c:487: error: expected ')' before '*' token
io/hpmud/musb.c:493: error: expected ')' before '*' token
io/hpmud/musb.c: In function 'release_interface':
io/hpmud/musb.c:539: error: 'file_descriptor' has no member named 'hd'
io/hpmud/musb.c:542: error: 'file_descriptor' has no member named 'write_active'
io/hpmud/musb.c:544: error: 'file_descriptor' has no member named 'fd'
io/hpmud/musb.c:545: error: 'file_descriptor' has no member named 'tid'
io/hpmud/musb.c:546: error: 'file_descriptor' has no member named 'write_active'
io/hpmud/musb.c:549: error: 'file_descriptor' has no member named 'hd'
io/hpmud/musb.c:549: error: 'file_descriptor' has no member named 'interface'
io/hpmud/musb.c:550: error: 'file_descriptor' has no member named 'hd'
io/hpmud/musb.c:551: error: 'file_descriptor' has no member named 'hd'
io/hpmud/musb.c:552: error: 'file_descriptor' has no member named 'mutex'
io/hpmud/musb.c:553: error: 'file_descriptor' has no member named 'write_done_cond'
io/hpmud/musb.c: At top level:
io/hpmud/musb.c:561: error: expected ')' before '*' token
io/hpmud/musb.c:579: error: expected ')' before '*' token
io/hpmud/musb.c:634: error: expected ')' before '*' token
io/hpmud/musb.c:682: error: expected '=', ',', ';', 'asm' or '__attribute__' before '*' token
io/hpmud/musb.c: In function 'device_id':
io/hpmud/musb.c:738: error: 'libusb_device_handle' undeclared (first use in this function)
io/hpmud/musb.c:738: error: 'hd' undeclared (first use in this function)
io/hpmud/musb.c:742: error: 'struct <anonymous>' has no member named 'hd'
io/hpmud/musb.c:743: error: 'struct <anonymous>' has no member named 'config'
io/hpmud/musb.c:744: error: 'struct <anonymous>' has no member named 'interface'
io/hpmud/musb.c:745: error: 'struct <anonymous>' has no member named 'alt_setting'
io/hpmud/musb.c:756: error: 'LIBUSB_ENDPOINT_IN' undeclared (first use in this function)
io/hpmud/musb.c:756: error: 'LIBUSB_REQUEST_TYPE_CLASS' undeclared (first use in this function)
io/hpmud/musb.c:756: error: 'LIBUSB_RECIPIENT_INTERFACE' undeclared (first use in this function)
io/hpmud/musb.c:757: error: 'LIBUSB_REQUEST_GET_STATUS' undeclared (first use in this function)
io/hpmud/musb.c: In function 'device_status':
io/hpmud/musb.c:783: error: 'libusb_device_handle' undeclared (first use in this function)
io/hpmud/musb.c:783: error: 'hd' undeclared (first use in this function)
io/hpmud/musb.c:788: error: 'struct <anonymous>' has no member named 'hd'
io/hpmud/musb.c:789: error: 'struct <anonymous>' has no member named 'interface'
io/hpmud/musb.c:798: error: 'LIBUSB_ENDPOINT_IN' undeclared (first use in this function)
io/hpmud/musb.c:798: error: 'LIBUSB_REQUEST_TYPE_CLASS' undeclared (first use in this function)
io/hpmud/musb.c:798: error: 'LIBUSB_RECIPIENT_INTERFACE' undeclared (first use in this function)
io/hpmud/musb.c:799: error: 'LIBUSB_REQUEST_CLEAR_FEATURE' undeclared (first use in this function)
io/hpmud/musb.c: At top level:
io/hpmud/musb.c:900: error: expected ')' before '*' token
io/hpmud/musb.c:908: error: expected ')' before '*' token
io/hpmud/musb.c: In function 'write_thread':
io/hpmud/musb.c:979: error: 'libusb_dev' undeclared (first use in this function)
io/hpmud/musb.c:979: error: 'file_descriptor' has no member named 'config'
io/hpmud/musb.c:979: error: 'file_descriptor' has no member named 'interface'
io/hpmud/musb.c:979: error: 'file_descriptor' has no member named 'alt_setting'
io/hpmud/musb.c:979: error: 'LIBUSB_TRANSFER_TYPE_BULK' undeclared (first use in this function)
io/hpmud/musb.c:987: error: 'file_descriptor' has no member named 'write_return'
io/hpmud/musb.c:987: error: 'file_descriptor' has no member named 'hd'
io/hpmud/musb.c:987: error: 'file_descriptor' has no member named 'write_buf'
io/hpmud/musb.c:987: error: 'file_descriptor' has no member named 'write_size'
io/hpmud/musb.c:990: error: 'file_descriptor' has no member named 'mutex'
io/hpmud/musb.c:991: error: 'file_descriptor' has no member named 'write_buf'
io/hpmud/musb.c:992: error: 'file_descriptor' has no member named 'write_done_cond'
io/hpmud/musb.c:993: error: 'file_descriptor' has no member named 'mutex'
io/hpmud/musb.c: In function 'musb_write':
io/hpmud/musb.c:1006: error: 'struct <anonymous>' has no member named 'hd'
io/hpmud/musb.c:1017: error: 'struct <anonymous>' has no member named 'write_active'
io/hpmud/musb.c:1019: error: 'struct <anonymous>' has no member named 'write_active'
io/hpmud/musb.c:1020: error: 'struct <anonymous>' has no member named 'write_buf'
io/hpmud/musb.c:1021: error: 'struct <anonymous>' has no member named 'write_size'
io/hpmud/musb.c:1024: error: 'struct <anonymous>' has no member named 'tid'
io/hpmud/musb.c:1031: error: 'struct <anonymous>' has no member named 'mutex'
io/hpmud/musb.c:1039: error: 'struct <anonymous>' has no member named 'write_buf'
io/hpmud/musb.c:1041: error: 'struct <anonymous>' has no member named 'write_done_cond'
io/hpmud/musb.c:1041: error: 'struct <anonymous>' has no member named 'mutex'
io/hpmud/musb.c:1043: error: 'struct <anonymous>' has no member named 'mutex'
io/hpmud/musb.c:1050: error: 'struct <anonymous>' has no member named 'write_active'
io/hpmud/musb.c:1052: error: 'struct <anonymous>' has no member named 'write_return'
io/hpmud/musb.c: In function 'musb_read':
io/hpmud/musb.c:1082: error: 'struct <anonymous>' has no member named 'hd'
io/hpmud/musb.c:1090: error: 'libusb_dev' undeclared (first use in this function)
io/hpmud/musb.c:1090: error: 'struct <anonymous>' has no member named 'config'
io/hpmud/musb.c:1090: error: 'struct <anonymous>' has no member named 'interface'
io/hpmud/musb.c:1090: error: 'struct <anonymous>' has no member named 'alt_setting'
io/hpmud/musb.c:1090: error: 'LIBUSB_TRANSFER_TYPE_BULK' undeclared (first use in this function)
io/hpmud/musb.c:1099: error: 'struct <anonymous>' has no member named 'hd'
io/hpmud/musb.c: In function 'musb_open':
io/hpmud/musb.c:1142: error: 'libusb_dev' undeclared (first use in this function)
io/hpmud/musb.c: In function 'musb_close':
io/hpmud/musb.c:1190: error: 'struct <anonymous>' has no member named 'hd'
io/hpmud/musb.c:1196: error: 'libusb_dev' undeclared (first use in this function)
io/hpmud/musb.c:1198: error: 'libusb_dev_list' undeclared (first use in this function)
io/hpmud/musb.c:1199: error: 'libusb_ctx' undeclared (first use in this function)
io/hpmud/musb.c: In function 'musb_get_device_id':
io/hpmud/musb.c:1228: error: 'struct <anonymous>' has no member named 'hd'
io/hpmud/musb.c:1238: error: 'libusb_dev' undeclared (first use in this function)
io/hpmud/musb.c: In function 'musb_get_device_status':
io/hpmud/musb.c:1281: error: 'struct <anonymous>' has no member named 'hd'
io/hpmud/musb.c:1291: error: 'libusb_dev' undeclared (first use in this function)
io/hpmud/musb.c: In function 'musb_raw_channel_open':
io/hpmud/musb.c:1394: error: 'libusb_dev' undeclared (first use in this function)
io/hpmud/musb.c: In function 'musb_raw_channel_close':
io/hpmud/musb.c:1414: error: 'libusb_dev' undeclared (first use in this function)
io/hpmud/musb.c:1414: error: 'struct <anonymous>' has no member named 'config'
io/hpmud/musb.c:1414: error: 'struct <anonymous>' has no member named 'interface'
io/hpmud/musb.c:1414: error: 'struct <anonymous>' has no member named 'alt_setting'
io/hpmud/musb.c:1414: error: 'LIBUSB_TRANSFER_TYPE_BULK' undeclared (first use in this function)
io/hpmud/musb.c:1416: error: 'struct <anonymous>' has no member named 'hd'
io/hpmud/musb.c:1419: error: 'struct <anonymous>' has no member named 'config'
io/hpmud/musb.c:1419: error: 'struct <anonymous>' has no member named 'interface'
io/hpmud/musb.c:1419: error: 'struct <anonymous>' has no member named 'alt_setting'
io/hpmud/musb.c:1421: error: 'struct <anonymous>' has no member named 'hd'
io/hpmud/musb.c: In function 'musb_comp_channel_open':
io/hpmud/musb.c:1544: error: 'libusb_dev' undeclared (first use in this function)
io/hpmud/musb.c: In function 'musb_mlc_channel_open':
io/hpmud/musb.c:1575: error: 'libusb_dev' undeclared (first use in this function)
io/hpmud/musb.c: In function 'musb_dot4_channel_open':
io/hpmud/musb.c:1786: error: 'libusb_dev' undeclared (first use in this function)
io/hpmud/musb.c: In function 'musb_probe_devices':
io/hpmud/musb.c:2020: error: 'libusb_context' undeclared (first use in this function)
io/hpmud/musb.c:2020: error: 'ctx' undeclared (first use in this function)
io/hpmud/musb.c:2021: error: 'libusb_device' undeclared (first use in this function)
io/hpmud/musb.c:2021: error: 'list' undeclared (first use in this function)
io/hpmud/musb.c:2022: error: 'dev' undeclared (first use in this function)
io/hpmud/musb.c:2023: error: storage size of 'devdesc' isn't known
io/hpmud/musb.c:2027: error: 'libusb_device_handle' undeclared (first use in this function)
io/hpmud/musb.c:2027: error: 'hd' undeclared (first use in this function)
io/hpmud/musb.c:2065: error: dereferencing pointer to incomplete type
io/hpmud/musb.c:2066: error: dereferencing pointer to incomplete type
io/hpmud/musb.c:2066: error: increment of pointer to unknown structure
io/hpmud/musb.c:2066: error: arithmetic on pointer to an incomplete type
io/hpmud/musb.c:2068: error: dereferencing pointer to incomplete type
io/hpmud/musb.c:2068: error: dereferencing pointer to incomplete type
io/hpmud/musb.c:2068: error: increment of pointer to unknown structure
io/hpmud/musb.c:2068: error: arithmetic on pointer to an incomplete type
io/hpmud/musb.c:2070: error: dereferencing pointer to incomplete type
io/hpmud/musb.c:2070: error: 'LIBUSB_CLASS_PRINTER' undeclared (first use in this function)
io/hpmud/musb.c: In function 'hpmud_make_usb_uri':
io/hpmud/musb.c:2146: error: 'libusb_context' undeclared (first use in this function)
io/hpmud/musb.c:2146: error: 'ctx' undeclared (first use in this function)
io/hpmud/musb.c:2147: error: 'libusb_device' undeclared (first use in this function)
io/hpmud/musb.c:2147: error: 'list' undeclared (first use in this function)
io/hpmud/musb.c:2148: error: 'dev' undeclared (first use in this function)
io/hpmud/musb.c:2148: error: 'found_dev' undeclared (first use in this function)
io/hpmud/musb.c:2149: error: 'libusb_device_handle' undeclared (first use in this function)
io/hpmud/musb.c:2149: error: 'hd' undeclared (first use in this function)
io/hpmud/musb.c:2150: error: storage size of 'devdesc' isn't known
io/hpmud/musb.c:2223: error: dereferencing pointer to incomplete type
io/hpmud/musb.c:2223: error: dereferencing pointer to incomplete type
io/hpmud/musb.c:2223: error: increment of pointer to unknown structure
io/hpmud/musb.c:2223: error: arithmetic on pointer to an incomplete type
io/hpmud/musb.c:2225: error: dereferencing pointer to incomplete type
io/hpmud/musb.c:2225: error: dereferencing pointer to incomplete type
io/hpmud/musb.c:2225: error: increment of pointer to unknown structure
io/hpmud/musb.c:2225: error: arithmetic on pointer to an incomplete type
io/hpmud/musb.c:2227: error: dereferencing pointer to incomplete type
io/hpmud/musb.c:2227: error: 'LIBUSB_CLASS_MASS_STORAGE' undeclared (first use in this function)
io/hpmud/musb.c: In function 'hpmud_make_usb_serial_uri':
io/hpmud/musb.c:2262: error: 'libusb_context' undeclared (first use in this function)
io/hpmud/musb.c:2262: error: 'ctx' undeclared (first use in this function)
io/hpmud/musb.c:2263: error: 'libusb_device' undeclared (first use in this function)
io/hpmud/musb.c:2263: error: 'list' undeclared (first use in this function)
io/hpmud/musb.c:2264: error: 'dev' undeclared (first use in this function)
io/hpmud/musb.c:2264: error: 'found_dev' undeclared (first use in this function)
make: *** [libhpmud_la-musb.lo] Error 1
Go to the top of the page
 
+Quote Post
osnola
posté 10 Mar 2013, 13:26
Message #17


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 1 560
Inscrit : 21 Sep 2004
Lieu : Nancy
Membre no 23 949



Bonjour,
Citation (imoopsy @ 9 Mar 2013, 14:12) *
Je crois que Dbus sert a faxé , moi je n'ai pas de fax , ne pourrait t-on va evité ce dbus?


Visiblement, on peut trouver les sources de Dbus en partant de http://dbus.sourcearchive.com/ ( a priori répertoire 1.6.8-1 ou peut-être 1.7.0-1 ) et il a l'air de compiler assez facilement, donc autant l'installer...

Une fois installé, normalement configure devrait pouvoir finir de configurer (ie. c'est pratiquement le dernier test).

Après mon environnement est trop particulier pour pouvoir dire quelque chose, mais en rajoutant -I/usr/local/include/libusb-1.0/ dans la variable CFLAGS sur la ligne de commande configure ( ie. comme j'ai fait une installation manuelle, libusb s'est installé dans /usr/local/include/ ), j'arrive à compiler tous les fichiers de hplibs sauf 5 ou 6 et j'ai un problème de symbole dupliqué dans ld, les erreurs ressemblent à :
Code
prnt/hpcups/Hbpl1.cpp: In constructor 'Hbpl1::Hbpl1()':
prnt/hpcups/Hbpl1.cpp:56: error: 'UTILS_PRINT_PLUGIN_LIBRARY' was not declared in this scope
prnt/hpcups/Hbpl1.cpp:56: error: 'PRNT_PLUGIN_HBPL1' was not declared in this scope
prnt/hpcups/Hbpl1.cpp:56: error: 'load_plugin_library' was not declared in this scope
prnt/hpcups/Hbpl1.cpp:60: error: 'get_library_symbol' was not declared in this scope
prnt/hpcups/Hbpl1.cpp: In destructor 'virtual Hbpl1::~Hbpl1()':
prnt/hpcups/Hbpl1.cpp:85: error: 'unload_library' was not declared in this scope

mais vu comment j'ai installé manuellement libusb, libsane, libdbus, libjpeg et l'état de mes binaires pkgconfig, ... , cela n'est pas obligatoirement la faute de hplip :-)

Ce message a été modifié par osnola - 10 Mar 2013, 13:28.
Go to the top of the page
 
+Quote Post
imoopsy
posté 10 Mar 2013, 14:24
Message #18


Adepte de Macbidouille
*

Groupe : Membres
Messages : 53
Inscrit : 10 Dec 2009
Membre no 146 866




J'ai bien installé DBUS et je n'ai plus d'erreur desormais.
J'ai tapé ceci
Code
./configure -prefix=/usr -disable-pp-build LDFLAGS="-L/opt/local/lib" CPPFLAGS="-I/opt/local/include  -I/usr/local/include/libusb-1.0/"


Cela ne fait pas d'erreur mais lorsque je tape
Code
make


Une erreur apparaitre qui cette fois ci semble différente lol
Code
macpook-bro-2:hplip-3.13.3 Nathalie$ make
/bin/sh ./libtool  --tag=CC   --mode=compile gcc -DPACKAGE_NAME=\"HP\ Linux\ Imaging\ and\ Printing\" -DPACKAGE_TARNAME=\"hplip\" -DPACKAGE_VERSION=\"3.13.3\" -DPACKAGE_STRING=\"HP\ Linux\ Imaging\ and\ Printing\ 3.13.3\" -DPACKAGE_BUGREPORT=\"3.13.3\" -DPACKAGE_URL=\"\" -DPACKAGE=\"hplip\" -DVERSION=\"3.13.3\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DLT_OBJDIR=\".libs/\" -DHAVE_LIBDL=1 -DHAVE_PTHREAD_H=1 -DHAVE_JPEGLIB_H=1 -DHAVE_UINT32_T=1 -DHAVE_LIBHPIP=1 -DHAVE_LIBHPIP=1 -DHAVE_LIBCRYPTO=1 -DHAVE_LIBNETSNMP=1 -DHAVE_NET_SNMP_NET_SNMP_CONFIG_H=1 -DHAVE_CUPS_CUPS_H=1 -DHAVE_LIBUSB_1_0_LIBUSB_H=1 -DHAVE_PYTHON2_6_PYTHON_H=1 -DHAVE_DBUS=1 -I. -Iip -Iio/hpmud -Iscan/sane -Iprnt/hpijs -Icommon/  -I/opt/local/include  -I/usr/local/include/libusb-1.0/ -I/usr/include/libusb-1.0 -DMUDNAME=\"hpmud\" -DCONFDIR=\"/etc/hp\" -g -O2 -DCONFDIR=\"/etc/hp\" -MT libhpmud_la-musb.lo -MD -MP -MF .deps/libhpmud_la-musb.Tpo -c -o libhpmud_la-musb.lo `test -f 'io/hpmud/musb.c' || echo './'`io/hpmud/musb.c
libtool: compile:  gcc "-DPACKAGE_NAME=\"HP Linux Imaging and Printing\"" -DPACKAGE_TARNAME=\"hplip\" -DPACKAGE_VERSION=\"3.13.3\" "-DPACKAGE_STRING=\"HP Linux Imaging and Printing 3.13.3\"" -DPACKAGE_BUGREPORT=\"3.13.3\" -DPACKAGE_URL=\"\" -DPACKAGE=\"hplip\" -DVERSION=\"3.13.3\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DLT_OBJDIR=\".libs/\" -DHAVE_LIBDL=1 -DHAVE_PTHREAD_H=1 -DHAVE_JPEGLIB_H=1 -DHAVE_UINT32_T=1 -DHAVE_LIBHPIP=1 -DHAVE_LIBHPIP=1 -DHAVE_LIBCRYPTO=1 -DHAVE_LIBNETSNMP=1 -DHAVE_NET_SNMP_NET_SNMP_CONFIG_H=1 -DHAVE_CUPS_CUPS_H=1 -DHAVE_LIBUSB_1_0_LIBUSB_H=1 -DHAVE_PYTHON2_6_PYTHON_H=1 -DHAVE_DBUS=1 -I. -Iip -Iio/hpmud -Iscan/sane -Iprnt/hpijs -Icommon/ -I/opt/local/include -I/usr/local/include/libusb-1.0/ -I/usr/include/libusb-1.0 -DMUDNAME=\"hpmud\" -DCONFDIR=\"/etc/hp\" -g -O2 -DCONFDIR=\"/etc/hp\" -MT libhpmud_la-musb.lo -MD -MP -MF .deps/libhpmud_la-musb.Tpo -c io/hpmud/musb.c  -fno-common -DPIC -o .libs/libhpmud_la-musb.o
io/hpmud/musb.c: In function 'get_interface':
io/hpmud/musb.c:411: warning: assignment discards qualifiers from pointer target type
io/hpmud/musb.c:413: warning: assignment discards qualifiers from pointer target type
/var/folders/TP/TP1bG4QoGxGBQn61Y5zN1U+++TI/-Tmp-//cc5ooWeL.s:unknown:FATAL:can't create output file: .libs/libhpmud_la-musb.o
make: *** [libhpmud_la-musb.lo] Error 1
macpook-bro-2:hplip-3.13.3 Nathalie$
Go to the top of the page
 
+Quote Post
osnola
posté 10 Mar 2013, 16:08
Message #19


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 1 560
Inscrit : 21 Sep 2004
Lieu : Nancy
Membre no 23 949



Peut-être un problème de droit, lié à des fichiers créés par root lors d'un sudo.
Si c'est le cas, parfois :
Code
sudo make clean

suffit à enlever les fichiers problèmatiques, parfois, il faut les enlever à la main. Après, il faut relancer make.

Note : si c'est juste un problème de droit, tu peux aussi voir si
Code
sudo make

permet d'aller plus loin ( même si cela risque de créer d'autres fichiers possédés par root ).
Go to the top of the page
 
+Quote Post
imoopsy
posté 11 Mar 2013, 10:13
Message #20


Adepte de Macbidouille
*

Groupe : Membres
Messages : 53
Inscrit : 10 Dec 2009
Membre no 146 866



Quand je suprrime les hplipmud ils reviennent quand je fais sudo make

et cela fini toujours avec:
Code
ld: duplicate symbol _getSIData in .libs/libhpmud_la-mlc.o and .libs/libhpmud_la-hpmud.o
collect2: ld returned 1 exit status

[libhpmud.la] Error 1



c'est assez déprimant...
Je crois que je vais abandonné !
Merci pour ton aide tout de même !
Go to the top of the page
 
+Quote Post
osnola
posté 11 Mar 2013, 10:44
Message #21


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 1 560
Inscrit : 21 Sep 2004
Lieu : Nancy
Membre no 23 949



Citation (imoopsy @ 11 Mar 2013, 10:13) *
Quand je suprrime les hplipmud ils reviennent quand je fais sudo make

et cela fini toujours avec:
Code
ld: duplicate symbol _getSIData in .libs/libhpmud_la-mlc.o and .libs/libhpmud_la-hpmud.o
collect2: ld returned 1 exit status

[libhpmud.la] Error 1

Au moins cela confirme que le problème précédent venait bien d'un problème de droit, que <<sudo make clean>> a des chances de résoudre...

Sinon pour cette erreur, il faut probablement éditer io/hpmud/hpmudi.h et remplacer ( à la fin du fichier ) :
Code
int (*getSIData)(char **pData , int *pDataLen, char **pModeSwitch, int *pModeSwitchLen);
void (*freeSIData)(char *pData, char *pModeSwitch);

par
Code
extern int (*getSIData)(char **pData , int *pDataLen, char **pModeSwitch, int *pModeSwitchLen);
extern void (*freeSIData)(char *pData, char *pModeSwitch);


Citation
c'est assez déprimant...
Je crois que je vais abandonné !
Merci pour ton aide tout de même !

C'est clair que si tu débutes, tu t'es attaqué à un énorme projet ; je trouve que c'est déjà plutôt bien (ie surprenant) que tu sois arrivé jusque là...
Go to the top of the page
 
+Quote Post
imoopsy
posté 11 Mar 2013, 18:20
Message #22


Adepte de Macbidouille
*

Groupe : Membres
Messages : 53
Inscrit : 10 Dec 2009
Membre no 146 866



Lorsque je fais le sudo make clean je n'ai pas d'erreur ( je pense que c'est normal )
J'ai bien realisé les manipulation que tu m'as dites !
Ensuite j'ai refait un sudo make et cette fois ci , erreur différente
Code
prnt/hpijs/context2.cpp:1302: error: 'strnlen' was not declared in this scope
make: *** [libapdk_la-context2.lo] Error 1


Je ne comprends pas , daprés les instructions plus haut , tout avait l'air si simple !

Ce message a été modifié par imoopsy - 11 Mar 2013, 18:20.
Go to the top of the page
 
+Quote Post
osnola
posté 11 Mar 2013, 20:46
Message #23


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 1 560
Inscrit : 21 Sep 2004
Lieu : Nancy
Membre no 23 949



Citation (imoopsy @ 11 Mar 2013, 18:20) *
Lorsque je fais le sudo make clean je n'ai pas d'erreur ( je pense que c'est normal )
J'ai bien realisé les manipulation que tu m'as dites !
Ensuite j'ai refait un sudo make et cette fois ci , erreur différente
Code
prnt/hpijs/context2.cpp:1302: error: 'strnlen' was not declared in this scope
make: *** [libapdk_la-context2.lo] Error 1

Si tu es en 10.7 ou plus, il doit suffire de rajouter :
Code
#include <string.h>

au début du fichier prnt/hpijs/context2.cpp ( ie. par
exemple comme première ligne, ou plus propre un peu
plus loin avec les autres include ).

Si tu es en 10.6 ou moins, je te trouverais demain matin, le code de cette petite
fonction qui existait sous Linux mais pas sur Darwin et qui a été rajoutée
en 10.7.

Citation
Je ne comprends pas , daprés les instructions plus haut , tout avait l'air si simple !

C'est probablement simple sous Linux, mais comme il y a de petites
différences entre les deux systèmes et que c'est une grosse librairie
que personne ne doit avoir recompilé sur Mac depuis des années
( ou alors n'a pas fait remonté de patch ) c'est loin d'être surprenant...
Go to the top of the page
 
+Quote Post
imoopsy
posté 11 Mar 2013, 21:02
Message #24


Adepte de Macbidouille
*

Groupe : Membres
Messages : 53
Inscrit : 10 Dec 2009
Membre no 146 866



Je suis en 10.6.8 ( snow leopard ) , je te remercie vraiment pour ton aide !
J'ai consulté des sujets sur MACPORT pour HPLIP mais comme je suis débutante je comprends pas grand chose , j'ai vu l'histoire des patchs a un moment je crois ou des gens qui partagé des Portfiles mais impossible de lancé ca ! ( http://trac.macports.org/ticket/30061 )

Merci encore !


Go to the top of the page
 
+Quote Post
osnola
posté 12 Mar 2013, 09:07
Message #25


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 1 560
Inscrit : 21 Sep 2004
Lieu : Nancy
Membre no 23 949



Citation (imoopsy @ 11 Mar 2013, 21:02) *
Je suis en 10.6.8 ( snow leopard ) , je te remercie vraiment pour ton aide !


Donc dans le fichier "prnt/hpijs/context2.cpp", après la ligne :
Code
//#include "bug.h"

il faut rajouter (je me suis inspiré de http://www.netmite.com/android/mydroid/1.5...tring/strnlen.c ) :
Code
#include <string.h>

static size_t  strnlen(const char*  str, size_t  maxlen)
{
    char*  p = (char *) memchr(str, 0, maxlen);

    if (p == 0)
        return maxlen;
    else
        return (p - str);
}


Il faudra faire la même chose dans le fichier prnt/hpijs/ljzjscolor.cpp , cette fois après la ligne :
Code
#include "ljzjscolor.h"


Citation
J'ai consulté des sujets sur MACPORT pour HPLIP mais comme je suis débutante je comprends pas grand chose , j'ai vu l'histoire des patchs a un moment je crois ou des gens qui partagé des Portfiles mais impossible de lancé ca ! ( http://trac.macports.org/ticket/30061 )

Merci encore !

Cela pourra peut-être servir d'inspiration pour corriger les erreurs de fonctions manquantes, qui vont apparaître prochainement....

Sinon il y a aussi http://answerpot.com/showthread.php?286907...hplip+%403.11.5 qui semble indiquer au moins un travail plus récent, mais lui aussi inachevé ?

Note : il est bien possible que les prochaines erreurs impliquent des fichiers de prnt/hpcups ( par exemple prnt/hpcups/Hbpl1.cpp ), si c'est le cas, regardes si ils contiennent la ligne :
Code
#include "utils.h"

(avec un u minuscule) et remplaces là par
Code
#include "common/utils.h"

car il y a dans ce répertoire un fichier Utils.h qui <<conflicte>> avec common/utils.h, ie. ils ont le même nom à la case près, ce qui ne pose de problème sous Linux mais en pose un sur Mac....

Ce message a été modifié par osnola - 12 Mar 2013, 12:00.
Go to the top of the page
 
+Quote Post
imoopsy
posté 16 Mar 2013, 11:57
Message #26


Adepte de Macbidouille
*

Groupe : Membres
Messages : 53
Inscrit : 10 Dec 2009
Membre no 146 866



Bonjour,
J'ai donc fait sudo make aprés avoir fait les manipulations plus haut ,

Code
libtool: link: gcc -DCONFDIR=\"/etc/hp\" -g -O2 -DCONFDIR=\"/etc/hp\" -o .libs/hp-mkuri hp_mkuri-hp-mkuri.o  -L/opt/local/lib ./.libs/libhpmud.dylib -lpthread -ldl -lnetsnmp /opt/local/lib/libusb-1.0.dylib -lobjc -lcrypto
g++ -DPACKAGE_NAME=\"HP\ Linux\ Imaging\ and\ Printing\" -DPACKAGE_TARNAME=\"hplip\" -DPACKAGE_VERSION=\"3.13.3\" -DPACKAGE_STRING=\"HP\ Linux\ Imaging\ and\ Printing\ 3.13.3\" -DPACKAGE_BUGREPORT=\"3.13.3\" -DPACKAGE_URL=\"\" -DPACKAGE=\"hplip\" -DVERSION=\"3.13.3\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DLT_OBJDIR=\".libs/\" -DHAVE_LIBDL=1 -DHAVE_PTHREAD_H=1 -DHAVE_JPEGLIB_H=1 -DHAVE_UINT32_T=1 -DHAVE_LIBHPIP=1 -DHAVE_LIBHPIP=1 -DHAVE_LIBCRYPTO=1 -DHAVE_LIBNETSNMP=1 -DHAVE_NET_SNMP_NET_SNMP_CONFIG_H=1 -DHAVE_CUPS_CUPS_H=1 -DHAVE_LIBUSB_1_0_LIBUSB_H=1 -DHAVE_PYTHON2_6_PYTHON_H=1 -DHAVE_DBUS=1 -I. -Iip -Iio/hpmud -Iscan/sane -Iprnt/hpijs -Icommon/  -I/opt/local/include  -I/usr/local/include/libusb-1.0/ -DAPDK_LITTLE_ENDIAN -I/opt/local/include/dbus-1.0 -I/opt/local/lib/dbus-1.0/include   -g -O2 -DCONFDIR=\"/etc/hp\" -MT hpcups-HPCupsFilter.o -MD -MP -MF .deps/hpcups-HPCupsFilter.Tpo -c -o hpcups-HPCupsFilter.o `test -f 'prnt/hpcups/HPCupsFilter.cpp' || echo './'`prnt/hpcups/HPCupsFilter.cpp
prnt/hpcups/HPCupsFilter.cpp: In member function ‘int HPCupsFilter::StartPrintJob(int, char**)’:
prnt/hpcups/HPCupsFilter.cpp:475: warning: format ‘%ld’ expects type ‘long int’, but argument 4 has type ‘int’
prnt/hpcups/HPCupsFilter.cpp: In member function ‘int HPCupsFilter::processRasterData(cups_raster_t*)’:
prnt/hpcups/HPCupsFilter.cpp:673: error: ‘createTempFile’ was not declared in this scope
prnt/hpcups/HPCupsFilter.cpp:684: error: ‘createTempFile’ was not declared in this scope
make: *** [hpcups-HPCupsFilter.o] Error 1
macpook-bro-2:hplip-3.13.3 Nathalie$


Comme tu as avais prvu une erreur dans le dossier HPCUPS , j'ai remplacer la ligne pour le fichier que tu m'as dit prnt/hpcups/Hbpl1.cpp mais également celui dit dans l'erreur donc prnt/hpcups/HpCupsFilter.cpp ( et non .o ) et cette fois ci :

Code
g++ -DPACKAGE_NAME=\"HP\ Linux\ Imaging\ and\ Printing\" -DPACKAGE_TARNAME=\"hplip\" -DPACKAGE_VERSION=\"3.13.3\" -DPACKAGE_STRING=\"HP\ Linux\ Imaging\ and\ Printing\ 3.13.3\" -DPACKAGE_BUGREPORT=\"3.13.3\" -DPACKAGE_URL=\"\" -DPACKAGE=\"hplip\" -DVERSION=\"3.13.3\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DLT_OBJDIR=\".libs/\" -DHAVE_LIBDL=1 -DHAVE_PTHREAD_H=1 -DHAVE_JPEGLIB_H=1 -DHAVE_UINT32_T=1 -DHAVE_LIBHPIP=1 -DHAVE_LIBHPIP=1 -DHAVE_LIBCRYPTO=1 -DHAVE_LIBNETSNMP=1 -DHAVE_NET_SNMP_NET_SNMP_CONFIG_H=1 -DHAVE_CUPS_CUPS_H=1 -DHAVE_LIBUSB_1_0_LIBUSB_H=1 -DHAVE_PYTHON2_6_PYTHON_H=1 -DHAVE_DBUS=1 -I. -Iip -Iio/hpmud -Iscan/sane -Iprnt/hpijs -Icommon/  -I/opt/local/include  -I/usr/local/include/libusb-1.0/ -DAPDK_LITTLE_ENDIAN -I/opt/local/include/dbus-1.0 -I/opt/local/lib/dbus-1.0/include   -g -O2 -DCONFDIR=\"/etc/hp\" -MT hpcups-ModeJbig.o -MD -MP -MF .deps/hpcups-ModeJbig.Tpo -c -o hpcups-ModeJbig.o `test -f 'prnt/hpcups/ModeJbig.cpp' || echo './'`prnt/hpcups/ModeJbig.cpp
prnt/hpcups/ModeJbig.cpp: In destructor ‘virtual ModeJbig::~ModeJbig()’:
prnt/hpcups/ModeJbig.cpp:119: error: ‘unload_library’ was not declared in this scope
prnt/hpcups/ModeJbig.cpp: In member function ‘DRIVER_ERROR ModeJbig::Init(int, int, int, ZJPLATFORM)’:
prnt/hpcups/ModeJbig.cpp:135: error: ‘UTILS_PRINT_PLUGIN_LIBRARY’ was not declared in this scope
prnt/hpcups/ModeJbig.cpp:135: error: ‘PRNT_PLUGIN_LJ’ was not declared in this scope
prnt/hpcups/ModeJbig.cpp:135: error: ‘load_plugin_library’ was not declared in this scope
prnt/hpcups/ModeJbig.cpp:139: error: ‘get_library_symbol’ was not declared in this scope


Dois-je continuer a remplacer la ligne dans tout les fichiers ou ils y une erreur se trouvant dans hpcups?
Go to the top of the page
 
+Quote Post
osnola
posté 16 Mar 2013, 12:12
Message #27


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 1 560
Inscrit : 21 Sep 2004
Lieu : Nancy
Membre no 23 949



Bonjour,

Citation (imoopsy @ 16 Mar 2013, 11:57) *
Bonjour,
Dois-je continuer a remplacer la ligne dans tout les fichiers ou ils y une erreur se trouvant dans hpcups?

Oui.

Normalement ( si je me rappelles bien ), il y 5 ou 6 fichiers .cpp dans hpcups dans lesquels il faut remplacer cette ligne...

Go to the top of the page
 
+Quote Post
imoopsy
posté 16 Mar 2013, 12:58
Message #28


Adepte de Macbidouille
*

Groupe : Membres
Messages : 53
Inscrit : 10 Dec 2009
Membre no 146 866



Alors le sudo make ne fait plus d'erreur j'ai donc lancé un sudo make install

Et maintenant :
Code
test -z "/tmp/myhplip/var/log/hp" || mkdir -p /tmp/myhplip/var/log/hp
chgrp "lp" -R /tmp/myhplip/var/log/hp
chgrp: -R: No such file or directory
make[1]: *** [install-dist_hplip_LogDATA] Error 1
make: *** [install-am] Error 2


J'ai ce genre d'erreur,
je sens qu'on ai proche !

Go to the top of the page
 
+Quote Post
osnola
posté 16 Mar 2013, 13:15
Message #29


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 1 560
Inscrit : 21 Sep 2004
Lieu : Nancy
Membre no 23 949



Pour cette erreur, il doit suffire d'éditer le fichier Makefile en remplaçant les 4 lignes
Code
chgrp "lp" -R $(DESTDIR)XXXXX

par
Code
chgrp -R "lp" $(DESTDIR)XXXXX

où XXXXX représente une chaine quelconque.
( en notant que pour le faire proprement, il faut mieux faire la même chose dans Makefile.am et dans Makefile.in, ie. si pour une raison ou une autre, make décide de relancer un configure, le fichier Makefile.in sera reconstruit à partir de Makefile.am ainsi que Makefile à partir de Makefile.in ).

Ce message a été modifié par osnola - 16 Mar 2013, 13:20.
Go to the top of the page
 
+Quote Post
imoopsy
posté 16 Mar 2013, 13:58
Message #30


Adepte de Macbidouille
*

Groupe : Membres
Messages : 53
Inscrit : 10 Dec 2009
Membre no 146 866



Je remplace donc cette ligne :
Code
chgrp "lp" -R $(DESTDIR)$(hplip_Logdir)




par

Code
chgrp -R "lp" $(DESTDIR)$(hplip_Logdir)


pour la premiere ligne par exemple?

J'ai remplacer pour MakeFile et le .IN et AM

et j'ai finalement ca :

Code
test -z "/tmp/myhplip/var/log/hp" || mkdir -p /tmp/myhplip/var/log/hp
chgrp -R "lp" DESTDIR)/var/log/hp
/bin/sh: -c: line 0: syntax error near unexpected token `)'
/bin/sh: -c: line 0: `chgrp -R "lp" DESTDIR)/var/log/hp'
make[1]: *** [install-dist_hplip_LogDATA] Error 2
make: *** [install-am] Error 2



Ce message a été modifié par imoopsy - 16 Mar 2013, 14:12.
Go to the top of the page
 
+Quote Post

2 Pages V   1 2 >
Reply to this topicStart new topic
1 utilisateur(s) sur ce sujet (1 invité(s) et 0 utilisateur(s) anonyme(s))
0 membre(s) :

 



Nous sommes le : 14th August 2018 - 14:15