IPB

Bienvenue invité ( Connexion | Inscription )

 
Reply to this topicStart new topic
> Instabilité Open Directory
Options
ericlovestztot
posté 14 Mar 2017, 09:48
Message #1


Nouveau Membre


Groupe : Membres
Messages : 9
Inscrit : 24 Jan 2017
Membre no 200 991



Bonjour,

Nous sommes en train de créer un réseau de Mac dans la configuration suivante :
- un MacMini serveur avec Mac OS X Server auquel est connecté une baie NAS Promise Pegasus 2 R6,
- 8 postes clients iMac sous Mac OS X Sierra.

Nous avons :
- créé un réseau local et VPN (.private),
- configuré le DNS avec une zone principale et une zone inverse,
- créé des comptes et groupes réseaux (Open Directory).

Tous les postes iMac clients sont configurés pour pointer sur le DNS du serveur (MacMini) puis sur la gateway (internet).

Nous avons partagé des dossiers du NAS aux différents groupes et comptes et nous constatons une instabilité de notre Open Directory. Lorsque nous examinons les droits d'un répertoire partagé, certains apparaissent en "Récupération".

Fichier joint  recup.jpg ( 63.87 Ko ) Nombre de téléchargements : 29


Auriez-vous des pistes d'investigations à nous indiquer ?

D'avance merci.

Ce message a été modifié par ericlovestztot - 14 Mar 2017, 16:39.
Go to the top of the page
 
+Quote Post
fmereo
posté 14 Mar 2017, 09:55
Message #2


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 2 419
Inscrit : 4 Oct 2002
Membre no 3 936



Vous utilisez quel protocole de partage ?

Quelle est la version d'OSX Serveur utilisée ?
Go to the top of the page
 
+Quote Post
ericlovestztot
posté 14 Mar 2017, 09:57
Message #3


Nouveau Membre


Groupe : Membres
Messages : 9
Inscrit : 24 Jan 2017
Membre no 200 991



SMB et AFP

Fichier joint  Protocope_partage.jpg ( 49.09 Ko ) Nombre de téléchargements : 21


Mac OS X Server version 5.2.

Ce message a été modifié par ericlovestztot - 14 Mar 2017, 10:03.
Go to the top of the page
 
+Quote Post
macinside
posté 16 Mar 2017, 14:52
Message #4


Macbidouilleur de vermeil !
****

Groupe : Membres
Messages : 1 154
Inscrit : 17 Jan 2001
Lieu : Vu pour la derniere fois entre Zurich et Genève ...
Membre no 5



euh, la gestion la gestion des droits ne s'effectue pas via le finder et les prefs systeme, mais via l'applicatio "server" ohmy.gif


--------------------

MacBook UniBody 2 Ghz et son cinema display :)
Go to the top of the page
 
+Quote Post
ericlovestztot
posté 16 Mar 2017, 17:07
Message #5


Nouveau Membre


Groupe : Membres
Messages : 9
Inscrit : 24 Jan 2017
Membre no 200 991



Citation (macinside @ 16 Mar 2017, 14:52) *
euh, la gestion la gestion des droits ne s'effectue pas via le finder et les prefs systeme, mais via l'applicatio "server" ohmy.gif

Certes, grâce à l'application server, nous avons créé les utilisateurs (et des groupes) et partagés 3 répertoires de la racine de notre NAS à ces utilisateurs, puis propagés ces droits dans les 3 arborescences.
Lorsque je vérifie, dans le finder, comment les droits se sont répercutés sur ces répertoires, je constate ces problèmes de récupérations, comme vous pouvez le voir sur ma copie d'écran.


Go to the top of the page
 
+Quote Post
fmereo
posté 19 Mar 2017, 20:41
Message #6


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 2 419
Inscrit : 4 Oct 2002
Membre no 3 936



Quels sont les symptômes/conséquences de cette instabilité de votre OD ?
Certains utilisateurs n'arrivent plus à se connecter ?
Ces derniers se connectent via quel protocole réseau ?
Go to the top of the page
 
+Quote Post
ericlovestztot
posté 20 Mar 2017, 16:12
Message #7


Nouveau Membre


Groupe : Membres
Messages : 9
Inscrit : 24 Jan 2017
Membre no 200 991



Citation (fmereo @ 19 Mar 2017, 20:41) *
Quels sont les symptômes/conséquences de cette instabilité de votre OD ?
Certains utilisateurs n'arrivent plus à se connecter ?
Ces derniers se connectent via quel protocole réseau ?

Comme indiqué plus haut, nous utilisons les 2 protocoles AFP et SMB.

Nous parvenons à nous connecter avec les comptes réseaux créés, mais comme vous le voyez dans les copies d'écran de mes messages précédents, le problème se situe au niveau du partage de répertoires/fichiers : une fois les partages de répertoires déclarés, l'on constate que ces droits ne descendent pas correctement dans l'arborescence. Ainsi, les utilisateurs n'ont pas l'accès qu'ils devraient avoir sur telle ou telle partie de l'arborescence.

Pourquoi alors est-ce que je parle d'instabilité de l'OD ?

En fait, au départ, tout fonctionne correctement :
- avec mon compte admin serveur, je créé un compte réseau client,
- je partage un répertoire à ce compte client et je fais descendre les droits dans l'arborescence,
- je vérifie, dans le Finder, que les droits du compte client sont bien descendus dans toute l'arborescence,
- et je vérifie que ce compte client a bien accès à ce qui est déclaré dans le partage.

Jusque-là, tout semble fonctionner normalement.

Puis je continue à modifier mon partage, d'ajouter de nouveaux utilisateurs sur le partage, etc..., et après quelques minutes de manipulations, je constate immanquablement ce dysfonctionnement : au bout d'un moment, les droits ne descendent plus correctement dans l'arborescence : certains comptes apparaissent en "récupération" sur les répertoires/fichiers de l'arborescence partagée.

A partir de là, rien n'y fait, si je supprime le partage et que je le recréé, le problème demeure. Par contre, si je supprime le compte client, que je le recréé et que je refais le partage, tout refonctionne pendant quelques minutes, puis le problème réapparait à nouveau.

Ce message a été modifié par ericlovestztot - 22 Mar 2017, 09:43.
Go to the top of the page
 
+Quote Post
fmereo
posté 22 Mar 2017, 17:21
Message #8


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 2 419
Inscrit : 4 Oct 2002
Membre no 3 936



OK donc le souci demeure en AFP comme en SMB…
Les Mac "tapent" le serveur de quelle manière exactement ?

je ne suis pas sûr que le souci vienne de l'OD… Que disent les log AFP et SMB ? Et ceux de l'OD ?
Go to the top of the page
 
+Quote Post
ericlovestztot
posté 23 Mar 2017, 14:31
Message #9


Nouveau Membre


Groupe : Membres
Messages : 9
Inscrit : 24 Jan 2017
Membre no 200 991



Je ne sais pas quel protocole est utilisé en priorité ! J'ai coché SMB et AFP lorsque j'ai défini les partages dans l'application serveur :

Fichier joint  Partage.jpg ( 78.41 Ko ) Nombre de téléchargements : 13


Comment puis-je voir et extraire les log ? Je débute... Et je galère !
Go to the top of the page
 
+Quote Post
roseau
posté 27 Mar 2017, 10:42
Message #10


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 5 188
Inscrit : 11 Feb 2003
Lieu : Bagneux
Membre no 6 110



As tu bien défini tes groupes utilisateurs, n'y a il pas redondance , quelle hiérarchie
Ton administrateur est il réseau ou local ( il me semble que c'est celui que le système cherche!!)

Ce sont des questions élémentaires auxquelles il faut répondre , d’ailleurs je t'invite à lire la doc technique Apple sur le sujet

bref c'est idiot mais c'est plutôt de ce coté qu'il faut chercher plutôt que coté bug de l'od


--------------------
MBP2016, MBP2015, Macmini late 2014 core I5 16 go yosemite/maverick MBpro 15" late 2014 core I7 2,2 16 go 10.9 , Mbp 15" late 2014 core i7 16 go 10.10; Macmini 2011 core i5 ( 10.9), MBPRO 13" fin 2010 10.9 , Imac debut 2010 10.5.8, Xserve/2008/ 1 2,8ghz quad-core xeon/osx server 10.9.4/mem 18 go/carte raid 3*1to raid 5,macbookpro 17" juin 2007 10.5.8, Antiquité: Macmini core 2 duo 1,8 /1024mo/10.5.8, Macmini 1,42/1024mo/10.4.11,G4 mono 1.25 (MDD 2003) /1500mo/10.4.11 server , 4400 200 upgrade g3/400,4400 240 , 6320, 7100 80/, lc 630, powerbook 180c,powerbook duo 210, Mac classic (panne vidéo) Mac SE...,os 10.4* , 10.3.9, os9.1/os8.1, os7.6, NAS CS407 Synology 4*500go (raid 5), NAS CS406 Synology 4*250go (raid 5)
Go to the top of the page
 
+Quote Post
ericlovestztot
posté 27 Mar 2017, 14:48
Message #11


Nouveau Membre


Groupe : Membres
Messages : 9
Inscrit : 24 Jan 2017
Membre no 200 991



Merci pour ces pistes intéressantes et qui me posent questions. Vous évoquez ceci :
Citation (roseau @ 27 Mar 2017, 11:42) *
Ton administrateur est il réseau ou local

En effet, le compte admin du serveur nommé SHDCOM-SERV est un compte local ! Doit-il être déclaré comme un compte réseau lui aussi ?
L'ensemble des autres comptes (ceux inclus dans les groupes utilisateurs de la copie d'écran ci-dessus) sont des utilisateurs réseaux qui ont été créés à partir du compte admin SHDCOM-SERV local !
Le problème viendrait-il de là selon vous ?

Ce message a été modifié par ericlovestztot - 27 Mar 2017, 14:55.
Go to the top of the page
 
+Quote Post
roseau
posté 27 Mar 2017, 21:48
Message #12


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 5 188
Inscrit : 11 Feb 2003
Lieu : Bagneux
Membre no 6 110



Citation (ericlovestztot @ 27 Mar 2017, 15:48) *
Merci pour ces pistes intéressantes et qui me posent questions. Vous évoquez ceci :
Citation (roseau @ 27 Mar 2017, 11:42) *
Ton administrateur est il réseau ou local

En effet, le compte admin du serveur nommé SHDCOM-SERV est un compte local ! Doit-il être déclaré comme un compte réseau lui aussi ?
L'ensemble des autres comptes (ceux inclus dans les groupes utilisateurs de la copie d'écran ci-dessus) sont des utilisateurs réseaux qui ont été créés à partir du compte admin SHDCOM-SERV local !
Le problème viendrait-il de là selon vous ?

Ne cherches pas plus loins l'administrateur du serveur n'est connu que du serveur, d'où
La recherche en boucle du propriétaire sur les clients

Tous les comptes et groupes utilises sur le réseau doivent être créés comme réseau sinon ils ne sont vus qu'en local

Ce message a été modifié par roseau - 29 Mar 2017, 08:07.


--------------------
MBP2016, MBP2015, Macmini late 2014 core I5 16 go yosemite/maverick MBpro 15" late 2014 core I7 2,2 16 go 10.9 , Mbp 15" late 2014 core i7 16 go 10.10; Macmini 2011 core i5 ( 10.9), MBPRO 13" fin 2010 10.9 , Imac debut 2010 10.5.8, Xserve/2008/ 1 2,8ghz quad-core xeon/osx server 10.9.4/mem 18 go/carte raid 3*1to raid 5,macbookpro 17" juin 2007 10.5.8, Antiquité: Macmini core 2 duo 1,8 /1024mo/10.5.8, Macmini 1,42/1024mo/10.4.11,G4 mono 1.25 (MDD 2003) /1500mo/10.4.11 server , 4400 200 upgrade g3/400,4400 240 , 6320, 7100 80/, lc 630, powerbook 180c,powerbook duo 210, Mac classic (panne vidéo) Mac SE...,os 10.4* , 10.3.9, os9.1/os8.1, os7.6, NAS CS407 Synology 4*500go (raid 5), NAS CS406 Synology 4*250go (raid 5)
Go to the top of the page
 
+Quote Post
ericlovestztot
posté 24 Oct 2017, 10:58
Message #13


Nouveau Membre


Groupe : Membres
Messages : 9
Inscrit : 24 Jan 2017
Membre no 200 991



ReBonjour à tous smile.gif
merci beaucoup pour vos messages précédents mais malheureusement je n'ai toujours pas réussi à régler mon problème.
Suite à nos échanges, j'ai bien crée un admin réseau dans mon opendirectory, puis ouvert une session sur mon Mac mini avec ce compte et fait un partage avec l'appli server pour des comptes réseaux, mais le problème est tjrs le même :
Le partage s'exécute, mais lorsque je contrôle les permissions sur les fichiers (cmd i) certaines permissions ne sont pas valides : Le nom du compte réseau apparaît toujours en "récupération".
Sincèrement je ne sais plus quoi faire.
Si quelqu'un a qqes idées pour essayer une autre solution je suis preneur.
Bien à vous.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 utilisateur(s) sur ce sujet (1 invité(s) et 0 utilisateur(s) anonyme(s))
0 membre(s) :

 



Nous sommes le : 21st November 2017 - 01:49