IPB

Bienvenue invité ( Connexion | Inscription )

 
Reply to this topicStart new topic
> Quelques soucis suite à réinstall
Options
Anard
posté 4 Jul 2018, 00:46
Message #1


Macbidouilleur de bronze !
**

Groupe : Membres
Messages : 420
Inscrit : 7 May 2015
Membre no 195 224



Coucou les aminches.

J'ai revu un peu ma config. Travaillant au départ avec un SSD partitionné pour macOS et Ubuntu, et commençant tous les deux à se sentir à l'étroit, j'ai décidé d'investir dans un nouveau SSD. Ca me permettra également de ne pas me retrouver contraint de démarrer Win en cas de défaillance du disque.
J'ai donc fait une clean install un peu laborieuse d'Ubuntu sur le nouveau SSD et ai tenté d'effacer mon ancienne partition Ubuntu pour étendre la macOS sur son disque dédié. Malheureusement ça a chié et j'ai dû faire une réinstall de macOS également... D'un côté c'est un mal pour un bien puisque ma recovery n'a jamais fonctionné et que maintenant elle roule.

Ça a pris un peu de temps pour remettre tout ça en place, macOS voulait que je fasse toutes les MAJ avant de récupérer mon TimeMachine, mais j'ai enfin l'install que je voulais : 3 SSD pour macOS, Ubuntu et Windows, un disque "Documents" partitionné en environ 3x200Go pour chacun, un disque partagé et un disque de sauvegardes (uniquement mac pour le moment).

Mais en refaisant mes "custom entries", j'ai remarqué qu'il y a encore quelques soucis pour que ce soit tout à fait propre.

  • Le disque système macOS contient la partition EFI Clover, la partition système et la recovery. Clover voit bien la partition système mais sans custom entries, il ajoutait une entrée "Linux" qui n'était autre que l'EFI. En supprimant grubx64.efi du dossier /EFI/ubuntu/, elle a disparu.
  • Le disque système Ubuntu contient la partition EFI avec Grub et la partition système. Après avoir fait mes custom entries, il me fait toujours apparaître deux entrées qui ont le même UUID et la même taille :
  • Le disque système Windows contient une partition "Microsoft reserved" que je ne sais pas ce que c'est et la partition système.
  • Le disque Documents est forcément un peu plus complexe et pas tout à fait logique:
    • une partition EFI qui semble contenir le bootloader de Windows. D'après l'UUID, c'est la partition que voit Clover pour booter Windows. Pourquoi l'a-t-il mis ici, c'est un mystère, mais ça ne m'arrange pas. En cas de défaillence de ce disque, je ne pourrais probablement plus démarrer Windows. lien vers la partition
    • Une partition Documents macOS
    • Une partition Documents Ubuntu
    • Une partition de swap pour décharger le SSD. Je ne suis pas certain que macOS l'utilise mais Ubuntu oui.
    • Une partition de Documents Windows (quasiment vide)
  • Le disque partagé dispose aussi d'une partition EFI qui contient des fichiers de boot, ce qui fait que sans custom entries, Clover les repère. J'ai été obligé d'enregisrer cette partition en custom entry et d'y mettre
    Code
    <key>Hidden</key><string>Always</string>
    pour qu'elle disparaisse. lien vers la partition
  • Le disque de sauvegarde est externe (USB) mais a aussi une première partition EFI qui contient un dossier "Temp". Cette partition n'est pas détectée par Clover, il n'y a apparemment pas de *.efi dedans (que des log et des txt).


Voilà, il y a des choses qui ne vont pas. Je me demande si je peux purement et simplement me permettre de supprimer les EFI de mon disque partagé et de mon disque de sauvegarde pour gagner 200Mo, et surtout éviter des conflits, ou est-ce qu'en UEFI, tous mes disques doivent avoir leur partition EFI ? Et si je dois les laisser, est-ce que je peux supprimer tout ce qu'il y a dans ces partitions pour éviter qu'elles ne soient détectées par Clover.
Est-ce que j'aurai un moyen simple de ramener la partition de boot de Windows sur son disque dédié ou est-ce que je suis obligé de passer par une réinstall de Windows également ? mad.gif Savez-vous pourquoi il a mis ça ici ?
Pourquoi Clover m'affiche deux entrées pour Ubuntu ? C'est encore cette histoire de boot sur Grub ou sur le kernel ? Ça me paraît étrange que ces 2 entrées soient identifiées exactement de la même façon. Et surtout, comment je peux en effacer une des deux sur Clover, vu qu'avec les custom entries, les partitions sont désignées par leur UUID ?

Ce que je veux au final, c'est qu'en cas de problème sur n'importe quel disque, je puisse démarrer comme si de rien n'était sur un des 2 autres. C'est pour ça qu'Ubuntu a installé son Grub sur son disque dédié... et que Windows aurait dû en faire autant.
Bon, si le disque Documents a une panne, je suis dans la merde, les trois systèmes deviendront complètement instables puisqu'ils auront perdus leurs dossiers /home mais à chaque jour suffit sa peine.

Allez, un petit rapport MacBidouille pour finir, comme ça vous savez tout..
PS : Je ne comprends pas bien pourquoi diskutil et Utilitaire de disque sous mac et Gparted sous linux voient ma partition "Documents Ubuntu" comme une HFS. Alors que fdisk sous Linux la voit bien comme Ext4...

Merci beaucoup pour vos conseils.

Ce message a été modifié par Anard - 4 Jul 2018, 01:15.


--------------------
"iMack" : GA-B85-D3H, Intel i5 4460, 8Go DDR3, GTX 570, SSD 128+120+60Go, HDD 500Go+1To / Clover - macOS Mojave / Ubuntu Bionic Beaver / Windows 10
"Portable" : Samsung P200, Intel Core2Duo T8100, 3Go DDR2, Radeon X1250, HDD 160Go / Grub2 - SliTaz 5.0 rolling / Windows 10
Go to the top of the page
 
+Quote Post
Anard
posté 9 Jul 2018, 08:01
Message #2


Macbidouilleur de bronze !
**

Groupe : Membres
Messages : 420
Inscrit : 7 May 2015
Membre no 195 224



Bonjour,

Pas d'idées ? Concernant Win, il a en effet installé son EFI sur mon disques "Utilisateurs". Tant pis, ça restera comme ça pour le moment.
Par contre je ne comprends pas du tout ce que sont ces deux entrées Linux dans Clover.
Quand je mets dans mon config.plist
Code
<key>GUI</key
<dict>
  <key>Scan</key>
  <true/>
</dict>

Ca fonctionne, il affiche aussi d'autres trucs (surtout des entrées Windows Legacy), les entrées ne sont pas classées dans l'ordre que je voudrais et ont un nom pas très parlant, mais Linux n'apparaît bien qu'une seule fois.
J'ai essayé de faire mes custom entries une par une : dès que j'écris celle de Linux, elle se retrouve doublée.
Code
    <key>GUI</key>
    <dict>
        <key>Scan</key>
        <dict>
            <key>Legacy</key>
            <false/>
            <key>Kernel</key>
            <false/>
        </dict>
        <key>Custom</key>
        <dict>
            <key>Entries</key>
            <array>
                <dict>
                    <key>Disabled</key>
                    <false/>
                    <key>FullTitle</key>
                    <string>Sierra</string>
                    <key>Ignore</key>
                    <false/>
                    <key>NoCaches</key>
                    <false/>
                    <key>Type</key>
                    <string>OSX</string>
                    <key>Volume</key>
                    <string>13EE866B-3A2F-47BC-83F5-580C71FB3C04</string>
                    <key>VolumeType</key>
                    <string>Internal</string>
                </dict>
                <dict>
                    <key>Disabled</key>
                    <false/>
                    <key>FullTitle</key>
                    <string>Bionic Beaver</string>
                    <key>Ignore</key>
                    <false/>
                    <key>Type</key>
                    <string>Linux</string>
                    <key>Volume</key>
                    <string>A2C1581F-083E-4DBF-B4B3-DD80A9BF70A9</string>
                    <key>VolumeType</key>
                    <string>Internal</string>
                </dict>
                <dict>
                    <key>Disabled</key>
                    <false/>
                    <key>FullTitle</key>
                    <string>Windows 10</string>
                    <key>Ignore</key>
                    <false/>
                    <key>Type</key>
                    <string>Windows</string>
                    <key>Volume</key>
                    <string>817C0D4E-644D-41B3-A889-B9191ED86131</string>
                    <key>VolumeType</key>
                    <string>Internal</string>
                </dict>
                <dict>
                    <key>Disabled</key>
                    <false/>
                    <key>FullTitle</key>
                    <string>Recovery macOS</string>
                    <key>Ignore</key>
                    <false/>
                    <key>NoCaches</key>
                    <false/>
                    <key>Type</key>
                    <string>OSXRecovery</string>
                    <key>Volume</key>
                    <string>E6D8B8AA-D8D3-42B0-9702-736579E2BC9E</string>
                </dict>
            </array>
        </dict>


Qu'est-ce que je fais mal ?

Ce message a été modifié par Anard - 9 Jul 2018, 08:03.


--------------------
"iMack" : GA-B85-D3H, Intel i5 4460, 8Go DDR3, GTX 570, SSD 128+120+60Go, HDD 500Go+1To / Clover - macOS Mojave / Ubuntu Bionic Beaver / Windows 10
"Portable" : Samsung P200, Intel Core2Duo T8100, 3Go DDR2, Radeon X1250, HDD 160Go / Grub2 - SliTaz 5.0 rolling / Windows 10
Go to the top of the page
 
+Quote Post
maclinuxG4
posté 9 Jul 2018, 16:50
Message #3


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 2 329
Inscrit : 28 Dec 2001
Lieu : ile de france
Membre no 1 715



t est sous quel version de clover ?

il as été corrigé la liste, car elle contenait plusieurs éléements.

NOTA: avant vérifie dans le shell les option boot, car, la redondance peut venir de la.

(command UEFI, list, voir les disques, puis les doublons. NE PAS SE TROMPER)


--------------------
hack gigadesign Z170-UD5 TH Skylane i7 6700k + 16 Go dimm + Nvidia GTX970 EVO 4095 Mo (port DP/ carte interne intel HDMI)+ 2 xST 1 T + 2x SSDD 500 Mo + ethernet + acer XF240H+ macOS Mac OS 10.12.6 + imprimante HP5520
 macpro1,1 Dual core 2,66 GHz, 4 Go FB-dimm+ radeon HD 5770 + ST 500 Go + LCD Samsung 710T + Mac OS 10.6.8 + plantronics DSP 500 + Canon S50 + imprimante HP5520 +  ipad mini
► NO WINDOWS BOOT... Only  linux manjaro

--------------------
Go to the top of the page
 
+Quote Post
Anard
posté 10 Jul 2018, 14:08
Message #4


Macbidouilleur de bronze !
**

Groupe : Membres
Messages : 420
Inscrit : 7 May 2015
Membre no 195 224



Je suis sur Clover r4586...
Pour le reste, j'avoue que je n'ai pas compris du tout... blink.gif


--------------------
"iMack" : GA-B85-D3H, Intel i5 4460, 8Go DDR3, GTX 570, SSD 128+120+60Go, HDD 500Go+1To / Clover - macOS Mojave / Ubuntu Bionic Beaver / Windows 10
"Portable" : Samsung P200, Intel Core2Duo T8100, 3Go DDR2, Radeon X1250, HDD 160Go / Grub2 - SliTaz 5.0 rolling / Windows 10
Go to the top of the page
 
+Quote Post
maclinuxG4
posté 10 Jul 2018, 17:58
Message #5


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 2 329
Inscrit : 28 Dec 2001
Lieu : ile de france
Membre no 1 715



si tu boot sous clover, tu as un accès UEFI en shell

--> si tu as des doublons, cela pourrait provenir de la



--------------------
hack gigadesign Z170-UD5 TH Skylane i7 6700k + 16 Go dimm + Nvidia GTX970 EVO 4095 Mo (port DP/ carte interne intel HDMI)+ 2 xST 1 T + 2x SSDD 500 Mo + ethernet + acer XF240H+ macOS Mac OS 10.12.6 + imprimante HP5520
 macpro1,1 Dual core 2,66 GHz, 4 Go FB-dimm+ radeon HD 5770 + ST 500 Go + LCD Samsung 710T + Mac OS 10.6.8 + plantronics DSP 500 + Canon S50 + imprimante HP5520 +  ipad mini
► NO WINDOWS BOOT... Only  linux manjaro

--------------------
Go to the top of the page
 
+Quote Post
Neutral_ch
posté 10 Jul 2018, 18:16
Message #6


Macbidouilleur de bronze !
**

Groupe : Membres
Messages : 384
Inscrit : 24 Feb 2016
Membre no 198 157



Citation (Anard @ 4 Jul 2018, 01:46) *
Voilà, il y a des choses qui ne vont pas. Je me demande si je peux purement et simplement me permettre de supprimer les EFI de mon disque partagé et de mon disque de sauvegarde pour gagner 200Mo, et surtout éviter des conflits, ou est-ce qu'en UEFI, tous mes disques doivent avoir leur partition EFI ? Et si je dois les laisser, est-ce que je peux supprimer tout ce qu'il y a dans ces partitions pour éviter qu'elles ne soient détectées par Clover.

Hello, si j'ai suivis, tu cherches simplement à cacher des partitions EFI au démarrage de Clover, visibles dans le menu bootloader (?)



--------------------
Hackintosh-> CM: GIGABYTE Z87X-UD3H (UEFI DualBIOS 9.0), Audio: ALC898, CPU: i7-4770k, GPU: Nvidia GTX 760, 4096Mo, Ram: 16Go,1600mhz DDR3
Wifi: TP-LINK TL-WDN4800 Dual Band Wireless N900, Bluetooth: Le moins cher en USB.. OS: Sierra 10.12.6 - Windows 7, 64bits
MBP A1286 (2011)-> i7 2.2ghz - AMD Radeon 6750 HD - 8go ram - SSD 250go MBP A1278 (2012)-> i5 2,5ghz - 8go ram - SSD 250go
Iphone-> 4S blanc 16go, tant que ça marche...
Go to the top of the page
 
+Quote Post
Anard
posté 10 Jul 2018, 23:27
Message #7


Macbidouilleur de bronze !
**

Groupe : Membres
Messages : 420
Inscrit : 7 May 2015
Membre no 195 224



Non pas tout à fait. En fait, j'ai plusieurs soucis, mais tous liés à es partitions EFI :

1 - J'ai des partitions EFI sur des disques qui ne contiennent aucun système. Je me demandais si je ferais mieux de les supprimer ou si c'est normal et qu'il vaut mieux les garder.

2 - Sans Custom Entries, Clover m'affiche les bonnes partitions, mais avec un nom barbare et dans un ordre que j'aimerais changer.
Quand j'édite mes custom entries, ça fonctionne bien pour macOS et Windows. Mais quand je crée la custom entry pour Linux, elle apparaît en double dans Clover (l'une comme "Linux" et l'autre comme "Ubuntu"). Ces deux entrées Clover pointent vers la même partition (en tout cas d'après leur UUID). Ca me paraît très bizarre et du coup je ne vois pas comment cacher cette seconde partition (puisque je les désigne par leur UUID). Que je sélectionne l'une ou l'autre, elles bootent correctement.
Je me rends compte que certains drivers de Clover se trouvent à la fois dans drivers64 et dans drivers64UEFI. Peut-être que ce serai lié ?

3 - Il semble que lors de son install, Windows ait installé sa partition EFI sur le disque Documents plutôt que sur son disque système. Je me demandais également s'il était possible de la déplacer sans avoir à réinstaller Windows, mais ça je ne pense pas.

Ce message a été modifié par Anard - 10 Jul 2018, 23:27.


--------------------
"iMack" : GA-B85-D3H, Intel i5 4460, 8Go DDR3, GTX 570, SSD 128+120+60Go, HDD 500Go+1To / Clover - macOS Mojave / Ubuntu Bionic Beaver / Windows 10
"Portable" : Samsung P200, Intel Core2Duo T8100, 3Go DDR2, Radeon X1250, HDD 160Go / Grub2 - SliTaz 5.0 rolling / Windows 10
Go to the top of the page
 
+Quote Post
Neutral_ch
posté 11 Jul 2018, 14:02
Message #8


Macbidouilleur de bronze !
**

Groupe : Membres
Messages : 384
Inscrit : 24 Feb 2016
Membre no 198 157



Citation (Anard @ 11 Jul 2018, 00:27) *
Non pas tout à fait. En fait, j'ai plusieurs soucis, mais tous liés à es partitions EFI :

1 - J'ai des partitions EFI sur des disques qui ne contiennent aucun système. Je me demandais si je ferais mieux de les supprimer ou si c'est normal et qu'il vaut mieux les garder.

Si tu ferais mieux de, je ne pense pas. Honnêtement elles ne dérangent en rien, elles ne sont pas vitale, si il n'existe pas d'OS sur le DD. Fait ton choix, mais tu peux tout laisser comme tel.

Citation
2 - Sans Custom Entries, Clover m'affiche les bonnes partitions, mais avec un nom barbare et dans un ordre que j'aimerais changer.
Quand j'édite mes custom entries, ça fonctionne bien pour macOS et Windows. Mais quand je crée la custom entry pour Linux, elle apparaît en double dans Clover (l'une comme "Linux" et l'autre comme "Ubuntu"). Ces deux entrées Clover pointent vers la même partition (en tout cas d'après leur UUID). Ca me paraît très bizarre et du coup je ne vois pas comment cacher cette seconde partition (puisque je les désigne par leur UUID). Que je sélectionne l'une ou l'autre, elles bootent correctement.
Je me rends compte que certains drivers de Clover se trouvent à la fois dans drivers64 et dans drivers64UEFI. Peut-être que ce serai lié ?

Hum, comme Windows via Clover je pense, peu importe la partition du DD lancé depuis Clover, il va au pire aller chercher l'amorçage dans l'EFI du DD correspondant. Si tu as 2 partitions visibles, elles ne peuvent pas être les mêmes, genre dupliqué (comme les partitions windows boot manager elles peuvent être cut au démarrage de Clover).

Fait un moment que je n'ai plus caché des partitions via config.plist, mais les miennes sont sous: Hide volume (UUID de clover). Tu devrais de toute manière avoir un UUID différent pour chaque partition, sans aucune exception.

Citation
3 - Il semble que lors de son install, Windows ait installé sa partition EFI sur le disque Documents plutôt que sur son disque système. Je me demandais également s'il était possible de la déplacer sans avoir à réinstaller Windows, mais ça je ne pense pas.

Alors là, pour ma part, impossible que Windows, pendant son installation, tout à coup, pouf, commence à créer/reformater/écrire, sur des EFI qui ne concerne pas le DD ou il est installé.


--------------------
Hackintosh-> CM: GIGABYTE Z87X-UD3H (UEFI DualBIOS 9.0), Audio: ALC898, CPU: i7-4770k, GPU: Nvidia GTX 760, 4096Mo, Ram: 16Go,1600mhz DDR3
Wifi: TP-LINK TL-WDN4800 Dual Band Wireless N900, Bluetooth: Le moins cher en USB.. OS: Sierra 10.12.6 - Windows 7, 64bits
MBP A1286 (2011)-> i7 2.2ghz - AMD Radeon 6750 HD - 8go ram - SSD 250go MBP A1278 (2012)-> i5 2,5ghz - 8go ram - SSD 250go
Iphone-> 4S blanc 16go, tant que ça marche...
Go to the top of the page
 
+Quote Post
polyzargone
posté 12 Jul 2018, 19:17
Message #9


Macbidouilleur d'Or !
*****

Groupe : Modérateurs
Messages : 9 889
Inscrit : 11 May 2006
Membre no 60 938



Citation (Anard @ 11 Jul 2018, 00:27) *
1 - J'ai des partitions EFI sur des disques qui ne contiennent aucun système. Je me demandais si je ferais mieux de les supprimer ou si c'est normal et qu'il vaut mieux les garder.


Si tu as formaté tes disques en GUID avec Utilitaire de disque, c'est normal. macOS créé automatiquement des partitions EFI même si aucun OS n'est installé dessus.

Si elles sont vides, tu peux soit les supprimer mais ça te laissera un espace vide d'environ 200 Mo en début de disque. Il faudrait alors utiliser gparted (par exemple) pour déplacer/agrandir la partition suivante mais ça peut être plus ou moins long en fonction de sa taille et de son contenu. Tout ça pour gagner 200 Mo, je ne suis pas sûr que ça en vaille la peine.

Donc tu peux aussi les garder ce qui pourrait s'avérer utile un jour si tu décides d'en faire des disques système wink.gif.

Citation (Anard @ 11 Jul 2018, 00:27) *
2 - Mais quand je crée la custom entry pour Linux, elle apparaît en double dans Clover (l'une comme "Linux" et l'autre comme "Ubuntu"). Ces deux entrées Clover pointent vers la même partition (en tout cas d'après leur UUID). Ca me paraît très bizarre et du coup je ne vois pas comment cacher cette seconde partition (puisque je les désigne par leur UUID). Que je sélectionne l'une ou l'autre, elles bootent correctement.
Je me rends compte que certains drivers de Clover se trouvent à la fois dans drivers64 et dans drivers64UEFI. Peut-être que ce serai lié ?


Poste un Rapport.zip avec, éventuellement, des captures de chaque partitions dans le menu de Clover (F10).

Je pense que c'est soit un problème de drivers, soit une mauvaise Custom entry.

Citation (Anard @ 11 Jul 2018, 00:27) *
3 - Il semble que lors de son install, Windows ait installé sa partition EFI sur le disque Documents plutôt que sur son disque système. Je me demandais également s'il était possible de la déplacer sans avoir à réinstaller Windows, mais ça je ne pense pas.


Tu aurais dû débrancher tous les disques avant l'installation de Windows. C'est valable également pour Linux parce qu'ils ont tendance à mettre leurs fichiers de boot là où ils veulent wink.gif.

Quoiqu'il en soit, il est possible de déplacer le dossier EFI/microsoft dans une autre partition EFI. Et si Windows ne démarre plus, il faudra débrancher tous les disques à nouveau (pour ne pas refaire la même erreur) et booter sur la clé d'install de Windows.

Ensuite, suit ce tuto à partir de l'Étape 5.




--------------------
Un MacmacOS 10.13 MacBook Air mi-2012 Core i5 1,7 GHz Intel HD 4000 SSD 64 Go
Des Hacks Gigabyte GA-H97-HD3 - Core i5 4570 3,20 GHz - Zotac Geforce GTX 1060 6 Go - 16 Go DDR3 - macOS 10.14/macOS 10.13.6/macOS 10.12/OS X 10.11.6/Win 10/Mint 18 Acer Aspire V3 772G Core i5 4210M 2,60 GHz - Intel HD 4600 + GTX 850M 2 Go (désactivée) - 16 Go DDR3 - macOS 10.14/macOS 10.13.6/macOS 10.12/Win 10/Mint 18 Dell Latitude e7440 Core i7 4600U 2,10 GHz - Intel HD 4400 - 16 Go DDR3 - macOS 10.14/macOS 10.13.6/Win 10 Medion MS-7616 - Core i5 650 3,20 GHz - Gainward GTX 650 Ti 2 Go - 8 Go DDR3 - macOS 10.14/macOS 10.13.6/Win 10 HP Elite 8300 USFF - Core i7 3770S 3,90 GHz - Intel HD 4000 - macOS 10.12/Win 10 - Clover (+ quelques autres...)

Politique vis à vis des outils automatisés et des distributions - Guide d'installation - Tutoriels - Lexique et utilité des Kexts - FAQ Générale du Hackintosh - FAQ des Bootloaders - FAQ des Bootflags - FAQ des problèmes les plus courants
Go to the top of the page
 
+Quote Post
Anard
posté 12 Jul 2018, 19:55
Message #10


Macbidouilleur de bronze !
**

Groupe : Membres
Messages : 420
Inscrit : 7 May 2015
Membre no 195 224



Merci pour ces réponses.

Citation
Si elles sont vides, tu peux soit les supprimer mais ça te laissera un espace vide d'environ 200 Mo en début de disque. Il faudrait alors utiliser gparted (par exemple) pour déplacer/agrandir la partition suivante mais ça peut être plus ou moins long en fonction de sa taille et de son contenu. Tout ça pour gagner 200 Mo, je ne suis pas sûr que ça en vaille la peine.

Elles contiennent des choses. Du coup il y en a une que j'ai vidée (sans la supprimer pour l'instant), et l'autre qui contient le bootloader de Windows donc pour le moment je la garde telle qu'elle.

Citation
Poste un Rapport.zip avec, éventuellement, des captures de chaque partitions dans le menu de Clover (F10).

C'est ce que j'avais fait dans mon premier post. Les captures d'écran sont toujours les mêmes, hormis le Recovery macOS qui est maintenant affiché. Et pour le reste, je crois n'avoir que vidé l'EFI inutile.
Voici donc le nouveau Rapport wink.gif

Concernant Windows, j'ai l'impression qu'il est le seul à n'avoir pas mis d'EFI sur son disque système (je pense qu'il a installé son bootloader sur mon disque Docs puisqu'il y a donc trouvé une partition EFI que macOS avait créée). En effet, lors de l'install, j'avais laissé ces deux disques branchés car je pensais que la redirection des dossiers utilisateurs se ferait au cours de l'installation.
Au début de son disque système, il a quand même une petite partition (de 16Mo si je me rappelles bien) de type inconnu et donc illisible.
Je vais bien lire le tuto d'Heinzolinger et verrai si je le réinstalle sans autre disques branchés ou si je tente de déplacer son bootloader.
Merci beaucoup.

Ce message a été modifié par Anard - 12 Jul 2018, 20:01.


--------------------
"iMack" : GA-B85-D3H, Intel i5 4460, 8Go DDR3, GTX 570, SSD 128+120+60Go, HDD 500Go+1To / Clover - macOS Mojave / Ubuntu Bionic Beaver / Windows 10
"Portable" : Samsung P200, Intel Core2Duo T8100, 3Go DDR2, Radeon X1250, HDD 160Go / Grub2 - SliTaz 5.0 rolling / Windows 10
Go to the top of the page
 
+Quote Post
polyzargone
posté 13 Jul 2018, 19:47
Message #11


Macbidouilleur d'Or !
*****

Groupe : Modérateurs
Messages : 9 889
Inscrit : 11 May 2006
Membre no 60 938



Bon en fait la question est la suivante : est-ce que tu peux refaire tes installations de Linux & Windows ou est-ce que c'est inenvisageable ?

Parce qu'en fait, tes "problèmes" viennent du fait que tu as laissé des disques branchés lors de l'installation de ces deux OS et que du coup, ils ont mis leurs bootloaders respectifs n'importe où. Sans parler des partitions propres à chaque OS qui sont bizarrement placées sur tes différents disques :

Le disque Windows n'a pas de partition EFI (en général, Windows l'appelle NO NAME et elle fait environ 100 Mo) :

Code
/dev/disk0 (internal, physical):
     #:                       TYPE NAME                    SIZE       IDENTIFIER
     0:      GUID_partition_scheme                        *60.0 GB    disk0
     1:         Microsoft Reserved                         16.8 MB    disk0s1
     2:       Microsoft Basic Data Windows                 59.5 GB    disk0s2
     3:           Windows Recovery                         505.4 MB   disk0s3


Sur le disque suivant (je suppose que c'est le disque destiné aux documents), tu as une partition HFS+ sans nom, une partition SWAP et une autre partition Windows Recovery :

Code
/dev/disk1 (internal, physical):
     #:                       TYPE NAME                    SIZE       IDENTIFIER
     0:      GUID_partition_scheme                        *500.1 GB   disk1
     1:                        EFI EFI                     209.7 MB   disk1s1
     2:                  Apple_HFS Docs Hack               200.0 GB   disk1s2
     3:                  Apple_HFS                         204.5 GB   disk1s3
     4:                 Linux Swap                         5.2 GB     disk1s4
     5:           Windows Recovery                         471.9 MB   disk1s5
     6:       Microsoft Basic Data Docs Windows            89.7 GB    disk1s6


Inutile de dire que les deux partitions SWAP et Windows Recovery n'ont rien à faire là tongue.gif !

Ensuite, tu as visiblement le disque dédié à Linux :

Code
/dev/disk2 (internal, physical):
     #:                       TYPE NAME                    SIZE       IDENTIFIER
     0:      GUID_partition_scheme                        *120.0 GB   disk2
     1:                        EFI EFI                     209.7 MB   disk2s1
     2:           Linux Filesystem                         119.8 GB   disk2s2


Logiquement, le dossier EFI/ubuntu devrait s'y trouver. C'est bien le cas ? Quoiqu'il en soit, c'est là que devrait aussi se trouver la partition SWAP et non sur le disque précédent.

Enfin, les disk3 et disk4 m'ont l'air OK. Mais je ne sais pas ce que contiennent leurs partitions EFI. Logiquement, on devrait trouver Clover dans la partition EFI du disk3 puisqu'il s'agit du disque contenant macOS :

Code
/dev/disk3 (internal, physical):
     #:                       TYPE NAME                    SIZE       IDENTIFIER
     0:      GUID_partition_scheme                        *128.0 GB   disk3
     1:                        EFI EFI                     209.7 MB   disk3s1
     2:                  Apple_HFS Hackintosh SSD          127.2 GB   disk3s2
     3:                 Apple_Boot Recovery HD             650.0 MB   disk3s3


Donc pour conclure, je dirais que tu as mal installé Windows et Linux. C'est pourquoi je conseille toujours de débrancher tous les disques lorsqu'on installe ces OS. Ils n'en font qu'à leur tête et mettent leurs fichiers là où bon leur semble. Ce qui n'est pas forcément là où on veut qu'ils soient.

NB : En ce qui concerne Clover, tu peux utiliser les drivers GrubEXFAT-64.efi ou VBoxExt4-64.efi pour qu'il reconnaisse Grub ou le noyau de Linux. Ce sera plus facile par la suite de masquer les entries.


--------------------
Un MacmacOS 10.13 MacBook Air mi-2012 Core i5 1,7 GHz Intel HD 4000 SSD 64 Go
Des Hacks Gigabyte GA-H97-HD3 - Core i5 4570 3,20 GHz - Zotac Geforce GTX 1060 6 Go - 16 Go DDR3 - macOS 10.14/macOS 10.13.6/macOS 10.12/OS X 10.11.6/Win 10/Mint 18 Acer Aspire V3 772G Core i5 4210M 2,60 GHz - Intel HD 4600 + GTX 850M 2 Go (désactivée) - 16 Go DDR3 - macOS 10.14/macOS 10.13.6/macOS 10.12/Win 10/Mint 18 Dell Latitude e7440 Core i7 4600U 2,10 GHz - Intel HD 4400 - 16 Go DDR3 - macOS 10.14/macOS 10.13.6/Win 10 Medion MS-7616 - Core i5 650 3,20 GHz - Gainward GTX 650 Ti 2 Go - 8 Go DDR3 - macOS 10.14/macOS 10.13.6/Win 10 HP Elite 8300 USFF - Core i7 3770S 3,90 GHz - Intel HD 4000 - macOS 10.12/Win 10 - Clover (+ quelques autres...)

Politique vis à vis des outils automatisés et des distributions - Guide d'installation - Tutoriels - Lexique et utilité des Kexts - FAQ Générale du Hackintosh - FAQ des Bootloaders - FAQ des Bootflags - FAQ des problèmes les plus courants
Go to the top of the page
 
+Quote Post
Anard
posté 13 Jul 2018, 20:06
Message #12


Macbidouilleur de bronze !
**

Groupe : Membres
Messages : 420
Inscrit : 7 May 2015
Membre no 195 224



Concernant la partition EFI du disques Documents, je pense que c'est ici que s'est logé Windows parce qu'il y a un dossier Microsoft qui contient un tas incalculable de bordel.

Le Swap sur le disque Documents... euh... j'ai fait exprès. Je pensais ainsi éviter des écritures trop fréquentes et inutiles sur le SSD,quitte à perdre un peu en rapidité. Au final, dans mon utilisation courante, c'est bien rare qu'elle soit utilisée, ma RAM suffit.
Concernant le Windows Recovery, je n'avais pas vu qu'il était dupliqué ohmy.gif
Et la partition HFS de 204,5Go, je ne comprends pas pourquoi elle est notée HFS par diskutil sous macOS et fdisk sous Linux. macOS n'arrive pas à la lire et sous Ubuntu, GParted et Disques la voient bien comme une partition Ext4 :


Clover est bien sur /dev/disk3s1 et Grub sur /dev/disk2s1

Ce message a été modifié par Anard - 13 Jul 2018, 20:11.


--------------------
"iMack" : GA-B85-D3H, Intel i5 4460, 8Go DDR3, GTX 570, SSD 128+120+60Go, HDD 500Go+1To / Clover - macOS Mojave / Ubuntu Bionic Beaver / Windows 10
"Portable" : Samsung P200, Intel Core2Duo T8100, 3Go DDR2, Radeon X1250, HDD 160Go / Grub2 - SliTaz 5.0 rolling / Windows 10
Go to the top of the page
 
+Quote Post
polyzargone
posté 14 Jul 2018, 10:10
Message #13


Macbidouilleur d'Or !
*****

Groupe : Modérateurs
Messages : 9 889
Inscrit : 11 May 2006
Membre no 60 938



Citation (Anard @ 13 Jul 2018, 21:06) *
Concernant la partition EFI du disques Documents, je pense que c'est ici que s'est logé Windows parce qu'il y a un dossier Microsoft qui contient un tas incalculable de bordel.


Formate les partitions EFI suivantes :

disk4s1 et disk1s1

Pour les fichiers de boot de Windows, tu peux les recréer et les mettre dans une nouvelle partition EFI sur le disk0 (v. Conversion d'un disque Windows de MBR vers GPT sans pertes).

Citation (Anard @ 13 Jul 2018, 21:06) *
Le Swap sur le disque Documents... euh... j'ai fait exprès. Je pensais ainsi éviter des écritures trop fréquentes et inutiles sur le SSD,quitte à perdre un peu en rapidité. Au final, dans mon utilisation courante, c'est bien rare qu'elle soit utilisée, ma RAM suffit.


Dans ce cas, c'est pas bien grave et tu peux la laisser là. C'est juste un peu inhabituel mais pas problématique en soi.

Citation (Anard @ 13 Jul 2018, 21:06) *
Concernant le Windows Recovery, je n'avais pas vu qu'il était dupliqué ohmy.gif

Clover est bien sur /dev/disk3s1 et Grub sur /dev/disk2s1


Ben du coup, c'est vraiment Windows qui a été "mal installé". Supprime la partition Windows Recovery inutile :

Code
   5:           Windows Recovery                         471.9 MB   disk1s5


Optionnel :

Je formaterai le disk0 qui contient uniquement Windows avec l'Utilitaire de disque de macOS (GUID Mac OS étendu journalisé) et je débrancherai tous les disques à part le disk0.

Ensuite, je te conseille de suivre ce tuto : Installer OS X et Windows en UEFI sur le même disque - Fonctionne également sur des disques différents

Il suffira de supprimer toutes les partitions HFS+ créées par l'Utilitaire de disque et de ne garder que la partition EFI (celle qui fait environ 200 Mo).

NB : Il se peut qu'en utilisant cette méthode, tu n'aies pas de partition Windows Recovery.

Citation (Anard @ 13 Jul 2018, 21:06) *
Et la partition HFS de 204,5Go, je ne comprends pas pourquoi elle est notée HFS par diskutil sous macOS et fdisk sous Linux. macOS n'arrive pas à la lire et sous Ubuntu, GParted et Disques la voient bien comme une partition Ext4 :


C'est probablement une erreur de diskutil. Tu devrais pouvoir la corriger avec gdisk.


--------------------
Un MacmacOS 10.13 MacBook Air mi-2012 Core i5 1,7 GHz Intel HD 4000 SSD 64 Go
Des Hacks Gigabyte GA-H97-HD3 - Core i5 4570 3,20 GHz - Zotac Geforce GTX 1060 6 Go - 16 Go DDR3 - macOS 10.14/macOS 10.13.6/macOS 10.12/OS X 10.11.6/Win 10/Mint 18 Acer Aspire V3 772G Core i5 4210M 2,60 GHz - Intel HD 4600 + GTX 850M 2 Go (désactivée) - 16 Go DDR3 - macOS 10.14/macOS 10.13.6/macOS 10.12/Win 10/Mint 18 Dell Latitude e7440 Core i7 4600U 2,10 GHz - Intel HD 4400 - 16 Go DDR3 - macOS 10.14/macOS 10.13.6/Win 10 Medion MS-7616 - Core i5 650 3,20 GHz - Gainward GTX 650 Ti 2 Go - 8 Go DDR3 - macOS 10.14/macOS 10.13.6/Win 10 HP Elite 8300 USFF - Core i7 3770S 3,90 GHz - Intel HD 4000 - macOS 10.12/Win 10 - Clover (+ quelques autres...)

Politique vis à vis des outils automatisés et des distributions - Guide d'installation - Tutoriels - Lexique et utilité des Kexts - FAQ Générale du Hackintosh - FAQ des Bootloaders - FAQ des Bootflags - FAQ des problèmes les plus courants
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 utilisateur(s) sur ce sujet (1 invité(s) et 0 utilisateur(s) anonyme(s))
0 membre(s) :

 



Nous sommes le : 23rd October 2018 - 13:18