IPB

Bienvenue invité ( Connexion | Inscription )

2 Pages V  < 1 2  
Reply to this topicStart new topic
> HPLIP sur MACOSX, ...?
Options
osnola
posté 16 Mar 2013, 16:04
Message #31


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 1 562
Inscrit : 21 Sep 2004
Lieu : Nancy
Membre no 23 949



Citation (imoopsy @ 16 Mar 2013, 13:58) *
Code
chgrp -R "lp" $(DESTDIR)$(hplip_Logdir)


...

Code
test -z "/tmp/myhplip/var/log/hp" || mkdir -p /tmp/myhplip/var/log/hp
chgrp -R "lp" DESTDIR)/var/log/hp
/bin/sh: -c: line 0: syntax error near unexpected token `)'
/bin/sh: -c: line 0: `chgrp -R "lp" DESTDIR)/var/log/hp'
make[1]: *** [install-dist_hplip_LogDATA] Error 2
make: *** [install-am] Error 2

C'est bizarre comme erreur, as-tu bien laissé un espace après "lp" et aussi le premier $( ?
Si oui, il va falloir que tu attaches le Makefile que tu obtiens pour que je regarde ce qui ne va pas...

Normalement, après avoir fait les changements, tu devrais obtenir ( pour le Makefile ) quelque chose qui ressemble à :
Code
...
install-dist_hplip_LogDATA:
    test -z "$(DESTDIR)$(hplip_Logdir)" || mkdir -p $(DESTDIR)$(hplip_Logdir)
    chgrp  -R "lp" $(DESTDIR)$(hplip_Logdir)
    chmod 775 $(DESTDIR)$(hplip_Logdir)
    test -z "$(DESTDIR)$(hplip_Logdir)" || mkdir -p $(DESTDIR)$(hplip_Logdir)
    chgrp -R "lp" $(DESTDIR)$(hplip_Logdir)
    chmod 775 $(DESTDIR)$(hplip_Logdir)

install-dist_hplip_tmpDATA:
    test -z "$(DESTDIR)$(hplip_tmpdir)" || mkdir -p $(DESTDIR)$(hplip_tmpdir)
    chgrp -R "lp" $(DESTDIR)$(hplip_tmpdir)
    chmod 1775 $(DESTDIR)$(hplip_tmpdir)
    test -z "$(DESTDIR)$(hplip_tmpdir)" || mkdir -p $(DESTDIR)$(hplip_tmpdir)
    chgrp -R "lp" $(DESTDIR)$(hplip_tmpdir)
    chmod 1775 $(DESTDIR)$(hplip_tmpdir)
...

( en notant qu'avant "test -z...", en fait il y a un caractère de tabulation et non des espaces )

Ce message a été modifié par osnola - 17 Mar 2013, 09:29.
Go to the top of the page
 
+Quote Post
imoopsy
posté 17 Mar 2013, 11:54
Message #32


Adepte de Macbidouille
*

Groupe : Membres
Messages : 53
Inscrit : 10 Dec 2009
Membre no 146 866



En effet j'avais oublier un $ , du coup ca ne marchait pas et bien j'ai le plaisir de te dire que je n'ai plus d'erreur , les derniers lignes du sudo make install donne

Code
if [ "yes" = "yes" ]; then \
       /bin/sh /Users/Nathalie/Desktop/stuff/hplip-3.13.3/install-sh -d /etc/sane.d; \
       if [ ! -f /etc/sane.d/dll.conf ]; then \
          touch /etc/sane.d/dll.conf; \
       fi; \
       if ! grep ^hpaio /etc/sane.d/dll.conf >/dev/null 2>/dev/null; then \
          echo "Adding hpaio entry to /etc/sane.d/dll.conf."; \
          echo hpaio >>/etc/sane.d/dll.conf; \
       fi \
    fi
/bin/sh /Users/Nathalie/Desktop/stuff/hplip-3.13.3/install-sh -d /usr/bin
for i in align.py info.py print.py toolbox.py clean.py colorcal.py unload.py testpage.py makeuri.py check.py fab.py levels.py sendfax.py setup.py makecopies.py probe.py timedate.py firmware.py scan.py systray.py plugin.py linefeedcal.py pqdiag.py faxsetup.py devicesettings.py printsettings.py query.py pkservice.py wificonfig.py diagnose_plugin.py uninstall.py upgrade.py config_usb_printer.py diagnose_queues.py logcapture.py doctor.py; do \
       cmd=`basename $i .py`; \
       if [ ! \( "$cmd" = "toolbox" -a "yes" = "no" \) ]; then \
          ln -sf ../share/hplip/$i /usr/bin/hp-$cmd; \
       fi \
    done
if [ "yes" = "yes" ]; then \
       mv /usr/lib/cups/backend/hpfax.py /usr/lib/cups/backend/hpfax; \
       chmod 700 /usr/lib/cups/backend/hpfax; \
    fi


J'imagine que c'est bon ? Je dois mettre yes ?

Lol , vraiment je te remercie pour ta patience, ton aide , je crois que beaucoup se serait décourager ( moi la premiere ) ca fait genre 3 week end que je passe dessus !

Ce message a été modifié par imoopsy - 17 Mar 2013, 12:09.
Go to the top of the page
 
+Quote Post
osnola
posté 17 Mar 2013, 13:23
Message #33


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 1 562
Inscrit : 21 Sep 2004
Lieu : Nancy
Membre no 23 949



Citation (imoopsy @ 17 Mar 2013, 11:54) *
En effet j'avais oublier un $ , du coup ca ne marchait pas et bien j'ai le plaisir de te dire que je n'ai plus d'erreur , les derniers lignes du sudo make install donne

....[/code]

J'imagine que c'est bon ? Je dois mettre yes ?

Si quand tu lances sudo make install, il n'affiche pas d'erreur, oui je suppose. Ensuite, il faut tester ensuite si le driver est bien appelé lorsque tu lances l'impression
( mais comme de toute façon, je n'ai pas de possibilité de lancer ce driver, il est inutile que je fasse l'installation, il faudra chercher sur le web ).

Citation
Lol , vraiment je te remercie pour ta patience, ton aide , je crois que beaucoup se serait décourager ( moi la premiere ) ca fait genre 3 week end que je passe dessus !

De rien, pour une première, tu as commencé par un package bien compliqué...

Edit:
Citation (imoopsy @ 17 Mar 2013, 11:54) *
Code
if [ "yes" = "yes" ]; then \
       /bin/sh /Users/Nathalie/Desktop/stuff/hplip-3.13.3/install-sh -d /etc/sane.d; \
       if [ ! -f /etc/sane.d/dll.conf ]; then \
...

Je suppose que cela correspond aux dernières lignes affichées ; dans ces lignes, make install teste si il a bien construit le scanner et le fax pour savoir si il doit ou non installer les
fichiers correspondant, ie. ces lignes se retrouvent dans le Makefile :
Code
if [ "$(scan_build)" = "yes" ]; then \
           $(mkinstalldirs) $(DESTDIR)/etc/sane.d; \
           if [ ! -f $(DESTDIR)/etc/sane.d/dll.conf ]; then \

et comme scan_build valait vrai(yes), il a bien installé ces fichiers, idem pour la variable fax_build...

Ce message a été modifié par osnola - 18 Mar 2013, 08:58.
Go to the top of the page
 
+Quote Post
imoopsy
posté 20 Mar 2013, 12:57
Message #34


Adepte de Macbidouille
*

Groupe : Membres
Messages : 53
Inscrit : 10 Dec 2009
Membre no 146 866



Super ! merci beaucoup pour les explications.
Malheureusement quand je tape hp-toolbox pour configuré cela me met :
Code
macpook-bro-2:hplip-3.13.3 Nathalie$ hp-toolbox
Traceback (most recent call last):
  File "/usr/bin/hp-toolbox", line 39, in <module>
    from base import status, tui, module
  File "/usr/share/hplip/base/status.py", line 59, in <module>
    import hpmudext
ImportError: No module named hpmudext
macpook-bro-2:hplip-3.13.3 Nathalie$



et quand je vais dans mon interface dans preférence , sur sane je n'ai pas dans la liste " hplip " donc je ne peux pas le coché, je crois qu'il n'a pas était reconnu par sane ou alors pas installé pour sane ...

Ce message a été modifié par imoopsy - 20 Mar 2013, 12:58.
Fichier(s) joint(s)
Fichier joint  Capture_d___e__cran_2013_03_20_a___12.52.37.png ( 105.06 Ko ) Nombre de téléchargements : 5
 
Go to the top of the page
 
+Quote Post
osnola
posté 24 Mar 2013, 10:49
Message #35


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 1 562
Inscrit : 21 Sep 2004
Lieu : Nancy
Membre no 23 949



Citation (imoopsy @ 20 Mar 2013, 12:57) *
Malheureusement quand je tape hp-toolbox pour configuré cela me met :
Code
macpook-bro-2:hplip-3.13.3 Nathalie$ hp-toolbox
Traceback (most recent call last):
  File "/usr/bin/hp-toolbox", line 39, in <module>
    from base import status, tui, module
  File "/usr/share/hplip/base/status.py", line 59, in <module>
    import hpmudext
ImportError: No module named hpmudext
macpook-bro-2:hplip-3.13.3 Nathalie$

Bonjour,
bon je viens de refaire mes librairies et de lancer une installation, pour cette erreur, cela doit pouvoir se résoudre en définissant la variable PYTHONPATH,
comme si dessous en bash ...
Code
export PYTHONPATH=/usr/local//lib/python2.6/site-packages/:

ou si tu utilises csh...
Code
setenv PYTHONPATH /usr/local//lib/python2.6/site-packages/:

après dans la même fenêtre, hp-toolbox devrait retrouver hpmudext... Il y a sûrement une façon de rajouter /usr/local//lib/python2.6/site-packages/ dans la liste des répertoires où python doit rechercher ses sources ; cela serait plus propre, mais je ne connais pas suffisamment python...

Après si il se plaint qu'il ne trouve pas Qt/PyQt 4, il te faudra sûrement installer pyqt ...


Go to the top of the page
 
+Quote Post
noop
posté 24 Mar 2013, 11:35
Message #36


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 2 964
Inscrit : 3 Nov 2005
Membre no 49 239



Code
chgrp -R "lp" DESTDIR)/var/log/hp


Il y a une erreur. Essaye:


Code
chgrp -R "lp" $($DESTDIR)/var/log/hp
Go to the top of the page
 
+Quote Post
Jaypee
posté 24 Mar 2013, 12:16
Message #37


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 2 344
Inscrit : 29 Aug 2002
Membre no 3 340



Python a un IDE qui s'appelle Leo, et il est aussi contruit sur Qt et PyQt.
J'ai voulu essayer, et j'y suis arrivé, mais il faut des outils supplémentaires du monde Python (SIP 4.04), le python du Mac est un 2.7 et n'a pa suffi, un 2.7.3 a été nécessaire, mais au final le tout dernier Qt 5.0.1 a été installé

PyQt et SIP sont ici:
Python


J-P
Go to the top of the page
 
+Quote Post
Bubu
posté 14 Jun 2018, 06:49
Message #38


Macbidouilleur de bronze !
**

Groupe : Membres
Messages : 265
Inscrit : 27 Dec 2002
Lieu : Punaauia (Tahiti / Polynésie française)
Membre no 5 317



Bonjour,

Le portage de HPLIP (Hewlett Packard Linux Imaging and Printing) sous OS X est attendu de longue date.

Pour rappel, ce logiciel permet de réutiliser les anciennes imprimantes multifonctions de marque Hewlett Packard (qu'elles soient de type laser ou jet d'encre) sous Linux et donc de lutter contre l'obsolescence programmée.

Les pilotes fournis par HPLIP prennent en charge toutes les fonctions sur plus de 2 800 modèles d'imprimantes HP : l'impression, la numérisation, l'envoi et la réception de télécopies.

Testé ce jour sous Linux Mint 19 (32 bits) avec une vieille imprimante laser multifonctions HP LaserJet 3200m sortie du grenier, cela fonctionne parfaitement !

Pour info, j'ai découvert qu'un dénommé Ricardo Fabbri a réussi à compiler HPLIP sous Mac OS X 10.9.4 en utilisant la méthode décrite sur ce site.

Apparemment, il utilise les librairies USB de MacPort. Pour rendre cette compilation possible, il a surtout dû effectuer de nombreuses modifications dans les fichiers sources et les a rendues publiques sur GitHub.

Un développeur charitable pourrait-il reprendre ce travail et compiler ce logiciel afin que l'on puisse le tester sous MacOS High Sierra ?

Cordialement,

Ce message a été modifié par Bubu - 14 Jun 2018, 10:05.
Go to the top of the page
 
+Quote Post

2 Pages V  < 1 2
Reply to this topicStart new topic
1 utilisateur(s) sur ce sujet (1 invité(s) et 0 utilisateur(s) anonyme(s))
0 membre(s) :

 



Nous sommes le : 19th September 2018 - 10:41