IPB

Bienvenue invité ( Connexion | Inscription )

> Programmation

Il est interdit de poster directement à la racine de ce forum.
Veuillez créer votre topic dans le sous-forum approprié.

 
Reply to this topicStart new topic
> Désinstaller proprement WebObject, Apple fait ce qu'elle déconseille
Options
sky.x
posté 7 Jan 2004, 14:44
Message #1


Macbidouilleur de vermeil !
****

Groupe : Membres
Messages : 1 437
Inscrit : 4 Oct 2001
Lieu : Swords (Co Dublin)
Membre no 938



Voilà, vous avez installé WebObject pour essayer (la version de démo..) et vous vous êtes rendu compte qu'OpenBase vous prend pas mal de ressource et que SPIP correspond plus à vos attentes, puisque vous n'êtes pas professionnel et que vous voulez faire un petit site personnel.

Vous lancer le désinstalleur et là, miracle, il vous demande d'activer le compte root.

Vous avez le choix entre activer ce compte (mais s'il est désactivé par défaut, c'est parce qu'il y a des raisons...) ou ouvrir un terminal et taper :

sudo /Applications/Utilities/WO52Uninstall.app/Contents/MacOS/WO52Uninstall

Vous tapez votre mot de passe puis entrée et "voilà".

Personnellement, quand j'ai vu le message "activez votre compte root", j'ai cru que ce désinstalleur était programmé par M$.

[EDIT]
Il faut ensuite commenté la dernière ligne de httpd.conf (dans /etc/httpd/httpd.conf) :
en ajoutant un # au début de la ligne :
#Include /System/Library/WebObjects/Adaptors/Apache/apache.conf

Pour cela (dans un terminal) :
sudo pico /etc/httpd/httpd.conf
(taper son mot de pass puis entrer)

Contrôle-W puis taper webobject
passer à la ligne suivant er mettre un # au debut.
Contrôle-O (sauver) puis entrer
contrôle-X (quitter)

Ce message a été modifié par sky.x - 8 Jan 2004, 13:04.


--------------------
Ce post contient des avis, vous n'êtes pas en accord avec moi ? Expliquez moi votre point de vue, mais ne profitez pas de ce que j'avance pour me juger.

Programmeurs sous OSX bienvenus là -> cocoa-x
Go to the top of the page
 
+Quote Post
Ynnead
posté 29 Jan 2007, 22:53
Message #2


Nouveau Membre


Groupe : Membres
Messages : 36
Inscrit : 30 Sep 2006
Membre no 69 348



Mhmmm... on va m'accuser de déterrer un vieux sujet (à la racine du forum en plus, honte à moi), mais j'estime que c'est quand mieux que d'en ouvrir un nouveau !

J'ai récemment téléchargé la dernière version de XCode, et j'en ai profité pour installer WebObjects et OpenBase dans la foulée. Hors la version de OpenBase est assez vieille (8), et pour tout dire elle fonctionne très mal (voir pas du tout : OpenBase Updater télécharge indéfiniement une mise à jour virtuelle, et rien ne se passe quand je clique désespérément sur "New Base"). Je suis donc en train de télécharger OpenBase 10 Solo, mais j'aimerai avant de l'installer savoir s'il faut désinstaller la version obsolète, et si oui comment le faire proprement... Si quelqu'un a déjà effectué l'opération, qu'il me fasse signe ! smile.gif
Merci d'avance

Ce message a été modifié par Ynnead - 29 Jan 2007, 22:57.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 utilisateur(s) sur ce sujet (1 invité(s) et 0 utilisateur(s) anonyme(s))
0 membre(s) :

 



Nous sommes le : 21st September 2017 - 08:06