IPB

Bienvenue invité ( Connexion | Inscription )

 
Reply to this topicStart new topic
> Eclipse : pb JVM
Options
Eddoul
posté 15 May 2018, 04:18
Message #1


Macbidouilleur de bronze !
**

Groupe : Membres
Messages : 495
Inscrit : 21 Dec 2007
Membre no 103 074



Bonjour,

J'ai installé Eclipse.
A l'ouverture, j'ai ce pb :
Code
version 1.6.0_65 of the JVM is not suitable for this product
Version 1.8 or greater is required


J'ai installé Java

Le fichier eclipse.ini
Code
-startup
../Eclipse/plugins/org.eclipse.equinox.launcher_1.4.0.v20161219-1356.jar
--launcher.library
../Eclipse/plugins/org.eclipse.equinox.launcher.cocoa.macosx.x86_64_1.1.551.v20171108-1834
-product
org.eclipse.epp.package.php.product
-showsplash
org.eclipse.epp.package.common
--launcher.defaultAction
openFile
--launcher.defaultAction
openFile
--launcher.appendVmargs
-vmargs
-Dosgi.requiredJavaVersion=1.8
-Dosgi.instance.area.default=@user.home/eclipse-workspace
-XX:+UseG1GC
-XX:+UseStringDeduplication
--add-modules=ALL-SYSTEM
-XstartOnFirstThread
-Dorg.eclipse.swt.internal.carbon.smallFonts
-Dosgi.requiredJavaVersion=1.8
-Xms256m
-Xmx1024m
--add-modules=ALL-SYSTEM
-Xdock:icon=../Resources/Eclipse.icns
-XstartOnFirstThread
-Dorg.eclipse.swt.internal.carbon.smallFonts



Que dois-je faire ?

Merci pour votre aide.

Eddy


--------------------
Machines en ma possession :
- Imac 20", 4,3Ghz, HDD 250, 4Go RAM
Go to the top of the page
 
+Quote Post
jeanjd63
posté 15 May 2018, 06:51
Message #2


Adepte de Macbidouille
*

Groupe : Membres
Messages : 163
Inscrit : 15 Nov 2007
Lieu : Ardèche
Membre no 99 922



Salut

Que te renvoient depuis le terminal :
java -version
et
ls -l /Library/Java/JavaVirtualMachines/
Go to the top of the page
 
+Quote Post
baron
posté 15 May 2018, 07:38
Message #3


Macbidouilleur d'Or !
*****

Groupe : Modérateurs
Messages : 11 409
Inscrit : 22 Jul 2004
Lieu : Louvain-la-Neuve (Gaule Gelbique)
Membre no 21 291



Peux-tu préciser ce qu'est Eclipse ?

Eventuellement un petit tour là :
https://www.java.com/fr/download/faq/java_mac.xml


--------------------
MacBook Pro 15’’ 2010 Core i5 2,53 GHz, 4 Go/500 Go – Mac OSX 10.6.8  Power Macintosh G3 beige de bureau, rev.1 @ 233MHz, 288 Mo/4Go – MacOS 9.1 — + carte PCI IDE/ATA Tempo 66 Acard 6260 avec HD interne Maxtor 80 Go + graveur interne CDRW/DVD LG GCC-4520B + tablette A4 Wacom UD-0608-A + LaCie ElectronBlueIV 19" + HP ScanJet 6100C   Routeur/modem ADSL Trendnet TW100-BRM504 > B-Box 3 + HP LaserJet 4000 N  
La recherche dans MacBidouille vous paraît obscure ? J'ai rédigé une proposition de FAQ. Le moteur logiciel a un peu changé depuis mais ça peut aider quand même.
Les corsaires mettent en berne…
Go to the top of the page
 
+Quote Post
Eddoul
posté 15 May 2018, 16:28
Message #4


Macbidouilleur de bronze !
**

Groupe : Membres
Messages : 495
Inscrit : 21 Dec 2007
Membre no 103 074



Citation (jeanjd63 @ 15 May 2018, 07:51) *
java -version

Code
java -version
java version "1.6.0_65"
Java(TM) SE Runtime Environment (build 1.6.0_65-b14-468)
Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-468, mixed mode)


Citation
ls -l /Library/Java/JavaVirtualMachines/

Code
ls -l /Library/Java/JavaVirtualMachines/
total 0
drwxr-xr-x  3 root  wheel  102 14 jul  2015 1.6.0.jdk


voilà la raison.
comment upgrader ?


--------------------
Machines en ma possession :
- Imac 20", 4,3Ghz, HDD 250, 4Go RAM
Go to the top of the page
 
+Quote Post
Eddoul
posté 15 May 2018, 16:48
Message #5


Macbidouilleur de bronze !
**

Groupe : Membres
Messages : 495
Inscrit : 21 Dec 2007
Membre no 103 074



j'ai installé la dernière version sur le site java : jre-8u171-macosx-x64
mais encore la même version java
Code
java version "1.6.0_65"
Java(TM) SE Runtime Environment (build 1.6.0_65-b14-468)
Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-468, mixed mode)


--------------------
Machines en ma possession :
- Imac 20", 4,3Ghz, HDD 250, 4Go RAM
Go to the top of the page
 
+Quote Post
jeanjd63
posté 15 May 2018, 16:57
Message #6


Adepte de Macbidouille
*

Groupe : Membres
Messages : 163
Inscrit : 15 Nov 2007
Lieu : Ardèche
Membre no 99 922



Je viens de faire l'essai d'installer Eclipse et il demande d'abord j'installation du JDK Mac et ensuite il râle sur la version.
J'ai téléchargé et installé ceci : http://download.oracle.com/otn-pub/java/jd...-macosx-x64.dmg
Et là ça passe.
Go to the top of the page
 
+Quote Post
Eddoul
posté 15 May 2018, 22:06
Message #7


Macbidouilleur de bronze !
**

Groupe : Membres
Messages : 495
Inscrit : 21 Dec 2007
Membre no 103 074



j'ai bien installé cette version Java 8 Update 171 qui s'est correctement terminée

Citation (jeanjd63 @ 15 May 2018, 17:57) *
Je viens de faire l'essai d'installer Eclipse et il demande d'abord j'installation du JDK Mac et ensuite il râle sur la version.

tu as installé quel version d'Eclipse ?


--------------------
Machines en ma possession :
- Imac 20", 4,3Ghz, HDD 250, 4Go RAM
Go to the top of the page
 
+Quote Post
jeanjd63
posté 16 May 2018, 05:21
Message #8


Adepte de Macbidouille
*

Groupe : Membres
Messages : 163
Inscrit : 15 Nov 2007
Lieu : Ardèche
Membre no 99 922



Citation (Eddoul @ 15 May 2018, 23:06) *
j'ai bien installé cette version Java 8 Update 171 qui s'est correctement terminée

Citation (jeanjd63 @ 15 May 2018, 17:57) *
Je viens de faire l'essai d'installer Eclipse et il demande d'abord j'installation du JDK Mac et ensuite il râle sur la version.

tu as installé quel version d'Eclipse ?


En fait je suis allé sur cette page : https://www.eclipse.org/downloads/ et quand j'ai voulu installer il a ralé et m'a téléchargé la version Mac du JDK : https://support.apple.com/kb/DL1572?locale=...iewlocale=fr_FR (celle qui est installée chez toi).
Et quand j'ai relancé, j'ai eu le message "version trop ancienne".
Alors j'ai installé la version 8 du JDK : http://download.oracle.com/otn-pub/java/jd...-macosx-x64.dmg
Et là il m'a proposé différentes version.
Ensuite j'ai arrêté.

As-tu essayé avec la version ci-dessus?
Go to the top of the page
 
+Quote Post
Eddoul
posté 16 May 2018, 17:32
Message #9


Macbidouilleur de bronze !
**

Groupe : Membres
Messages : 495
Inscrit : 21 Dec 2007
Membre no 103 074



Pour Oracle, je me suis créé un compte et je me suis connecté, mais j'ai toujours ceci :



Sorry!

In order to download products from Oracle Technology Network you must agree to the OTN license terms.


Be sure that...
Your browser has "cookies" and JavaScript enabled.
You clicked on "Accept License" for the product you wish to download.
You attempt the download within 30 minutes of accepting the license.

From here you can go...


Back to Previous Page
Site Map
OTN Homepage


--------------------
Machines en ma possession :
- Imac 20", 4,3Ghz, HDD 250, 4Go RAM
Go to the top of the page
 
+Quote Post
jeanjd63
posté 16 May 2018, 17:45
Message #10


Adepte de Macbidouille
*

Groupe : Membres
Messages : 163
Inscrit : 15 Nov 2007
Lieu : Ardèche
Membre no 99 922



Ok
Passe par cette page : http://www.oracle.com/technetwork/java/jav...ds-2133151.html
Tu coches la case "Accept License Agreement" :
Et tu choisis Java SE Development Kit 8u172 qui correspond à Mac OS X x64

Ce message a été modifié par jeanjd63 - 16 May 2018, 17:52.
Go to the top of the page
 
+Quote Post
Eddoul
posté 16 May 2018, 20:22
Message #11


Macbidouilleur de bronze !
**

Groupe : Membres
Messages : 495
Inscrit : 21 Dec 2007
Membre no 103 074



j'ai installé la package de ce Java.
L'install de Eclipse se lance.

MErci.


--------------------
Machines en ma possession :
- Imac 20", 4,3Ghz, HDD 250, 4Go RAM
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 utilisateur(s) sur ce sujet (1 invité(s) et 0 utilisateur(s) anonyme(s))
0 membre(s) :

 



Nous sommes le : 22nd May 2018 - 03:25