IPB

Bienvenue invité ( Connexion | Inscription )

 
Reply to this topicStart new topic
> Installation d'un logiciel linux compilé.
Options
Dodo_v
posté 13 Apr 2013, 21:53
Message #1


Nouveau Membre


Groupe : Membres
Messages : 27
Inscrit : 20 Nov 2010
Lieu : Strasbourg
Membre no 161 494



Bonjour à tous,

Avant tout, l'objectif : je souhaite installer Quartus Web Edition 9.1 ( Lien Site officiel ) il s'agit d'un logiciel de design et programmation de FPGA, mais aussi ASIC ... bref.

J'ai donc téléchargé la version linux, en espérant avoir quelque chose de plus mac-friendly que de passer par wine.

En décompressant l'archive, j'ai donc ce que je pense être un programme d'installation (indice : le fichier s'apelle "install") si je le lance le terminal répond : "The current operating system is not supported in this release"

J'ai donc imaginé passer par MacPorts, mais à ce que j'y comprend, MacPorts ne peut compiler et installer que les programmes que l'équipe macports diffuse sous forme de code source... or, il me semble avoir quelque chose de déjà compilé.
Quelqu'un s'est déjà retrouvé dans ce cas ?

Voilà j'espère avoir été assez clair.

Merci.


--------------------
Etudiant en électronique.

MacBook Pro 13" Late April 2010 - 2.4Ghz, 8Go, Nvidia 320M 256Mo, Crucial M4 256Go
Nokia N8 + Bluephone elite 2 :D
Go to the top of the page
 
+Quote Post
audionuma
posté 14 Apr 2013, 04:59
Message #2


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 1 899
Inscrit : 27 Apr 2004
Membre no 18 176



Bonjour,
je ne pense pas que tu puisse installer sous mac OS un binaire compilé pour linux. Le code source ne semble pas être disponible, donc tu ne peux pas essayer de le compiler pour mac OS.
Tu peux installer une machine virtuelle linux avec virtualbox et tester ton appli dans la machine virtuelle.


--------------------
Membre du club des AIPBP (Anciens Inscrits Pas Beaucoup de Posts) Voir la liste
Go to the top of the page
 
+Quote Post
sparo
posté 14 Apr 2013, 07:47
Message #3


Macbidouilleur de bronze !
**

Groupe : Membres
Messages : 265
Inscrit : 19 Dec 2011
Membre no 173 114



Tu utilise virtualbox(ou autre) pour virtualiser un linux ou un windows et plus de probleme !!!


--------------------
iMac 27" quad i5 2.8GHz / MBA i7 2GHz / iPad2 / iPhone4s / AppleTV 2G / RaspberryPi / Synology DS110J / un portable sous seven + Dell E6420 ATG (pour le boulot)
Go to the top of the page
 
+Quote Post
Dodo_v
posté 14 Apr 2013, 08:55
Message #4


Nouveau Membre


Groupe : Membres
Messages : 27
Inscrit : 20 Nov 2010
Lieu : Strasbourg
Membre no 161 494



Ok, c'est déjà ce que je suis en train de faire ... même si je ne parvient même pas à installer ce programme sous ubuntu ... --'
Merci pour vos réponses.


--------------------
Etudiant en électronique.

MacBook Pro 13" Late April 2010 - 2.4Ghz, 8Go, Nvidia 320M 256Mo, Crucial M4 256Go
Nokia N8 + Bluephone elite 2 :D
Go to the top of the page
 
+Quote Post
noop
posté 14 Apr 2013, 11:07
Message #5


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 2 964
Inscrit : 3 Nov 2005
Membre no 49 239



si tu as ubuntu sous virtualbox, tu peux recompiler le programme

make
make install
install
Go to the top of the page
 
+Quote Post
LeFrettchen
posté 16 Apr 2013, 20:14
Message #6


Macbidouilleur de vermeil !
****

Groupe : Membres
Messages : 919
Inscrit : 25 Feb 2007
Lieu : Bronvaux
Membre no 81 417



Citation (Dodo_v @ 14 Apr 2013, 09:55) *
Ok, c'est déjà ce que je suis en train de faire ... même si je ne parvient même pas à installer ce programme sous ubuntu ... --'

Normal, sur le site, c'est bien spécifié qu'il s'agit d'une version Red Hat Enterprise Linux 5 ou Red Hat Enterprise Linux 6.
C'est pas fait pour autre chose, y'à peu de chance que ça fonctionne directement sur Ubuntu ou toute autre distribution Linux.

Quartus : Configuration nécessaire

Il est aussi spécifié que les versions Linux sont payantes ! même les anciennes versions comme la version 9.1


Citation (noop @ 14 Apr 2013, 12:07) *
si tu as ubuntu sous virtualbox, tu peux recompiler le programme

make
make install
install

C'est un logiciel payant sous Linux, aucune chance de trouver le code source, sauf en l'achetant au prix fort.
Et donc, impossible de compiler pour Ubuntu !


Donc, deux solutions :
  1. soit le logiciel est fourni en paquet précompilé .rpm, et il est possible de le convertir en version Ubuntu (avec le logiciel alien, par exemple),
  2. soit le logiciel est fourni en fichier binaire .bin, et là, c'est la loterie pour le convertir.


--------------------
Go to the top of the page
 
+Quote Post
Dodo_v
posté 17 Apr 2013, 09:48
Message #7


Nouveau Membre


Groupe : Membres
Messages : 27
Inscrit : 20 Nov 2010
Lieu : Strasbourg
Membre no 161 494



Citation (LeFrettchen @ 16 Apr 2013, 21:14) *
Citation (Dodo_v @ 14 Apr 2013, 09:55) *
Ok, c'est déjà ce que je suis en train de faire ... même si je ne parvient même pas à installer ce programme sous ubuntu ... --'

Normal, sur le site, c'est bien spécifié qu'il s'agit d'une version Red Hat Enterprise Linux 5 ou Red Hat Enterprise Linux 6.
C'est pas fait pour autre chose, y'à peu de chance que ça fonctionne directement sur Ubuntu ou toute autre distribution Linux.

Quartus : Configuration nécessaire

Il est aussi spécifié que les versions Linux sont payantes ! même les anciennes versions comme la version 9.1



Ok... je ne savait pas qu'il y avait une telle disparité dans le monde linux ...
Il me semble bien que la Web Edition est gratuite, la seule limitation est qu'elle ne supporte pas les FPGA récents. Mais je n'ai pas pour but de programmer du FGPA depuis mon ordinateur.


--------------------
Etudiant en électronique.

MacBook Pro 13" Late April 2010 - 2.4Ghz, 8Go, Nvidia 320M 256Mo, Crucial M4 256Go
Nokia N8 + Bluephone elite 2 :D
Go to the top of the page
 
+Quote Post
audionuma
posté 17 Apr 2013, 19:56
Message #8


Macbidouilleur d'Or !
*****

Groupe : Membres
Messages : 1 899
Inscrit : 27 Apr 2004
Membre no 18 176



Dernière chance : si le binaire est destiné à RedHat, tu peux tenter de l'installer sous CentOS ... On ne sait jamais.


--------------------
Membre du club des AIPBP (Anciens Inscrits Pas Beaucoup de Posts) Voir la liste
Go to the top of the page
 
+Quote Post
LeFrettchen
posté 17 Apr 2013, 20:42
Message #9


Macbidouilleur de vermeil !
****

Groupe : Membres
Messages : 919
Inscrit : 25 Feb 2007
Lieu : Bronvaux
Membre no 81 417



Citation (Dodo_v @ 17 Apr 2013, 10:48) *
Il me semble bien que la Web Edition est gratuite

La version Windows peut-être, mais il est bien spécifié que la Web Édition Linux est payante !


--------------------
Go to the top of the page
 
+Quote Post
ericb2
posté 8 Dec 2016, 10:24
Message #10


Macbidouilleur d'argent !
***

Groupe : Membres
Messages : 784
Inscrit : 16 Nov 2003
Membre no 11 701



Bonjour,


Lien trouvés avec le moteur startpage (mots clés : fpga programing linux) :

On retrouver bien Altera, version "opensource" (méfiance, mot galvaudé)

C'est ici => https://github.com/altera-opensource
En particulier : https://github.com/altera-opensource/linux-socfpga


Et concernant les FPGA sous Linux, voici ce que j'ai trouvé (en 15s):

xxxxxxx@ma machine_qui_est_un_mbp :~$ apt-cache search fpga

bladerf-fpga-hostedx115 - nuand bladeRF FPGA bitstream downloader (hostedx115)
bladerf-fpga-hostedx40 - nuand bladeRF FPGA bitstream downloader (hostedx40)
confluence - language for synchronous reactive hardware system design
fpgatools - tool to program field-programmable gate arrays
libasl-dev - multiphysics simulation software (development files)
libasl-doc - multiphysics simulation software (documentation)
libasl0 - multiphysics simulation software (shared libraries)
libasl0-dbg - multiphysics simulation software (debugging symbols)
libbladerf-dev - nuand bladeRF software-defined radio device (header files)
libbladerf1 - nuand bladeRF software-defined radio device
bfgminer - mineur de bitcoin GPU, FGPA et ASIC multi-parc à fil d'exécution multiple
bladerf - périphérique de radio définie par logiciel nuand bladeRF (outils)
libfpga-dev - development files for fpgatools
libfpga0 - bibliothèques de fpgatools
openwince-jtag - programmation de circuits JTAG comme les CPU ou FPGA

=> openwince ? (je ne connais pas du tout)


hth


Edit : OT, mais lecture conseillée : https://www.reddit.com/r/FPGA/comments/32ex..._so_bad_a_rant/

Ce message a été modifié par ericb2 - 8 Dec 2016, 10:35.
Go to the top of the page
 
+Quote Post
Dodo_v
posté 8 Dec 2016, 13:29
Message #11


Nouveau Membre


Groupe : Membres
Messages : 27
Inscrit : 20 Nov 2010
Lieu : Strasbourg
Membre no 161 494



Salut ericb2,
Tu déterres les morts là !
Je m'étais finalement orienté vers Sigasi, un IDE pour VHDL, comme la fonction de synthèse n'était pas requise pour moi (préparation de travaux pratiques pour mes études).

Entre temps j'ai quitté MacOS et suis devenu complètement addict à Linux et KDE Plasma.

Salutations,
Dorian


--------------------
Etudiant en électronique.

MacBook Pro 13" Late April 2010 - 2.4Ghz, 8Go, Nvidia 320M 256Mo, Crucial M4 256Go
Nokia N8 + Bluephone elite 2 :D
Go to the top of the page
 
+Quote Post
ericb2
posté 8 Dec 2016, 14:23
Message #12


Macbidouilleur d'argent !
***

Groupe : Membres
Messages : 784
Inscrit : 16 Nov 2003
Membre no 11 701



Je n'avais pas vu la date du post, en effet :-)

Mais ce n'est pas perdu, et ça m'a permis de voir le chemin parcouru : on m'a proposé de bosser sur un sujet proche, et je faisais des recherches sur la programmation des FPGA sous Linux (c'était pas terrible il y a 5 à 10 ans).

Et merci pour la solution sigasi ( http://www.sigasi.com/ si je ne me suis pas trompé ).




Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 utilisateur(s) sur ce sujet (1 invité(s) et 0 utilisateur(s) anonyme(s))
0 membre(s) :

 



Nous sommes le : 18th June 2018 - 04:36